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Introduction

The chapters in Part I guide you through the Macromedia 
Studio MX installation, provide information on 
Macromedia resources, and introduce the Macromedia 
Studio MX product family. 

The following chapters are in this part:

• Introduction, “Getting Started”

• Chapter 1, “Introducing the Macromedia Studio MX 
Tools”





INTRODUCTION

Getting Started

Macromedia Studio MX is an integrated suite of easy-to-use, powerful development tools that 
support emerging standards and web technologies for creating websites and Rich Internet 
Applications that can be delivered across major platforms and devices. The suite includes 
Macromedia Flash MX, Dreamweaver MX, Fireworks MX, FreeHand, the Developer Edition of 
ColdFusion MX Server, and Macromedia Flash Player 6. Macromedia Studio MX has capabilities 
for each part of the web production process, including creating graphics, laying out HTML pages, 
coding application logic, building rich user interfaces, and assembling complete solutions.

Macromedia MX products are built for rapid development. Easy to learn and use, they provide a 
wide range of features that help increase developer productivity, from prebuilt components and 
templates to an integrated workflow and shared user interface. Macromedia Studio MX 
empowers developers to create Rich Internet Applications with the most effective and intuitive 
user experiences. Using Macromedia Studio MX, designers and developers can create responsive 
applications that combine the functionality of traditional client/server solutions with the broad 
reach and low-cost deployment of web applications. 

Macromedia Studio MX provides a new workspace and many common features and interface 
elements to speed your workflow. This release is a major step forward in fulfilling the Macromedia 
commitment to a flexible and productive web development platform. Macromedia Studio MX builds 
on the strengths of the individual products and enhances their ability to work together seamlessly.

You can install the Developer Edition of the ColdFusion MX Server on your local machine to 
easily evaluate Rich Internet Application development by building and deploying applications 
using the Macromedia Studio MX tools. See Chapter 16, “Installing the Developer Edition of 
Macromedia ColdFusion MX Server,” on page 373.

For details on the Macromedia Studio MX product family, see “Introducing the Macromedia 
Studio MX Tools” on page 19 or the individual product sections of this book.

About this book
The goal of this book is to guide you in exploring the Macromedia Studio MX family of products 
and learning about how they work together to provide you with the most powerful and 
productive web development environment available today. You can read the complete 
documentation for all the Macromedia Studio MX products in HTML format in the individual 
product Help menus, in Adobe Acrobat (PDF) format, available on the CD-ROM, and in the 
product sections on the Macromedia website, http://www.macromedia.com.
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This book is organized so that you can quickly become familiar with each of the products by 
taking a tutorial that shows you the basics of building a website, designing a Flash movie for the 
web, producing a web document, or creating an image file. If you have experience in one or more 
of the products, you can read about the new features and enhancements in this release and how to 
integrate the products into a web development workflow.

The book is divided into the following sections:

Introduction

Part I of this book introduces the Studio MX tools.

• This chapter, “Getting Started,” presents installation instructions, a summary of new features, 
resources for learning to use the products, and accessibility information.

• Chapter 1 briefly describes the Studio family products, their common interface elements, and 
productivity tools.

Web applications and workflow

Part II of the book provides an overview of web technologies and presents a development 
workflow using the Studio MX tools.

• Chapter 2 covers the basics of web technologies and web applications.

• Chapter 3 presents a detailed development workflow based on building an interactive 
web application.

Product sections

Parts III through VI cover each product in the Studio MX family in detail. Each part contains the 
following chapters about the respective product:

• An introduction that briefly describes the product, summarizes new features, and provides 
references to resources for learning more about the product

• A tutorial designed for new users of the product

• A guide to using the products interactively

Part VII of the book contains two chapters on ColdFusion MX that explain how to install 
ColdFusion and how to use it with the other Studio MX products.

For information on additional resources, see “Learning Macromedia Studio MX” on page 16.

Installing Macromedia Studio MX
Macromedia Studio MX is very easy to install on Windows and Macintosh systems. Macromedia 
recommends installing the complete Macromedia Studio MX in one simple operation, but you 
can selectively install individual applications.

The Developer Edition of ColdFusion MX Server for Windows is installed separately. For more 
information, see Chapter 16, “Installing the Developer Edition of Macromedia ColdFusion MX 
Server,” on page 373.
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Installing Macromedia Studio MX on Windows

Follow these steps to install Macromedia Studio MX on Windows.

To install Macromedia Studio MX on Windows:

1 Insert the Macromedia Studio MX CD in your computer’s CD-ROM drive to open the Install 
Macromedia Studio MX screen.

If the screen does not appear, or you are installing from a network drive, use Windows 
Explorer to locate the Install Macromedia Studio MX.exe program in the root directory and 
double-click it.

2 Do one of the following:

• Select the Studio MX Install option on the installation selection screen. Macromedia 
recommends selecting this option.

• If you want to install only a single program, select it from the screen. Repeat this process to 
install other products individually. 

Before installing ColdFusion MX, see “Installing the Developer Edition of Macromedia 
ColdFusion MX Server” on page 373.

3 Complete the License Agreement and User Information screens, and click OK.

You might see an additional User Information screen, depending on the serial number you 
entered and the Macromedia applications detected on your system. If so, complete the 
information on this screen to continue.

4 Accept the default location for the installed applications or browse to select a different location.

5 Click Next to install the selected programs.

A final wizard screen appears when the installation is complete.
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6 Click Finish to close the installation. 

If you selected the Studio MX Install option, the Macromedia Studio MX Read Me file opens. 
If you installed a single product, the informational file for that product opens.

The main installation screen stays open until you click the Close button. 

The installed Macromedia Studio MX applications are now available on the Windows Start 
menu under Programs > Macromedia.

7 To view all the great extras provided with Macromedia Studio MX, select Browse CD Contents.

To uninstall the programs:

Select Start > Settings > Control Panel > Add/Remove Programs, and select the program you want 
to uninstall.

About installing ColdFusion MX Server

The Developer Edition of ColdFusion MX Server is a free version that you can use to develop 
web applications on the local host and on one remote IP address. This edition is intended for 
evaluation purposes and is not licensed for deployment.

For information on ColdFusion Server installation requirements, see “ColdFusion MX system 
requirements for Windows” on page 373.

Installing Macromedia Studio MX on the Macintosh

Follow these steps to install Macromedia Studio MX on the Macintosh.

To install Macromedia Studio MX on the Macintosh:

1 Insert the Macromedia Studio MX CD in your computer’s CD-ROM drive to open the Install 
Macromedia Studio MX screen.

If the screen does not appear, double-click the Install Macromedia Studio MX icon on the 
CD-ROM. 

2 Do one of the following:

• Select the Studio MX Install option on the installation selection screen. Macromedia 
recommends selecting this option.

• If you want to install only a single program, select it from the screen. Repeat this process to 
install other products individually. 

3 Click Continue to go to the next screen.

4 Complete the License Agreement screen.

5 On the Location screen, either accept the default location for the installed applications or 
browse to select a different location. Click Install to continue.
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6 Complete the User Information screen, and click OK.

You might see an additional User Information screen, depending on the serial number you 
entered and the Macromedia applications detected on your system. If so, complete the 
information on this screen to continue.

If you selected the Studio MX Install option, the Macromedia Studio MX Read Me file opens. 
If you installed a single product, the informational file for that product opens.

The main installation screen stays open until you click the Close button.

The installed Macromedia Studio MX applications are now available in the Applications folder.

To uninstall the programs:

Drag a product folder from the Application folder to the trash can.

Preventing network license infringement

If the Network License Detection dialog box appears when you attempt to open a Macromedia 
application, you may have exceeded the number of licensed copies permitted for that serial 
number. This dialog box appears when Macromedia applications detect another user on a 
company network using the same serial number as the licensee. You must have a software license 
(with a unique serial number) for each copy of Macromedia software installed on every computer. 

Note: This message may appear if you attempt to install a copy of a Macromedia Studio bundle on multiple computers. 
Macromedia Studio bundles are considered a single product and are licensed for installation on one computer.

To prevent license infringement, do one of the following: 

• Purchase a licensed copy of Macromedia software for each computer. For more information, 
visit an authorized Macromedia reseller or visit the Macromedia online store at http://
dynamic.macromedia.com/bin/MM/store/US/home.jsp.

• Work with your IT department to locate the individuals who are using the same serial number 
on your network. Provide the user name and IP address that appears in the Network License 
Detection dialog box.

We apologize for any inconvenience this may cause. If you believe you received this dialog box in 
error, use the Support Center menu on the Support page at http://www.macromedia.com/support/
to locate your product, then search for articles related to network license detection. The 
Macromedia Support Center provides the latest information about our software. If you need to 
contact Macromedia Customer Service at http://www.macromedia.com/support/email/cscontact, 
have a copy of your product invoice or receipt ready. For more information on licensing, refer to the 
End User License Agreement, with the filename License.htm, located in the directory where your 
Macromedia software was installed.
Getting Started 15



Registering Macromedia Studio MX

To get additional Macromedia support, it’s a good idea to register your copy of Macromedia 
Studio MX electronically or by mail.

When you register, you will be put on the priority list to receive up-to-the-minute notices about 
upgrades and new Macromedia products. You will receive timely e-mail notices about product 
updates and new content appearing on http://www.macromedia.com.

To register Macromedia Studio MX:

In any of the Macromedia Studio MX products, select Help and then select either the online or 
the print registration option. When you register one of the Studio MX products, the others are 
registered as well.

Learning Macromedia Studio MX
In addition to this book, Macromedia provides a wide range of resources for learning about all 
aspects of designing, developing, and integrating web content in the most productive way with 
the Macromedia Studio MX product family.

Following is a brief list of resources.

• The Read Me file that opens at the end of the installation contains links to the most up-to-date 
information on features and product issues, as well as other resources.

• The Designer & Developer Center at http://www.macromedia.com/desdev/ provides a wealth 
of practical information on web technologies and website design and development.

• The Website and Production Management Techniques site at http://www.macromedia.com/
resources/techniques/ presents a proven framework for successfully managing the complex 
creative and organizational issues in launching and maintaining an effective web presence.

• The Macromedia Online Forums at http://www.macromedia.com/support/forums/ provide a 
place for developers of all experience levels to share ideas and techniques for using the entire family 
of Macromedia products. These forums are also frequented by Macromedia technical support 
personnel, members of the product development teams, and Team Macromedia members.

Accessibility and the Macromedia Studio MX product family
Macromedia supports the creation of great web experiences that are accessible to everyone, 
and we are working to make the interface and tools in our products more accessible to users 
with disabilities.

For the latest information on product features and resources that support accessible design, see the 
Macromedia accessibility page at http://www.macromedia.com/accessibility/.

The World Wide Web Consortium (W3C) guidelines on web content encourage developers to 
adopt design and coding practices for accessibility. For more information on the W3C guidelines, 
see the Web Content Authoring Guidelines at http://www.w3.org/TR/WAI-WEBCONTENT/
full-checklist.html.

The following accessibility features are available both for working in the products and for using 
the products to develop accessible content.
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Macromedia Dreamweaver MX accessibility

• Dreamweaver MX provides support for JAWS and Window Eyes screen reader programs. 

• Support for Windows high-contrast display settings helps make Dreamweaver accessible to 
all users.

• The application also provides support for keyboard navigation of the interface.

• Accessibility dialog boxes in Dreamweaver prompt you to enter accessibility tags and attributes 
when you insert images, media objects, tables, and other elements that require accessibility support.

• Dreamweaver comes with sample web pages designed for accessibility.

For more information, see Dreamweaver Help> Using Dreamweaver > 
Dreamweaver and Accessibility.

Macromedia Flash MX accessibility

• Flash movie text, input text fields, buttons, movie clips, and movies are accessible by default. 
That means these items are all included in the information that the Macromedia Flash Player 6 
provides to screen reader software, whether the Flash movie was created with Flash MX or an 
earlier version.

• You can set descriptive properties for each of these object types, and these settings are included 
in the information that the Macromedia Flash Player 6 provides to screen reader software.

• The Macromedia Flash Player automatically provides names for static and dynamic text objects.

• You can assign labels to buttons and input text fields so that they are identified appropriately 
by a screen reader. 

• You can use the ActionScript method Accessibility.isActive to detect if a screen reader is 
running during movie runtime. This is useful if you want to make your movie behave in 
customized ways when a screen reader is present.

• You can set a custom tab order and define shortcut keys for accessible objects.

For more information, see Flash Help > Using Flash > Creating Accessible Content.

Macromedia Fireworks MX accessibility

• Commands to evaluate graphics for accessibility are available on the Dreamweaver Exchange. 
The Select Blank ALT Tags and Set Blank ALT Tags commands enable authors to quickly 
locate image tags that do not contain ALT text and provide alternate text for images. Alternate 
text allows images to be interpreted by text-only assistive devices.

• The Object inspector lets you assign alternate text attributes to any hotspot or image slice.

• Designers can easily create and share custom color swatch panels to ensure proper contrast in 
hue and saturation for web graphics, such as buttons, that require adequate contrast between 
foreground and background to be more easily seen by readers with some visual limitations.

• Fireworks MX provides robust integration with the accessibility features of Macromedia Flash 
MX and Dreamweaver MX. 

For more information, see the Fireworks accessibility site at http://www.macromedia.com/
macromedia/accessibility/features/fireworks.html.
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Macromedia FreeHand 10 accessibility

• FreeHand 10 supports customizable keyboard shortcuts and menu accelerators.

• Most functionality is available in dialog boxes, and panel menus may be accessed through 
assistive technology.

• Standard color management, as well as multiple color spacing and fine control over color 
values, help in creating accessible content. The colors and their associated color values can be 
manipulated both visually and alphanumerically.

• FreeHand uses system API for rendering text, except when text is converted to paths.

• Standard system-level controls display and gather user data by default.

• Tooltip text is provided for every image that functions as a user interface element.

Contacting Macromedia

Corporate headquarters Macromedia, Inc.
600 Townsend Street
San Francisco, CA 94103
Tel: 415.252.2000
Fax: 415.626.0554
Web: http:// www.macromedia.com

Technical support Macromedia offers a range of telephone and web-based support options. Go to 
http://www.macromedia.com/support/ for a complete description of technical 
support services.

Sales Toll Free: 888.939.2545
Tel: 617.219.2100
Fax: 617.219.2101
E-mail: sales@macromedia.com 
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CHAPTER 1

Introducing the Macromedia Studio MX Tools

Macromedia Studio MX includes the following easy-to-use, powerful development tools that 
support a wide range web technologies and standards for creating Rich Internet Applications:

Dreamweaver MX is the first choice of professionals for building and managing 
HTML-based websites.

Flash MX is the most powerful solution for developing rich Internet content and applications 
delivered across various platforms and devices using the Macromedia Flash Player.

Fireworks MX is a powerful and flexible production environment for creating, editing, and 
animating web graphics.

FreeHand is a vector-based drawing application capable of producing the highest quality 
illustrations for print and for the web.

ColdFusion MX is a rapid server scripting environment for creating Rich Internet Applications.

The following sections contain brief descriptions of the Macromedia Studio MX products.

Macromedia Dreamweaver MX
Macromedia Dreamweaver MX is the professional choice for building websites and Rich Internet 
Applications. It is an easy-to-use and powerful authoring tool that every member of the 
development team can use to quickly build robust websites and Rich Internet Applications. For 
the first time, designers, developers, and programmers can work within one environment to easily 
create and manage any professional website, whether it’s built using HTML, XHTML, XML, 
web services, ColdFusion, ASP.NET, ASP, JSP, or PHP. Dreamweaver MX combines the 
renowned visual layout tools of Dreamweaver, the rapid web application features of Dreamweaver 
UltraDev, and the extensive code editing support of HomeSite+ to provide a complete solution 
for the websites of today and the Rich Internet Applications of tomorrow. 

Whether you enjoy the control of hand-coding HTML or prefer to work in a visual editing 
environment, Dreamweaver MX makes it easy to get started and provides you with helpful tools 
to enhance your web design experience.

Dreamweaver MX includes many coding tools and features: HTML, CSS, and JavaScript 
references on the Coding panel, a JavaScript Debugger, and code editors (the Code view and 
Code inspector) that allow you to edit JavaScript, XML, and other text documents directly in 
Dreamweaver MX. Macromedia Roundtrip HTML technology imports HTML documents 
without reformatting the code; you can set Dreamweaver MX to clean up and reformat HTML 
when you want it to.
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The visual editing features in Dreamweaver MX let you quickly add design and functionality to 
your pages without writing a line of code. You can view all your site elements or assets and drag 
them from an easy-to-use panel directly into a document. You can open HomeSite+ from within 
Dreamweaver MX to use its coding features. 

Dreamweaver MX is fully customizable. Using Dreamweaver MX, you can create your own 
objects and commands, modify keyboard shortcuts, and even write JavaScript code to extend 
Dreamweaver MX capabilities with new behaviors, Property inspectors, and site reports.

Dreamweaver MX integration features

Dreamweaver MX is tightly integrated with the other Macromedia Studio MX tools to enable you 
to simplify your web design workflow. 

• Roundtrip HTML allows you to make changes to a file in Macromedia Flash MX, Fireworks 
MX, or Dreamweaver MX and have those changes seamlessly reflected in the other applications.

• When you export files from Macromedia Flash MX or Fireworks MX to a site defined in 
Dreamweaver MX, Design Notes containing references to the PNG or Macromedia Flash 
authoring file (FLA) are automatically exported to the site along with the web-ready file 
(GIF, JPEG, or SWF). 

• You can initiate the graphic production process by using an image placeholder in a 
Dreamweaver document, then launching Fireworks MX to design the graphic. If you save the 
graphic as both a PNG and a web-ready graphic file, when you return to Dreamweaver MX, 
the replacement image is updated in the document.

• Dreamweaver MX automatically launches the associated application and the source document 
to let you edit a Macromedia Flash MX SWF file or a Fireworks MX image from within a 
Dreamweaver document.

• Using the Create Web Photo Album command, you can generate a website that showcases an 
album of images by calling Fireworks MX to create a thumbnail and a larger-sized image for 
each of the images in the selected folder. Dreamweaver MX then creates a web page containing 
all the thumbnails, as well as links to the larger images. 

• If you change the format of an image, the link checker prompts you to update references to the 
image. For example, if you change the format of an image called my_image from GIF to JPEG, 
clicking OK at the prompt changes all references to my_image.gif in your site to my_image.jpg.

• Using the Macromedia Flash Button feature, you can convert type into anti-aliased Flash text.

• You can preview a Macromedia Flash MX object in a Dreamweaver MX document window at 
authoring time using the Play/Stop button in the Flash Property inspector. 

• The Insert bar in Dreamweaver MX lets you add Macromedia Flash buttons for navigation 
directly into Dreamweaver MX.

• Dreamweaver MX updates links automatically whenever you move or rename a file. You can 
also manually change any link, including URL, e-mail, FTP, null, and script links.

For details about all the integration features, see Dreamweaver Help and Chapter 6, 
“Dreamweaver MX Integration with the Macromedia Studio MX Product Family,” on page 139.
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Macromedia Flash MX
Macromedia Flash MX provides everything you need to create and deploy rich content and 
powerful Internet applications. Whether you are designing motion graphics or building data-
driven applications, Macromedia Flash MX has the tools you need to produce great results and 
deliver the best user experiences across multiple platforms and devices. New functionality, such as 
embedded video, workflow enhancements for color management, and Timeline interaction, 
extend the creative capabilities of the tool. 

Prebuilt user interface elements and templates allow both experienced and first-time developers to 
quickly create otherwise complex interactivity with drag-and-drop simplicity. Designers and 
developers can quickly build user interfaces with the high level of control and functionality that the 
Flash Player affords. Through an enhanced ActionScript editing environment, a powerful debugger, 
and optimized data handling using XML, designers and developers can leverage their existing skills 
to produce complete Internet-driven applications using Flash as their presentation layer.

As the leading rich client, Macromedia Flash MX allows for the broadest distribution of content 
and the most effective method for creating powerful and highly effective Internet applications.

Macromedia Flash MX integration features

From simple graphics production to complex development tasks, Macromedia Flash MX works 
seamlessly with the other Macromedia Studio MX products.

• You can delineate any set of parameters when you place a Macromedia Flash MX file in 
Dreamweaver MX using the Property inspector or the Parameters button.

• You can dynamically pass name/value pairs to a SWF file by passing them through the URL 
loading the file. The passed variables tell the navigation SWF where the user was in the site, 
and thus, which menu sections to highlight. You can use this technique to create navigational 
elements for an HTML site.

• When you export and save a compressed SWF file with an HTML file using the Publish 
command, you can launch Macromedia Flash MX from a Dreamweaver document to edit the 
source document.

• Flash MX lets you import PNG images from Fireworks MX as editable objects that you can 
modify in Flash, or as flattened files that you can edit and update in Fireworks.

• When importing FreeHand files into Flash MX, you can maintain layers, text blocks, library 
symbols, and pages. You can also choose a page range to import.

For details about all the integration features, see Flash Help and Chapter 9, “Macromedia Flash 
MX Integration with the Macromedia Studio MX Product Family,” on page 215.

Macromedia Fireworks MX
Macromedia Fireworks MX provides the easiest way to create, optimize, and export interactive 
graphics in a single, web-based environment. Fireworks MX includes the tools to ensure success 
for every person responsible for creating web graphics, from the HTML developer who maintains 
and edits graphics to the design expert who demands the most professional bitmap-editing 
control. Fireworks MX delivers a streamlined environment for creating everything from simple 
graphical buttons to sophisticated rollover effects and pop-up menus.
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Powerful creative tools, support for major file formats and HTML standards, and integration 
with popular HTML editors allow designers to use Fireworks MX comfortably in any work 
environment. The single, web-centric workspace offers robust bitmap editing, precise text 
control, creative flexibility, automation, and extensibility, enabling rapid production and easy 
updates. Broad support for different file formats, emerging standards such as XHTML, and 
Section 508 compliance ensure that output meets today’s and tomorrow’s needs.

Using Fireworks MX, you can create, edit, and animate web graphics, add advanced interactivity, 
and optimize images in a professional environment. In Fireworks, you can create and edit both 
bitmap and vector graphics in a single application. You can also automate the workflow to meet 
the demands of time-consuming updates and changes.

Fireworks MX integration features

You can easily create and edit graphics directly in Macromedia Fireworks MX or in other 
Macromedia Studio MX products.

• Fireworks MX can be launched to edit selected graphics from inside Flash MX, Dreamweaver 
MX, HomeSite+, and FreeHand.

• Fireworks behaviors are preserved upon export, allowing you to export interactive elements 
such as buttons and rollovers.

• Roundtrip HTML allows you to make changes in either Fireworks MX or Dreamweaver MX 
and have those changes seamlessly reflected in the other application.

• You can integrate optimized Fireworks bitmap graphics into vector-based Flash MX websites.

• Fireworks lets you create JavaScript pop-up menus that you can then edit and use in 
Dreamweaver documents.

For details about all the integration features, see Fireworks Help > Using Fireworks > Using 
Fireworks with other applications and Chapter 12, “Fireworks MX Integration with the 
Macromedia Studio MX Product Family,” on page 291.

Macromedia FreeHand
Macromedia FreeHand is a vector-based drawing application. With FreeHand, you can create 
vector graphics that can be scaled and printed at any resolution, without losing detail or clarity.

You can use FreeHand to create print and web graphic illustrations such as logos and advertising 
banners. You can also use FreeHand to turn your artwork into Macromedia Flash animations.

The FreeHand user interface contains a workspace and Tools panel that are consistent with the 
other Macromedia Studio MX applications to give you a true integrated print and web solution. 

FreeHand integration features

Macromedia FreeHand offers you tremendous flexibility in working across the Macromedia 
Studio MX product family.

• You can use Macromedia FreeHand to quickly storyboard the design elements and layout for 
your website, then develop the structure and content in Macromedia Flash MX and 
Dreamweaver MX.

• FreeHand objects can be imported into Flash MX or Fireworks MX simply by copying and 
pasting or by dragging them between the applications.
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• The Animate Layers feature lets you create a document that can be exported to Flash MX 
as an animation.

• Flash MX actions can be assigned to FreeHand documents to create interactive movies for 
web display.

• You can export FreeHand art in Macromedia Flash (SWF) file format to use in creating 
dynamic vector art for display on the web.

• Using the Macromedia Flash Player window, you can preview and test Flash MX movies 
inside FreeHand.

For details about all the integration features, see FreeHand Help and Chapter 15, “FreeHand 
Integration with the Macromedia Studio MX Product Family,” on page 363.

Macromedia ColdFusion MX Server
Macromedia ColdFusion MX Server is a rapid server scripting environment for creating Rich 
Internet Applications. Combining highly approachable scripting, effortless connectivity to 
enterprise data, and powerful built-in search and charting capabilities, ColdFusion MX enables 
developers to easily build and deploy dynamic websites, content publishing systems, self-service 
applications, commerce sites, and more.

The flexible ColdFusion MX environment supports Windows, Linux, and UNIX operating 
systems, integrates with Java and .NET standards, and offers breakthrough ease of use for XML 
and web services. ColdFusion also provides high-performance connectivity to Macromedia Flash 
clients and native support for server-side ActionScript. With the ability to run as a stand-alone 
server or deploy on enterprise-class application servers such as IBM WebSphere, ColdFusion MX 
enables any development team to rapidly deliver superior user experiences with their applications.

Macromedia ColdFusion MX moves the award-winning ease of use and productivity of the 
ColdFusion server scripting environment to a highly scalable, standards-based Java technology 
architecture, and extends the environment with innovative new support for Rich Internet 
Application development, XML web services, and Microsoft .NET technology.

ColdFusion MX Server integration features

The Macromedia Studio MX tools support dynamic web application development in a 
number of ways.

• ColdFusion MX provides complete support for the new features in the Dreamweaver MX 
development environment, including powerful visual layout and prototyping, enhanced code 
editing and development capabilities, and integrated debugging.

• With the introduction of server-side ActionScript, Macromedia Flash developers can now use 
the same scripting language for both client and server logic.

• ColdFusion MX delivers fully integrated application services for adding full-text searching, 
dynamic charting, and high-performance connectivity for Macromedia Flash clients to your 
applications.

• ColdFusion MX gives you virtually unlimited extensibility for development with custom tag 
libraries, reusable components, Java/C++, and thousands of available third-party add-ons that 
can easily be incorporated into applications using Dreamweaver MX and Flash MX.

For information on how to develop ColdFusion applications with the Macromedia Studio MX 
product family, see Dreamweaver Help and Flash Help.
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Macromedia Extension Manager
An extension is a piece of software that can be added to a Macromedia application to enhance the 
application’s capabilities. Macromedia offers several types of extensions, including interface 
elements, accessibility extensions, HTML, JavaScript, and ActionScript code snippets, and 
additional symbol libraries. All Macromedia applications that support the Macromedia Extension 
Manager can use font extension packages that install a font to your hard disk. 

The Macromedia Extension Manager provides an easy and convenient way to install and delete 
extensions in Macromedia applications, and to find information about extensions you’ve 
installed. It also provides a convenient way to navigate to the Macromedia Exchange site, where 
you can find more extensions, get information about extensions, and write reviews of extensions. 

The Macromedia Exchange website at www.macromedia.com/exchange/ is a repository for many 
kinds of extensions; some are created by Macromedia, some by other developers. If you find an 
extension you’re interested in on the website, you can download it using your web browser and 
then install it in an application using the Macromedia Extension Manager. 

Installing the Macromedia Extension Manager

The Macromedia Extension Manager is installed as part of the full Macromedia Studio MX 
installation or with the separate Dreamweaver MX installation. If you select a different 
installation option, you can install it from the Extension Manager folder on the Studio MX 
product CD-ROM, or download the latest version from www.macromedia.com/exchange/.

Exploring the MX workspace
To make it easy to work across the Macromedia Studio MX products, they support many 
common features and interface elements, such as menus, panels, file launch-and-edit procedures, 
and keyboard shortcuts. You can easily customize the workspace to suit your work style. 

Working with shared features

Page design, graphics production, content development, and project management are a few of the 
tasks that benefit from expanded support across the Macromedia Studio MX products.

Editing objects and documents with the Property inspector

The Property inspector simplifies document creation by making it easy to access the most 
commonly used attributes of the current selection. You can make changes to object or document 
attributes in the Property inspector without having to access any menus or panels.

The Property inspector displays information and settings for the current document, text, symbol, 
shape, bitmap, video, group, frame, or tool. When two or more different types of objects are 
selected, the Property inspector displays the total number of objects selected.
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The following screen shot shows the Property inspector in Dreamweaver MX for an image file. 
This compact interface provides you with the image’s properties, displays a thumbnail, and lets 
you edit and enhance those properties. You can even convert the image to an image map.

The Property inspectors in Dreamweaver MX, Flash MX, and Fireworks MX work the same 
way—the only difference is that each of them displays the specific properties and controls for its 
tools. To access context-sensitive help for a Property inspector, you just click the question mark in 
the upper right corner.

For more information about the Property inspector, see each product’s help system.

Getting help from the Answers panel

The Answers panel in Macromedia Flash MX, Dreamweaver MX, and Fireworks MX provides 
quick access to information that helps you work effectively with the products. This includes 
tutorials, TechNotes, extensions, and other useful content. 

The following screen shot shows the Flash MX Answers panel.

To get the latest information on a product from macromedia.com, you just click the Update button.
Introducing the Macromedia Studio MX Tools 25



Accessing Macromedia Sitespring for project management

If you use Macromedia Sitespring to manage development projects, you can log in to your 
Sitespring home page from Dreamweaver MX, Flash MX, or Fireworks MX. From there you can 
quickly view the status of your projects. 

The Sitespring panel displays task information for the selected project.

For more information on working with Sitespring, see the Sitespring documentation. 

To download a trial version of Sitespring, go to www.macromedia.com/software/sitespring/trial/. 
After you install Sitespring, view the Read Me file for links to information on working with this 
powerful and easy-to-use project management system. 

Using common menus and keyboard shortcuts

The menus in the Macromedia Studio MX products are structured so that common items appear 
where you expect to see them as you work across the products.

You can apply the Macromedia standard keyboard shortcuts to all the products, or set custom 
shortcuts that you are comfortable working with. For more information, see each product’s 
help system.

Sharing the Tools panel

Macromedia Flash MX, Fireworks MX, and FreeHand provide a common interface and default 
location for the Tools panel, so that you can seamlessly work with tools, color palettes, and other 
features to build images and move them across the products.

The common Pen tool gives you the same drawing functionality across the products but lets you set 
custom preferences to get the most productive use from this drawing tool in the individual products.

For more information about tools and the Tools panel, see each product’s help system.

Working with MX panels

Panels in the Macromedia Studio MX products help you view, organize, and change elements 
in a document. You can customize a product’s interface by displaying the panels you need for a 
specific task and hiding other panels.
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The following illustration shows the elements available in all the Studio MX products for moving 
and resizing panels, for accessing menus, and for positioning panel tabs.

The title bar contains interface elements to move and resize a panel. To open the context menu 
for a panel or panel group, right-click (Windows) or control-click (Macintosh) in the title bar.

The gripper can be used to move a panel to a different part of the screen by clicking the gripper 
and dragging the panel.

The expander and panel title let you collapse or expand a panel by clicking in this area. In 
Dreamweaver MX and Fireworks MX, you double-click to maximize the panel and collapse the 
other panels in the docked area. 

The Options menu gives you various options related to each panel. To display it, you simply click 
the icon in the upper right corner of the panel.

Tabs can be used to reposition a panel. To move a panel away from a panel group, you click the 
tab and drag the panel. To resize a panel and surrounding panels, you click and drag the space 
next to a tab. A panel must contain more than one tab for the tabs to be displayed. Macromedia 
Flash MX does not use tabbed panels.

When you create a new panel group in Macromedia Flash MX or Dreamweaver MX, the group is 
named automatically from the tab name. The panel name updates when you add or remove tabs. 
You can rename a panel group using the Options menu. If the group contains only one panel, 
then the panel name cannot be edited.

For more information about panels, see each product’s help system.

Options menu

Title bar

Gripper

Tabs

Expander and Title
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Web Development

The chapters in Part II provide an overview of web 
technologies and present a development workflow using the 
Macromedia Studio MX tools.

The following chapters are in this part:

• Chapter 2, “Understanding Web Technologies and 
Applications”

• Chapter 3, “Web Development Workflow”





CHAPTER 2

Understanding Web Technologies

and Applications

This chapter discusses the basic concepts and terminology of the Internet and web applications 
and presents a scenario-based workflow for a data-driven application. It concludes with a look at 
the exciting new trends in developing accessible, rich client experiences for users.

Understanding the Internet and related technologies
One way to think of the Internet is to picture it as a wide-area network that spans multiple 
geographic locations. Each location in this enormous network is made up of a group of computers 
that are relatively close in proximity to one another and are connected by hardware and cabling.

Users communicate from one location to another using a communication protocol known as IP 
(Internet Protocol). This protocol, running on each computer connected to the Internet, ensures 
that communication breakdowns do not occur and that the networked computers can 
communicate and exchange data properly with one another.

Every computer connected to the Internet has a unique IP address. If duplicate IP addresses 
existed, information using a given address could end up in the wrong place. It would be like using 
the same street address for two residences. As a sender of information, you would never know if 
the intended receiver did receive your information.

Internet applications

Software applications that run on the Internet are known as Internet applications. The following 
table lists some of the most popular Internet applications:

Application Description

WWW World Wide Web. The web is a hypertext information system. It lets you read and navigate to text 
and visual information in a nonlinear way that is based on what you want to read next. This freely 
available information is linked together in various ways on the Internet and is available for you to 
browse whenever you want.
A website is a location on the World Wide Web. When you view a page, your browser connects 
to the website where the page is located to get the information.

E-mail Electronic mail. E-mail programs, such as Microsoft Outlook, let you send and receive mail 
electronically over the Internet.

FTP File Transfer Protocol. This protocol lets you transfer information between hosts using an FTP site.

Telnet Telnet lets you log on to a computer from a remote location.

NFS Network File System. NFS lets you share files between hosts.
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Internet applications communicate across the Internet by using IP, which transmits application 
data in small packets to a destination IP address. The receiving host processes the information 
that it receives. 

Intranet applications

An intranet is a private local area network (LAN) or wide area network (WAN) that lets you use 
and interact with your Internet-based applications in a secure environment. These private 
networks exist in large corporations, small companies, and even home offices. Private networks let 
companies and organizations determine who can share their information and who can access it.

An intranet application is an application that works on a private intranet (network). It differs from 
an Internet application only in who can access it and the location of the client computer accessing 
it. An intranet application can also operate over a public Internet. When an intranet application 
runs on the Internet, the application is called an Internet application. These terms, Internet 
applications and intranet applications, are used throughout this book.

Web servers

A web server is a software program that serves web pages to requesting clients. The web-server 
software runs on any computer. Often people refer to the host running the web-server software as 
the web server and think of the server as the hardware. Technically, however, the web server is just 
the software program and not the hardware. 

How a web server and connecting hosts communicate

When a user at a specific IP address requests a file, the web server retrieves that file and returns it 
to the requesting IP address. The contents of a file are not important to the web server. It is the 
web browser, not the web server, that makes the request and interprets and displays the data in the 
file that was returned from the web server.

When you make a request from a web server, an IP connection is made across the Internet 
between the client making the request and the host running the web-server software. As soon as a 
request is satisfied by the web server, the Internet connection between the client and the host 
breaks. Images or links from a single page to other pages all require separate connections. Often, it 
takes many requests to retrieve all the information on one web page.

Web pages

The information on the World Wide Web is presented in web pages. You can create web pages 
using a number of client-side technologies. A web page can include a variety of information: text, 
lists, forms for capturing data, tables for presenting data, scripts that perform a function, 
multimedia content that animate pages, and so on. 

No matter the content of the web page, the web browser must process and display the page.
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Web browsers

A web browser is a software program residing on a computer that you use to view pages on and 
navigate the World Wide Web. When you use a browser to request a page on a website, that 
browser is making a web connection to a web server.

As mentioned previously, the web browser processes the web pages that it receives from a web 
server and displays the pages to the user. Depending on your browser’s features, you might be able 
to play multimedia files, view and interact with Java applets, read your e-mail, or use other 
advanced features.

Some of the most popular web browsers today are Microsoft Internet Explorer, Netscape 
Navigator, and Mozilla. Unfortunately, most browsers today parse web pages differently. Web 
designers must pay special attention to the way a browser behaves, or users might not see the 
pages as the designers intended. Therefore, web designers need to test their pages on multiple 
browsers before publishing them on their website.

HTML

Web page authors create plain text files using the Hypertext Markup Language. This language, 
known as HTML, consists of a series of easy-to-learn tags that you can use to mark up a page of 
text. Tags can indicate page elements, structure, formatting, hypertext links to other locations, 
and so on. Web browsers read the HTML tags, and they format the text and styles that appear on 
the computer screen. 

HTML tags usually have a starting and ending tag surrounding the text that they affect. The 
starting tag turns on a feature (heading, bold, and so on), and the ending tag turns it off. All 
ending tags have a forward slash (/) preceding the tag name.

Most HTML tags look like this:

<TheTagName>text</TheTagName>

The tag name is always enclosed in angle brackets (<>) and is case-insensitive, which means that 
you can specify the tag name in uppercase, lowercase, or mixed case. 

Most web browsers let you view the source code of an HTML page. This option is usually located 
in a menu or a button.

JavaScript

Web developers write JavaScript to create small programs that run in the browser. JavaScript is 
one of the most popular client-side scripting languages today. It is supported by almost all 
browsers on the market. Web developers use JavaScript to do the following:

• Validate user actions

• Create scrolling messages in a browser’s status bar

• Animate text or images

JavaScript can be inserted in the HTML file. The <script> tag tells the browser that the 
following chunk of text, bounded by the closing </script> tag, is not HTML, but rather script 
code to be processed.

Although using JavaScript might seem similar to inserting HTML tags, JavaScript is more 
difficult to learn than HTML. For more information about JavaScript, see any JavaScript primer.
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ActionScript

Macromedia Flash developers write ActionScript to control the interaction and playback of the 
Flash Player. The ActionScript syntax and style closely resemble that of JavaScript. ActionScript is 
the most widely used rich client scripting language today, and it has been an integral part of the 
Flash authoring process since Flash Player 4. Flash developers use ActionScript for a number of 
functions, including the following:

• Creating interactive user interfaces

• Controlling graphics, text, and multimedia elements

• Loading and processing data from the server, including XML and multimedia elements 
(JPG, MP3, video)

For more information about ActionScript, see Flash Help.

URLs

Every piece of information on the World Wide Web has a unique address. This address is called a 
Uniform Resource Locator, or URL. A URL is a pointer to some bit of data on the web. This 
information might include a web document, a file on an FTP site, or even an e-mail address. In 
addition, you use special URLs to send e-mail and for using the Telnet program. URLs contain 
information about the following:

• How to get the information (what protocol to use: FTP, HTTP, and so on)

• The Internet host name to contact (for example, http://www.macromedia.com; http://
localhost/mysite; or ftp.mysite.com)

• The directory or other location in which to find the requested information

Understanding web applications
A web application is a website that contains pages stored on a web server with partly or entirely 
undetermined content. The web page’s final content is determined only when the user requests a 
page from the web server. Because the final content of the page varies from request to request 
based on the user’s actions, this kind of page is called a dynamic page.

Web applications are built to address a variety of challenges and problems. This section describes 
common uses for web applications and gives a simple example. 

Common uses for web applications 

Web applications have many uses for both users and developers, including the following: 

• Letting users find information quickly and easily on a content-rich website. 

This kind of web application gives users the ability to search, organize, and navigate 
content as they see fit. Examples include company intranets, Microsoft MSDN (http://
www.msdn.microsoft.com), and Amazon.com (http://www.amazon.com).

• Collecting, saving, and analyzing data provided by users. 

In the past, data entered in HTML forms was sent as e-mail messages to employees or CGI 
applications for processing. A web application can save form data directly into a database and 
also extract the data and create web-based reports for analysis. Examples include online 
banking pages, online store check-out pages, surveys, and user-feedback forms.
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• Updating websites that have constantly changing content.

A web application frees the web designer from continually updating the site’s HTML. 
Content providers such as news editors provide the web application with content, and the 
web application updates the site automatically. Examples include The Economist (http://
www.economist.com) and CNN (http://www.cnn.com).

Web application example

Clay is a professional web designer and developer responsible for maintaining the intranet and 
Internet sites of a medium-sized company of 1000 employees. One day, Jill from Human 
Resources comes to him with a problem. HR administers an employee fitness program that gives 
employees points for every mile walked, biked, or run. Each employee must report his or her 
monthly mile totals in an e-mail to Jill. At the end of the month, Jill gathers all the e-mail 
messages, calculates the number of points for each employee, and awards employees small cash 
prizes according to their point totals. 

Jill’s problem is that the fitness program has grown too successful. So many employees now 
participate that Jill is inundated with e-mails at the end of each month. Jill asks Clay if he can 
come up with a web-based solution.

Clay proposes an intranet-based web application that performs the following tasks: 

• Lets employees enter their mileage on a web page using a simple HTML form

• Stores the employees’ mileage in a database

• Calculates fitness points based on the mileage data

• Lets employees track their monthly progress

• Gives Jill one-click access to point totals at the end of each month

Clay gets the application up and running in no time using Macromedia Dreamweaver MX, which 
has the tools he needs to build this kind of application quickly and easily. He decides to use a 
small but robust database to store the information about each employee, and ColdFusion MX to 
process his dynamic pages. In addition to the features listed above, the application includes a set 
of search and results pages, so that Jill and the other employees can search for specific records in 
the database. It also includes a detail page for each employee, which contains extra information 
such as phone extension, cube location, and how long each employee has participated in the 
fitness program.

Over the next year, the company fitness program becomes so successful that it gains recognition 
from the local community. The president of the company decides to feature interactive pages 
about the program on the company’s Internet site. He asks Clay to develop an application that 
would allow users to perform the following tasks:

• Selectively view information about the fitness program history on one part of the screen

• Search for information about the program on another part of the screen

• Communicate with the fitness program director through an instant message

• View video clips of different fitness program activities
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Clay informs the president that all these tasks are possible with a Rich Internet Application. Using 
Macromedia Flash MX, Clay builds a new interface that incorporates all the requested 
information into a single web page. He also expands his server logic in Macromedia ColdFusion 
MX and deploys the new application by gathering all his application assets in Dreamweaver MX 
and publishing the new files to the company’s server. Visitors to the company’s Internet site are 
now able to view many different types of information about the fitness program in one screen. 
Additionally, each time a user interacts with a particular part of the page, only that section of the 
interface refreshes in the browser window.

Frequently used web application terms 

The following terms are used frequently when discussing web applications.

An application server is software that helps a web server process web pages containing server-side 
scripts or tags. When such a page is requested from the server, the web server hands the page off to 
the application server for processing before sending the page to the browser. For more 
information, see “How web applications work” on page 38.

Common application servers include Macromedia ColdFusion Server, Macromedia JRun Server, 
the Microsoft .NET Framework, IBM WebSphere, and Apache Tomcat.

A database is a collection of data stored in tables. Each row of a table constitutes one data record, 
and each column constitutes a field in the record, as follows: 

A database driver is software that acts as an interpreter between a web application and a database. 
Data in a database is stored in a proprietary format. A database driver lets the web application 
read and manipulate data that would otherwise be undecipherable. 

A database management system (DBMS, or database system) is software used to create and 
manipulate databases. Common database systems include Microsoft Access, Oracle 9i, and MySQL.

A database query is the operation that extracts a recordset from a database. A query consists of 
search criteria expressed in a database language called Structured Query Language (SQL). For 
example, the query can specify that only certain columns or only certain records be included in 
the recordset.

A dynamic page is a web page customized at runtime by an application server before the page is 
sent to a browser. For more information, see “How web applications work” on page 38.

Number LastName FirstName Position Goal

Records
(rows)

Fields (columns)
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A recordset is a subset of data extracted from one or more tables in a database, as in the following 
example: 

A relational database is a database containing two or more tables that share data. The following 
database is relational because the two tables share the DepartmentID column. 

A server technology is the technology that an application server uses to modify dynamic pages 
at runtime. 

A static page is a web page that is not modified at runtime by an application server before the 
page is sent to a browser. For more information, see “Processing static web pages” on page 38.

A web application is a website that contains pages stored on a web server with partly or entirely 
undetermined content. The final content of these pages is determined only when the user 
requests a page from the web server.

A web server is software that serves web pages in response to requests from web browsers. A page 
request is generated when a user clicks a link on a web page open in the browser, chooses a 
bookmark in the browser, or enters a URL in a browser’s Address box and clicks Go. 

Popular web servers include Microsoft Internet Information Server, Microsoft Personal Web 
Server, Apache HTTP Server, Netscape Enterprise Server, and iPlanet Web Server. 

Number

Database table

LastName FirstName Position Goals

Recordset table

LastName FirstName Position
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How web applications work

A web application is a collection of static and dynamic web pages. A static web page is one that 
does not change when a user requests it: the web server sends the page to the requesting web 
browser without modifying it. In contrast, a dynamic web page is modified by the server before it 
is sent to the requesting browser. The changing nature of the page is the reason it’s called dynamic. 

For example, you could design a page to display fitness results and leave certain information (such 
as employee name and results) to be determined when the page is requested by an employee. 

The following sections describe how web pages are processed and then discuss how you can 
develop dynamic web content using Macromedia Dreamweaver MX, Macromedia Flash MX, and 
ColdFusion MX.

Processing static web pages

A website comprises a set of related HTML pages and files hosted on a computer running a web server.

A web server is software that serves web pages in response to requests from web browsers. A page 
request is generated when a user clicks a link on a web page, chooses a bookmark in a browser, or 
enters a URL in a browser’s Address box and clicks Go. 

The final content of a static web page is determined by the page designer and doesn’t change 
when the page is requested. Here’s an example:

<html>
<head>
<title>Call Department</title>
</head>
<body>
<strong>Call Department</strong><br>
Talk to someone in Sales.
</body>
</html>

Every line of the page’s HTML code is written by the designer before the page is placed on the server. 
Because the HTML doesn’t change once it’s on the server, this kind of page is called a static page.

Note: Strictly speaking, a “static” page may not be static at all. For example, a rollover image or a Macromedia Flash 
movie can make a static page come alive. However, this guide refers to a page as static if it is sent to the browser 
without modifications.
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When the web server receives a request for a static page, the server reads the request, finds the 
page, and sends it to the requesting browser, as shown in the following figure:    

In the case of web applications, which contain dynamic as well as static web pages, certain lines of 
code are undetermined when the user requests the page. These lines must be determined by some 
mechanism before the page can be sent to the browser. The mechanism is discussed in the 
following section.

Processing dynamic web pages

When a web server receives a request for a static web page, the server sends the page to the 
requesting browser without delay. The web server reacts differently when it receives a request for a 
dynamic page: it passes the page to a special software extension responsible for finishing the page. 
This special software is called an application server. An example of an application server is 
Macromedia ColdFusion MX, which can be installed from the Macromedia Studio MX CD-ROM 
to run with a web server. For more information on installing ColdFusion MX, see Chapter 16, 
“Installing the Developer Edition of Macromedia ColdFusion MX Server,” on page 373.
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Step 1: Web browser
requests static page.

Step 2: Web server
finds page.

Step 3: Web server 
sends page to 
requesting browser.
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The application server reads the code on the page, finishes the page according to the instructions 
in the code, and then removes the code from the page. The result is a static page that the 
application server passes back to the web server, which then sends the page to the requesting 
browser. All the browser gets when the page arrives is pure HTML. Here’s a view of the process: 

Accessing a database

An application server lets you work with server-side resources, such as databases. For example, a 
dynamic page may instruct the application server to extract data from a database and insert it into 
the page’s HTML.

The instruction to extract data from a database is called a database query. A query consists of 
search criteria expressed in a database language called SQL (Structured Query Language). The 
SQL query is written into the page’s server-side scripts or tags. For more information, see 
Dreamweaver Help > Using Dreamweaver > Beginner’s Guide to Databases.

An application server cannot communicate directly with a database, because the database’s 
proprietary format renders the data undecipherable, in much the same way that a Word 
document opened in Notepad is undecipherable. The application server can communicate only 
through the intermediary of a database driver, software that acts like an interpreter between the 
application server and the database. 

After the driver establishes communication, the data source is queried and a recordset is created 
containing the query results. A recordset is a subset of data extracted from one or more tables in 
a database. The recordset is returned to the application server, and the data are used in the 
dynamic page.
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Here’s a simple database query written in SQL:

SELECT lastname, firstname, fitpoints
FROM employees

This statement creates a three-column recordset and fills it with rows containing the last name, 
first name, and fitness points of all employees in the database. For more information, see 
Dreamweaver Help > Using Dreamweaver > SQL Primer.

The following illustration shows the process of querying a database and returning data to the browser: 

You can use almost any database with your web application, as long as you have the appropriate 
database driver for it.
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If you plan to build small, low-cost applications, you can use a file-based database, such as one 
created in Microsoft Access. If you plan to build robust, business-critical applications, you can use 
a server-based database, such as one created in Microsoft SQL Server, Oracle 9i, or MySQL. 

If your database is located on a system other than your web server, make sure you have a fast 
connection between the two systems so that your web application can operate quickly and efficiently.

Authoring dynamic pages

Authoring a dynamic page consists of writing the HTML first, then adding the server-side 
scripts or tags to the HTML to make the page dynamic. When you view the resulting code, the 
language appears embedded in the page’s HTML. Accordingly, these languages are known as 
HTML embedded programming languages. The following example uses ColdFusion Markup 
Language (CFML):

<html>
<body>
<b>Call Department</b><br>
<!--- embedded instructions start here --->
<cfset department="Sales">
<cfoutput>

Talk to someone in #department#.
</cfoutput>
<!--- embedded instructions end here --->
</body>
</html>

The embedded instructions on this page perform the following actions: 

• Create a variable called Department and assign the string "Sales" to it.

• Write the variable’s string value, "Sales", in the HTML code. 

The application server returns the following page to the web server:

<html>
<body>
<b>Call Department</b><br>
Talk to someone in Sales.
</body>
</html>

The web server sends the page to the requesting browser, which displays it as follows:

Call Department
Talk to someone in Sales.

Developing Rich Internet Applications

With Macromedia Flash MX, developers have a new structured development model and set of 
server-side technologies for building faster, more powerful, and extremely flexible Rich Internet 
Applications. With tools for application server integration and new communication capabilities, 
Flash MX allows developers to deliver a new brand of applications that go beyond the traditional 
Internet application model described in the previous sections. Flash MX developers can use these 
new solutions to create next-generation applications such as a calendar application that 
automatically synchs data when users are connected, a shared whiteboard application that allows a 
group of users to contribute ideas from across the world, and an e-learning application that allows 
instructors to train multiple participants simultaneously.
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The fastest and most efficient way Flash MX communicates with application servers and web 
services is through the Flash Action Message Format (AMF), a high-performance, optimized 
protocol that runs over HTTP and enables ActionScript to invoke and use data and logic hosted 
on an application server, or an XML web service on the Internet. AMF supports passing both 
simple and complex data types between Flash ActionScript and any server-side programming 
language. AMF is enabled by Flash Remoting, a new server component included with 
ColdFusion MX and available for other J2EE and .NET servers.

The tight integration between Flash MX and ColdFusion MX allows ActionScript to call 
ColdFusion methods or functions. In the above illustration, a user interacts with a Flash movie 
embedded in an HTML page. The SWF file then uses AMF to communicate with the 
ColdFusion server, where previously defined ColdFusion services obtain data from the database 
and return the results to the Flash Player.

Flash MX introduces a new component model for encapsulating behavior and data associated 
with visual interfaces. This component model is complemented by ColdFusion Components 
(CFCs), a new server-side component model for encapsulating scripts and data used in 
ColdFusion MX. Flash components can be combined with ColdFusion Components to form rich 
client-server interactions.

For more information, see the Macromedia Flash ColdFusion Resource Center at 
www.macromedia.com/software/coldfusion/resources/flash_coldfusion/.
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CHAPTER 3

Web Development Workflow

This chapter demonstrates how the individual components of Macromedia Studio MX—
Dreamweaver, Flash, Fireworks, FreeHand, and ColdFusion—work together to provide an 
optimal design and application development environment for web designers and developers. As 
the Internet rapidly continues to evolve, users are coming to expect richer content, application, 
and communication experiences. At the same time, designers and developers increasingly demand 
tools that will allow them to create their content and applications more easily and less expensively 
while delivering those richer experiences to their users. Together, the tools of Macromedia Studio 
MX comprise a complete environment that enables the design and development of client-side 
interfaces for rich content and applications, and server-side logic for applications deployed with 
HTML clients, Flash clients, ColdFusion, and a variety of other server technologies.

A typical web development workflow involves the following stages:

• Planning the site, which includes defining the site’s strategy or goals, targeting an audience, 
and determining your site’s data source requirements.

• Setting up the development environment, which includes selecting your web and application 
servers and defining data sources.

• Planning page and screen design, which includes mapping out your pages and application 
interfaces with a drawing tool such as FreeHand, and laying out the pages in HTML with 
Dreamweaver MX.

• Creating content assets, which includes creating images and rich media with Flash MX, 
Fireworks MX, and FreeHand.

• Building application assets, which includes creating dynamic pages and Rich Internet 
Applications with Dreamweaver MX and Flash MX.

• Assembling, testing, and deploying your site, which includes compiling your assets, ensuring 
that you have met accessibility requirements, testing your code, and publishing your site to a 
server with Dreamweaver MX.

Macromedia Studio MX gives you all the tools you need to work through this process from start 
to finish. The combination of Dreamweaver, Flash, Fireworks, FreeHand, and ColdFusion lets 
you easily create, deploy, and maintain engaging, dynamic websites and applications in both 
coding and design environments. Your end results will be richer user interfaces that increase 
transaction efficiency, and more robust application logic that integrates with a broad range of 
back-end systems.
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This chapter introduces a sample web development workflow. While it suggests methods for 
maximizing your design and development efforts, it does not provide the only workflow possible. 
The workflow that you and your team members adopt will depend on your resources, your 
personal working habits, and the specific needs of your website. This chapter is intended to 
provide ideas and best practices for designing and developing websites and applications with 
Macromedia Studio MX.

For more information on any of the individual products in Macromedia Studio MX, see chapters 
4 through 17 of this book, or each product’s help system (Help > Using Dreamweaver, Help > 
Using Flash, and so on). 

Planning your website
Planning and organizing your site involves much more than determining what the site will look 
like and where the files will go: to plan your site you need to examine the site goals, static and 
dynamic page requirements, and audience profiles. Additionally, you should consider technical 
requirements such as user access and browser, plug-in, or download restrictions. Careful planning 
before you begin site development will save you a great deal of time later.

Establishing site goals and determining your audience

Determining your site goals is the very first step you should take when you create a website. Ask 
yourself or your client questions about the site, and write down your goals so that you remember 
them as you go through the design process. A specific list of goals will help you focus and target 
your website to your particular needs. The complexity of your goals will affect the navigation, the 
media that you use, and even the look and feel of your site. A website that provides news about a 
specific subject should have a very different look and navigation from that of a website that sells 
products. Similarly, a site that delivers rich content and applications to its users will look very 
different from a site that displays dynamic data using more traditional, HTML-based methods.

After you have decided what you want your website to accomplish, you need to decide who you 
want your visitors to be. This may seem to be an unnecessary question, since most people want 
everyone to visit their website; but it is difficult to create a website that every person in the world 
will be able to use. People around the world use different browsers, connect at different speeds, 
may or may not have media plug-ins, and use different types of devices to view Internet content. 
Because all of these factors can affect the use of your site, determining your target audience is a 
crucial step during the initial phase of website planning.

Think about the people who will be attracted to your website, and whom you hope to attract. 
What kinds of computers do you think they will be using? What platform might be the 
dominant one (Macintosh, Windows, Linux, and so on)? What is their average connection speed 
(33.6 Kbps modem or DSL)? What kinds of browsers, monitor sizes, and other devices will they 
be using? Are you creating an intranet site where everyone will be using the same computer, 
operating system, and browser? All of these factors can greatly affect the way your web page 
appears to visitors and will also affect the way you test your site once you’ve created it.
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Determining data source requirements and creating a database

Whether you are developing a Rich Internet Application with Macromedia Flash MX, or a more 
traditional HTML-based web application with Macromedia Dreamweaver MX, you will 
probably use a database to store the information that your website will deliver to your users. 
Before you build your database, however, you must determine the data source requirements for 
your website. If you want to display dynamic data on your web pages, what type of data will you 
display and where? If users are going to interact with an application interface, what types of 
questions will they be asking the application to answer, and what information will they want to 
retrieve from the database? As with site goals and target audiences, you should have a firm idea of 
what your data source requirements will be before you begin developing your website.

After you have determined your data source requirements, think about how to structure a 
database that will optimally convey stored information to your users. You can decide how you 
want to structure your database before you begin conceptualizing your page layouts, or while you 
develop the application interface itself. Your individual workflow needs will determine exactly 
how and when you create your database. 

The first step is to choose the tables in the database. A database table contains collections of 
related entities, such as persons, objects, or events, and divides this information into horizontal 
rows and vertical columns. In database terminology, each table column represents a field, and 
each table row represents a record.

Once you have decided on the number and types of tables that will make up your database, 
choose the columns for each table. Columns describe the properties of each entity or record in the 
table. For example, you might have a database table called Players that contains information 
about members of a hockey team. The Players table might contain a column for each team 
member’s first name, last name, position, number of goals, and so on (see the image above). Each 
horizontal row in the Players table would represent a single record for an individual team 
member, much like a trading card contains information about a particular person.

Make sure each of your tables has a primary key column—a column that contains values unique 
to each row in the table. This allows you to select an exact row when searching the database. Most 
primary key columns consist of ID numbers, but you can use other kinds of primary keys such as 
government form numbers or product serial numbers. 

For more information, see your database vendor’s documentation.

Number LastName FirstName Position Goal

Records
(rows)

Fields (columns)
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Sketching the site navigation in FreeHand and presenting the plan in HTML

Once you have determined your site’s goals, target audience, and data source requirements, you 
are ready to begin conceptualizing the site’s navigation scheme. The site navigation is a “map” that 
depicts how your web pages relate to one another. Specifically, it shows how users will travel 
through your site as they click links and interact with application interfaces.

You can use Macromedia FreeHand to conceptualize your site’s navigation scheme.

FreeHand allows you to create vector graphics quickly and efficiently while providing common 
user interface elements that help you easily integrate Macromedia Flash MX and Fireworks MX 
into your web development workflow. For instance, the Tools panel is one of many user interface 
features shared by these Macromedia Studio MX products. It contains tools that allow you to 
select, draw, and edit objects, apply color to objects, and create text.

After sketching your site navigation, you can present the preliminary plan to your client or 
members of your group. FreeHand allows you to convert your drawings to HTML pages in one 
easy step. The Publish HTML feature translates your document into HTML and opens your 
illustration directly in a browser window.

For more information, see “FreeHand Basics” and “Creating Web Graphics and Animation” in 
FreeHand Help > Using FreeHand.
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Setting up the development environment
Whether you are developing your project single-handedly or collaborating with a team of people, 
you need to set up a development environment before you begin using Macromedia Studio MX 
to build your website. At the most basic level, your development environment will consist of a 
web server, an application server, and a Dreamweaver MX site.

Setting up your web and application servers

A web server is software that serves files in response to requests from web browsers. When the web 
server receives a request for a static HTML page, the server reads the request, finds the page, and 
sends it to the requesting browser. Common web servers include Microsoft Internet Information 
Server (IIS), Netscape Enterprise Server, iPlanet Web Server, and Apache HTTP Server. For more 
information, see “Understanding Web Technologies and Applications” on page 31.

Choose a web server and install it on your local computer or on a networked computer. For more 
information, see the server vendor’s documentation or your system administrator.

To run HTML-based or Rich Internet Applications, your web server needs to work with an 
application server. An application server is software that helps the web server process dynamic 
pages before the pages are sent to requesting browsers by the web server. The application server 
reads the code on the dynamic page, finishes the page according to the instructions in the code, 
then strips out the code. In the case of an HTML-based application, the result is a static page of 
HTML that the application server passes back to the web server, which then sends the page to the 
requesting browser. In the case of a Rich Internet Application, the result is a Flash movie that 
returns the variables requested by the browser.

Your choice of application server will depend on several factors, including your budget, the server 
technology you want to use, and the web server you choose. Macromedia ColdFusion MX and 
JRun servers provide easy-to-administer, cost-effective solutions. Enhanced integration with Flash 
MX and Dreamweaver MX makes ColdFusion MX the ideal choice for building and deploying 
powerful Internet applications.

Application servers use different technologies. Dreamweaver MX supports five server 
technologies: ColdFusion, ASP.NET, ASP, JSP, and PHP. The following table shows common 
application servers available for these five server technologies.

Make sure the application server you want to use works with your web server. For example, the 
.NET Framework works only with Microsoft IIS.

Server technology Application server

ColdFusion Macromedia ColdFusion MX

ASP.NET Microsoft IIS 5 with .NET Framework

ASP Microsoft IIS or PWS
Sun Chili!Soft ASP

JSP Macromedia JRun
IBM WebSphere
Jakarta Tomcat
BEA WebLogic

PHP PHP server
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After your web and application servers are up and running, create a root folder for your 
application on the computer running the web server. Make sure the folder is published by the web 
server—in other words, that the web server can serve any file in this folder or in any of its 
subfolders in response to an HTTP request from a web browser. For example, on a computer 
running PWS or IIS, any file in the Inetpub/wwwroot folder or in any of its subfolders can be 
served to a web browser.

For more information, see Dreamweaver Help > Using Dreamweaver > Setting up an 
application server.

Defining your site in Dreamweaver MX

In Dreamweaver MX, the term site can refer either to a website or to a local storage location for 
the documents belonging to a website. The latter is what you need to establish before you begin 
building your website. A Dreamweaver MX site organizes all the documents associated with your 
website and enables you to track and maintain links, manage files, share files, and FTP your site 
files to a web server. Dreamweaver MX does not work properly unless you define a site.

The preferred approach to creating a website using Dreamweaver MX is to create and edit pages 
on your local disk, and then upload copies of the site’s files to a remote web server to make them 
publicly available. You use the Dreamweaver MX Site Definition window (Site > New Site) to 
define local and remote site information, and then you use the Site panel to manage your site.

The Site panel lets you choose between four different views: Local, Remote, Testing Server, and Map.

Local view displays the website files that you are storing on your local machine.

Remote view displays the files that you have published to your web server. If you are developing a 
web application, the remote folder is the root folder you created for your web application on the 
web server.

Testing Server view displays the directory structure of the testing server. Typically, this is also the 
root folder you created for your web application on the web server.

Map view displays a graphical map of your site based on how the documents are linked to one another.

For more information, see Dreamweaver Help > Using Dreamweaver > Defining a Dreamweaver Site.
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Establishing ColdFusion data sources

A ColdFusion data source is a one-word identifier, such as Acme, that points to the database and 
contains all the information needed to connect to it. ColdFusion data sources are similar to 
Windows data source names (DSNs) in that they automatically include all the DSNs set up on 
the Windows system running ColdFusion. They’re unlike DSNs in that you can create data 
sources for databases using Object Linking and Embedding DataBase (OLE DB) providers or 
native drivers. (DSNs can point to databases only if you’re using Open DataBase Connectivity 
(ODBC) drivers installed on a Windows computer.)

You can create a data source using ColdFusion Administrator. If you’re using an ODBC driver on 
a Windows computer, you can also set up a DSN on the computer. System DSNs are 
automatically treated as ColdFusion data sources.

When you open a ColdFusion page in Dreamweaver, ColdFusion data sources appear in the 
Databases panel (Window > Databases).

You can modify these data sources directly from the Dreamweaver MX workspace. Click the 
Modify Data Sources button in the upper right corner of the Databases panel, and Dreamweaver 
MX automatically launches ColdFusion Administrator.

For more information, see Dreamweaver Help > Using Dreamweaver > Database connections for 
ColdFusion developers.

For more information on ASP.NET, ASP, JSP, and PHP database connectivity, see “Database 
connections for ASP.NET developers,” “Database connections for ASP developers,” “Database 
connections for JSP developers,” and “Database connections for PHP developers” in 
Dreamweaver Help > Using Dreamweaver.
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Establishing a source control system in Dreamweaver MX

If you’re working in a collaborative environment, you can check files in and out from local and 
remote servers. Checking out a file is the equivalent of declaring “I’m working on this file now—
don’t touch it!” When a file is checked out, Dreamweaver MX displays the name of the person who 
checked out the file in the Site panel, along with a red check mark (if one of your team members 
checked out the file) or green check mark (if you checked out the file) next to the file’s icon.

Checking in a file makes the file available to other team members to check out and edit. When you 
check in a file after editing it, a lock symbol appears beside your local version, indicating it is 
read-only. This prevents you from making changes to the file when you do not have it checked out.

For more information, see Dreamweaver Help > Using Dreamweaver > Setting up the Check In/
Check Out system.

Planning page and screen design
A web design project usually begins with storyboards or flowcharts that the designers and 
developers then turn into sample pages. You can use Macromedia Studio MX to create mock-up 
sample pages as you work toward a final design. Mock-ups typically depict the pages’ design 
layout, technical components, themes and color, graphic images, and other media elements. Your 
mock-up should look like a blueprint that you and your other team members will follow when 
designing the site. Once you have a visual guideline of how you’d like your pages to look, you can 
begin planning page layouts in Dreamweaver.
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Creating page mock-ups with FreeHand to determine your site’s look and feel

Planning your page design and layout before you actually begin building your web pages will save 
you a great deal of time during the development process. It is important to maintain consistency in 
your page design and layout. Give your site pages a similar look, color scheme, navigation, and so 
forth. This will help avoid confusing your users and will help you deliver a better user experience.

Macromedia FreeHand is ideal for sketching a preliminary design for the main pages of your website.

The impressive design tools in FreeHand let you maximize your creative abilities while designing 
sophisticated vector-based illustrations. The FreeHand Pen tool looks and behaves exactly like the 
Pen tool in Macromedia Flash MX and Fireworks MX, offering a seamless transition when you 
work between applications. FreeHand color selection models and interfaces also look like and 
behave identically to those in Flash, Fireworks, and Dreamweaver.
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Creating Flash screen mock-ups

You can also use Macromedia FreeHand to create mock-ups for your Flash animations and Rich 
Internet Application interfaces.

FreeHand is the ideal choice for creating Flash screen mock-ups because of its tight integration 
with Macromedia Flash MX. FreeHand provides all the traditional Bézier tools users expect in a 
professional drawing package, and it expands the creative relationship with Flash by offering 
complex vector-graphic editing capabilities. The Test Movie feature lets you see how your 
FreeHand artwork will appear when imported into Flash.

After you’ve created your screen mock-ups, import your FreeHand work directly into Flash. 
FreeHand illustrations become the building blocks of your Flash movies, saving you and your 
team members the extra effort of re-creating movie assets in Flash. You can preserve FreeHand 
layers, text blocks, library symbols, and pages, and choose a page range to import.

For more information, see FreeHand Help > Using FreeHand > Exporting Flash movies, or 
Flash Help > Using Flash > Importing FreeHand files.
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Creating page layouts in Dreamweaver MX

Page layout is one of the most important parts of web design. The term page layout refers to the 
way your page will look in the browser, such as where menus, images, and Flash movies will be 
placed. Macromedia Dreamweaver MX gives you several different ways to create and control your 
web page layout.

One common method for creating a page layout is to use HTML tables to position elements. 
Tables can be difficult to use, however, since they were originally created for displaying tabular 
data, not for laying out web pages.

To streamline the process of using tables for page layout, Dreamweaver provides Layout view. In 
Layout view, you can design your page using tables as the underlying structure, while avoiding 
some of the traditional pitfalls of using tables. For example, you can easily draw layout cells on 
your page, then move the cells where you want them. Your layout can have a fixed width, or it can 
automatically stretch to the full width of the browser window. When you switch back to Standard 
view, your page will contain table cells and columns that correspond to the layout cells you placed 
on the page.

Open a new Dreamweaver file (File > New) to begin planning your web page. In Layout view 
(View > Table View > Layout View), lay out your page before adding any content. Draw layout 
cells to hold header graphics, navigation bars, Flash movies, and other assets.

When you draw a layout cell that isn’t inside a layout table, Dreamweaver automatically creates a 
layout table as a container for the cell. A layout cell cannot exist outside of a layout table. You can 
lay out your page using several layout cells within one layout table—which is the most common 
approach to web-page layout—or you can use multiple layout tables for more complex layouts. 
Using multiple layout tables isolates sections of your layout, so that they aren’t affected by changes 
in other sections.
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You can also nest layout tables by placing a new layout table inside an existing layout table. This 
structure allows you to simplify the table structure when the rows or columns in one part of the 
layout don’t line up with the rows or columns in another part. For example, using nested layout 
tables, you could easily create a two-column layout with four rows in the left column and three 
rows in the right column.

Later, you can add text, images, and other content to layout cells in Layout view just as you would 
add content to table cells in Standard view.

For more information, see Dreamweaver Help > Using Dreamweaver > Laying out pages in 
Layout view.

Creating content assets
Once you know what your design and layout will look like, you can create and gather the assets 
that you will need. Assets can be items such as images, text, Flash movies, or other media. The 
Dreamweaver MX Assets panel (Window > Assets) displays and provides access to all the assets in 
your site.

Creating images in FreeHand and Fireworks MX

You can use both Macromedia FreeHand and Fireworks MX to create images for your website.

Macromedia FreeHand is a vector-based drawing application. With FreeHand, you can create 
print and web graphic illustrations such as figures, logos, and advertising banners. You can also 
use FreeHand to turn your artwork into Flash animations. The FreeHand workspace and Tools 
panel are consistent with those in the other Macromedia Studio MX products. You have already 
seen how FreeHand can be used to storyboard a website, Flash animation, or Rich Internet 
Application. For more information, see “Planning page and screen design” on page 52.

Macromedia Fireworks MX is the ideal tool for professional web graphics design and production. 
It is the first production environment to address the special challenges facing web graphic 
designers and developers. Using Live Effects in Fireworks, you can enhance graphics by applying 
bevels, embossing, drop shadows, glows, and other effects to vector objects, bitmaps, and text. 
Live Effects are nondestructive, meaning they are always editable. Fireworks also generates 
JavaScript, making rollovers, buttons, and pop-up menus easy to create, and its optimization 
features shrink the file size of web graphics without sacrificing quality.
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You can use Fireworks to create, edit, and animate web graphics, add advanced interactivity, 
and optimize images. You can easily edit optimization settings in the Export Preview dialog box 
(File > Export Preview).

Fireworks MX combines both bitmap- and vector-editing tools. In Fireworks, everything is 
editable, all the time. And you can automate workflow tasks to meet the demands of updates and 
changes. Like FreeHand, Fireworks integrates with other Macromedia Studio MX products in 
sophisticated ways that help you optimize your workflow. Once you’ve created your images and 
included them in your site, you can launch, edit, and work in Fireworks without ever having to 
leave the Dreamweaver or Flash workspaces.

Creating rich media elements with Flash MX

Flash movies are graphics, text, animation, and applications for websites. They consist primarily 
of vector graphics, but they can also contain imported video, bitmap graphics, and sounds. Flash 
movies can incorporate interactivity to permit input from viewers, and you can create nonlinear 
movies that interact with other web applications. Flash movies use compact vector graphics, so 
they download rapidly and scale to the viewer’s screen size.

You’ve probably watched and interacted with Flash movies on many websites. Millions of Web 
users have received the Flash Player with their computers, browsers, or system software; others 
have downloaded it from the Macromedia website. The Flash Player resides on the local 
computer, where it plays back movies in browsers or as stand-alone applications. Viewing a Flash 
movie on the Flash Player is similar to viewing a DVD on a DVD player—the Flash Player is the 
device used to display the movies you create in the Flash authoring application.
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Flash documents, which have the .fla filename extension, contain all the information required to 
develop, design, and test interactive content. However, Flash documents are not the movies the 
Flash Player displays. Instead, you publish your FLA documents as Flash movies, which have the 
.swf filename extension and contain only the information needed to display the movie.

Using Flash, you can animate objects to make them appear to move across the Stage and change 
their shape, size, color, opacity, rotation, and other properties. You can create frame-by-frame 
animation, in which you designate a separate image for each frame, or tweened animation, in which 
you set the first and last frames of an animation and direct Flash to create the frames in between.

Additionally, Flash provides a variety of methods for creating original artwork and importing 
artwork from other applications. You can create objects with the drawing and painting tools, as 
well as modify the attributes of existing objects. You can also import vector graphics, bitmap 
graphics, and video from other applications (such as FreeHand and Fireworks), and modify the 
imported graphics in Flash.

For more information, see Flash Help > Using Flash > Working in Flash.

Creating templates and libraries for reusing assets

Dreamweaver templates and libraries can help you create web pages with a consistent design. 
Using templates and libraries also makes it easier to maintain your website, since they let you 
redesign your site and change hundreds of pages in seconds.

A template is a document you can use to create multiple pages that share the same layout. 
When you create a template, you can indicate which elements of a page should remain 
constant (non-editable, or locked) in documents based on that template, and which elements 
can be changed.
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For example, if you’re publishing an online magazine, the masthead and overall layout probably 
won’t change from one issue to the next, or even from one story in the magazine to the next, but 
the title and content of each story will be different. A designer can create the layout of a story page 
for the magazine, with placeholder text where the story’s title and contents will be (and with those 
regions marked as editable); the designer can then save that layout as a template. The person 
putting together a new issue of the magazine creates a new page based on the template, and 
replaces the placeholder text with the actual title and text of the new story.

You can modify a template even after you’ve created documents based on it. When you modify a 
template, the locked (non-editable) regions in the documents that are based on the template are 
updated to match the changes to the template.

Templates are best for situations in which you want a set of pages to have an identical layout—
when you want to design the complete final layout for a set of pages first, and then add content 
later. If you simply want your pages to have the same headers and footers, with different layouts in 
between, use library items instead. Library items are page elements such as images, text, Flash 
movies, and other media that you can reuse or update frequently throughout your website. As 
with templates, you can update all the pages that use a library item whenever you change the 
item’s contents.

For example, suppose you’re building a large site for a company. The company has a slogan that it 
wants to appear on every page of the site, but the marketing department is still ironing out the 
details of just what the slogan should say. If you create a library item to contain the slogan and use 
that library item on every page, then when the marketing department provides the final slogan, 
you can change the library item and automatically update every page that uses it.

For more information, see Dreamweaver Help > Using Dreamweaver > Managing site assets, 
libraries, and templates.

The Flash MX library lets you easily reuse your assets. The library in a Flash document stores 
symbols created in Flash, plus imported files such as video clips, sound clips, bitmaps, and vector 
artwork. The Library panel displays a scroll list with the names of all items in the library, allowing 
you to view and organize these elements as you work. You can open the library of any Flash 
document while you are working in Flash to make the library items from that file available for the 
current document. You can create your own permanent libraries that will be available whenever you 
launch Flash, or use any of several sample libraries that come with Flash. The sample libraries 
contain buttons, graphics, movie clips, and sounds that you can add to your own Flash documents.

For more information, see Flash Help > Using Flash > Using the library.

Building application assets
A powerful aspect of dynamic web application development is the ability to present database-
stored information in a web format. Macromedia Studio MX products help you build such 
applications rapidly, providing a wide range of features that increase developer productivity, from 
prebuilt components and templates to an integrated workflow and shared user interface. Using 
Macromedia Studio MX, designers and developers can create responsive HTML-based or Rich 
Internet Applications that combine the functionality of traditional client/server solutions with the 
broad reach and low-cost deployment of web applications.
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Building dynamic pages in Dreamweaver MX

A key benefit provided by Macromedia Dreamweaver MX is the ability to create dynamic 
websites without having to be experienced in programming languages. The Dreamweaver visual 
tools let you develop dynamic websites without having to hand-code the complex programmatic 
logic required to create a site supporting the display of dynamic content stored in a database. 
Dreamweaver lets you create dynamic websites using any of several popular web programming 
languages and server technologies, including ColdFusion, ASP.NET, Microsoft Active Server 
Pages (ASP), JavaServer Pages (JSP), and PHP.

For coders, Dreamweaver MX offers enhanced runtime code and a code-centric workspace 
derived from Macromedia ColdFusion Studio and Macromedia HomeSite+. You can work in 
Code view, Design view, or Code and Design view, which enables you to see both your code and 
your interfaces as you develop your dynamic pages and applications. The ColdFusion code that 
Dreamweaver generates for your dynamic pages is now easier to understand and looks more like 
what you would write by hand. The code will be familiar to anyone who has learned ColdFusion 
techniques from popular textbooks or online tutorials.

Dynamic websites require a content source from which to extract data before they can display it 
on a web page. In Dreamweaver, these data sources can be databases, request variables, server 
variables, form variables, or stored procedures.

Before you can use these content sources in a web page, you must do the following:

• Create a connection to the dynamic content source (such as a database) and the application 
server processing the page.

• Specify what information in the database you want to display, or what variables you want to 
include in the page.

• Use the Dreamweaver point-and-click interface to select and insert dynamic content elements 
into the selected page.

Dreamweaver allows you to easily connect to a database and create a recordset from which to extract 
dynamic content. A recordset is the result of a database query. It extracts the specific information 
you request and allows you to display that information within a specified page. You define the 
recordset based on the information contained in the database and the content you want to display.
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To create a recordset in Dreamweaver, you use the Recordset dialog box.

You can launch the Recordset dialog box either by using the Application pane of the Insert bar or 
by clicking the Plus (+) button in the Bindings panel and choosing Recordset (Query). The 
Simple Recordset dialog box lets you select an existing database connection and create a database 
query by selecting the table or tables whose data you want to include in the recordset. You can 
even use the Filter section of the dialog box to create simple search and return criteria for the 
query. You can test the query from within the Recordset dialog box, and make any needed 
adjustments before adding it to the Bindings panel.

Once a database connection is established and a recordset defined, the recordset appears in the 
Bindings panel. 
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From here you can import your data sources into any web page within the defined site. You can 
insert any of the values shown in the Bindings panel into a web page by selecting the item and 
clicking the Insert button at the bottom of the panel. Alternatively, you can select an item and 
drag it onto the page, just as you would any image or media element from the Assets panel.

In the above illustration, you can see the dynamic placeholders for headlines and headline 
descriptions that have been dragged to the page from the Bindings panel. In front of the 
Dreamweaver file, you can see the output when a user views the page in a browser window. The 
Dreamweaver file includes a Repeat Region server behavior, which allows you to display multiple 
records on a single page. (In this case, it is displaying the first three records in the database.) It also 
contains a placeholder for a dynamic image, which the user sees as the triangular bullet, repeated 
for each news item.

For more information, see Dreamweaver Help > Using Dreamweaver > Making Pages Dynamic.

In addition to displaying dynamic data, Dreamweaver MX lets you build sets of pages that enable 
your users to search, insert, delete, and update records in your database. For example, you can 
rapidly develop a powerful application that will enable you to post a directory of employees on 
your company’s intranet, search the directory by parameters of your choice (name, department, 
and so forth), add and delete records to and from the directory, and change records in the 
database. You can do all this without ever having to type a line of code. More advanced users have 
the option of using the enhanced coding environment in Dreamweaver MX.

For more information, see Dreamweaver Help > Using Dreamweaver > 
Developing Applications Rapidly.
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Building Rich Internet Application assets with Flash MX

Macromedia Flash MX combines a broad range of multimedia design and Rich Internet 
Application development abilities in one product. Developers can build Rich Internet 
Applications using the multimedia capabilities of Flash along with its sophisticated tools, 
including a powerful ActionScript editor, a robust debugger, and predefined Flash components. 

While Flash MX provides an open framework for application development with .NET, and J2EE 
servers, enhanced integration with ColdFusion MX offers the fastest way for developers to build 
Rich Internet Applications. Broad-ranging support includes code samples and reference material, 
high-performance connectivity, common language support between Dreamweaver, Flash, and 
ColdFusion, seamless integration with Flash components, and an integrated tool set for uniting 
back-end logic with Flash user interfaces.

You begin building your Flash/ColdFusion Rich Internet Applications by building Flash services 
in ColdFusion. Flash services consist of any ColdFusion functionality that you expose to Flash. 
For more information, see Dreamweaver Help > Using ColdFusion > Building Flash Services.

Next, you create your Flash application interfaces using previously designed FreeHand graphics, 
or page elements designed in Flash. Flash MX offers enhanced design tools, such as the Free 
Transform tool. You can easily align your bitmaps, lines, and fills with precision to pixel 
boundaries on the Stage. Color Mixer enhancements in Flash MX make it easier than ever to mix 
colors and create color swatches.

You can use the Flash user interface components, including scroll bars, rich text fields, input buttons, 
radio buttons, check boxes, and list and combo boxes, to develop your Rich Internet Applications.

These components ensure a common user experience across Rich Internet Applications created 
with Flash MX. You can also create customized, reusable components to meet the demands of a 
variety of projects. The Live Preview feature gives you immediate feedback on user interfaces built 
with components through a live, inline rendering of how components will look in a published 
movie. For more information, see Flash Help > Using Flash > Using Components.

The benefits of developing Rich Internet Applications in Flash are numerous. With Rich Internet 
Applications you can reach millions of users while reducing server load and content download 
time, include animation, audio, video, and two-way messaging in a single interface, deliver fully 
accessible content to users with disabilities, provide immediate rich content experiences regardless 
of connection speed, and develop for multiple device platforms (such as wireless handsets, ITV, 
and game consoles), allowing rich content and applications to be viewed anywhere. Information 
exchanged between the Flash Player and the application server does not require a full-page refresh, 
resulting in lower bandwidth costs, increased user efficiency, and an overall better user experience.
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For more information, see Flash Help > Using Flash > Application development in Flash, and the 
Flash ColdFusion Resource Center at http://www.macromedia.com/software/coldfusion/
resources/flash_coldfusion/.

Assembling, testing, and deploying
The last phase of the web development process is assembling the assets you’ve created, testing the 
web pages you’ve built, and deploying your site to a server so that the world can see it. 
Macromedia Studio MX provides a number of features that help you streamline this process.

Assembling your assets in Dreamweaver MX

Using Dreamweaver MX, you can easily add many types of content to web pages. You can add 
assets and design elements, such as text, images, colors, movies, sound, and other forms of media. 
The Assets panel (Window > Assets) lets you easily organize the assets in a site; you can drag most 
assets directly from the Assets panel into a Dreamweaver document.

In addition to dragging saved assets to the page from the Assets panel, you can do the following:

• Type directly in a Dreamweaver document, or import text from other documents, then format 
the text using the Dreamweaver Property inspector or HTML Styles panel.

• Insert images, including rollover images, image maps, and Fireworks sliced images. Alignment 
tools help you position images on a page.

• Insert other types of media in a web page, such as Flash, Shockwave, and QuickTime movies, 
sound, and applets.

• Add content in the Dreamweaver code editors. Using the Dreamweaver Code view or Code 
inspector, you can write your own HTML or JavaScript code.

• Create standard HTML links, including anchor links and e-mail links, or easily set up 
graphical navigation systems, such as jump menus and navigation bars.

• Apply reusable content throughout your site using Dreamweaver templates and library items. 
You can create new pages from a template, then add or change content in the editable areas.
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Once you have assembled your assets, you can edit them directly from the Dreamweaver 
workspace. You can launch Fireworks to edit images inserted in a Dreamweaver document by 
selecting the image and clicking the Fireworks Edit button in the Property inspector. When you 
launch and edit an image or an image slice that is part of a Fireworks table, Dreamweaver 
launches Fireworks and the PNG file from which the image was exported.

In the PNG file’s window, Fireworks tells you that you are editing the image from Dreamweaver. 
When you finish your edits and close the PNG file, your saved changes appear in the image in the 
Dreamweaver document (GIF, JPG, and so on) that you selected for editing.

Similarly, you can edit Flash files by selecting the Flash movie placeholder in the Dreamweaver 
document and clicking the Flash Edit button in the Property inspector. Dreamweaver launches 
the Flash file (FLA) and saves any changes you make in it to the SWF file.

For more information, see “Working with Dreamweaver and Fireworks” and “Working with 
Dreamweaver and Flash” in Dreamweaver Help > Using Dreamweaver.

Using Dreamweaver MX and Flash MX to ensure accessibility

Macromedia supports efforts to make websites and web products accessible to people with visual, 
auditory, motor, and other disabilities. Flash MX and Dreamweaver MX provide tools that help 
you author accessible content. Examples of accessibility features for websites include screen reader 
support, labels and descriptions for graphics, keyboard shortcuts, high-contrast display colors, 
and so on. Additionally, Dreamweaver provides features that make the software product itself 
accessible to impaired users. Specifically, Dreamweaver supports screen readers, operating system 
accessibility features, and keyboard navigation.
Web Development Workflow 65



To make information accessible to screen readers and to your website users, Dreamweaver supports 
caption text for graphic elements, including push buttons, controls, images, and tables. This enables 
you to add labels and descriptions to elements so that a screen reader can read them to the user.

For example, you could add the description “Boy’s red jacket size large” to a product image in 
your document. Then, when the image appears on a page for a sight-impaired user, the screen 
reader reads the description, and the user knows which product is being displayed on the page.

Accessible Flash movie content is supported by the Flash Player 6. To take advantage of accessible 
Flash content, users must have a Windows operating system that supports Flash accessibility, and 
the appropriate screen reader software (including Flash Player 6).

Flash provides several accessibility authoring features that go beyond simply providing names for 
objects. You can provide a description for text or text fields, buttons, or movie clips, and keyboard 
shortcuts for input text fields or buttons. You can also turn off automatic labeling behavior for 
your movie, which prevents text strings from being read by screen readers.

Additionally, you can choose to hide a selected object from screen readers. For example, you might 
choose to hide animated movie clips if you think the verbal description does not enhance the 
accessible version of the movie. You can also choose to hide accessible objects that are contained 
inside a movie clip or movie, and expose only the movie clip or movie itself to screen readers.

Keep in mind that screen reader technology is designed primarily to convey information about 
static user interfaces. Making your Flash movie accessible will be most successful if you keep 
dynamic content to a minimum, and emphasize text and user interface features. You can select 
which objects in a movie to expose to a screen reader, and you can omit animations or visually 
oriented movie clips to increase accessibility.

Designing accessible websites requires that you understand accessibility requirements and make 
many ongoing subjective decisions that cannot be made by a development tool. For example, one 
accessibility requirement is that you not convey meaning with color. The only way to ensure that 
a website is accessible is through deliberate planning, development, testing, and evaluation.

For more information, see Dreamweaver Help > Using Dreamweaver > Dreamweaver and 
Accessibility and Flash Help > Using Flash > Creating Accessible Content.

You can also visit the Macromedia Accessibility Resource Center at http://macromedia.com/
macromedia/accessibility/ to learn more about making your web content meet government 
accessibility requirements.

Testing and validating HTML and JavaScript in Dreamweaver MX

You can use the Dreamweaver Validator to determine if your code contains tag or syntax errors. 
The Validator supports many tag-based languages, including HTML 2.0, HTML 3.2, HTML 
4.0, XHTML 1.0 Strict, Internet Explorer 3.0 Extensions, Internet Explorer 4.0 Extensions, 
Netscape Navigator 3.0 Extensions, Netscape Navigator 4.0 Extensions, ColdFusion, ColdFusion 
3.0, ColdFusion 3.1, ColdFusion 4.0, ColdFusion 4.5, ColdFusion 5.0, Synchronized 
Multimedia Integration Language 1.0, Wireless Markup Language, and JavaServer Page Tags. You 
can also validate a document as an XML (or XHTML) document.

Using the JavaScript Debugger, you can isolate errors in your client-side JavaScript code. You can 
write code in Code view (or the Code inspector), then run the debugger to check your code for 
syntax and logical errors. If the page has one or more syntax errors, the browser displays an error 
message; if your page contains a logical error, your page functions incorrectly but the browser does 
not display an error message.
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The debugger checks your code for syntax errors first, and then runs with the browser to help you 
identify any logical errors. If you have logical errors, you can use the JavaScript Debugger window 
to examine variables and document properties while your program is running. You can set 
breakpoints (similar to alert statements) in your code to stop the execution of the program and 
display the values of JavaScript objects and properties in a variable list. You can also step to the 
next statement or step into a function call to see the variable values change.

For more information, see “Validating your tags” and “Using the JavaScript Debugger” in 
Dreamweaver Help > Using Dreamweaver.

Debugging dynamic pages in Dreamweaver MX

While developing Macromedia ColdFusion applications, you can configure ColdFusion to 
display information in a browser to help you debug the application. For example, if a page 
contains an error, ColdFusion displays possible causes for the error at the bottom of a ColdFusion 
page when you open the page in a browser. You can view this information and fix the page 
without leaving the Dreamweaver workspace.

Note: This feature is not supported on the Macintosh. Macintosh developers can use the Preview in Browser 
command or F12 to open a ColdFusion page in a separate browser. If the page contains errors, information about 
the possible causes for the error appears at the bottom of the page.

To debug a ColdFusion page without leaving the Dreamweaver workspace, open the ColdFusion 
page in Dreamweaver and click the Server Debug icon on the document toolbar, or select View > 
Server Debug.

Dreamweaver requests the file from the ColdFusion MX server and displays it in an internal 
Internet Explorer browser window. If the page contains errors, possible causes for the errors 
appear at the bottom of the page. At the same time, a Server Debug panel opens. The panel 
provides a large amount of useful information, such as all the pages the server processed to render 
the page, all the SQL queries executed on the page, and all the server variables and their values, if 
any. The panel also provides a summary of execution times.

For more information, see Dreamweaver Help > Using Dreamweaver > 
Using the ColdFusion Debugger.

Server Debug icon
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Debugging Flash movies

The Flash Debugger allows you to find errors in a movie while it’s running in the Flash Player. 
You can use the Debugger in test mode with local files, or you can use the Debugger to test files 
on a web server in a remote location. The Debugger lets you set breakpoints in your ActionScript 
that stop the Flash Player and step through the code as it runs. You can then go back to your 
scripts and edit them so that they produce the correct results.

To activate the Debugger in test mode, choose Control > Debug Movie. This opens the Debugger 
and also opens the movie in test mode.

Once the Debugger is activated, it displays the URL or local file path of the movie in the status 
bar, tells whether the Debugger is running in test mode or from a remote location, and shows a 
live view of the movie clip display list. When movie clips are added to or removed from the 
movie, the display list reflects the changes immediately. You can resize the display list by moving 
the horizontal splitter.

For more information, see Flash Help > Using Flash > Using the Debugger.

If you are building complex client-side interactions with ActionScript, we recommend that you 
read and contribute to the growing list of ActionScript best practices available at the Flash MX 
Application Development Center: http://www.macromedia.com/desdev/mx/flash.

Testing your site in Dreamweaver MX

Before uploading your site to a server and declaring it ready for viewing, it’s a good idea to test it 
locally. (In fact, it’s a good idea to test and troubleshoot your site frequently throughout its 
construction—you can catch problems early and avoid repeating them.)

You want to make sure that your pages look and work as expected in the browsers you’re targeting, 
that there are no broken links, and that the pages don’t take too long to download. You can also 
test and troubleshoot your entire site by running a site report before you publish your site.
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The following guidelines will help you create the best experiences for visitors to your site:

• Preview your pages in as many different browsers and on as many different platforms as 
possible. This gives you an opportunity to see differences in layout, color, font sizes, and 
default browser window size that cannot be predicted in a target browser check.

• Make sure your pages function as expected in the browsers you’re targeting and that they “fail 
gracefully” in other browsers. This means that your pages should be legible and functional in 
browsers that do not support styles, layers, plug-ins, or JavaScript. For pages that fail badly in 
older browsers, consider using the Check Browser behavior in Dreamweaver to automatically 
redirect visitors to another page.

• Check your site for broken links, and then fix them. Other sites undergo redesign and 
reorganization too, and the page you’re linking to may have been moved or deleted. For a 
simple list of links to external sites, you can run a link check in Dreamweaver. Alternatively, 
you can run a sitewide report that checks for and produces a report on invalid external links. 

• Monitor the size of your pages and the time they take to download. Keep in mind that for 
pages that consist of one large table, visitors will see nothing until the entire table finishes 
loading. Consider breaking up large tables; if this is not possible, consider putting a small 
amount of content—such as a welcome message or an advertising banner—outside the table at 
the top of the page so users can view this material while the table downloads.

• You can check your entire site for problems, such as untitled documents, empty tags, and 
redundant nested tags, by running site reports in Dreamweaver. Running these reports before 
you publish your site means fewer problems later on.

For more information, see Dreamweaver Help > Using Dreamweaver > Testing a site.

Deploying your site files to a server with Dreamweaver MX

You’ve now created a functional website. The next step is to publish it by uploading the files to a 
remote web server.

Before you can proceed, you must have access to a remote web server (such as your ISP’s server, a 
server owned by the client you’re working for, or an intranet server within your company). If you 
don’t already have access to such a server, contact your ISP or client.

The Put command in Dreamweaver copies files from the local site to the remote site, generally 
without changing the file’s checked-out status. There are two common situations in which you 
might use Put instead of Check In:

• When you’re not in a collaborative environment and you aren’t using the Check In/
Check Out system.

• When you want to put the current version of the file on the server but you’re going to 
keep editing it.
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To put a file on a remote server, choose Put from the File Management button after you have 
saved the file in the Document window.

Alternatively, you can click the Put button on the Site panel toolbar, or choose Site > Put to 
upload your file. If the file hasn’t been saved, a dialog box may appear (depending on your 
preference setting in the Site panel of the Preferences dialog box) allowing you to save the file 
before putting it on the remote server.

For more information, see Dreamweaver Help > Using Dreamweaver > 
Putting files onto a remote server.

Maintaining and updating your site

Once the bulk of the site has been published, you need to continue to update and maintain it. 
Publishing your site—that is, deploying the site to a server and making it live—is an ongoing 
process. In the Dreamweaver Site window, you’ll find many tools to help you manage your site, 
transfer files to and from a remote server, set up a check-in/check-out process to prevent files from 
being overwritten, and synchronize the files on your local and remote sites. It’s important to 
define and implement a version-control system, using either the Dreamweaver MX tools or an 
external version-control application.

You can also find information in the Macromedia Dreamweaver discussion forums on the 
Macromedia website. These forums are a great resource for information on different browsers, 
platforms, design tips, coding questions, and so on.
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Further reading
For more information on any of the Macromedia Studio MX tools, including documentation, 
tutorials, TechNotes, and other instructional media, visit each product’s Support Center:

• Dreamweaver: http://www.macromedia.com/support/dreamweaver/

• Flash: http://www.macromedia.com/support/flash/

• Fireworks: http://www.macromedia.com/support/fireworks/

• FreeHand: http://www.macromedia.com/support/freehand/

• ColdFusion: http://www.macromedia.com/support/coldfusion/
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Dreamweaver MX

The chapters in Part III introduce Macromedia 
Dreamweaver MX, present three tutorials, and describe how 
Dreamweaver works within the Studio MX product family. 

The following chapters are in this part:

• Chapter 4, “Welcome to Dreamweaver MX”

• Chapter 5, “Dreamweaver MX Tutorials”

• Chapter 6, “Dreamweaver MX Integration with the 
Macromedia Studio MX Product Family”





CHAPTER 4

Welcome to Dreamweaver MX

Macromedia Dreamweaver MX is a professional HTML editor for designing, coding, and 
developing websites, web pages, and web applications. With Dreamweaver, you can choose 
whether to hand-code HTML or work in a visual editing environment. 

And Dreamweaver now incorporates and expands on all the capabilities of Macromedia UltraDev, 
helping you to build dynamic, database-backed web applications using server languages such as 
ColdFusion Markup Language (CFML), ActionScript, Microsoft Active Server Pages (ASP), 
ASP.NET, Sun JavaServer Pages (JSP), and PHP.

What’s new in Dreamweaver MX
Dreamweaver MX contains a wide variety of new features, such as enhanced templates to 
help visual designers, and many new coding capabilities. Dreamweaver also now includes all 
the application-development features of Dreamweaver UltraDev 4 and offers many new ones, 
including a code-centric workspace derived from Macromedia ColdFusion Studio, better 
runtime code, and support for the latest web application technologies.

Complete control over code and design in Dreamweaver MX

You can build the site you want, the way you want, using either the Dreamweaver design tools or 
the rich coding environment.

A new integrated workspace layout (Microsoft Windows only) provides a more familiar working 
environment with a multiple-document interface (MDI), including fully dockable panels and 
tabbed document windows.

Panel management in Dreamweaver is consistent with the way panels work in Macromedia 
Flash MX and Fireworks MX. You can group together collapsible, dockable panels and collapse 
or expand them as needed, for a smooth, highly configurable workflow.

Predesigned sample web components include professional-quality layouts to give you a head 
start on your designs, as well as JavaScript function libraries that give you access to sophisticated 
client-side interactivity without having to read hundreds of pages of textbooks.

Enhanced Dreamweaver templates allow you to set up sophisticated rules for contributors to input 
content without compromising site design. Template inheritance allows for more customized 
layout control, and editable regions allow contributors to be more flexible in their input.

The Site Definition Wizard allows you to set up a site quickly and easily, whether you’re building a 
dynamic site for the first time or setting up an account with an ISP.

Code Hints provide easy access to customized menus showing appropriate tag attributes, method 
properties, function parameters, and Cascading Style Sheet styles while you edit in Code view.
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A customizable Insert bar allows quick access to objects and behaviors in Dreamweaver and is 
completely extensible.

The Document toolbar can now be customized to fit your needs and preferences, using XML 
and JavaScript.

A file explorer is now integrated into the Site panel, allowing you to browse for assets and files on 
the desktop and network volumes without having to leave Dreamweaver to use the native file 
explorer in your operating system.

The Answers panel connects you directly with online resources from the Macromedia Support 
Center. You can retrieve new content at any time to ensure that you always have access to the 
latest tips and tricks.

Enhanced table editing and manipulation generates better code for table edits in Layout view and 
Standard view, streamlining attribute handling and ensuring that all layouts are as lean as possible 
without compromising cross-browser compatibility.

Cascading JavaScript pop-up menus can now be created in Dreamweaver, a capability formerly 
available only in Fireworks.

Syntax coloring is now completely configurable and customizable according to your individual needs.

The Standard toolbar allows quick access to commonly used file commands (Open, Save, and 
New) and Clipboard commands.

Printing from Code view now allows you to print out your source code, with appropriate 
formatting applied.

Robust support in Dreamweaver MX for all the latest server technologies

With Dreamweaver MX, you can rapidly build dynamic, database-driven web applications both 
by hand-coding and by using visual objects and behaviors.

Server code libraries for ColdFusion, ASP, ASP.NET, JSP, and PHP allow you to visually create 
dynamic websites using all of the leading server-side technologies. In one development 
environment, you can integrate with a variety of sites and back-end technologies.

The Snippets panel allows you to store arbitrary pieces of code for later reuse. You can easily reuse 
complicated code, layouts, and functions.

The Tag Library editor provides an integrated tag database for storing information on native and 
custom tags. It allows you to edit the properties of existing tags and to import new ones.

Hundreds of tag editors allow you to quickly edit the relevant attributes of specific tags in HTML, 
CFML, and ASP.NET while in Code view.

ASP.NET custom tag support allows you to import custom ASP.NET server controls (custom 
tags) into ASP.NET pages and to see their structure and attributes displayed in the Tag Chooser, 
Code Hints, and Tag inspector.

ASP.NET Web Form tags are now rendered on both the Windows and Macintosh systems, to 
allow for sophisticated visualization and editing. Web Form tag editors allow you to quickly 
author ASP.NET Web Forms using validation and server-side controls.

ASP.NET DataGrid and DataList objects can be easily created in Dreamweaver for complex data 
display and manipulation. 

An integrated Database panel allows you to quickly look at the structure and content of your 
databases, to browse tables, stored procedures, and views before creating your queries.
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The Tag Chooser shows the structure of all tags available in Dreamweaver, including custom tags 
imported through the Tag Library editor. You can use it to quickly place and edit tags in your 
pages, and to view reference information for individual tags.

A customizable XML-based tag database stores information on the structure of all available tags. 
This central information storage mechanism allows features such as Code Hints, the Tag Chooser, 
and the Tag inspector to work with both native and custom imported tags.

ColdFusion MX detection allows the Site Definition Wizard to automatically configure itself to set up 
a ColdFusion site using a locally installed copy of Macromedia ColdFusion MX Developer Edition.

The Server Debug panel for ColdFusion MX streamlines the debugging workflow for ColdFusion 
MX by displaying debug output directly within Dreamweaver. Using this panel you can view 
variable information, query information, and other key page statistics, and jump directly to 
problem areas, all without leaving the development environment.

The ColdFusion runtime code generated by Dreamweaver server behaviors and objects has been 
revamped to be more tag-oriented, making it nearly indistinguishable from code a developer 
would write by hand.

RDS support allows you to transfer files back and forth, and browse the structure of databases on 
ColdFusion servers, using RDS connections.

JSP tag libraries help developers by abstracting server logic away from JSP pages. Dreamweaver 
can import JSP tag library information from TLD (tag library descriptor) files and make them 
available in Code Hints, the Tag Chooser, and the Tag inspector.

Full JavaBeans introspection shows getProperty and setProperty methods of JavaBeans in the 
Bindings panel, and can display all methods and properties of JavaBeans in the Server 
Components panel to allow developers to fully integrate Beans with their JSP applications.

Dynamic form objects allow you to create database-driven select lists and other form elements 
simply by selecting the appropriate form object from the Insert bar.

The Server Behavior Builder from UltraDev 4 has been enhanced to allow users to build server 
behaviors with more complicated user interface elements, including check boxes, radio groups, 
and connection menus.

An integrated HomeSite 5 and ColdFusion Studio 5 bundle provides a fully licensed version of 
Macromedia HomeSite+, the combination of ColdFusion Studio and HomeSite 5, fully 
integrated and included with Dreamweaver.

Easy access in Dreamweaver MX to the latest standards

Dreamweaver MX lets you build websites compliant with the latest web standards, including XML 
and web services, and keep your skills up to date with cutting-edge development technologies.

Web services introspection for .NET, ColdFusion, and Java allows you to introspect and 
interoperate with the latest XML-based web services standards in all leading server technologies. 
You can incorporate complicated functionality into your web applications using the web service 
introspection feature in Dreamweaver.

XML editing and validation allows you to import document type definitions (DTDs and schemas, 
and ensure that documents are well formed.
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Enhanced CSS support, including TopStyle integration, helps you build sites compliant with the 
latest Cascading Style Sheets (CSS) standards. The Dreamweaver CSS panel has been enhanced to 
show internally and externally defined styles and to allow for design-time style sheets. Many new 
CSS2 constructs are also supported.

XHTML support lets you ensure that your sites are up to date with the latest standards in HTML 
design by configuring Dreamweaver to generate XHTML-compliant code. You can also quickly 
convert legacy HTML files to XHTML using the XHTML converter.

Section 508 accessibility site reporting helps you determine whether your site meets accessibility 
guidelines and pinpoint problems quickly and easily.

Integrated accessibility reference content in the Reference panel gives you context and 
background on best practices in designing for accessibility.

The accessibility option for generating compliant code helps during the editing cycle to ensure 
that the content you are creating meets accessibility guidelines. You can configure Dreamweaver 
to prompt you for specific accessibility-related attributes when appropriate tags and objects are 
inserted on the page.

ColdFusion Component support offers you increased modularity and portability of server logic by 
exposing properties through CFML. Dreamweaver includes support for introspecting, creating, 
and editing ColdFusion Components.

Code validator ensures that your documents are meeting the appropriate standards by providing a 
validation report against a specific browser profile or a specific version of a standard, including 
XHTML transitional and HTML 4.0.

The launch-and-edit features in Macromedia Flash MX and Fireworks MX accelerate graphics, 
animation, and HTML editing between Macromedia Flash MX, Dreamweaver, and Fireworks 
MX, allowing you to launch and optimize directly from Dreamweaver.

A Tag inspector for viewing XML, HTML, and CFML allows you to see the structure of a document 
quickly and easily. You can quickly spot and eliminate improper nesting and parent relationships 
without having to look at the raw source code.

Secure FTP login integrates with MacSSH and PUTTY for Windows to allow for SSH-enabled 
secure transfer of login information from the integrated Dreamweaver FTP client.

Full UTF-8 character-set support in all languages allows you to create and transform pages using 
UTF-8 encoding.

Full Mac OS X and Windows XP support allows Dreamweaver to run at full speed in the latest 
operating systems, while supporting all the latest user interface improvements.

Macromedia Sitespring integration helps you use best practices in production and client 
management in the Dreamweaver workspace.
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Learning Dreamweaver
Dreamweaver includes a variety of resources to help you learn the program quickly and become 
proficient in creating your own websites and pages. These resources include an online help system 
and tutorials. In addition, you can find regularly updated tips, TechNotes, examples, and 
information at the Dreamweaver Support Center on the Macromedia website.

Dreamweaver MX tutorials

The basics of setting up a website and editing code are covered in Chapter 5, “Dreamweaver MX 
Tutorials,” on page 83. 

If you’re already familiar with the Dreamweaver design features but want to know more about 
building web applications, start with “Dreamweaver tutorial 3: Building a web application” on 
page 118, which teaches you how to create interactive pages that connect to databases.

Dreamweaver Help

Dreamweaver Help provides comprehensive information about all Dreamweaver features, 
optimized for online reading. Dreamweaver Help is displayed in the help viewer provided by your 
operating system: Microsoft HTML Help (Windows) or Apple Help (Macintosh). On both 
platforms, you can find the information you need in any of four ways:

The table of contents enables you to see all the information organized by subject. Click top-level 
entries to view subtopics. 

The index, like a traditional printed index, allows you to look up specific terms or concepts.

Search allows you to find any character string, anywhere in the text of the help system.

Context-sensitive help provides a way to open a relevant help topic from each dialog box, panel, 
and inspector. To view context-sensitive help, click a Help button in a dialog box, or choose Help 
from the Options menu in a panel group’s title bar, or click the question-mark icon in an 
inspector or other kind of window. 

Each help topic provides buttons you can click to move from topic to topic. The Left Arrow and 
Right Arrow buttons move to the previous or next topic in a section (in the order in which the 
topics are listed in the table of contents).

Extending Dreamweaver

The Extending Dreamweaver help system provides information on the Dreamweaver Document 
Object Model and the application programming interfaces (APIs) that allow JavaScript and C 
developers to create extensions for Dreamweaver.

Click here to open Help
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Dreamweaver Support Center

To get the most out of Dreamweaver, you can consult a web-based support center. The 
Dreamweaver Support Center website at http://www.macromedia.com/support/dreamweaver/ 
is updated regularly with the latest information on Dreamweaver, plus advice from expert users, 
examples, tips, updates, and information on advanced topics. Check the website often for the 
latest news on Dreamweaver and how to get the most out of the program.

Dreamweaver online forums

Discuss technical issues and share helpful hints with other Dreamweaver users by visiting the 
Dreamweaver online forums. You’ll find information on accessing the forums on the Macromedia 
website at http://www.macromedia.com/go/dreamweaver_newsgroup.

HTML and web technologies resources
The following are some useful resources available on the web:

The HTML 4.01 specification (http://www.w3.org/TR/REC-html40/) is the official 
specification for HTML from the World Wide Web Consortium.

Index DOT HTML (http://www.blooberry.com/indexdot/html/) is a comprehensive listing of 
HTML tags, attributes, and values, as well as their compatibility with the various browsers.

The XHTML 1.0 specification (http://www.w3.org/TR/xhtml1/) is the official specification for 
Extensible HyperText Markup Language.

The O’Reilly XML.com site (http://www.xml.com/) provides information, tutorials, and tips 
about Extensible Markup Language (XML), as well as other web technologies.

The Cascading Style Sheets, level 1 specification (CSS1) (http://www.w3.org/TR/REC-CSS1) 
and level 2 specification (CSS2) (http://www.w3.org/TR/REC-CSS2/) are the official 
specifications for style sheets from the World Wide Web Consortium.

WebReview.com’s Style Sheet Reference Guide (http://www.webreview.com/style/index.shtml) 
explains what CSS styles are and which browsers they work in.

The Microsoft ASP Overview pages (http://msdn.microsoft.com/workshop/server/asp/
ASPover.asp) provide information about Active Server Pages (ASP).

The Microsoft ASP.NET page (http://www.asp.net/) provides information about ASP.NET.

The Sun JSP page (http://java.sun.com/products/jsp/) provides information about JavaServer 
Pages (JSP).

The PHP pages (http://www.php.net/) provide information about PHP: Hypertext Preprocessor.

The MySQL site (http://www.mysql.com/) provides information about MySQL.

The Entities Table (http://www.bbsinc.com/iso8859.html) lists the entity names used in ISO 
8859-1 (Latin-1).

The Dynamic HTML Events page (http://msdn.microsoft.com/workshop/author/dhtml/
reference/events.asp#om40_event) provides information about events in Microsoft Internet 
Explorer.

The Macromedia ColdFusion Server product page (http://www.macromedia.com/software/
coldfusion/) provides information about the ColdFusion Server.
Chapter 480



The Macromedia JRun Server product page (http://www.macromedia.com/software/jrun/) 
provides information about the JRun Java application server.

The IBM WebSphere page (http://www.ibm.com/software/webservers/appserv/) provides 
information about the WebSphere application server.

The Chili!Soft product page (http://www.Chilisoft.com/products/) provides information about 
the Sun Chili!Soft ASP application server. 

JavaScript Bible, by Danny Goodman (IDG Books), comprehensively covers the 
JavaScript 1.2 language. 

JavaScript: The Definitive Guide, by David Flanagan (O’Reilly & Associates), provides reference 
information for every JavaScript function, object, method, property, and event handler.

CGI Scripts for Fun and Profit (http://www.hotwired.lycos.com/webmonkey/99/26/
index4a.html) is an article from the Hotwired Webmonkey site on incorporating ready-made 
CGI (Common Gateway Interface) scripts into your pages.

The CGI Resource Index (http://www.cgi-resources.com/) is a repository of all things related to 
CGI, including ready-made scripts, documentation, books, and even programmers for hire.

The Common Gateway Interface site (http://hoohoo.ncsa.uiuc.edu/cgi/) includes an 
introduction to CGI.
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CHAPTER 5

Dreamweaver MX Tutorials

The three tutorials in this chapter are a great way to quickly learn the fundamentals of web 
development in Macromedia Dreamweaver MX. The tutorials will introduce you to these web skills:

• Creating a website

• Using coding tools to supplement Dreamweaver’s visual development environment

• Building a dynamic, data-driven web application

The best way to approach these tutorials is to take them sequentially, building your skills as you 
become familiar with the web development workflow and the Dreamweaver tools.

Dreamweaver tutorial 1: Creating your first website
This tutorial provides a series of brief lessons that guide you through the process of creating a 
simple, static website using the visual authoring tools in Macromedia Dreamweaver MX. For 
information on using the hand-coding tools in Dreamweaver, see “Dreamweaver tutorial 2: 
Editing code” on page 109; for information on creating a database-driven dynamic web 
application, see “Dreamweaver tutorial 3: Building a web application” on page 118.

The order of lessons in this tutorial follows one possible workflow for creating a site. When 
creating your own sites, you can follow whatever workflow is most comfortable for you.

To create a static website:

1 Plan and prepare (see “Set up a local site” on page 84 and “Add assets to your site” on page 88).

2 Create pages (see “Create and save a new page” on page 89).

3 Lay out and set up the pages (see “Adjust the layout” on page 91 and “Set a page title” on page 96).

4 Add content to your pages (see “Add styled text” on page 97 and “Add images” on page 100).

5 Link pages together (see “Add text links between pages” on page 105 and “Create rollovers for 
graphical links” on page 105).

6 Publish your site (see “Preview in browser” on page 107 and “Set up a remote site, then 
publish” on page 108).
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Set up a local site
The most common approach to creating a website using Dreamweaver is to create and edit pages 
on your local disk, and then upload copies of those pages to a remote web server to make them 
publicly available. It’s possible to use Dreamweaver in other ways (such as running a web server on 
your local computer, or uploading files to a staging server, or using a mounted disk as if it were 
your local disk), but the lessons in this tutorial assume that you’re working locally and then 
uploading to a remote server.

In Dreamweaver, the word site is used as shorthand to refer to any of the following things:

• A website: a set of pages on a server, to be viewed by a visitor to the site using a web browser.

• A remote site: the files on the server that make up a website, from your (the author’s) point of 
view rather than a visitor’s point of view.

• A local site: the files on your local disk that correspond to the files in the remote site. You edit 
the files on your local disk, then upload them to the remote site.

• A Dreamweaver site definition: a set of defining characteristics for a local site, plus information 
on how the local site corresponds to a remote site.

Normally, you would start creating a website by planning it: figuring out how many pages to 
create, what content appears on each page, and how the pages are connected to each other. In this 
lesson, though, the site you’re creating is a very simple one, so it doesn’t take much planning: it 
will consist of only two web pages, with links between them. So for this site, you can skip the 
planning, and proceed to creating a site definition.

You’ll create a site definition using the Site Definition dialog box. You can fill in this dialog box in 
either of two views: Basic or Advanced. The Basic approach guides you through site setup step by step. 
If you’d rather edit site information without guidance, you can click the Advanced tab at any time.

The following procedure describes how to set options in the Basic version of the dialog box, 
which is also known as the Site Definition Wizard. For details of how to set options in the 
Advanced version, click the Advanced tab and then click the Help button.

To define a site:

1 Choose Site > New Site. (That is, choose New Site from the Site menu.)

The Site Definition dialog box appears.

2 If the dialog box is showing the Advanced tab, click Basic.

The first screen of the Site Definition Wizard appears, asking you to enter a name for your site.
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3 In the text box, enter a name to identify the site within Dreamweaver. The name can be 
anything you want. For example, you could name the site Global Car Rental. 

4 Click Next to proceed to the next step.

The next screen of the wizard appears, asking if you want to work with a server technology.

5 Select the No option to indicate that for now, this site is a static site, with no dynamic pages.

To set up a site to create a web application, you would need to choose a dynamic document 
type—such as Macromedia ColdFusion, Microsoft Active Server Pages (ASP), Microsoft 
ASP.NET, Sun JavaServer Pages (JSP), or PHP: Hypertext Preprocessor (PHP)—and then 
supply information about your application server (for more information, see “Dreamweaver 
tutorial 3: Building a web application” on page 118).

6 Click Next to proceed to the next step.

The next screen of the wizard appears, asking how you want to work with your files.

7 Select the option labeled “Edit local copies on my machine, then upload to server when ready 
(recommended).”

There are a variety of ways that you can work with files during site development, but for the 
purposes of this lesson, choose this option.
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8 The text box allows you to specify a folder on your local disk where Dreamweaver should store 
the local version of the site’s files. It’s easier to specify an accurate folder name if you browse to 
the folder rather than typing the path, so click the folder icon next to the text box.

The Choose Local Root Folder for Site dialog box appears.

9 In the Choose Local Root Folder for Site dialog box, start by navigating to a folder on your 
local disk where you can store all of your sites. Don’t click OK yet.

Note: This sites folder will eventually contain multiple sites, so don’t choose the sites folder as the local root 
folder. You will soon create a local root folder for this particular site inside the sites folder.

If you don’t already have a sites folder, create one now (using the folder-creation button in the 
Choose Local Root Folder for Site dialog box). Name the folder Sites. The recommended 
location for the sites folder depends on your operating system:

• In Windows, if you don’t already have a place to store sites, create a folder at the top level of 
your C drive, and name the folder Sites. That is, the path to the folder is C:\Sites.

• In Mac OS 9, if you don’t already have a place to store sites, create a folder at the top level of 
your disk drive named Sites.

• In Mac OS X, your home folder (/Users/your_user_name) contains a folder named 
Documents. Navigate to that folder, and create a folder named Sites inside it.

10 Still in the Choose Local Root Folder for Site dialog box, create a new folder inside your Sites 
folder. Name the new folder GettingStarted, and click OK to dismiss the Choose Local Root 
Folder for Site dialog box.

This new folder is the local root folder for your site.

11 Click Next to proceed to the next step.

The next screen of the wizard appears, asking how you connect to your remote server.

12 For now, choose None from the pop-up menu. Click Next to proceed to the next step.

The next screen of the wizard appears, showing a summary of your settings.
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13 Click Done to finish.

You can set up information about your remote site later (see “Set up a remote site, then publish” 
on page 108); for now, the local site information is all you need to start creating a page.

An alert appears to tell you that Dreamweaver will create a site cache. The site cache is a way 
for Dreamweaver to store information about the site, to make various site operations faster.

14 Click OK to allow Dreamweaver to create the site cache.

The Site panel now shows the new local root folder for your current site, and an icon to let you 
view all of your local disks in a hierarchical tree view. The icon is labeled Desktop (Windows) or 
Computer (Macintosh).

The Site panel normally shows all the files and folders in your site, but right now your site doesn’t 
contain any files or folders. When there are files in a site, the file list in the Site panel acts as a file 
manager, allowing you to copy, paste, delete, move, and open files just as you would on a 
computer desktop.

If you already have a set of local HTML files that you want to use to create a website, you can use 
the file browser in the Site panel to copy those files into your newly created site’s folder. However, 
you may want to complete the lessons in this guide using the files provided with Dreamweaver 
before you start using your own files.

If you already have a website on a remote server and you want to edit that site using 
Dreamweaver, see Dreamweaver Help > Using Dreamweaver.
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Add assets to your site

After creating a local site, if you have already created assets (images or other pieces of content) for 
the site, place the assets in a folder inside the local site’s root folder. Then when you’re ready to 
add content to your pages, the assets will be ready to use.

The images and text files for the Global Car Rental site are provided with Dreamweaver. If you’re 
creating the Global Car Rental pages, you must copy the images for the site into your site’s local 
root folder. You can do this using the Site panel.

The assets are inside a folder called Design. For simplicity and consistency with the rest of this 
Getting Started guide, you’ll copy the entire Design folder into your site, then work inside that folder.

To copy a folder of images into your site’s local root folder:

1 If the Site panel isn’t already open, open it by choosing Window > Site.

The Site panel appears. (If the Site panel was already open, it may not appear at this step. If the 
Site panel does not appear, choose Window > Site again to display it.)

2 In the Site panel, expand the Desktop (Windows) or Computer (Macintosh) icon to see your 
available disks.

3 Expand folders as necessary to reach the Dreamweaver application folder.

4 Expand the Samples folder.

5 Expand the GettingStarted folder in the Samples folder.

6 Select the Design folder in the GettingStarted folder and press Control+C (Windows) or 
Command+C (Macintosh) to copy it.

The Design folder contains a folder named Assets, which contains various assets related to the 
site, including an images subfolder.

7 Still in the Site panel, scroll to your site’s local root folder (the folder that you created when you 
defined the site) and select that folder. Then press Control+V (Windows) or Command+V 
(Macintosh) to paste a copy of the Design folder into your site.
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Create and save a new page
Now that your site is set up, you can create web pages to populate it.

When you started Dreamweaver, a blank HTML document was automatically created. Before 
you proceed, close that document.

To close the default blank document:

Choose File > Close.

To create a new page:

1 Choose File > New.

The New Document dialog box appears.

2 In the category list on the left, select the Page Designs category.

The list in the middle column of the dialog box is relabeled Page Designs. A list of 
pre-designed page designs appears.

3 Scroll down in the Page Designs list and choose the item named Text: Article D with Navigation.

Note: There is another item with a similar name. Be careful not to choose the item named Text: Article D, which 
has no navigation bar.
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A small preview of the page appears on the right side of the dialog box.

If you prefer, you can create a page using any of the other provided page designs, or create a 
page with no preset design by choosing an item from the Basic Page category. The rest of this 
lesson assumes that you’re using the Text: Article D with Navigation page design.

4 Make sure the Document radio button is selected at the lower right of the dialog box.

5 Click Create.

A new page appears, using the layout you chose, in a new Document window. The page is 
filled with placeholder “Lorem ipsum” text to show how the page design will look when real 
text is added to it. 

6 Save your document.

To save your new page:

1 Choose File > Save. 

2 In the Save As dialog box, browse to the Design folder inside the site root folder.

Reminder: the site root folder is the folder you created when you set up the site in “Set up a 
local site” on page 84.
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3 Enter the filename index.htm.

4 Click Save.

The filename now appears in the title bar of the Document window, in parentheses, after the 
words “Untitled Document.”

Adjust the layout
The predesigned pages provide a starting point, but they’re unlikely to exactly match the layout 
you need for your own pages.

To modify the layout of a page, use Dreamweaver’s layout tools. This tutorial touches on some of 
the tools, but for more information, see Dreamweaver Help > Using Dreamweaver.

First, remove the layout elements that you don’t need. To create the Global Car Rental page 
layout, remove several unnecessary tables and cells (see the following section).

Then add image placeholders and adjust the widths of table columns (using Dreamweaver’s 
Layout view) to make everything fit nicely. See “Add an image placeholder” on page 94 and 
“Make a column autostretch” on page 95.

Remove unnecessary elements

In any predesigned page design, there are likely to be elements that you don’t need for your final 
page. You can select such elements and delete them.

If you’re creating the Global Car Rental page, the following elements in the standard page design 
are unnecessary:

• Two of the navigation links at the top of the page

• The title and header area above the main text column

• A small box next to the title in the sidebar column

• The copyright bar at the bottom of the page

The general procedure for removing an element is to select it and then to press Backspace 
(Windows) or Delete (Macintosh). The following procedures show how to select and delete each 
unnecessary element. When you’re done, check to make sure you’ve removed everything you 
intended to remove, then save the document.

To remove unnecessary navigation links:

1 Choose View > Table View > Standard View to ensure that you’re viewing tables in Standard view.

2 In the document’s navigation bar, drag from the table cell with the “Sic Amet” link to the table 
cell with the “Consectetur” link. 

Both table cells are highlighted to indicate that they’re selected.
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3 Press Backspace (Windows) or Delete (Macintosh).

The table cells are removed. The other table cells (the “Lorem,” “Ipsum,” and “Dolor” links) 
automatically expand to fill the width of the table.

To remove the unnecessary text-column title:

1 At the top of the text columns, click the word Title. 

2 In the tag selector at the bottom of the Document window, click the leftmost <table> tag, the 
one that appears immediately to the right of the <body> tag. (If you can’t see the <body> tag in 
the floating workspace, widen the Document window.)

3 Press Backspace (Windows) or Delete (Macintosh) to remove the table containing the title.

Note: There are two <table> tags in the tag selector, because the title area is a table nested inside another table. 
In this case, you should delete the outer table, indicated by the leftmost <table> tag.

To remove the unnecessary box in the sidebar header:

1 In the right column, to the left of the word News, click in the box containing the 
exclamation point.

2 In the tag selector, click the rightmost <td> tag to select the box around the exclamation mark.

3 Press Backspace (Windows) or Delete (Macintosh).
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To remove the unnecessary copyright bar:

1 Scroll to the bottom of the page. Click anywhere in the copyright bar at the bottom.

2 In the tag selector, click the leftmost <table> tag, the one that appears immediately to the 
right of the <body> tag. Then press Delete to remove the table containing the copyright 
information.

To check and save your page:

1 Look at your page to make sure you’ve removed unnecessary elements.

Your page should now look similar to the following image:

2 Save your document.
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Add an image placeholder

Now create a placeholder to stand in for the image that you’ll add later.

To add an image placeholder:

1 Click at the beginning of the main text column, at the top left of the text, just before the first 
boldface word of the text. Then press Enter (Windows) or Return (Macintosh) to put a blank 
line before the text. Then click in the new blank line.

The insertion point should now be on a line by itself. If it isn’t, place the insertion point on the 
blank line.

2 Choose Insert > Image Placeholder.

3 In the Image Placeholder dialog box, enter a name for the placeholder (such as SplashImage) and 
a width and height. For the Global Car Rental page, enter 523 for width and 220 for height.

Note: Placeholder names must start with a letter and can contain only letters and numbers.

4 Click OK.

A gray box with the specified dimensions appears. This is a placeholder for an image, used to 
help you lay out pages without having to have the final images on hand.

5 You may need to widen your document window to see the column of text on the right.
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Make a column autostretch

The sidebar column of text on the right in the index.htm page is a fixed width. To make it change 
its width as the visitor resizes the browser window, make the column autostretch. Then adjust the 
width of the wide column containing the image placeholder. 

To make the left column autostretch:

1 If the Insert bar is not showing, choose Window > Insert to display it.

2 In the Insert bar, click the Layout tab.

3 Click the Layout View button to switch to Layout view.

4 Read the informational dialog box, then click OK.

For each table in your page, a green tab appears at the table’s upper left corner. The tab is 
labeled “Layout Table.”

5 In the Document window, click the Layout Table tab above and to the left of the image 
placeholder you inserted, to select the table that contains both text columns.

A column header appears over each of the two text columns, showing the width of 
each column.

6 If the Document window is too narrow to show all of the column on the right, widen your 
Document window.

Even after you widen your Document window, other Layout Table tabs may obscure the 
number showing the width in the column header on the right. Don’t click those other Layout 
Table tabs.

7 Carefully click the column header over the right column. (Be sure to click above the top of the 
green Layout Table tabs in the right column.)

A pop-up menu appears.

8 In the pop-up menu, choose Make Column Autostretch.

A dialog box appears, titled Choose Spacer Image, to prompt you to choose a spacer image.

Note: If you have already chosen a spacer image at some point, this dialog box does not appear; in that case, the 
right column is now set to Autostretch. If the dialog box does not appear, skip the rest of this procedure.
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9 In the Choose Spacer Image dialog box, select the Use an existing spacer image file option 
and click OK.

Another dialog box appears, titled Select Spacer Image File.

10 In the Select Spacer Image File dialog box, browse to your local root folder and open the 
Assets folder. Then open the Images folder and select spacer.gif, and click OK (Windows) or 
Open (Macintosh).

The right column is now set to Autostretch; in a browser, the right column will be as wide as 
possible after the left column is drawn at its fixed width.

To adjust the width of the main text column:

1 Click the column header over the left column and choose Make Cell Widths Consistent from 
the pop-up menu that appears.

The left column is now set to a fixed width (equal to the width of the image plus the cell 
padding and cell spacing amounts).

2 Click the Standard View button in the Insert bar to switch back to Standard view.

3 Save your document.

Set a page title
You can set a variety of properties for a page, including its title, background color, text color, and so 
on. (To set page properties, choose Modify > Page Properties.) But if you just want to set the page 
title (the title that appears in the browser’s title bar), you can do that in the Document toolbar.

To set a page title for your document:

1 If the Document toolbar isn’t already visible, choose View > Toolbars > Document.

 Document toolbar appears. In the integrated workspace, it appears at the top of the document 
area by default; in the floating workspace, it appears as part of the Document window. 

2 In the Title text box, where it says “Untitled Document,” type a title for the page, such as 
Global Car Rental Home Page. Then press Enter (Windows) or Return (Macintosh) to see the 
page title update in the Document window’s title bar.

3 Save your document.

Show Code View

Show Design View

Document Title

Refresh Design View

Reference

Code Navigation
View Options

Show Code and Design Views

Preview/Debug in Browser

File Management

Live Data View
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Add styled text
You can type text into the Document window, or copy and paste it from another source (such as a 
Microsoft Word file). For more information, see the following section. Then you can format the 
text using the CSS Styles panel (see “Add styles to the text” on page 98).

Before entering text, make sure you’re in Design view by choosing View > Design.

Add text

As you enter and format text in Design view, Dreamweaver creates the underlying HTML code. 
To enter code directly, use Code view. For information on Code view, see Dreamweaver Help > 
Using Dreamweaver > Editing code in Dreamweaver.

The predesigned pages provided with Dreamweaver contain placeholder “Lorem ipsum” text; if 
you’re basing your page on a predesigned page, you’ll have to replace the placeholder text with 
your own text when you’re ready to start adding content. It can be useful to leave the placeholder 
text in place until you’re done with design and layout, though, so that you or your client can look 
at the layout without being distracted by the text.

To add text to your page:

1 Triple-click in the bold placeholder text at the top of the left column (under the image 
placeholder) to select the entire bold paragraph.

2 Type Safety Tips (or your own heading text if you prefer).

3 Select the three paragraphs of placeholder text below the horizontal rule.

4 Type the following text (or your own text if you prefer):

The safety of our loyal customers is important to us. Read these safety tips to ensure that 
your next trip goes off without a hitch!

5 In the right column, triple-click the word “News” and type Globe-Trotter Promotions to 
replace it.

6 In the Site panel, locate the promotions.txt file in your Assets folder. Double-click the file’s 
icon to open it.

This file contains copy for Global Car Rentals special promotions.

Note: In this sample site, the file containing the copy is a text file. For other sites, you may be given HTML 
documents generated by Microsoft Word; you can import that HTML and clean it up using the Dreamweaver 
Import Word HTML command. For more information, see Dreamweaver Help > Using Dreamweaver. 

Note that the text file appears in a new Document window with a dark bar down the left side. This 
window is in Code view and can’t be switched to Design view because the file is not an HTML file.

Note: If you prefer, use your own text on the page instead of using the provided text.
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7 In the promotions.txt Document window, press Control+A (Windows) or Command+A 
(Macintosh) to select all the text, then choose Edit > Copy to copy the text.

8 In the index.htm Document window, select all of the placeholder text in the lower cell of the 
right-hand column, and choose Edit > Paste.

The text is pasted into the table.

9 Click just before the word “Rent” (the second paragraph of text you just pasted), and choose 
Insert > Horizontal Rule to put a horizontal line between the two promotions.

10 Save your document.

11 Switch to the promotions.txt file. Close that file by choosing File > Close.

Add styles to the text

There are several ways to style text in HTML. One approach is to use Cascading Style Sheets 
(CSS) to define specific HTML tags as being formatted in specific ways.

This lesson shows how to create a simple CSS style sheet from a predesigned style sheet, then 
apply the new style sheet to text and modify the styles.

To create a CSS style sheet:

1 Choose File > New.

2 In the New Document dialog box, select the CSS Style Sheets category from the category list 
on the left.

The list in the middle column of the dialog box is relabeled CSS Style Sheets. A list of 
predesigned style sheets appears.

3 In the CSS Style Sheets list, select a style sheet. For the Global Car Rental site, select Basic: 
Verdana, which redefines the body, td, and th tags by specifying fonts for them. Then click Create.

Dreamweaver creates a new text file containing a small set of predefined CSS styles.

4 Choose File > Save to save the new CSS file. Save it in the site’s assets folder; name it text.css 
(or any other name you like).

5 Choose File > Close to close the CSS file.
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To style your text using CSS styles:

1 In the Window menu, choose an HTML file (such as index.htm).

Note: If your system preferences are set to not show file extensions, the index.htm file appears in the Window 
menu with the name index.

2 Choose Window > CSS Styles to display the CSS Styles panel.

3 At the top of the CSS Styles panel, click the Edit Styles radio button to show available styles.

If you haven’t previously defined styles for this document, no styles are available.

4 At the bottom of the CSS Styles panel, click the Attach Style Sheet button.

The Link External Style Sheet dialog box appears.

5 In the Link External Style Sheet dialog box, click Browse to locate a style sheet.

6 In the Select Style Sheet File dialog box, browse to and select the new style sheet you created in 
the assets folder, then click OK (Windows) or Choose (Macintosh) to attach the style sheet. 

7 In the Link External Style Sheet dialog box, click OK to attach the style sheet.

The style sheet’s name and contents appear in the CSS Styles panel. The styles defined in the style 
sheet are applied to the text in the HTML document. For example, body text appears in Verdana.

8 Save your document.

To edit the styles in the style sheet:

1 At the top of the CSS Styles panel, click the Edit Styles radio button to show available styles.

2 Select the name of the CSS file in the CSS Styles panel and click the Edit Style Sheet button at 
the bottom of the CSS Styles panel.

A dialog box appears showing the names of the styles in the style sheet. 

3 Select one of the styles, such as body, and click Edit.

The CSS Style Definition dialog box appears.

4 Enter a size for the text, such as 13 pixels. Adjust other options as you like.

5 Click OK to redefine the style.
Dreamweaver MX Tutorials 99



6 Edit the other styles. To create the styles used in the Global Car Rental site, set the body, td, 
and th styles to a size of 13 pixels.

7 When you’re done editing styles, click the Save button to save your changes and close the 
stylesheet dialog box.

The changed styles are applied to your document. For example, body text appears in 
13-pixel Verdana.

Add images
In this lesson, you can add images to the page you’re working on. If you have your own images, 
you can use them instead, but the first time you try adding an image, we recommend using one 
supplied with Dreamweaver’s sample site.

If you haven’t already followed the procedure in “Add assets to your site” on page 88 for copying 
the Global Car Rental site’s assets into your site’s local root folder, do so now.

To add an image to your document:

1 Save your document if you haven’t already done so.

You can insert an image into an unsaved document, but if you do, a dialog box will appear, 
informing you that the URL used for the image will be the full local path to the image. If you 
take this approach, Dreamweaver fixes the URLs when you do save the document, but it’s 
easiest to save the document before adding images.

2 To insert an image in place of an existing image placeholder, double-click the placeholder. For 
example, to insert the company logo at the top left of the Global Car Rental page, double-click 
the small placeholder that’s labeled “image (100 x 50).”

The Select Image Source dialog box appears.

3 Near the bottom of the dialog box, make sure that the Relative To pop-up menu is set to 
Document. 

For information on document-relative and root-relative URLs, see Dreamweaver Help > 
Using Dreamweaver.

4 Browse to an image in your assets folder (such as logo.jpg).

5 Click OK or Select (Windows) or Open or Choose (Macintosh) to insert the image.

In the Document window, the image appears where the placeholder was.

6 Click the large image placeholder that you created in “Add an image placeholder” on page 94 
to select it. (Don’t double-click it.)

You can use the same approach that you used for the other placeholder to replace this 
placeholder with an image, but the following instructions provide an alternate approach.

7 Make sure the Site panel and the Property inspector are showing (choose Window > Site Files 
and Window > Properties if they aren’t visible).
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8 In the Property inspector, drag from the Src text box’s Point-to-File icon to the Site panel. 
(Make sure to drag from the Point-to-File icon next to the Src text box, not the one next to the 
Link text box.) Continue to hold the mouse button down as you point to the assets folder (if 
the folder is closed); the folder opens. Continue to hold the button down as you point to the 
images folder; that folder opens as well. Continue to hold the button down until the pointer is 
over the vintage.jpg file. Release the mouse button to select vintage.jpg.

In the Document window, the image appears where the placeholder was. If the wrong image 
appears, look at the filename in the Src text box; if you selected the wrong file, drag the 
Point-to-File icon again.

9 To insert images in places where you don’t already have placeholders, click in the Design view 
to place the insertion point where you want the image, then choose Insert > Image.

If you insert an image for which the image file isn’t inside your site’s local root folder, 
Dreamweaver provides the option to automatically copy the image into the site.

10 Save your document.

Set background colors
In the predesigned pages provided with Dreamweaver, the background colors of table cells are 
mostly set to gray; for most sites, you’ll have to change the colors to match your site’s color scheme.

To set the background color of a table cell:

1 If the Property inspector isn’t open, choose Window > Properties to open it.

2 If the Property inspector is collapsed (showing only its title bar), click the expander arrow in 
the title bar to expand it.

3 If the Property inspector isn’t showing all properties, click the expander arrow at the lower right 
corner of the Property inspector to view all properties.

4 Control-click (Windows) or Command-click (Macintosh) a cell to select the cell. For example, 
in the Global Car Rental sample page, there’s now a table cell that contains the logo image for the 
car rental company; Control-click or Command-click the cell that contains that logo image.

The lower half of the Property inspector shows cell properties. If the lower half of the Property 
inspector isn’t visible, click the expander arrow at the lower right corner of the Property 
inspector to view all properties.
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5 In the Property inspector, click the Background Color button that appears next to the lower of 
the two Bg labels.

The color picker appears and the pointer changes to an eyedropper.

6 Select a color. You can either select a color in the color picker’s palette, or click anywhere on 
your display to select the color of the pixel you clicked. For example, click the background of 
the Global logo image to make the background color of the table cell match the image 
background color.

The table cell’s background color changes to the color you picked.

7 Repeat that procedure for each table cell that you want to change the background color of. In the 
Global Car Rental sample page, change the background colors of all of the navigation-bar table 
cells and of the header cell in the second column of text (the cell that now contains the text 
“Globe-Trotter Promotions”), to make them all match the background color of the Global logo.

8 Save your document.

Look at the code
Take a quick time-out for a look at what Dreamweaver is doing when you add content to a page. 
As you add text, images, and other content, Dreamweaver generates HTML code.

Dreamweaver lets you view your document in either of two ways: Design view (where the 
document looks much like it would look in a browser), and Code view (where you can see the 
underlying HTML code). You can also use a split view that shows both Code and Design views.

To view the HTML code for your document:

1 If the Document toolbar isn’t already visible, choose View > Toolbars > Document.
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2 In the Document toolbar, click the Code and Design view button. 

The window splits, showing the underlying HTML code.

You can edit the code in Code view. Changes you make to the code don’t appear in Design 
view until you refresh the view.

To make code changes appear in Design view, do one of the following:

• Click anywhere in Design view.

• Click the Refresh button in the Document toolbar. 

Dreamweaver provides many advanced features to help you code in Code view; for more 
information, see Dreamweaver Help > Using Dreamweaver > Editing code in Dreamweaver.

When you’re working on your own pages, you can use whichever view is most comfortable for 
you. We’ll assume for the rest of this tutorial that you’re using Design view.

To show Design view only:

1 If the Document toolbar isn’t already visible, choose View > Toolbars > Document.

2 In the Document toolbar, click the Design view button.

Create a second page
In this lesson, you’ll create a second page for your site; in the next lesson, “Add text links between 
pages” on page 105, you’ll create links between the pages.

There are several possible ways to create a second page. In this lesson, you’ll create a second page 
by making a copy of the first one, so that the second page will have the same layout as the first.

Note: If you want to create a layout of your own from scratch instead, you can either use the Dreamweaver table-
editing tools or Layout view. Other layout options include frames and layers. None of these options are covered in 
this lesson, however.

In a more complex site, the best way to make sure all your pages have the same layout would be to 
use a template. For information about where to read about table editing, Layout view, frames, 
layers, and templates, see “Further reading” on page 109.
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The second page to create in the Global Car Rental site is the customer service page. You’ll create 
the customer service page by making a copy of the main (index.htm) page, then removing content 
that shouldn’t appear on the customer service page, then adding new content.

For more information on how to add and format text, see “Add styled text” on page 97.

To create a copy of your first page (index.htm):

1 In the Site panel, right-click (Windows) or Control-click (Macintosh) the filename of the first 
page you created, index.htm (or whatever name you gave the file).

2 From the context menu, choose Duplicate.

A copy of the file appears.

Tip: If the copy doesn’t appear immediately, click the Refresh button in the Site panel to make it appear.

3 Select the new duplicated file. Pause for a moment, then click it again to make the filename 
editable (this is the same technique used in Windows Explorer and in the Finder).

4 Give the new file a new name, such as customerService.htm.

To remove unnecessary material from the new page:

1 Open the new customerService.htm page by double-clicking it in the Site panel.

Look at the Document window’s title bar to be sure that you’re looking at the 
customerService.htm file. The title bar should say “Global Car Rental Home Page” and then a 
folder name and a filename; the filename should be customerServe.htm (or whatever you 
named it in the previous procedure).

2 In the customerService.htm page, select the large image (the image showing the car in the main 
text column) by clicking it.

3 In the tag selector, click the <td> tag.

4 Press Backspace (Windows) or Delete (Macintosh).

Everything in the table cell, including the image and the text, is deleted.

5 Save your document.

To add text to the new page:

1 In the Site panel, locate the custServInfo.htm file in your Assets folder. Double-click the file’s 
icon to open it.

This file contains content to be added to the customer service page. If you were creating your 
own site, you would add your own content here, but for the purposes of this lesson, this 
content is provided for you.

2 In the custServInfo.htm Document window, choose View > Code to view the HTML code.

3 Still in the custServInfo.htm Document window, press Control+A (Windows) or 
Command+A (Macintosh) to select everything in the file.

If you’re not in Code view when you do this, you may have to press Control+A or Command+A 
several times to select everything; if the insertion point is inside a table cell, Select All initially 
selects only that cell. For simplicity, switch to Code view before selecting everything.

4 Press Control+C (Windows) or Command+C (Macintosh) to copy everything.
Chapter 5104



5 Switch back to the customerService.htm document. Click inside the now-empty main text 
column (the wide column on the left).

6 Choose Edit > Paste HTML.

The HTML code that you copied from the custServInfo.htm file is pasted into this document. 
(If you choose Edit > Paste instead of Edit > Paste HTML, the HTML code is pasted into 
Design view as if it’s text. If HTML code appears in your Design view at this step, choose 
Edit > Undo and try again.)

The text.css style sheet is already attached to this page, so text is formatted automatically.

Add text links between pages
You can create links at any stage of the site-creation process. If you’re following the lessons of this 
guide in order, then you’ve already created your pages and placed content in them; so in this 
lesson you’ll create links between the pages you’ve created.

The following are two other general approaches to creating links for a site:

• Create a set of dummy pages first, then add links between them, and then add content to the pages.

• As you create a page, specify links to pages that don’t exist yet; later, create pages that have the 
filenames you linked to. 

To create a link from the customer service page to index.htm:

1 Switch to the customer service page if it’s not the current page. (If the page is not open, open it 
by double-clicking its icon in the Site panel.)

2 In the bottom of the wide text column on the left side, select the words “Home Page”.

If you didn’t add text to the left column of the customer service page when you created it, enter 
the words Home Page in that text column and select those words.

3 If the Property inspector isn’t open, open it by choosing Window > Properties. 

4 Click the folder icon next to the Link text box in the Property inspector. Browse to the 
index.htm file in your site’s local root folder.

Create rollovers for graphical links
A rollover image is an image that appears to change when a visitor to your site points to the image 
with the pointer. For example, a button on a page may appear to light up when the visitor points to it.

A rollover image consists of two images: the image displayed when the page first loads in the 
browser, and the image displayed when the pointer moves over the original image.

Note: When creating a rollover, make sure to use two images that have the same dimensions.

To create a rollover:

1 Switch to the main (index.htm) page if it’s not the current page. (If the page is not open, open 
it by double-clicking its icon in the Site panel.)

2 In the Document window, place the insertion point where you want the rollover image to 
appear. On the Global Car Rental main page, for example, double-click in the navigation-bar 
table cell that says “Lorem” and press Backspace (Windows) or Delete (Macintosh) to delete 
the text, leaving the insertion point in the cell.
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3 Choose Insert > Interactive Images > Rollover Image. 

4 In the Insert Rollover Image dialog box, type a name for the image, such as home-image, in the 
Image Name text box.

This gives the image a unique name, and makes it easily identifiable in the HTML code.

5 In the Original Image text box, click Browse; then navigate to the btnHome.jpg file in your 
site’s images folder (inside the assets folder). Make sure the Relative To pop-up menu is set to 
Document; then click OK or Select (Windows), or Open or Choose (Macintosh).

The Original Image text box indicates which image to display when the page first appears in 
the browser.

6 In the Rollover Image text box, click Browse; then navigate to btnHome_on.jpg in your site’s 
images folder. Make sure the Relative To pop-up menu is set to Document; then click OK or 
Select (Windows), or Open or Choose (Macintosh).

The Rollover Image text box indicates which image to display when the pointer is pointing to 
the image in the browser.

7 Make sure the Preload Rollover Image option is selected so the rollover images load when the 
page opens in the browser, ensuring a quick transition between images when a user moves the 
pointer over the original image.

8 In the When Clicked, Go To URL text box, click the Browse button and browse to index.htm.

The index.htm file is the file that you’re editing, so this step causes the rollover image to link to 
the page that you’re placing the rollover image on. It might seem unnecessary to have a link to 
the page that the link is on, but you’ll be using the same set of navigation rollovers on other 
pages as well, so this link will allow visitors to return to the index.htm page from other pages 
that contain this navigation bar.

9 Click OK to close the dialog box.

The specified original image appears in the document.

10 Save your document.

Note: Rollover images don’t change when you point to them with the pointer in the Dreamweaver Document 
window; rollover images work only in a browser. To make sure your rollovers work, you have to preview your 
document in a browser. For information on previewing, see “Preview in browser” on page 107. 

For the Global Car Rental site, create two more rollovers in the other two navigation-bar table 
cells (the ones that say “Ipsum” and “Dolor”): one rollover that uses the btnCustomerService.jpg 
and btnCustomerService_on.jpg images, and is linked to customerService.htm, and another 
rollover that uses the btnLocations.jpg and btnLocations_on.jpg images, and is linked to 
locations.htm. Note that you haven’t yet created the locations.htm file; just type the filename into 
the When Clicked, Go To URL text box in the Insert Rollover Image dialog box.
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Copy the navigation bar
Now that you’ve created a working navigation bar, you can reuse it in all of your pages. In this 
lesson, you’ll copy the navigation-bar table cells and paste them into your second page.

There are a variety of other ways to reuse content in Dreamweaver, including library items, 
templates, and snippets. 

To copy the navigation bar into another page:

1 In the index.htm file, click in the table cell that contains the Home rollover image.

2 In the tag selector, select the rightmost <tr> tag.

The table row containing the three navigation-bar rollovers is selected.

3 Choose Edit > Copy.

4 Switch to the customerService.htm file.

5 Click in the navigation-bar table cell that says “Lorem.”

6 In the tag selector, select the rightmost <tr> tag.

7 Choose Edit > Paste.

The navigation-bar rollover images are pasted in place of the existing table cells.

8 Save your document.

Preview in browser
The Design view gives a rough idea of what your page will look like in a browser, but the only way 
to be sure how it will look is to preview it in a browser. Each version of each browser has its own 
quirks; Dreamweaver strives to produce HTML that will look as similar as possible from one 
browser to another, but sometimes differences can’t be avoided. (That’s why Dreamweaver doesn’t 
display a preview directly; there’s no way for Dreamweaver to mimic all the different behaviors of 
all the different browsers.)

Preview in Browser shows how the pages will look when you’ve published them.

To preview your pages:

1 If index.htm isn’t the current document, switch to it. (If it’s not open, open it.)

2 Press the F12 key.

Your primary browser starts if it’s not running already. It displays the index page.

Note: Dreamweaver should automatically detect your primary browser and use that for previewing. If the preview 
doesn’t appear, or if it doesn’t appear in the browser you expect, switch back to Dreamweaver (if necessary) and 
choose File > Preview in Browser > Edit Browser List. The Preview in Browser Preferences dialog box appears; 
add the correct browser to the list. For more information, click the Help button in the Preferences dialog box.

3 Move the pointer to point to the rollover images to see the images change. Click links to make 
sure they work.
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Set up a remote site, then publish
You’ve now created a small but functional website. The next step is to publish it by uploading the 
files to a remote web server.

Before you can proceed, you must have access to a remote web server (such as your ISP’s server, a 
server owned by the client you’re working for, or an intranet server within your company, or an 
IIS or PWS server on a Windows computer). If you don’t already have access to such a server, 
contact your ISP, your client, or your system administrator.

The following procedure works best if your remote root folder is empty. If your remote site 
already contains files, then create an empty folder in your remote site (on the server), and use that 
empty folder as your remote root folder.

The following procedure assumes that you have set up a local site. For more information, see “Set 
up a local site” on page 84.

To connect to a remote site:

1 Choose Site > Edit Sites.

2 Select a site (such as Global Car Rental) and click Edit.

3 Click the Basic tab at the top of the dialog box.

4 You’ve already filled in the first few steps in the Basic tab, when you set up your local site, so 
click Next a few times, until the Sharing Files step is highlighted at the top of the wizard. 

5 In the pop-up menu labeled “How do you connect to your remote server?”, choose a method 
for connecting to the remote site.

The most common method for connecting to a server on the Internet is FTP; the most 
common method for connecting a server on your intranet is Local/Network. If you aren’t sure 
what to choose here, ask the server’s system administrator.

6 If you choose FTP, enter the following options:

• Enter the hostname of the server (such as ftp.macromedia.com).

• In the text box that asks what folder contains your files, enter the path on the server from the ftp 
root folder to the remote site’s root folder. If you’re not sure, consult your system administrator.

In many cases, this text box should be left blank.
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• Enter your user name and password in the appropriate text boxes and click Test Connection.

• If the connection is unsuccessful, consult your system administrator.

7 If you choose Local/Network, then click the folder icon next to the text box and browse to the 
remote site’s root folder.

8 Click Next.

9 Don’t enable check-in and check-out for this site.

If you and your co-workers are working together on a larger site, using the check-in and 
check-out feature helps prevent you from overwriting each others’ files. For this site, though, 
you don’t need this feature.

10 Click Next.

11 Click Done to finish setting up the remote site.

12 Click Done again to finish editing the site.

To upload your pages to a remote site:

1 In the Site panel, select the site’s local root folder.

2 Click the Put Files button.

All of the site’s files are uploaded to the remote site.

3 Open your remote site in a browser to make sure everything uploaded correctly.

Further reading
Dreamweaver is a big application, with dozens of powerful features. This tutorial touches on only 
the basics. For more detailed information on topics covered in this tutorial, see Dreamweaver Help > 
Using Dreamweaver.

This tutorial focused on using Design view to create a static site. For information on Code view 
and hand-coding in Dreamweaver, see “Dreamweaver tutorial 2: Editing code” on page 109. For 
information about the basics of creating a database-driven web application, see “Dreamweaver 
tutorial 3: Building a web application” on page 118.

Dreamweaver tutorial 2: Editing code
While web developers can benefit from the rich visual tools offered by Macromedia 
Dreamweaver MX, many developers also use coding tools to get the job done. Dreamweaver MX 
has many new features to give you the professional coding environment you need.

This tutorial gives you a quick view of the new Dreamweaver MX professional coding 
environment. For more information, see Dreamweaver Help > Using Dreamweaver > 
Coding in Dreamweaver.

Switch to the coding workspace
If you didn’t do so during installation, you can make your workspace look and feel like the 
popular coding environments of Macromedia HomeSite and Macromedia ColdFusion Studio.

Note: Macintosh users cannot change the workspace.
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To adopt the new coding workspace: 

1 Choose Edit > Preferences, then choose General from the list of categories on the left.

The General category appears. 

2 Click the Change Workspace button.

The Workspace Setup dialog box appears. 

3 Select the Dreamweaver MX Workspace option, then select the HomeSite/Coder-Style option.
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4 Click OK twice to close the Preferences dialog box.

5 Close Dreamweaver and then restart it.

Copy a folder to your site
Before you start the lessons, you need to set up a site and copy a folder into the site. The 
integrated file browser in the Site panel enables you to view your local disk and network. This is 
useful for working with files that are not in the current site showing in the Site panel.

To copy pages to your site:

1 Choose Window > Site to open the Site panel, if it’s not already open.

2 In the Site panel, from the Site pop-up menu, select the name of the site you defined in the 
first tutorial in this chapter.

If you have not defined a site, see “Set up a local site” on page 84. You need to define a site 
before you continue.

When you select the site name from the pop-up menu, Dreamweaver displays the files in the site.

3 Expand the Desktop (Windows) or Computer (Macintosh) icon to see your available disks.

4 Expand folders as necessary to reach the Dreamweaver application folder, and then expand the 
Samples folder.

5 In the Samples folder, expand the GettingStarted folder, then select the Code folder, and press 
Control+C (Windows) or Command+C (Macintosh) to copy it.

6 Scroll back to the top of the Site panel, and select the site folder. 

7 Press Control+V (Windows) or Command+V (Macintosh) to paste a copy of the folder in your site.

View the finished pages
Before you start, you can view finished pages to see how your pages might look. Of course, your 
pages may vary.

To view the finished pages:

1 Choose Window > Site to open the Site panel, if it’s not already open.

2 Expand the Desktop (Windows) or Computer (Macintosh) icon to see your available disks.

3 Expand folders as necessary to reach the Dreamweaver application folder, and then expand the 
Samples folder.

4 In the Samples folder, expand the GettingStarted folder, then expand the FinalSite folder.

5 In the FinalSite folder, double-click index.htm to open it, then double-click 
location_comp.htm.

Dreamweaver displays the pages in the Document window.

6 Close the pages when you are finished.
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Open multiple pages
Use the Site panel to open the pages you need for this lesson.

To open pages:

1 Choose Window > Site to open the Site panel, if it’s not already open.

2 In your site, expand the Code folder.

3 Double-click index.htm to open it, then double-click location_start.htm.

These are the two files you’ll need for this lesson. 

4 In the Document window, click the Show Code View button on the toolbar or choose View > 
Code to switch to Code view and see the file’s source code.

5 To switch between the pages quickly, press Control+Tab or click the tab at the bottom of the 
page (Windows only).

Note: You must maximize the page to see the tabs.

Add an image by dragging it
In this lesson you’ll add a button to the home page for a Locations page, similar to the buttons for 
Home and Customer Service. You can enter the code directly on the page, click the image icon on 
the Insert bar, or use the image (IMG) tag editor (select the image, right-click in Windows or 
Control-click in Macintosh, then select Edit Tag).

Another option is to drag the image from its folder.

To add an image by dragging it:

1 Open index.htm in Code view, if it’s not already open.

2 In the Files panel group, open the Assets panel (Windows > Assets).

3 Select the image file for btnLocations.jpg.

4 Drag the image file to the page code, and then drop it in the code for the third cell in the first table.

Tip: Look for the code for the Home and Customer Service buttons. Drop the Locations image before the 
closing /td tag for the table cell that follows the two cells for those buttons.

Dreamweaver inserts the code at the insertion point to create the image.

5 Choose File > Save.
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Add a link with the Tag Chooser 
Now you’ll make the button you added link to the Locations page. In addition to manually 
entering code for a link and using the Insert bar to add a link, you can use the Tag Chooser.

To write code with the help of the Tag Chooser:

1 Open index.htm in Code view, if it’s not already open.

2 In the code for the first table, find and select the code for the Location button you inserted in 
the last section.

Note: Make sure you highlight the entire <img> tag.

3 Right-click (Windows) or Control-click (Macintosh) the selected text, and then select Insert 
Tag from the pop-up menu. 

The Tag Chooser appears.

4 Choose HTML Tags, Page Elements, General, and then select A in the right pane.

Note: You can also choose HTML Tags, and then select the A tag in the right pane, without first selecting Page 
Elements, General.

5 Click Insert.

A tag editor for the anchor tag (<a>) appears. 

6 In the HREF text box, enter location_start.htm or click the Browse button to browse to the file.

Note: If you want to link to a web page, enter the page’s URL.

7 Click OK to close the tag editor.

8 Click Close to close the Tag Chooser.

Dreamweaver inserts the code in your page to create the link.

9 In the Document window, choose File > Save.
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Edit a tag
Next, you’ll use the Tag inspector to find a specific tag in the Locations page and quickly make 
changes to it. 

To edit a tag using the Tag inspector:

1 Open location_start.htm in Code view, if it’s not already open.

2 Do one of the following to open the Tag inspector, if it’s not already open:

• Choose Window > Tag Inspector.

• In the Code panel group, click the Tag Inspector tab. 

The Tag inspector gives you a structured view of all the tags in your page. It also displays the 
attributes of each tag.

3 In the Document window Code view, find the text for the heading “Rental Locations.”

4 Select the non-breaking space entity (&nbsp;) between the paragraph tags that follow the heading:

<p><FONT SIZE="+2" COLOR="#FF6600">Rental Locations</FONT></p>
<p>
&nbsp;</p>

5 Choose Insert > Table, then click OK in the Insert Table dialog box to accept the default values.

Dreamweaver inserts table code.
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6 Click the Refresh button on the toolbar.

The Tag Inspector panel updates so that focus is on the Table tag you just inserted. A list of 
attributes appears below the tag.

7 In the Document window, click a few different tags to see how the Tag inspector updates the 
tag and attributes it displays, then click the Table tag again so that its attributes appear in the 
Tag inspector.

8 In the Tag Inspector panel, click in the empty text box beside the align attribute.

An arrow for a pop-up menu appears.

9 Click the pop-up menu arrow, and select center.

Dreamweaver changes the code in the Document window.

10 Click the Show Design View button on the toolbar or choose View > Design to see the table.

11 In the Document window, choose File > Save.

Look up information about a tag
If you need help with a tag’s attributes and attribute values, you can look up reference information 
within Dreamweaver.

To look up information about a tag:

1 Open location_start.htm in Code view, if it’s not already open.

2 In the Document window, select the text “bgcolor” in the body tag.

3 Right-click (Windows) or Control-click (Macintosh) the selected text, and then choose 
Reference from the pop-up menu.

The Reference panel opens and displays information about the bgcolor attribute.

Note: You can also choose Window > Reference to access the Reference panel. This panel is integrated in the 
development environment in the Code group panel.

4 For information about a specific tag attribute, select the attribute from the pop-up menu.
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Add an image with Code Hints
In this lesson you’ll add a logo to the Locations page.

To add code to the page manually, simply click in the Document window and start typing. You 
can also use the new Code Hints feature in Dreamweaver to speed up your work. 

To write code with the help of Code Hints:

1 Open location_start.htm in Code view, if it’s not already open.

2 Find the code for the table row that contains the text “The International Car Rental 
Specialists”; select the non-breaking space entity (&nbsp;) in the code for the cell that comes 
before that text:

<td rowspan="2" bgcolor="#424973">&nbsp;</td>

3 Type the opening bracket (<) of the image tag.

A list of tags appears at the insertion point. 

Note: You can set the length of the delay by selecting Edit > Preferences or Dreamweaver > Preferences 
(Mac OS X), and then selecting Code Hints from the category list on the left. You can open Code Hints by 
pressing the Spacebar, and you can close Code Hints at any time by pressing Escape. 

4 Select the img tag from the list, and then press Enter (Windows) or Return (Macintosh) to 
insert the tag.

Tip: To quickly scroll to a tag, type the first letter of the tag.

5 Press the Spacebar to display a list of attributes for the tag.

6 Type src, and then press Enter (Windows) or Return (Macintosh).

A Browse button appears below the code you just typed.

7 Select the browse button to navigate to the image file or enter the image file path, Assets/
images/logo.jpg.

8 Press the Spacebar, select the alt attribute, and then press Enter (Windows) or 
Return (Macintosh).

9 Type Logo, then move the cursor to the right of the quotation mark that appears after the 
word Logo.

10 Press the spacebar, select the align attribute, and then press Enter (Windows) or Return 
(Macintosh).

A list of known values for the align attribute appears.

11 Select top from the list, and then press Enter (Windows) or Return (Macintosh).

12 Type a closing bracket (>) to complete the tag.

13 In the Document window, choose File > Save.

To add an attribute to an existing tag, place the insertion point just before the tag’s closing bracket 
(>) and press the Spacebar. A list of attributes appears. Add the attribute and specify its value, if any.
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Check your changes
After making any change to your code, you can get immediate visual feedback.

To see a visual representation of your code, do either of the following:

• Click the Show Design View button on the toolbar or select View > Design.

• View the page in a web browser by pressing F12. To close the browser and return to your code, 
press Alt-F4 (Windows only).

Add a link with the Insert bar
Now, you’ll add a link to the logo image you inserted so that when the user clicks it, the home 
page opens.

One way you can create the link is by simply placing an anchor tag (<a>) around the image tag in 
the code and setting the anchor tag’s attributes—with or without the help of Code Hints. 
Another way to add the link is to use the Insert bar.

To write code with the help of the Insert bar:

1 Open location_start.htm in Code view, if it’s not already open.

2 Highlight the code for the logo.jpg image you inserted.

Note: Make sure you highlight the entire <img> tag.

3 In the Common tab of the Insert bar, click the Hyperlink button.

The Hyperlink dialog box appears with the image tag already entered.

4 In the Link text box, enter index.htm or click the folder icon to browse to it.

Note: To link to a web page, enter the page’s URL.

5 Click OK.

Dreamweaver inserts the code in your page to create the link around the image.

6 Choose File > Save.
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Printing your code
You can print your code to edit it offline, archive it, or distribute it.

To print the code:

1 Open a page in Code view.

2 Choose File > Print Code.

Tip: To print with line numbers, choose View > Code View Options > Line Numbers before you print.

Further reading
For information on the hand-coding features in Dreamweaver, and for information on accessing 
your code while working in Dreamweaver’s visual design environment, see Dreamweaver Help > 
Using Dreamweaver. 

Dreamweaver tutorial 3: Building a web application
This tutorial shows you how to use Macromedia Dreamweaver MX to quickly begin developing 
dynamic database-driven web applications. A powerful aspect of dynamic web applications 
development is the ability to present database stored information in a web format.

As you complete this lesson, you’ll learn how to incorporate database information in your website. 
You’ll develop web applications for the Global Car Rental site, using an existing database 
containing three tables of data—locations, comments, and regions. You’ll also use Dreamweaver 
to create a simple SQL query to extract data from the database. 

In this lesson, you’ll build the following dynamic pages:

• An insert page that allows site visitors to send comments to the company

• A detail page that lists the customer’s comments and contact information

Before you begin
To take this tutorial, you first need to complete the setup tasks listed in the next section so that 
you can work with the sample ColdFusion pages included with Dreamweaver MX. 

The setup checklists guide you through installing and configuring both a web server and the 
ColdFusion MX Server Developer Edition included on the Macromedia Studio MX CD-ROM 
(Windows version only). You can also download the Developer Edition from 
www.macromedia.com/software/coldfusion/.

These setup procedures describe one way to set up the sample application if you’re using 
ColdFusion with Microsoft Internet Information Server (IIS) or Personal Web Server (PWS). For 
more information on these web servers, see Dreamweaver Help > Using Dreamweaver > 
Installing a Web Server in Windows. If you’re using ColdFusion MX with a different web server, 
see Dreamweaver Help > Using Dreamweaver > Setting Up a Web Application.

The screen examples in this tutorial show Macromedia ColdFusion dialog boxes. However, you 
can complete the lessons in this chapter in all other server models supported by Dreamweaver 
MX: PHP, ASP.NET, ASP, and JSP. For information on working with these models, see 
Dreamweaver Help.

Setting up a web application is a three-step process. First, configure your system. Second, define a 
Dreamweaver site. Third, connect the application to your database. This setup guide follows this 
three-step process. 
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Setup checklists for ColdFusion developers

To set up a web application, you must configure your system, define a Dreamweaver site, and 
connect to a database. This section provides checklists for each task. The procedures are described 
in the rest of the chapter.

Configure your system

1 Make sure you have a web server.

2 Install the Developer Edition of ColdFusion MX Server.

For installation requirements and instructions, see Chapter 16, “Installing the Developer 
Edition of Macromedia ColdFusion MX Server,” on page 373.

3 Create a root folder. 

Define a Dreamweaver site

1 Copy the sample files to a folder on your hard disk.

2 Define the folder as a Dreamweaver local folder.

3 Define a web server folder as a Dreamweaver remote folder.

4 Specify a folder to process dynamic pages.

5 Upload the sample files to the web server.

Connect to the database

1 If you have a remote server configuration, copy the sample database to the remote computer.

2 Create a ColdFusion data source in ColdFusion Administrator.

3 View the connection in Dreamweaver.

Configure your system

This section provides instructions for two common system configurations—one where 
Microsoft IIS or PWS is installed on your hard disk, and one where IIS or PWS is installed on a 
remote Windows computer. If you don’t want to use these configurations, see Dreamweaver Help > 
Using Dreamweaver > Setting Up a Web Application. 

You can also use the stand-alone web server installed with the Developer Edition of 
ColdFusion MX. See “Installing Macromedia ColdFusion MX Server on Windows” on page 374.
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The following illustration shows the two configurations described in this section:

1 Make sure you have a web server (see “Check for a web server” on page 120).

2 Install the ColdFusion application server (see Chapter 16, “Installing the Developer Edition of 
Macromedia ColdFusion MX Server,” on page 373).

3 Create a root folder (see “Create a root folder” on page 121). 

Note: Installing the web server and application server are one-time-only tasks.

Check for a web server 

To develop and test dynamic web pages, you need a web server. A web server is software that 
serves web pages in response to requests from web browsers.

Make sure Microsoft IIS or PWS is installed and running on your hard disk or on a remote 
Windows computer. (Macintosh users need to install Microsoft IIS or PWS on a remote 
Windows computer.) A quick way to check whether PWS or IIS is installed on a system is to look 
at the folder structure. Does it contain a c:\Inetpub or d:\Inetpub folder? PWS and IIS create this 
folder during installation.

If PWS or IIS is not installed on the system, install it now. For instructions, see 
Dreamweaver Help > Using Dreamweaver > Installing a Web Server in Windows.
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Install ColdFusion MX Server

To process dynamic web pages, you need an application server. An application server is software 
that helps a web server process web pages containing server-side scripts or tags. When such a page 
is requested from the server, the web server hands the page off to the application server for 
processing before sending the page to the browser.

For system requirements and installation instructions, see Chapter 16, “Installing the Developer 
Edition of Macromedia ColdFusion MX Server,” on page 373.

After completing the installation, follow the instructions in “Confirming the installation of and 
administering ColdFusion MX Server” on page 375 to make sure that ColdFusion MX is 
installed and running.

The next step is to create a root folder for your web application. 

Create a root folder

After the server software is installed, create a root folder for your web application on the system 
running Microsoft PWS or IIS, and make sure the folder has the necessary permissions. 

1 Create a folder called MySampleApp on the system running PWS or IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By default, your PWS or IIS web 
server is set up in the Inetpub\wwwroot folder. The web server will serve any page in this folder 
or in any of its subfolders in response to an HTTP request from a web browser.

2 Make sure the Read and Scripts permissions are enabled for the folder.

If you’re using PWS, launch Personal Web Manager by double-clicking the web server icon in 
the system tray. (The icon depicts a hand holding a web page.) In Personal Web Manager, click 
the Advanced icon. The Advanced Options dialog box appears. Select Home and click Edit 
Properties. The Edit Directory dialog box appears. Make sure the Read and Scripts options are 
selected. For security reasons, you should not select the Execute option. 

If you’re using IIS, launch the IIS administrative tool (in Windows XP, select Start > Control 
Panel > Performance Maintenance > Administrative Tools > Internet Information Services). 
Under Web Sites > Default Web Site, right-click your MySampleSite folder and choose 
Properties from the pop-up menu. In the Execute Permissions text box, make sure the Scripts 
option is selected. For security reasons, do not select the Scripts and Executables option. 

The web server is now configured to serve web pages in your root folder in response to HTTP 
requests from web browsers.

After configuring your system, you must define a Dreamweaver site.

Define a Dreamweaver site

After configuring your system, you must copy the sample files to a local folder and define a 
Dreamweaver site to manage the files. 

1 Copy the sample files to a folder on your hard disk (see “Copy the sample files” on page 122).

2 Define the folder as a Dreamweaver local folder (see “Define a local folder” on page 122).

3 Define your root folder on the web server as a Dreamweaver remote folder (see “Define a 
remote folder” on page 122).
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4 Specify a folder to process dynamic pages (see “Specify where dynamic pages can be processed” 
on page 123).

5 Upload the sample files to the web server (see “Upload the samples files” on page 124).

Copy the sample files

If not already done, copy the sample files from the Dreamweaver application folder to a folder on 
your hard disk.

1 Create a new folder called Sites on your hard disk.

For example, create C:\Sites (Windows) or Hard Drive:Documents:Sites (Macintosh).

2 Locate the GettingStarted folder in the Dreamweaver application folder on your hard disk.

The path to the folder is as follows:

\Macromedia\Dreamweaver MX\Samples\GettingStarted\

3 Copy the GettingStarted folder into the Sites folder.

After copying the GettingStarted folder, define the folder as a Dreamweaver local folder.

Define a local folder

After copying the GettingStarted folder, define the folder containing the ColdFusion sample files 
as a Dreamweaver local folder. 

1 In Dreamweaver, select Site > New Site.

The Site Definition dialog box appears. 

2 If the wizard is showing, click Advanced.

3 In the Site Name text box, enter GlobalCar - ColdFusion.

The name identifies your site within Dreamweaver. 

4 In the Local Root Folder text box, specify the folder in the GettingStarted folder that contains 
the ColdFusion sample files.

You can click the folder icon next to the text box to find and select the folder. In Windows, the 
folder should be as follows:

C:\Sites\GettingStarted\Develop\coldfusion

On the Macintosh, the folder should be as follows:

Hard Drive:Documents:Sites:GettingStarted:Develop:coldfusion

Leave the Site Definition dialog box open. You need to define a web server folder as a 
Dreamweaver remote folder next. 

Define a remote folder

After defining a local folder, define a web server folder as a Dreamweaver remote folder. 

1 In the advanced Site Definition dialog box, click Remote Info in the Category list. 

The Remote Info screen appears.

2 In the Access text box, choose how you want to move your files to and from the server—
directly (the Local/Network option) or FTP. 
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3 Enter the path or FTP settings to the web server folder you created in “Create a root folder” on 
page 121.

The folder may be on your hard disk or on a remote computer. Even if you created the folder 
on your hard disk, that folder is still the valid “remote” folder. Here’s an example if you chose 
Local/Network access:

Remote Folder: c:\Inetpub\wwwroot\MySampleApp

For more information on FTP, see Dreamweaver Help > Using Dreamweaver > Setting Remote 
Info options for FTP access.

Leave the Site Definition dialog box open. You need to define a folder to process dynamic pages next.

Specify where dynamic pages can be processed

After defining the Dreamweaver remote folder, specify a folder to process dynamic pages as 
described in this section. Dreamweaver uses this folder to display dynamic pages and connect to 
databases while you work. 

1 In the advanced Site Definition dialog box, click Testing Server in the Category list.

The Testing Server screen appears. Dreamweaver needs the services of a testing server to 
generate and display dynamic content while you work. The testing server can be your local 
computer, a development server, a staging server, or a production server. As long as it can 
process ColdFusion pages, the choice doesn’t matter. In this case, you can use the same settings 
as the Remote Info category (see “Define a remote folder” on page 122) because they point to 
a server capable of processing ColdFusion pages.

2 Select ColdFusion as your server technology.

3 In the Access text box, choose the method (Local/Network or FTP) you specified for accessing 
your remote folder.

Dreamweaver enters the settings you specified in the Remote Info category. Leave the 
settings unchanged.

4 In the URL Prefix text box, enter the root URL you would enter in a web browser to request a 
page in your web application.

To display live data in your pages while you work, Dreamweaver creates a temporary file, 
copies it to the website’s root folder, and attempts to request it using the URL prefix. 

Dreamweaver makes a best guess at the URL prefix based on the information you provided in 
the Site Definition dialog box. For example, if the folder specified in the Remote Folder text 
box is c:\Inetpub\wwwroot\MySampleApp, then the URL prefix should be as follows:

http://localhost/MySampleApp/

Tip: The URL prefix should never specify a particular page on the site. 

However, the suggested URL prefix may be incorrect. Correct or enter a new URL prefix 
if Dreamweaver’s suggestion is incorrect. For more information, see Dreamweaver Help > 
Using Dreamweaver > About the URL prefix.

5 Click OK, then click Done.

After specifying a folder to process dynamic pages, upload the sample files to the web server.
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Upload the samples files 

After specifying a folder to process dynamic pages, upload the sample files to the web server as 
described in this section. You must “upload” the files even if the web server is running on your 
local computer. 

If you don’t upload the files, features such as Live Data view and Preview in Browser may not work 
properly with dynamic pages. For example, image links might be broken in Live Data view because 
the image files are not on the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing from the server. 

1 In the Site panel (Window > Site), select the root folder in the Local Files pane.

The root folder should be the first folder in the list.

2 Click the blue up arrow on the toolbar. 

Dreamweaver copies all the files to the web server folder you defined in “Define a remote 
folder” on page 122. 

The Dreamweaver site is defined. The next step is to connect to the sample database installed 
with Dreamweaver.

Connect to the sample database

During installation, Dreamweaver copies a sample Microsoft Access database to your hard disk. 
This section describes how to create a connection to the sample database.

Note: If you want to connect to another database, see Dreamweaver Help > Using Dreamweaver > 
Database Connections for ColdFusion Developers.

1 If you have a remote server configuration, copy the sample database to the remote computer 
(see “Set up the database (remote server configuration)” on page 124).

2 Create a ColdFusion data source in ColdFusion Administrator (see “Create a ColdFusion data 
source” on page 125).

3 View the connection in Dreamweaver (see “Connect to the sample database” on page 125).

Set up the database (remote server configuration)

This section applies only if you have a remote server configuration—that is, if your web server is 
running on a remote computer. If your web server is running on the same computer as 
Dreamweaver, skip to “Create a ColdFusion data source” on page 125.

Before attempting to connect to the sample database, copy the database to the remote computer’s 
hard disk. The database file, global.mdb, is located in the following folder on your local hard disk:

\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

You can place the file in any folder on the remote computer, or you can create a new folder for it.

After the database is in place, create a ColdFusion data source in ColdFusion Administrator. 
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Create a ColdFusion data source

Create a ColdFusion data source called connGlobal in ColdFusion Administrator pointing to the 
sample database file. 

1 In Dreamweaver, open a ColdFusion page.

2 In the Databases panel (Window > Databases), click the Modify Data Sources icon (the second 
icon from the right on the panel toolbar).

ColdFusion Administrator opens in a browser. 

3 Log in to ColdFusion Administrator and create a data source called connGlobal pointing to 
the global.mdb database file. 

If ColdFusion is running on your local computer, create a data source that points to the 
database file in the following folder:

c:\Program Files\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

If ColdFusion is running on a remote computer, create a data source that points to the 
database file you placed on the remote computer in “Set up the database (remote server 
configuration)” on page 124.

For more information, see Dreamweaver Help > Using Dreamweaver > Using ColdFusion. 

After creating the ColdFusion data source, you can connect to the database in Dreamweaver. 

Connect to the sample database

After creating the ColdFusion data source, you can use it to connect to the database in Dreamweaver.

Open any ColdFusion page in Dreamweaver, then open the Databases panel (Window > 
Databases). Your ColdFusion data sources appear in the panel.

If the data source you created does not appear in the panel, do one of the following:

• Double-check the connection parameters in ColdFusion Administrator. 

• Check the settings for the folder Dreamweaver uses to process dynamic pages (see “Specify 
where dynamic pages can be processed” on page 123).

• See Dreamweaver Help > Using Dreamweaver > Troubleshooting Database Connections.

If the data source called connGlobal appears in the panel, the sample ColdFusion application is 
set up for this tutorial. 
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Begin the tutorial
Now you are ready to create a data-driven web application.

Open a document to work in

A good starting point for developing a database application is to create a list of the records stored 
in the database. In the application you’re building in this chapter, you will list information in the 
customer comments table of the database. Later, you’ll create a dynamic web page which lets a 
customer insert comments or questions directly to the database.

Let’s start by locating the documents you’ll work with as you create these pages.

1 Do one of the following to open the Site panel:

• In the Files panel group, click the expander arrow to display the Site panel. 

• Choose Window > Site.

• Press F8.

The Site panel opens. 
Chapter 5126



2 In the Site pop-up menu, select the Global Car site you defined for your server pages. 

3 In the Site panel, double-click the customerComment file to open it.

The document opens in the Document window.

4 If you are currently viewing the document in Code view, click the Show Design View button 
or the Show Code and Design Views button in the Document toolbar, so you can use the 
screen examples provided as checkpoints while you complete the lesson.

You will edit the partially completed page. 

Define a recordset

Now you’ll create a recordset to select the data you want to display. A recordset is a subset of 
information extracted from a database by a database query. (In ASP.NET, a recordset is known as 
a DataSet.) A database query consists of search criteria, which defines what’s included in the 
recordset. You then use the information extracted as a source of content for your dynamic pages.

Dreamweaver MX provides an easy-to-use interface for creating simple SQL queries—you don’t 
need to know SQL to create a recordset in Dreamweaver.

You’ll create a recordset that selects all of the values from the COMMENTS table in the 
Global database.

1 In Dreamweaver, open the Recordset or DataSet (ASP.NET) dialog box by doing one of 
the following:

• In the Insert bar’s Application tab, click the Recordset or DataSet (ASP.NET) button. 

• Choose Window > Bindings to open the Bindings panel, then click the Plus (+) button and 
select Recordset or DataSet (ASP.NET).
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• Click the Application panel group’s expander arrow, then in the Bindings panel click the plus 
(+) button and select Recordset or DataSet (ASP.NET). 

The Recordset or DataSet dialog box appears. If the dialog box you see looks more complex 
than the dialog box below, click the Simple button.

2 In the Name text box, enter rsComments. 

3 In the Data Source pop-up menu (ColdFusion) or Connection pop-up menu (other server 
page types), select connGlobal.

The Recordset or DataSet dialog box updates with data from the database.

In the Table pop-up menu, COMMENTS is already selected. In Columns, All is selected.
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4 Accept the default value to request the complete recordset.

5 In the Sort pop-up menu, select LAST_NAME, and in the second pop-up menu, select Ascending.

The retrieved records list data in alphabetical order by customer last name. 

6 Click Test to test the recordset or dataset. 

The records from the database that match your recordset or dataset selection criteria are 
displayed in the Test SQL Statement window. 

7 Click OK to close the Test SQL Statement window.

8 Click OK to close the Recordset or DataSet dialog box.

The recordset appears in the Bindings panel.
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Tip: If you do not see all the recordset fields, click the plus (+) button in front of Recordset (rsComments) to 
expand the recordset display. 

Display the database records

Next, you’ll create a page which lists the records that currently exist in the COMMENTS table. 
You will dynamically generate the page rather than manually enter the information. 

You’ll start by creating a table to structure the data list. 

1 In the customerComment document, place the insertion point after “Customer Comments”, 
then press Enter (Windows) or Return (Macintosh) to set where the table will be inserted.

2 Insert a table by doing one of the following:

• In the Insert bar, click the Common tab, then click the Table button or drag it to the document.

• In the Insert bar, click the Layout tab, then click the Table button or drag it to the document. 

• Select Insert > Table.

The Insert Table dialog box appears.
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3 In the dialog box, set the following options:

In Rows, enter 2.

In Cell Padding enter 2.

In Columns, enter 4.

In Cell Spacing, enter 2.

In Width, enter 80.

The completed dialog box should look like this:

4 Click OK.

The table is inserted in the document.

5 In the top row of the table add labels for the table entries:

In the first cell of the table, enter First Name.

In the next cell, enter Last Name.

In the next cell, enter E-mail Address.

In the last cell, enter Comments.

6 Save your document (File > Save).

Add dynamic fields to the table

You’re now ready to add the recordset fields to the table. 

1 Open the Bindings panel, if it isn’t already open, by doing one of the following. 

• Choose Window > Bindings.

• Click the Application panel group’s expander arrow, then select the Bindings panel. 

2 Add the FIRST_NAME field to the table, by doing one of the following:

• Place the insertion point in the table cell below the First Name label, then in the Bindings 
panel select FIRST_NAME, and click Insert.

• Drag FIRST_NAME from the Bindings panel to the table cell.
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3 Repeat step 2 to add LAST_NAME, EMAIL, and COMMENTS to the table.

Your page should look like this:

4 Save your document.

Set a repeated region

The table you created only contains one row for data. To see all the records you’ll set the table row 
as a repeated region. The page will repeat with date records for each record that matches the 
recordset search requirements.

1 In the Document window, select the bottom table row by doing one of the following:

• Place the pointer in the first cell, then drag to the right to select all of the cells in the row.

• Click in one of the cells, then in the tag selector, click the <tr> tag.

• Position the pointer to the left of the table row, when it changes to an arrow click the table row 
border to select the row.

2 Set a repeated region, by doing one of the following: 

• In the Server Behaviors panel, click the Plus (+) button, then select Repeat Region. 

• In the Insert bar’s Application tab, click the Repeated Region button. 

• Select Insert > Application Objects > Repeated Region.

The Repeat Region dialog box appears. 

3 In the dialog box, accept the default setting, click OK.

The table row appears in a tabbed outline.

4 Save your document.
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View your pages

Next, you’ll save the pages, then you’ll view the pages to see how the application you developed 
works. To view pages as they would look when processed by the server, you can use Live Data view. 

1 With customerComment still selected, do one of the following to view the data in your pages:

• In the Document toolbar, click the Live Data View button.

• Select View > Live Data.

The page updates with a list of customer data extracted from the database.

Create a record insert form
The next page you’ll create for the Global website is a customer comment page. You want 
customers to enter comments and insert them directly in the database. You’ll connect this page to 
the Comments table in the Global database. 

Dreamweaver includes several application objects that help you create web application pages 
quickly and easily. You’ll use an application object to create the insert page. The Insert Record 
application object creates an HTML form, data fields that link (or bind) to the database, and the 
necessary server scripts to create a dynamic page.

Add a Record Insertion Form application object 

You can use a Record Insertion Form application object to create a form which links to the fields 
of a database. The application object lets you select which fields to include in the form, label 
fields, and select the type of form objects to insert. When a user enters data in the form fields and 
clicks the submit button, a new record is inserted in a database. You can also set a page to open 
after a record has successfully been submitted so the submitter knows the database was updated.

1 In the Site panel, locate the file named customerInsert, then double-click the file to open it.

The document opens in the Document window.

2 Place the insertion point in the document after the word “possible”, then press Enter or Return 
to set where the application object will be inserted. 
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3 Do one of the following to insert a record insertion object:

• In the Insert bar’s Application tab, click the Record Insertion Form button. 

• Choose Insert > Application Objects > Record Insertion Form.

The Record Insertion Form dialog box appears. 

4 In the Data Source (ColdFusion) or Connection pop-up menu, choose connGlobal.

5 In the Table pop-up menu, make sure COMMENTS is selected.

6 In the After Inserting, Go To or On Success, Go To (ASP.NET) text box, click Browse.

7 In the dialog box that appears, select the file named insertOK, then click OK to close the 
dialog box.

You’ve selected a page to display to a site visitor to acknowledge receipt of the information 
they’ve submitted. 

Create the insert form

In the Form Fields section of the Record Insertion Form dialog box, you define the form a visitor 
enters data into.

1 In the Record Insertion Form dialog box, remove the fields you don’t want included in the 
form by doing the following:

Select COMMENT_ID, then click the Minus (-) button.

Select TELEPHONE, then click the Minus (-) button.

Select SUBMIT_DATE, then click the Minus (-) button.

Select ANSWERED, then click the Minus (-) button.
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2 If you are creating a page for ASP.NET, change the alphabetical order of the form fields by 
doing the following:

In the Column list, select COMMENTS, then click the Down arrow button to position 
COMMENTS below LAST_NAME.

In the Column list, select EMAIL, then click the Down arrow button to position it below 
LAST_NAME.

3 In the Form Fields list, select FIRST_NAME to specify how the field will be displayed in the form.

4 In the Label text box, enter First Name. 

This is the label that will appear in the HTML form next to the text field.

5 Set the type of form object for the field by doing one of the following:

• If you are using ASP.NET, in Display As accept the default value Text Field and in the Submit 
As pop-up menu, change the default value WChar to VARCHAR.

• If you are using other server page types, in Display As accept the default value Text Field and in 
Submit As accept the default value Text. 

6 In the Default Value field, type Enter your first name to set initial text for the field which lets 
the user know the type of information to provide.

The FIRST_NAME entry should look similar this when you are done.

7 Repeat steps 3–6 for the LAST_NAME and EMAIL form fields. 

In the Default Value text box, enter the initial text you want to appear in the field when it is 
displayed in the form.

8 Select COMMENTS to set values for this field.

9 In the Label field, enter Comments. 

10 Set values for the Comments form field by doing one of the following:

• If you are using ASP.NET, in the Display As pop-up menu select Text Area, then in the 
Submit As pop-up menu, select VARCHAR.

• If you are using other server page types, in the Display As pop-up menu, select Text Area, and 
in the Submit As pop-up menu accept the default value Text. 
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11 In Default Value text box, enter text that will initially appear in this field in the form or leave 
this field blank.

The dialog box should look similar to this when you are done:

12 Click OK to close the dialog box.

The Record Insertion Form application object is inserted in the document. 

13 Save your document.
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Copy files to the server
Next, you’ll save your changes, and copy the files you’ve updated to your server. After you copy 
the files, you’ll view the insert record page, add a comment or question, and submit the data to 
test the application.

1 In the Site panel, select customerInsert, then click the Put File(s) button (blue up arrow) to 
copy the local file to your server. 

2 When Dreamweaver asks whether you want to copy dependent files to the server, select Yes.

Note: With some server models, Dreamweaver creates a Connections folder in your local folder. You must also 
copy that folder to your remote server for the web application to work. In the Site panel, select the Connections 
folder, then click the Put File (s) button to copy the folder to your server.

3 With customerInsert selected, choose File > Preview in Browser or press F12 (Windows) to 
view your document. 

4 Enter test data in the form, then click the Insert Record button in the document to submit 
your data.

Information updates in the database, and the insertOK page appears.

View the update

Let’s view the changes you made to the database. You can view the changes by opening the 
customerComment document you created in the first part of this lesson, or you can view the 
changes by viewing the database.

• In Dreamweaver, in the Site panel, double-click the document named customerComment, 
then select File > Preview in Browser, and select a browser to view the page in.

The record you entered appears in the Customer Comments list. 

• In Dreamweaver, in the Database panel (Window > Database), locate the connGlobal database 
icon, click the plus (+) button in front of Tables to view the list of tables in the database. Right-
click (Windows) or Control-click (Macintosh), the COMMENTS table and select View Data.

A list of the records in the database appears; the comment you just entered appears as the last 
entry in the table. 

Further reading
For more detailed information about topics covered in this tutorial, see the following topics in 
Dreamweaver Help:

• Storing and Retrieving Data for Your Page

• Defining Sources of Dynamic Data

• Adding Dynamic Content to Web Pages

• Creating recordset navigation links

• Building an insert page rapidly

• Building an insert page block by block
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CHAPTER 6

Dreamweaver MX Integration with the

Macromedia Studio MX Product Family

Macromedia Fireworks MX and Macromedia Flash MX are powerful web development tools designed 
to create graphics and SWF movies that are viewable in web pages. Macromedia Dreamweaver MX is 
tightly integrated with these tools to enable you to simplify your web design workflow.

To set up smooth integration between Macromedia Flash MX, Dreamweaver MX, and Fireworks 
MX, be sure to enable Design Notes when you define your Dreamweaver sites. By default, this 
option is preselected in the Site definition setup. For information about enabling Design Notes, 
see Dreamweaver Help > Using Dreamweaver > Enabling and disabling Design Notes.

When you export files from Macromedia Flash MX or Fireworks MX, to a Dreamweaver-defined 
site, Design Notes that contain references to the PNG or Macromedia Flash authoring file (FLA) 
are automatically exported to the site along with the web-ready file (GIF, JPEG, or SWF). 

You can easily insert Fireworks images or tables and Macromedia Flash movies in a Dreamweaver 
document. You can also take advantage of the integration features between Macromedia Flash 
MX, Fireworks MX, and Dreamweaver MX to make changes to an image or movie after you’ve 
inserted it in a Dreamweaver document. 

While working in Dreamweaver MX, you can also initiate the graphic production process by 
inserting and then updating an image placeholder graphic. For information about image 
placeholders, see Dreamweaver Help > Using Dreamweaver > Inserting an image placeholder. 

After you insert an image placeholder in Dreamweaver MX, you can launch Fireworks MX to 
create a new graphic. In Fireworks, you can design the graphic and add hotspots, behaviors, or 
any other elements you want. You can then save the graphic as a PNG and export it as a 
web-ready graphic file (or files), such as a GIF or JPEG. You can export a sliced table as HTML 
and images. When you return to Dreamweaver MX, the replacement image or Fireworks table is 
updated in the document.

About Fireworks MX and Macromedia Flash MX integration
Roundtrip editing and Design Notes enable Dreamweaver MX to integrate operations with 
Fireworks MX and Macromedia Flash MX. Roundtrip editing ensures that code updates transfer 
correctly between Dreamweaver MX and these other applications—for example, to preserve 
rollover behaviors or links to other files—while Design Notes allow Dreamweaver MX to locate 
the appropriate source document for an exported image or movie file. For information about 
using Design Notes in Dreamweaver MX, see Dreamweaver Help > Using Dreamweaver > 
Using Design Notes in Fireworks and Flash with Dreamweaver.
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In addition to location information, Design Notes contain other pertinent information 
about exported files. For example, when you export a Fireworks table, Fireworks MX writes a 
Design Note for each exported image file in the table. If the exported file contains hotspots or 
rollovers, the JavaScript for the hotspots or rollovers is contained in the HTML document that 
Fireworks MX exports.

For best results, when developing graphics and movies for web publication, save the Fireworks 
MX and Macromedia Flash MX source and web-ready files in a Dreamweaver-defined site. This 
ensures that any user sharing the site will be able to locate the source document when editing a 
Fireworks image or table or when editing a SWF movie while working in Dreamweaver. 

The key to developing a smoothly integrated workflow with these applications is to first set up the 
work environment. For information about setting up the Dreamweaver and Fireworks MX work 
environment, see “Working with Dreamweaver and Macromedia Fireworks MX” on page 140. 
For information about setting up the Dreamweaver and Macromedia Flash MX work 
environment, see “Working with Dreamweaver MX and Macromedia Flash MX” on page 149.

Working with Dreamweaver and Macromedia Fireworks MX
Dreamweaver MX and Fireworks MX recognize and share many of the same file edits, including 
changes to links, image maps, and table slices. Together, the two applications provide 
a streamlined workflow for editing, optimizing, and placing web graphics files in HTML pages.

To set up an integrated work environment, you must complete some preliminary tasks, such as 
defining a local site in Dreamweaver and making sure Design Notes are enabled for the site. 
Design Notes are automatically enabled unless you alter your default settings. 

You must also set Fireworks MX as the primary external image editor for Dreamweaver to easily 
launch Fireworks MX for editing. For information about setting Fireworks MX as an external 
editor, see Dreamweaver Help > Using Dreamweaver > Using an external image editor.

To ensure smooth integration for launching and editing, when you are ready to export your 
Fireworks HTML and graphic files, export them to the Dreamweaver site folder. When you 
export a GIF or JPEG graphic from Fireworks MX to a Dreamweaver site folder, Fireworks MX 
creates a folder named _notes in the same folder. This folder contains the Design Notes, small 
files with the Macromedia Note file extension (.mno). 

Design Notes contain information about the graphic files that Fireworks MX exports. When you 
launch and edit a Fireworks image or table in Dreamweaver, Dreamweaver uses this information 
to locate the source PNG. For information about specifying whether Dreamweaver automatically 
launches the PNG file when available, see “Specifying launch-and-edit preferences for 
Fireworks MX source files” on page 141.

When you select an image in a Dreamweaver document that was exported from Fireworks MX 
and has a corresponding MNO file, the Property inspector displays the Fireworks MX icon and 
the file’s source path. 

Setting Fireworks MX as the external image editor for Dreamweaver MX allows you to go 
between Dreamweaver MX and Fireworks MX effortlessly when you need to edit an image. In 
Dreamweaver preferences, set Fireworks MX as the primary editor for your graphic file types—
GIF, PNG, and JPEG files. For information about setting an image editor, see “Using an 
external image editor” or “Setting external image editor preferences” in Dreamweaver Help > 
Using Dreamweaver. 
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Specifying launch-and-edit preferences for Fireworks MX source files

The Fireworks MX launch-and-edit preferences let you specify how to handle source PNG files 
when launching Fireworks files from another application, such as Dreamweaver.

Dreamweaver MX recognizes the Fireworks MX launch-and-edit preferences only in certain cases 
in which you launch and optimize a Fireworks image. Specifically, you must be launching and 
optimizing an image that is not part of a Fireworks table and does not contain a correct Design 
Notes path to a source PNG file. In all other cases, including all launch-and-edit cases of 
Fireworks images, Dreamweaver automatically launches the source PNG file, prompting you to 
locate the source file if it cannot be found.

To specify launch-and-edit preferences for Fireworks:

1 In Fireworks, choose Edit > Preferences or Fireworks > Preferences (Mac OS X).

2 Click the Launch and Edit tab (Windows) or choose Launch and Edit from the pop-up 
menu (Macintosh).

3 Specify the preference options to use when editing or optimizing Fireworks images placed in an 
external application:

Always Use Source PNG automatically launches the Fireworks PNG file that is defined in the 
Design Note as the source for the placed image. Updates are made to both the source PNG and 
its corresponding placed image.

Never Use Source PNG automatically launches the placed Fireworks image, whether or not a 
source PNG file exists. Updates are made to the placed image only.

Ask When Launching lets you specify each time whether or not to launch the source PNG file. 
When you edit or optimize a placed image, Fireworks MX displays a message prompting you 
to make a launch-and-edit decision. You can also specify global launch-and-edit preferences 
from this message box. 

Inserting a Fireworks MX image in a Dreamweaver MX document

Fireworks graphics can be placed in a Dreamweaver document a number of ways. You can place a 
Fireworks exported graphic directly in a Dreamweaver document using the Insert Image 
command, or you can create a new Fireworks graphic from a Dreamweaver image placeholder. 

To insert a Fireworks MX image into a Dreamweaver document: 

1 In the Dreamweaver document, place the insertion point where you want the image to appear, 
then do one of the following: 

• Choose Insert > Image.

• In the Common category of the Insert bar, click the Image button or drag it to the document. 

2 Navigate to the desired Fireworks exported file, and click OK (Windows) or Open (Macintosh).

Note: If the Fireworks file is not in the current Dreamweaver site, a message appears asking whether you want to 
copy the file to the root folder. Click Yes.
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Updating a Dreamweaver MX image placeholder in Fireworks MX

You can create a placeholder image in a Dreamweaver document and then launch Fireworks MX to 
design a graphic image or Fireworks table to replace it. For information about inserting an image 
placeholder, see Dreamweaver Help > Using Dreamweaver > Inserting an image placeholder.

To create a new image from an image placeholder, you must have both Dreamweaver MX and 
Fireworks MX installed on your system. Fireworks MX recognizes the following image 
placeholder settings you may have set while working with the image placeholder in Dreamweaver: 

• Image size, which correlates to the Fireworks MX canvas size

• Image ID, which Fireworks MX uses as the default document name for the source file and 
export file you create

• Text alignment

• Behaviors that are recognized by Fireworks MX, such as swap image, pop-up menu, navigation 
bar, and set text

Fireworks MX also recognizes links you attached to the image placeholder while working in 
Dreamweaver. 

Note: Although links you’ve added to an image placeholder can’t be seen in Fireworks, they are preserved. If you 
draw a hotspot and add a link in Fireworks MX, it will not delete the link you added to the image placeholder in 
Dreamweaver, However, if you draw out a slice in Fireworks in the new image, it will delete the link in the 
Dreamweaver document when you replace the image placeholder.

Because they are not recognized by Fireworks, the following image placeholder settings are 
disabled in the image placeholder Property inspector: image alignment, color, Vspace and 
Hspace, and maps.

When you create a new image in Fireworks to replace an image placeholder in Dreamweaver, 
Fireworks MX prompts you to save the file as a PNG file (source document) and to export the file 
in a web-ready format such as a GIF, JPEG, or in the case of sliced images, as HTML and images. 
The new image or Fireworks table automatically replaces the image placeholder in the 
Dreamweaver document. 

To edit a Dreamweaver placeholder image in Fireworks MX:

1 Make sure you’ve already set Fireworks MX as the image editor for PNG files. For more 
information, see Dreamweaver Help > Using Dreamweaver > Setting external image 
editor preferences.

2 In the Document window, click the image placeholder to select it.

3 Do one of the following to launch Fireworks MX for editing:

• In the Property inspector, click Create. 

• Press Control (Windows) or Command (Macintosh), then double-click the image placeholder.
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• Right-click the image placeholder, then choose Create Image in Fireworks.

Fireworks launches, in Editing from Dreamweaver mode.

4 Use Fireworks options to design the image. 

5 When you are finished, click Done.

The Save As dialog box appears. Fireworks prompts you to save the PNG file. 

6 In the Save In field, choose the folder you defined as your Dreamweaver local site folder.

If you named the image placeholder when you inserted it in the Dreamweaver document, 
Fireworks populates the File Name field with that name. You can change the name if you want to.

7 To save the PNG file, click Save.

The Export dialog box appears. Use this dialog box to export the image as a GIF.

8 In the dialog box, for Save In choose the Dreamweaver local site folder.

9 The Name text field automatically updates to the same name you used for the PNG file. Enter 
text to change the name if you want to.

10 For Save As Type, select the type of file or files you want to export—for example, Images only 
or HTML and Images. 

11 Click Save.

The file is saved, and the focus returns to Dreamweaver. In the Dreamweaver document, the 
exported file or Fireworks table replaces the image placeholder.

Editing a Fireworks MX image or table

You can launch Fireworks to edit images inserted in a Dreamweaver document. When you launch 
and edit an image or an image slice that is part of a Fireworks table, Dreamweaver launches 
Fireworks and the PNG file from which the image or table was exported.

When the image is part of a Fireworks table, you can launch the entire Fireworks table for edits, as 
long as the <!--fw table--> comment exists in the HTML code. If the source PNG was exported 
from Fireworks to a Dreamweaver site using the Dreamweaver Style HTML and images setting, 
the Fireworks table comment is automatically inserted in the HTML code.

To launch and edit a Fireworks image placed in Dreamweaver:

1 In Dreamweaver, choose Window > Properties to open the Property inspector if it isn’t 
already open.
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2 Click the image or image slice to select it.

The Property inspector identifies the selection as a Fireworks image or table based on the 
selected item, and displays the name of the PNG source file.

3 To launch Fireworks for editing, do one of the following:

• In the Property inspector, click Edit.

• Control-double-click (Windows) or Command-double-click (Macintosh) the selected image.

• Right-click (Windows) or Control-click (Macintosh) the selected image, and choose Edit with 
Fireworks from the context menu. 

Fireworks launches and opens the associated PNG for editing.

Note: If Fireworks cannot locate the source file, you are prompted to locate the PNG source file. When you work 
with the Fireworks source file, changes are saved to both the source file and the exported file; otherwise, only the 
exported file is updated. 

4 In Fireworks, edit the source PNG.

5 When you are finished making edits, click Done.

Fireworks saves the changes in the PNG file, exports the updated image (or HTML and images), 
and returns the focus to Dreamweaver. In Dreamweaver, the updated image or table appears.

Opening a Fireworks MX pop-up menu in Dreamweaver MX 

Fireworks supports image-based pop-up menus and HTML-based pop-up menus. Dreamweaver 
supports only HTML-based pop-up menus. In Dreamweaver, you can open a Fireworks pop-up 
menu and make edits to all menu item properties except for the background images of 
image-based pop-up menus. 

The Show Pop-Up Menu behavior in Dreamweaver allows you to edit or update the contents of a 
Fireworks HTML-based pop-up menu. You can add, delete, or change menu items, rearrange 
them, and set where a menu is positioned in a page. For information about setting or modifying 
pop-up menu options in Dreamweaver, see Dreamweaver Help > Using Dreamweaver > 
Show Pop-Up Menu. 

If the pop-up menu you want to edit is an image-based pop-up menu and you want to preserve 
the image-based cell backgrounds, you should use edit the pop-up menu in Fireworks rather than 
in Dreamweaver.

To edit the background images in an image-based pop-up menu:

Select the image you want to update, then click Edit. For information about editing a Fireworks 
image, see “Editing a Fireworks MX image or table” on page 143.

To open the Fireworks pop-up menu:

1 In the Dreamweaver document, select the hotspot or image that triggers the pop-up menu. 

2 Open the Behaviors panel (Shift+F3) if it isn’t already open, then in the Actions list, 
double-click Show Pop-Up Menu.

The Show Pop-Up Menu dialog box appears.

3 Make the changes you want to make to the pop-up menu.

4 When you finish modifying the pop-up menu, click OK.
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Launching Fireworks MX to optimize an image

You can launch Fireworks from Dreamweaver to make quick export changes, such as resizing an 
image or changing the file type, to placed Fireworks images and animations. Fireworks lets you make 
changes to optimization settings, animation settings, and the size and area of the exported image.

To change optimization settings for a Fireworks image placed in Dreamweaver:

1 In Dreamweaver, select the desired image and choose Commands > Optimize Image in Fireworks. 

2 If prompted, specify whether to launch a source Fireworks file for the placed image.

3 In Fireworks, make the desired edits in the Optimization dialog box:

• To edit optimization settings, click the Options tab. For more information, see Fireworks Help.

• To edit the size and area of the exported image, click the File tab.

4 When you are finished editing the image, click Update. 

The image is exported using the new optimization settings, the GIF or JPEG placed in 
Dreamweaver is updated, and the PNG source file is saved if a source file was selected. 

If you changed the format of the image, the Dreamweaver link checker prompts you to update 
references to the image. For example, if you changed the format of an image called my_image 
from GIF to JPEG, clicking OK at this prompt changes all references to my_image.gif in your 
site to my_image.jpg.

Inserting Fireworks MX HTML code in a Dreamweaver MX document

The Export command in Fireworks lets you export and save optimized images and HTML files to a 
location inside the desired Dreamweaver site folder. You can then insert the file in Dreamweaver.

For information about exporting Fireworks files as HTML, see Fireworks Help. 

Dreamweaver lets you insert Fireworks-generated HTML code, complete with associated images, 
slices, and JavaScript, into a document. This insertion feature makes it easy for you to create design 
elements in Fireworks and then incorporate them into an existing Dreamweaver document.

To insert Fireworks HTML into a Dreamweaver document:

1 In Dreamweaver, place the insertion point in the document where you want the Fireworks 
HTML code to begin.

2 Do one of the following:

• Choose Insert > Interactive Images > Fireworks HTML.

• In the Common category of the Insert bar, click the Insert Fireworks HTML button.

3 In the dialog box that appears, click Browse to choose the desired Fireworks HTML file.

4 Select the Delete File After Insertion option to move the original Fireworks HTML file to the 
Recycle Bin (Windows) or Trash (Macintosh) when the operation is complete. 

Use this option if you no longer need the Fireworks HTML file after inserting it. This option 
does not affect the source PNG file associated with the HTML file.

Note: If the HTML file is on a network drive, it is permanently deleted—not moved to the Recycle Bin or Trash.

5 Click OK to insert the HTML code, along with its associated images, slices, and JavaScript, 
into the Dreamweaver document.
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Pasting Fireworks MX HTML into Dreamweaver MX

A fast way to place Fireworks-generated images and tables in Dreamweaver is to copy and paste 
Fireworks HTML code directly into a Dreamweaver document.

To copy and paste Fireworks HTML into Dreamweaver:

1 In Fireworks, choose Edit > Copy HTML Code. 

2 Follow the wizard as it guides you through the settings for exporting your HTML and images. 
When prompted, specify your Dreamweaver site folder as the destination for the exported images.

The wizard exports the images to the specified destination and copies the HTML code to 
the Clipboard.

3 In Dreamweaver, place the insertion point in the document where you want to paste the 
HTML code, and choose Edit > Paste.

All HTML and JavaScript code associated with the Fireworks files you exported is copied into 
the Dreamweaver document, and all links to images are updated.

To export and paste Fireworks HTML into Dreamweaver:

1 In Fireworks, choose File > Export.

2 In the Export dialog box, specify your Dreamweaver site folder as the destination for the 
exported images.

3 In the Save As pop-up menu, choose HTML and Images.

4 In the HTML pop-up menu, choose Copy to Clipboard, then click Save.

5 In Dreamweaver, place the insertion point in the document where you want to paste the 
exported HTML code, and choose Edit > Paste.

All HTML and JavaScript code associated with the Fireworks files you exported is copied into 
the Dreamweaver document, and all links to images are updated.

Updating Fireworks MX HTML placed in Dreamweaver MX

In Fireworks, the File > Update HTML command provides an alternative to the launch-and-edit 
technique for updating Fireworks files placed in Dreamweaver. With Update HTML, you can 
edit a source PNG image in Fireworks and then automatically update any exported HTML code 
and image files placed in a Dreamweaver document. This command lets you update 
Dreamweaver files even when Dreamweaver is not running.

To update Fireworks HTML placed in Dreamweaver:

1 In Fireworks, open the source PNG and make the desired edits to it.

2 Choose File > Save

3 In Fireworks, choose File > Update HTML. 

4 Navigate to the Dreamweaver file containing the HTML you want to update, and click Open.
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5 Navigate to the destination folder where you want to place the updated image files, and click 
Select (Windows) or Choose (Macintosh).

Fireworks updates the HTML and JavaScript code in the Dreamweaver document. Fireworks 
also exports updated images associated with the HTML and places the images in the specified 
destination folder.

If Fireworks cannot find matching HTML code to update, it gives you the option of inserting 
new HTML code into the Dreamweaver document. Fireworks places the JavaScript section of 
the new code at the beginning of the document and places the HTML table or link to the 
image at the end.

Creating a web photo album in Dreamweaver MX
The Create Web Photo Album command in Dreamweaver lets you automatically generate a 
website that showcases an album of images from a given folder. This command uses JavaScript to 
call Fireworks, which creates a thumbnail and a larger-sized image for each of the images in the 
folder. Dreamweaver then creates a web page containing all the thumbnails, as well as links to the 
larger images. To use the Create Web Photo Album feature, you must have both Dreamweaver 
and Fireworks 4 or later installed on your system.

Before you begin, place all the images for your photo album in a single folder. (The folder is not 
required to be in a site.) In addition, make sure that the image filenames end in extensions 
recognized by the Create Web Photo Album command (.gif, .jpg, .jpeg, .png, .psd, .tif, or .tiff ). 
Images with unrecognized file extensions are not included in the photo album.

To create a web photo album:

1 In Dreamweaver, choose Commands > Create Web Photo Album.

2 In the Photo Album Title text box, enter a title. The title will be displayed in a gray rectangle at 
the top of the page containing the thumbnails.

If desired, you can enter up to two lines of additional text to appear directly beneath the title, 
in the Subheading Info and Other Info text boxes.

3 Choose the folder containing source images by clicking the Browse button next to the 
Source Images Folder text box. Then choose (or create) a destination folder in which to place 
all the exported images and HTML files by clicking the Browse button next to the Destination 
Folder text box.

The destination folder should not already contain a photo album—if it does, and if any new 
images have the same names as previously used images, you might overwrite existing 
thumbnail and image files.

4 Specify display options for the thumbnail images:

• Choose a size for the thumbnail images from the Thumbnail Size pop-up menu. Images 
are scaled proportionally to create thumbnails that fit within a square that has the indicated 
pixel dimensions.

• To display the filename of each original image below the corresponding thumbnail, select 
Show Filenames.

• Enter the number of columns for the table that displays the thumbnails.
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5 Choose a format for the thumbnail images from the Thumbnail Format pop-up menu:

GIF WebSnap 128 creates GIF thumbnails that use a web adaptive palette of up to 128 colors.

GIF WebSnap 256 creates GIF thumbnails that use a web adaptive palette of up to 256 colors.

JPEG—Better Quality creates JPEG thumbnails with relatively higher quality and larger file sizes.

JPEG—Smaller File creates JPEG thumbnails with relatively lower quality and smaller file sizes.

6 Choose a format for the large-size images from the Photo Format pop-up menu. A large-size 
image of the specified format is created for each of your original images. You may specify a 
format for the large-size images that differs from the format you specified for the thumbnails.

Note: The Create Web Photo Album command does not let you use your original image files as the large-size 
images, because original image formats other than GIF and JPEG might not be displayed properly on all 
browsers. Note that if your original images are JPEG files, the large-size images generated may have larger file 
sizes or lower quality than the original files.

7 Choose a Scale percentage for the large-size images.

Setting Scale to 100% creates large-size images the same size as the originals. The scale 
percentage is applied to all the images; if your original images aren’t all the same size, scaling 
them by the same percentage may not produce the desired results.

8 Select Create Navigation Page for Each Photo to create an individual web page for each source 
image, containing navigation links labeled Back, Home, and Next. 

If you select this option, the thumbnails link to the navigation pages. If you don’t select this 
option, the thumbnails link directly to the large-size images. 

9 Click OK to create the HTML and image files for the web photo album.

Fireworks launches (if it’s not already running) and creates the thumbnails and large-size 
images. This may take several minutes if you’ve included a large number of image files. When 
the processing is complete, Dreamweaver becomes active again, and creates the page 
containing the thumbnails.
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10 When a dialog box appears that says “Album Created,” click OK. 

You may have to wait a few seconds for your photo album page to appear. The thumbnails are 
shown in alphabetical order by filename.

Note: Clicking the Cancel button in the Dreamweaver dialog box after processing has begun does not stop the 
process of creating the photo album; it merely prevents Dreamweaver from displaying the main photo album page. 

Working with Dreamweaver MX and Macromedia Flash MX
You can easily insert a Macromedia Flash movie (SWF file) in a Dreamweaver document. You can 
then use the Property inspector to set web playback and display options for the SWF file. For 
information about inserting a Macromedia Flash movie in Dreamweaver, see Dreamweaver Help > 
Using Dreamweaver > Inserting Flash movies.

The link checker in Dreamweaver lets you easily edit links in files you insert in a Dreamweaver 
document, including Macromedia Flash movies. You can update the link in the SWF movie, and 
then update the change in the Macromedia Flash authoring document. For information, see 
“Updating links in a Flash MX SWF file” on page 151.

If you have Macromedia Flash MX and Dreamweaver MX, you can also update a movie that has 
been placed in a Dreamweaver document. When both applications are installed on your computer, 
and a SWF movie is selected in the Dreamweaver document, the Property inspector displays an 
active Edit button. If you do not have Macromedia Flash MX, the Edit button is disabled.

When you click Edit, Dreamweaver launches Macromedia Flash MX to locate the Macromedia 
Flash authoring file (FLA) for the selected SWF file. If Design Notes are enabled for the 
Dreamweaver site, information about the original source file is automatically stored in a Design 
Note for the SWF file when you export it to a Dreamweaver site. If Macromedia Flash MX cannot 
locate the Macromedia Flash authoring file, you are prompted to locate it. You cannot update a 
SWF file directly—you make changes to the source file, then export it as a SWF movie file. 

After successfully launching a source document to edit, you can work in Macromedia Flash MX to 
make changes to a movie. When you are finished making changes, Macromedia Flash MX updates 
the Macromedia Flash authoring document, reexports the movie file, closes, and then returns the 
focus to the Dreamweaver document. You can view the updated SWF in the document.

For more information, see the next section and “Updating links in a Flash MX SWF file” on page 151.
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Editing a Macromedia Flash MX movie from Dreamweaver MX

You cannot directly edit a SWF file in Dreamweaver. If you want to make changes to an exported 
SWF, you must select the Macromedia Flash movie placeholder in the Dreamweaver document 
and launch Flash MX to edit the movie.

To launch and edit a Macromedia Flash movie (SWF file) inserted from Dreamweaver:

1 In Dreamweaver, choose Window > Properties to open the Property inspector, if it isn’t 
already open.

2 In the Dreamweaver document, do one of the following:

• Click the Macromedia Flash movie placeholder to select it; then in the Property inspector, 
click Edit.

• Control-double-click (Windows) or Command-double-click (Macintosh) the movie 
placeholder for the movie you want to edit.

• Right-click (Windows) or Control-click (Macintosh) the desired movie, and choose Edit with 
Flash from the context menu.

Dreamweaver launches Macromedia Flash MX and opens the FLA file for you to edit. If 
Dreamweaver cannot locate the FLA file, it prompts you to open it.

Note: If the FLA file or SWF file is locked, Dreamweaver prompts you to check the file out, cancel the request, or 
view the file.
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3 In Macromedia Flash MX, edit the movie. The Document window indicates that you are 
modifying a movie from Dreamweaver. 

4 When you are finished making edits, click Done. 

Your changes to the source FLA file are saved, and the SWF file is updated.

5 Do one of the following:

• To view the updated SWF file in the document, click Play in the Property inspector.

• To preview your page in a browser window, press F12.

Updating links in a Flash MX SWF file

You can update a link in a SWF file in the Dreamweaver Site Map view. For information about 
Site Map view, see Dreamweaver Help > Using Dreamweaver > Using the site map. Before you 
can create a site map, you must set a home page for your site. In Site Map view, you need to 
display dependent files in order to update a link in a SWF file. By default, the site map does not 
show dependent files. For information about displaying dependent files, see Dreamweaver Help > 
Using Dreamweaver > Showing and hiding site map files.

Any links updated by Dreamweaver in the SWF file are conveyed to the FLA source document 
when a launch and edit is performed. Dreamweaver automatically logs any link changes to the 
SWF file in the Design Notes, and when Macromedia Flash MX passes the changes to the FLA 
file, it removes them from the Design Notes.

To update a URL link in a SWF file:

1 Set up a home page for the site, if you haven’t already done so.

2 Open Site Map view.
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3 To show dependent files, choose View > Show Dependent Files (Windows) or Site > 
Site Map View > Show Dependent Files (Macintosh).

The link appears beneath the SWF file.

4 Change the link by doing one of the following:

• To change the link in the selected SWF, right-click the link, then choose Change Link. In the 
dialog box that appears in the URL text box, type the new URL path.

• To update all instances of the link, choose Site > Change Link Sitewide. In the dialog box that 
appears, in the Change All Links To text box, browse to or type the path of the link you are 
changing, and in the Into Links To field, browse to or type the path of the new URL.

5 Click OK.
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The chapters in Part IV introduce Macromedia Flash MX, 
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• Chapter 7, “Welcome to Macromedia Flash MX”

• Chapter 8, “Flash MX Tutorial”

• Chapter 9, “Macromedia Flash MX Integration with the 
Macromedia Studio MX Product Family”





CHAPTER 7

Welcome to Macromedia Flash MX

Macromedia Flash MX is the professional standard authoring tool for producing high-impact web 
experiences. Whether you are a designer creating animated logos, website navigation controls, or 
long-form animations, or an application developer creating websites or web applications, you’ll 
find the power and flexibility of Macromedia Flash MX ideal for your own creativity.

Macromedia Flash MX enhances creativity by providing designers with preset templates and 
libraries. Using symbols and shared libraries, designers can create powerful artwork while 
maintaining small file size for the web. Timeline enhancements make creating animated artwork 
even easier, and increased support for video lets you add movie clips to your designs.

Internet users and businesses are demanding more from their investments in Internet technology, 
and the ability to deliver true value to users is forcing many companies to look toward richer 
models for Internet applications—models that combine the power of the traditional desktop with 
the deployment and content-rich nature of web applications. Companies are also anticipating a 
growth in the use of web services and toward a world in which applications will need to share 
functionality and data across many types of client devices. These trends are driving the industry 
toward next-generation rich clients. Macromedia Flash MX and the Macromedia Flash Player are 
leading this new wave of innovation in client-side Internet content and applications. 

The following section describes how new features in Macromedia Flash MX enable the crucial 
components of rich client technologies.

What’s new in Macromedia Flash MX
Designers who require a higher-level of control and integration with industry-standard design 
tools now have an unparalleled creative application for creating media rich content.

Powerful new features give application developers access to new capabilities that make 
Macromedia Flash MX a robust and exciting application development environment. Predefined 
components provide reusable drag-and-drop interface elements for Macromedia Flash content, 
such as list boxes, radio buttons, and scroll bars. Developers can work with advanced scripting 
and debugging tools and built-in code reference to rapidly deploy rich web applications. 

For all Macromedia Flash MX users

The ability to save Macromedia Flash MX documents in Flash 5 format lets you upgrade now and 
still collaborate with designers who are working on Flash 5 projects. See Flash Help > Using Flash > 
Saving Flash documents.

Accessible content that can be seen and heard by persons with disabilities is now easy to develop, 
expanding the audience for Macromedia Flash movies and applications. See Flash Help > 
Using Flash > .
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Korean and Chinese language support reaches audiences in more of the world. Features like 
vertical text fields and Unicode support make it easy to create Asian-language content. See 
Flash Help > Using Flash > Creating text.

For the Macromedia Flash MX designer

Macromedia Flash MX enhances creativity by providing designers with a higher level of control 
and expanded integration capabilities with a rich set of design tools. New features help designers 
to quickly create a broad range of content. Instead of focusing on how Macromedia Flash MX 
works, they can give more attention to their designs.

Timeline enhancements such as folders for organizing layers, improved pointer feedback, and the 
ability to resize, cut, and paste multiple frames make it easier to use the Timeline, helping you 
work faster and with less effort. See Flash Help > Using Flash > About the Timeline.

Enhanced editing of symbols in place makes document creation easier by letting designers work 
on symbols in the context of their movies. New controls above the Stage make it easier than ever 
to edit symbols in place. See Flash Help > Using Flash > Editing symbols.

Library improvements eliminate production bottlenecks by simplifying the creation and 
manipulation of library symbols. Moving symbols or folders between Macromedia Flash 
documents or creating new library symbols is now as easy as dragging. See Flash Help > Using 
Flash > Working with common libraries. The new Resolve Library Conflict dialog box simplifies 
adding library symbols to a document that has an existing library symbol with the same name. See 
Flash Help > Using Flash > Resolving conflicts between library assets.

Shared library assets improve Macromedia Flash movie authoring by letting you share library 
assets with other Macromedia Flash documents, either while authoring or when a movie is played 
with the Macromedia Flash Player. Shared runtime libraries help you create smaller files and make 
easy updates to multiple movies simultaneously by letting your movies show library symbols and 
shared objects that are stored on an intranet or the Internet. Shared author-time libraries improve 
your work pace by letting you track, update, and swap symbols in any Macromedia Flash document 
available on your computer or network. See Flash Help > Using Flash > Using shared library assets.

Workspace enhancements make the Macromedia Flash MX workspace more manageable and 
easier to understand for new and veteran designers. The most commonly used features now 
appear in one context-sensitive Property inspector, eliminating the need to access many other 
windows, panels, and dialog boxes. See Flash Help > Using Flash > Panels and the Property 
inspector. Other frequently used features now appear in easily collapsible panels that dock and 
undock as necessary to conserve screen space. Designers can even save custom panel layouts to 
personalize their Macromedia Flash workspace. See Flash Help > Using Flash > Using panels.

New starter templates included with Macromedia Flash MX simplify the creation of new 
documents by eliminating many of the common tasks required to start a new document. See 
Flash Help > Using Flash > Creating a new document.You can also create your own templates 
from documents. See Flash Help > Using Flash > Saving Flash documents.

Color Mixer improvements make creating, editing, and using colors and gradients easier than ever. 
See Flash Help > Using Flash > Working with solid colors and gradient fills in the Color Mixer.

Complete lessons that address the new features in Macromedia Flash MX make it easy to become 
familiar with its powerful tools and features. To get started with the lessons, choose Flash Help > 
Lessons > Getting Started with Flash.

Video support expands the creative possibilities for Macromedia Flash movies by letting you 
import video clips in a variety of formats. See Flash Help > Using Flash > Importing video.
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The Free Transform tool opens new possibilities for your creative expression by letting you 
combine the effects of multiple object transformations at once. See Flash Help > Using Flash > 
Transforming objects freely.

The Envelope modifier lets you easily create graphic objects that would otherwise be difficult to 
create by letting you warp and distort the shape of the bounding box that surrounds them. See 
Flash Help > Using Flash > Modifying shapes with the Envelope modifier.

Pixel-level editing adds precision and polish to your work by letting you align objects with 
pixel-level precision in your Macromedia Flash documents. You can precisely place objects or 
points of objects where you want them to appear in your final movie. See Flash Help > 
Using Flash > Pixel snapping.

The Break Apart feature makes it easy to make creative edits to individual text characters without 
having to convert the text to symbols, simplifying the creation of complex designs and animation. 
See Flash Help > Using Flash > About transforming text.

The Distribute to Layers command quickly and automatically distributes any number of selected 
objects to their own layers. See Flash Help > Using Flash > Distributing objects to layers for 
tweened animation.

Movie clip mask layers let you create animated masks by placing a movie clip on a mask layer. See 
Flash Help > Using Flash > Using mask layers. You can also use ActionScript to create an 
animated mask with a movie clip. See Flash Help > Using Flash > Using movie clips as masks.

Enhanced sound control enhances the production quality of your movies by letting you 
synchronize movie events with the start or end of sound clips. See Flash Help > Using Flash > 
About the onSoundComplete event.

For the Macromedia Flash MX developer

The powerful Macromedia Flash MX environment includes enhanced scripting and debugging 
tools, built-in code reference, and predefined components you can use to rapidly develop rich 
web applications.

Enhanced ActionScript gives you the ability to dynamically load JPEG and MP3 sound files at 
runtime, and lets you update your files at any time without having to republish the movie. See 
“Placing artwork into Flash” and “Importing sounds” in Flash Help > Using Flash.

Anchor points enhance navigation in Macromedia Flash movies by letting users use the Forward 
and Back buttons in their browsers to jump from anchor to anchor. See Flash Help > Using Flash > 
Using named anchors.

The improved ActionScript editor makes it easier for new and veteran authors to access the full 
potential of ActionScript. See Flash Help > Using Flash > About scripting in ActionScript.

Code hinting speeds content development of ActionScript by automatically detecting what 
command you are typing and offering hints to reveal the exact syntax of the command. See 
Flash Help > Using Flash > Using code hints.

Macromedia Flash components accelerate web application development by providing reusable 
drag-and-drop interface elements for Macromedia Flash content, such as list boxes, radio buttons, 
and scroll bars. See Flash Help > Using Flash > Using Components.

The improved debugger combines the debugging capabilities already in existence with an 
ActionScript debugger by allowing you to set breakpoints and single-step through the code as it 
executes. See Flash Help > Using Flash > Testing a movie.
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The Object Model integrates movie clips, buttons, and text fields into the ActionScript 
object-oriented scripting language. See “Working with Movie Clips and Buttons” and 
“Controlling text with ActionScript” in Flash Help > Using Flash.

The Event Model makes ActionScript event handling more powerful and easier to understand. The 
event model now allows for more sophisticated control over user events such as mouse movement 
and keyboard input. See Flash Help > Using Flash > Controlling when ActionScript runs.

The Live Preview feature for components makes it possible to actively view changes in user 
interface components within the authoring environment. See Flash Help > Using Flash > 
Components with Live Preview. 

Enhanced text support allows for detailed control using ActionScript over every property of a text 
object, including its formatting, size, and layout. See Flash Help > Using Flash > Working with Text.

The new drawing API enhances the object-oriented programming power of ActionScript by 
offering a set of shape-drawing capabilities through the MovieClip object, allowing for 
programmatic control over the Macromedia Flash MX rendering engine. See Flash Help > 
Using Flash > About the MovieClip object.

Strict Equality and Switch statements allow for concise definition of flow control statements such 
as if, then, and else, further increasing ActionScript support for ECMA-262. See their entries 
in Flash Help > ActionScript Dictionary.

SetInterval and clearInterval functions allow designers to set up a generic routine that will be 
called at periodic intervals throughout the lifetime of a movie. See their entries in Flash Help > 
ActionScript Dictionary.

Conversion of String, Array, and XML to Native Objects increases performance by optimizing the 
Number, Boolean, Object, String, Array, and XML ActionScript objects. Performance in the 
Macromedia Flash Player is increased as much as 100 times. See their entries in Flash Help > 
ActionScript Dictionary.

SWF Compression uses existing Z-lib compression code to improve download times for complex 
Macromedia Flash content. See Flash Help > Using Flash > Publishing.

Delivering rich web experiences with the 
Macromedia Flash Player

The Macromedia Flash Player is a high-performance runtime environment for processing code, 
graphic and audio content, and data communications. It works the same across any combination 
of operating system, chip architecture, and web browser and supports all popular desktop and 
workstation environments. 

Over 98% of online users have the Macromedia Flash Player installed, and a growing number of 
devices, such as PDAs and smart phones, support it. This makes the Macromedia Flash Player the 
first choice of developers for delivering rich content in the most efficient way to the greatest 
number of users.

The advanced technical resources in Macromedia Flash MX and the Macromedia Flash Player 
combine to give you the most powerful web development environment and deployment 
capabilities available today. 

Following is a summary of some of these features:

Vector graphics output results in much smaller files, faster transmission, and output that can more 
easily scale to a variety of output formats and devices.
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Streaming content delivery loads the first few frames of content immediately, improving both the 
perceived and the real application performance.

File caching, including audio and video data, allows an application to load immediately when the 
user returns to it during a session.

Shared objects on the client computer store complex data for reuse across or within an 
application session. 

Dynamic visual transitions load new interface elements at runtime without refreshing the whole 
screen or page.

Custom user interface components and behaviors let you create interface controls and add 
behavior and dynamic data to them using ActionScript. Hundreds of free user interface 
components are available from the Macromedia Flash developer community. 

Macromedia Flash web services can now be developed using Macromedia ColdFusion MX, Sun 
Java, and Microsoft .Net to invoke logic and get data from services built with server-side 
ActionScript or CFML and deployed on the Macromedia ColdFusion MX Server, as well as 
services built with standard Java Servlets, Java Classes, EJBs, and .Net objects. 

Basic support for integrating data is now available with the LoadVariables command, as well as 
improved support for loading and using XML documents. Macromedia Flash MX can work with 
data generated from almost any server-side application environment.

Stand-alone, offline Macromedia Flash MX applications can be run by delivering the application, 
its data, and the full Macromedia Flash Player. 

Learning about Macromedia Flash MX
The Macromedia Flash MX package contains a variety of media to help you learn the program 
quickly and become proficient in creating your own Macromedia Flash movies. These media 
include an electronic version of the manual, online help that appears in your web browser, a 
built-in ActionScript Reference panel, interactive lessons, and a regularly updated website. In 
addition, there are many third-party resources available to designers and developers.

About the Macromedia Flash MX printed and electronic manuals

Information that appears in the printed version of Using Flash is primarily intended for users who are 
in their first three to six months of learning Macromedia Flash MX and focuses on using Macromedia 
Flash MX tools and commands. Online lessons and tutorials supplement this information.

Chapters on ActionScript explain how to write and create interactions with the Macromedia 
Flash scripting language. 

Using Macromedia Flash Help

Macromedia Flash MX contains two help systems: Using Flash and the ActionScript Dictionary. 
For the best experience when using Macromedia Flash Help, Macromedia recommends that you 
use Netscape Navigator 4.0 or later or Microsoft Internet Explorer 4.0 or later on Windows, and 
Netscape Navigator 4.0 or later or Microsoft Internet Explorer 4.5 or later on the Macintosh. If 
you use a 3.0 browser, all the content of the movies and the Macromedia Flash Help is still 
accessible, but some features (such as Search) will not work. Running Macromedia Flash MX and 
Macromedia Flash Help simultaneously on a Macintosh may require up to 32 MB of memory, 
depending on your browser’s memory needs.
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To use Macromedia Flash Help:

1 Choose one of the help systems from the Help menu. 

2 Navigate the help topics using any of these features:

Contents organizes information by subject. Click top-level entries to view subtopics. 

Index organizes information like a traditional printed index. Click a term to jump to a related topic.

Search finds any character string in all topic text. Search requires a 4.0 or later browser with 
Java enabled. To search for a phrase, type it into the text entry box. 

To search for files that contain two keywords (for example, layers and style), separate the words 
with a plus (+) sign.

To search for files that contain a complete phrase, separate the words with a space.

Previous and Next buttons let you move through the topics within a section. 

The Macromedia Flash MX icon links you to the Flash Support Center website. 

Using Macromedia Flash MX lessons and tutorials

Macromedia Flash MX lessons provide quick interactive instructions that introduce you to the 
main features of Macromedia Flash MX, letting you practice on isolated examples. If you are new to 
Macromedia Flash MX, or if you have used only a limited set of its features, start with the lessons.

Macromedia Flash MX tutorials provide in-depth interactive instructions that help you 
familiarize yourself with Macromedia Flash MX and provide detailed instruction on some 
powerful Macromedia Flash MX features.
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The Introduction to Flash MX tutorial introduces the workflow in Macromedia Flash MX by 
showing you how to create a basic movie. The tutorial assumes an understanding of the topics 
covered in the lessons. 

The Introduction to ActionScript tutorial teaches you the basic principles of ActionScript, the 
object-oriented language Macromedia Flash MX uses to add interactivity to movies. 

The Introduction to Components tutorial is designed to introduce components to beginner and 
intermediate Macromedia Flash MX users and show how they can be used to quickly create a 
simple application. Before taking this tutorial, you should complete the Macromedia Flash MX 
lessons, the Introduction to Macromedia Flash MX tutorial, and the Introduction to ActionScript 
tutorial or be familiar with ActionScript.

To start the lessons:

Choose Help > Lessons > Getting Started with Flash. 

To start a tutorial, do one of the following:

• Choose Help > Tutorials > Introduction to Flash MX. 

• Choose Help > Tutorials > Introduction to ActionScript. 

• Choose Help > Tutorials > Introduction to Components. 

The first tutorial is also available in chapter 8 of this book,” Introduction to Macromedia 
Flash MX Tutorial.”

Using additional Macromedia resources

The Flash Support Center website is updated regularly with the latest information on 
Macromedia Flash, plus advice from expert users, advanced topics, examples, tips, and other 
updates. Check the website often for the latest news on Macromedia Flash and how to get the 
most out of the program at http://www.macromedia.com/support/flash.

The ActionScript Reference panel provides detailed information on ActionScript syntax and usage. 
The hierarchical structure of the information lets you easily find the specific information you need.

To display the ActionScript Reference panel:

Choose Window > Reference. 

Third-party resources

Macromedia recommends several websites with links to third-party resources on 
Macromedia Flash MX.

• Macromedia Flash community sites

http://www.macromedia.com/support/flash/ts/documents/flash_websites.htm

http://www.macromedia.com/support/flash/ts/documents/tn4148-flashmaillists.html

• Macromedia Flash books

http://www.macromedia.com/software/flash/productinfo/books/

• Object-oriented programming concepts

http://java.sun.com/docs/books/tutorial/java/concepts
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CHAPTER 8

Flash MX Tutorial

This tutorial guides you through the process of creating a compelling web experience with 
Macromedia Flash MX. By completing the tutorial, you’ll learn how to design a movie, from 
opening a new document to publishing the movie for web playback. The tutorial takes 
approximately three hours to complete, depending on your experience, and will teach you how to 
do the following tasks:

• Analyze a completed movie

• Define document properties and create a gradient

• Create and mask vector art

• Tween bitmap effects within a movie clip

• Load dynamic text

• Modify buttons and add navigation

• Add streaming and event sounds

• Test and publish the movie

We recommend that you complete the eight sections that comprise the tutorial in sequence, 
although you may choose to review only the sections that interest you. If you do complete the 
sections of the tutorial out of sequence, keep in mind that later sections assume you’ve mastered 
skills introduced in earlier sections.

What you should know
Before taking the tutorial, complete the seven lessons found in Flash Help. These interactive 
lessons created in Macromedia Flash MX introduce you to the concepts you need to know to 
complete the tutorial. Lesson topics include the following:

• Getting Started with Flash

• Illustrating in Flash

• Adding and Editing Text

• Creating and Editing Symbols

• Understanding Layers

• Creating Buttons

• Creating Tweened Animation

To take a lesson, choose Help > Lessons, then select from the list. 
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View the completed movie
You can open a completed version of the tutorial movie to better understand how your finished 
file will appear.

In this section, you’ll accomplish the following tasks:

• Analyze the completed movie using the Property inspector and Movie Explorer

• Examine a movie clip and discern its relationship to the main movie

• View the types of assets included in the movie

1 Within your Flash application folder, browse to Tutorials/FlashIntro and double-click 
stiletto.swf to open the completed movie in the stand-alone Macromedia Flash Player. 

Published Flash movies have the .swf extension; documents in the authoring environment have 
the .fla extension.

2 When the movie opens, watch the three views of the car fade in and out.

You’ll create this animation by tweening bitmap effects within a movie clip.

3 Listen to the sound that plays continuously while the movie plays. This is an example of a 
streaming sound.

4 Roll over the three buttons along the lower right edge of the window to view the rollover effect, 
and to hear the event sounds included in each button.

5 Click a button to see where it links, then close the browser that opened and return to the SWF file.

6 After viewing the movie, click its close box. 
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Analyze the stiletto.fla file
It’s helpful to analyze the completed FLA file to see how the author designed the document. To 
analyze the file, you can view the properties for an object, view the Timeline and Stage, look at 
library assets, and use the Movie Explorer.

1 In Macromedia Flash, choose File > Open. Navigate to your Flash application folder and open 
Tutorials/FlashIntro/stiletto.fla.

You now see the completed tutorial movie in the authoring environment.

2 To view all layers in the main Timeline, drag down the bar that separates the Stage from 
the Timeline.

3 In the Timeline, unlock the Copy layer and the Images layer.

Drag the bar that separates the 
Stage from the Timeline
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View document properties

The Property inspector lets you view specifications for selected objects. The specifications depend 
on the type of object selected. If you select a text object, for example, settings to view and modify 
text attributes appear. 

1 If the Property inspector isn’t open, choose Window > Properties.

2 On the Stage, scroll down if necessary and select the rectangular block where descriptive text 
appeared in the finished SWF file. The text does not appear in the FLA file because it loads 
from an external TXT file into a dynamic text field.

In the Property inspector, you can view the size, style, and color of the text, among other attributes.

If the Property inspector is not fully expanded, click the white triangle in lower right corner.

3 On the Stage, select the car.

Movie clip settings replace the text settings. Movie clips are symbols with their own 
independent Timelines. You can think of them as movies within movies.

Text box
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View the movie clip

Now you’ll open symbol-editing mode to view the Timeline for a movie clip.

1 On the Stage, double-click the movie clip of the car.

As you learned in the Creating Tweened Animation lesson, you define changes in animation in 
keyframes. When you scroll around the Timeline, note which layers have keyframes in them 
and which frames are keyframes. 

Beginning and intermediate keyframes that include content are indicated in the Timeline by 
solid circles, ending keyframes appear as small outlined rectangles.

2 In the Timeline, select the playhead and drag it slowly across the frames. 

Watch how changes in action on the Stage correspond to changes in the Timeline. As you drag 
the playhead, the movie plays sequentially. You can add ActionScript, the Macromedia Flash 
scripting language, to movies to make the playhead jump to specific frames. 

3 When you finish viewing the movie clip, do one of the following to return to the main movie:

• Choose Edit > Edit Document.

• Click the Back button.

• Click Scene 1 above the Stage. 

View library assets

The Library panel contains the symbols and imported objects in your document. 

1 If the Library panel isn’t open, choose Window > Library.

2 Drag the Library panel to enlarge it, if necessary, to view the objects within the library.

3 If the Artwork folder is not expanded, double-click it to view the objects in the folder.

4 Click view1.png to view the image in the preview area at the top of the Library panel.

5 Expand the other folders in the Library panel to view the assets included in the document, 
such as buttons and movie clips.
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6 When you finish viewing the assets, close the Library panel.

Analyze the movie structure with the Movie Explorer

The Movie Explorer helps you arrange, locate, and edit media. With its hierarchical tree structure, 
the Movie Explorer provides information about the organization and flow of a movie, especially 
useful when you analyze a movie authored by someone else. 

1 If the Movie Explorer is not already open, choose Window > Movie Explorer.

2 If necessary, enlarge the Movie Explorer to view the tree structure within the pane.

The Movie Explorer filtering buttons display or hide information.
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3 Click the pop-up menu in the title bar of the Movie Explorer, and verify that Show Movie 
Elements and Show Symbol Definitions are selected.

4 Deselect the Show Frames and Layers button along the top of the Movie Explorer. Verify that 
the only filtering buttons selected are Show Text; Show Buttons, Movie Clips, and Graphics; 
Show ActionScripts; and Show Video, Sounds, and Bitmaps.

5 Examine the list to view some of the assets included in the movie and to see their relationship 
to other assets.

6 To expand an object or category, click the Plus (+) button to the left of the name.

7 Select the Show Frames and Layers filtering button. Scroll down to the Symbol Definitions 
category. With the category expanded, double-click the Car Animation movie clip.

You’re now in symbol-editing mode for the movie clip.
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8 In the Movie Explorer, with the Car Animation category selected and expanded, expand the 
View 3 Fade icon, then double-click Frame 60.

In the Timeline for the movie clip, the playhead moves to Frame 60 of the View 3 Fade layer.

To view an item listed in the hierarchical tree, click the corresponding icon. If you click a frame 
icon, the playhead moves to that frame in the Timeline. If you click an asset, such as a bitmap 
image, the Property inspector displays the image settings. Double-clicking an icon that 
represents a symbol opens symbol-editing mode.

9 Close the Movie Explorer. To close the document, choose File > Close.

If you’ve made changes to the file, do not save them.

Define properties for a new document and 
create a gradient background

To learn how to create a movie in Macromedia Flash, let’s start from the very first step in the 
process: opening a new file. Then, by completing this section, you’ll learn how to complete the 
following tasks:

• Open a new file and define document properties

• Create and transform a gradient background

Open a new file

Now you’re ready to create your own version of the tutorial movie.

1 Choose File > New.

2 Choose File > Save As.

3 Name the file mystiletto.fla and save it within your Flash application folder, in the Tutorials/
FlashIntro/My_Stiletto subfolder.

Note: As you complete the tutorial, remember to save your work frequently.

Define document properties

Configuring document properties is a common first step in authoring. You can use the Property 
inspector and Document Properties dialog box to specify settings that affect the entire movie, 
such as the frames per second (fps) playback rate, and the Stage size and background color. 

1 If the Property inspector isn’t open, choose Window > Properties. In the Property inspector, 
verify that 12 is the number in the Frame Rate text box.

The movie will play at 12 frames per second, an optimal frame rate for playing animations 
on the web.

Note: If the Property inspector is not fully expanded, click the white triangle in lower right corner.
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2 The Background Color box indicates the color of the Stage. Click the down arrow on the 
Background Color box, then move the Eyedropper tool over the color swatches to view their 
hexadecimal values in the Hexadecimal text box.

3 Find and click the gray color swatch with the hexadecimal value of 999999.

4 To resize the Stage, click the Size button, which indicates the size of the Stage. In the Document 
Properties dialog box, type 640 px in the first Dimensions text box and 290 px in the second 
Dimensions text box. Verify that Pixels is selected in the pop-up menu, and click OK.

The Stage dimensions change to reflect the new settings of 640 x 290 pixels.

Specify grid settings

On the Stage, you can align objects along horizontal and vertical grid lines. Even when the grid is 
not visible, you can snap objects to it. Now you’ll modify the distance between the horizontal and 
vertical grid lines, and create a grid in alignment with the Stage borders. 

1 Choose View > Grid > Edit Grid.

2 In the Grid dialog box, type 10 px in the grid width text box and 10 px in the grid height 
text box. 

3 Select Snap to Grid and verify that Show Grid is not selected.

Objects will now snap to the grid, even when the grid is not visible.

Select this shade of gray

Hexadecimal text box
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4 Verify that Normal is selected for Snap Accuracy, and click OK.

Snap accuracy determines how close an object must be to a grid line before snapping to it.

Create a gradient background

A gradient displays subtle variations of a color, or transitions between two or more colors. In the 
finished tutorial file, the background is a gradient that blends black and dark blue with a 
transparent area that allows part of the gray Stage color to be displayed. You achieve this effect 
using the Color Mixer.

Note: While gradients offer interesting effects in movies, overuse of gradients can adversely affect computer 
processor speeds and decrease the speed at which an animation plays. When designing a movie, consider both 
your artistic and performance requirements to determine the best use of gradients.

Draw a rectangle

Earlier in the tutorial, you created a grid that aligned against the Stage and allowed you to snap objects 
to the grid lines. Now you’ll draw a rectangle that snaps to the area of the grid bordering the Stage.

1 In the pop-up menu above the right side of the Stage, enter 75% to view the entire Stage.

This setting indicates your magnified or scaled-down view of the Stage. The setting does not 
affect the actual size of the Stage in your movie, which you specified in the Document 
Properties dialog box.

2 In the toolbox, select the Rectangle tool.
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3 In the toolbox, click the Stroke Color control. Select No Stroke (the button with the red 
diagonal line above the color palette).

The selected fill color of the shape is unimportant; you’ll soon change the color.

4 Starting from the upper left corner of the Stage, drag to the lower right corner of the Stage to 
draw a rectangle that covers the Stage.

When you release the pointer, the rectangle snaps to the edges of the Stage, along the hidden grid.

Note: While completing the tutorial, you may find it useful to undo a change you’ve made. Flash can undo several 
of your recent changes, depending on the number of undo levels you have set in Preferences. To undo, choose 
Edit > Undo or press Control+Z (Windows) or Command+Z (Macintosh). Conversely, you can redo what you’ve 
undone by choosing Edit > Redo or pressing Control+Y (Windows) or Command+Y (Macintosh).
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Specify a color for the gradient

Dark blue is the first color you’ll add to your gradient.

1 In the toolbox, select the Arrow tool. On the Stage, click inside the rectangle to select the fill.

When you drew the rectangle, the Property inspector displayed properties for the Rectangle 
tool. When you select a shape that has already been created, the Property inspector displays 
properties for the shape.

2 If the Color Mixer is not open, choose Window > Color Mixer. 

3 To expand the Color Mixer, click the white arrow in the panel title bar.

4 If the Color Mixer is not fully expanded, click the arrow in the lower right of the panel.

5 In the Fill Style pop-up menu, select Radial.

6 Click the gradient slider to the left of the gradient bar to select it. 

Click here to expand the panel

Gradient slider

Gradient bar
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7 Click the color box in the upper left corner of the window to open the color palette. Use one of 
the following methods to select dark blue:

• Type 000066 in the hexadecimal value text box and press Enter or Return.

• Move the eyedropper over the color swatches until you find the dark blue with the hexadecimal 
value of 000066, then click the swatch to select it.

Change the alpha value

In the Color Mixer, the Alpha text box indicates the transparency of the color, with 0% indicating 
that the color is completely transparent, and 100% indicating the color is completely opaque. 
You’ll specify an alpha value of 0% to create a gradient that includes dark blue and black along 
with the gray Stage color that shows through the transparent areas of the gradient.

• In the Color Mixer, either type 0 in the Alpha text box and press Enter or Return, or move the 
Alpha slider to 0. 

Click this shade of blue
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Add a second gradient color

You’ll now add black to the gradient.

1 In the Color Mixer, click the gradient slider to the right of the gradient bar to select it.

2 Click the color box to open the color palette and select the black with a hexadecimal value 
of 000000.

Remember, you can either type the hexadecimal value in the Hexadecimal text box and press 
Enter or Return, or you can find and select the color swatch with the same hexadecimal value.

Transform the gradient fill

When you transform an object, you rotate, scale, or skew it. You can transform a fill using the Fill 
Transform tool.

1 In the toolbox, select the Fill Transform tool. On the Stage, click anywhere inside the rectangle.

An ellipse that indicates the shape and location of the gradient appears around the Stage. The 
ellipse has controls for the location, width, scale, and rotation of the radial gradient.

Width

Scale

Rotation

Center placement
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2 Drag the center control to the left of the Stage so that it’s approximately 1/3 of the distance 
from the left edge of the Stage, as shown in the following illustration.

As you change the shape and placement of the ellipse, the shape and placement of the color 
transitions on the Stage change accordingly.

3 Drag the square handle on the ellipse, which controls gradient width, to the left to make the 
ellipse narrower; the approximate shape of the ellipse is shown in the following illustration.
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4 Drag the circular middle handle, which controls the size of the gradient, to the right to make 
the ellipse larger, as shown in the following illustration.

5 Drag the bottom circular handle, which controls the rotation of the ellipse, toward the left to 
rotate the ellipse to the approximate angle shown in the following illustration.
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Name and lock a layer

The gradient shape appears on Layer 1 in the Timeline, currently the only layer in your 
document. In preparation for adding and moving additional objects on the Stage, you’ll rename 
and lock the layer. In the next section of the tutorial, you’ll create a new layer.

As you learned in the Understanding Layers lesson, by locking the layer, you ensure that you or 
other users don’t make inadvertent changes to objects on the layer.

1 In the Timeline, double-click the Layer 1 name and type Background to rename the layer.

2 Click away from the layer name, then click the padlock icon to lock the layer. 

Create and mask vector art
When you draw in Macromedia Flash, you create vector art, which is a mathematical 
representation of lines, curves, color, and position. Vector art is resolution-independent; you can 
rescale the art to any size or display it at any resolution without losing clarity. Additionally, vector 
art downloads faster than comparable bitmap images. 

Along with the gradient, the finished file contains background shapes. You’ll use the Oval tool to 
create the shapes.

Specifically, in this section you’ll learn how to complete the following tasks:

• Add a layer

• Create and “cut out” shapes

• Mask the layer containing the shapes

To complete this section, you can either continue to work on your mystiletto.fla file, or you can 
browse to your Flash application folder and open Tutorials/FlashIntro/stiletto2.fla. If you do use 
the stiletto2.fla file, save the file with a new name in your My_Stiletto folder to maintain an 
unadulterated version of the original file.

Add a layer

Rather than create the shapes on the Background layer, you’ll add a new layer on which you can 
draw the shapes.

1 To add a new layer, choose Insert > Layer, or click the Insert Layer button. Name the new 
layer Shapes. 

2 In the toolbox, select the Oval tool.

Insert Layer button
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3 In the Property inspector, select Hairline from the Stroke Style pop-up menu. Click the Stroke 
Color control. In the color palette, select the gray with a hexadecimal value of 999999.

Remember, you can either enter the hexadecimal value in the hexadecimal text box, or find and 
click the color swatch with the same hexadecimal value.

4 If the Color Mixer isn’t open, choose Window > Color Mixer. In the Fill Style pop-up menu, 
select Solid. Click the Fill Color control to select it. In the R (red) field, type 109. In the G 
(green) and B (blue) text boxes, type 45, then press Enter or Return.

You are specifying the values for the amount of red, green, and blue within a color.

5 In the Timeline, verify that the Shapes layer is selected. On the Stage, constrain the oval to a 
circle by holding down Shift as you drag, to draw a circle that extends from the canvas area 
above the Stage to the canvas below the Stage.

Note: If you make a mistake, choose Edit > Undo and try again.

6 Select the Arrow tool in the toolbox, then double-click the circle on the Stage to select both the 
fill and the stroke.

7 If the Transform panel isn’t open, choose Window > Transform.
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8 To expand the Transform panel, click the white arrow in the upper left corner. Select Skew and 
type 20.0 in the Skew Horizontally text box, then press Enter or Return.

The circle that you drew changes into a skewed oval.

Create and transform a duplicate shape

You’ll now create and transform a duplicate oval.

1 With the oval fill and stroke still selected on the Stage, choose Edit > Duplicate.
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2 In the Property inspector, use the Fill Color control to select black.

3 In the toolbox, select the Free Transform tool.

A guide with handles appears around the duplicate oval.

4 Move the pointer over a corner handle until a diagonal indicator with arrows at both ends 
appears. Drag the corner handle inward to make the oval smaller. Verify that the stroke of the 
inside oval is not touching the stroke of the outside oval.
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5 Move your pointer above the corner handle until the pointer changes into a circular rotation 
indicator. Drag the rotation indicator to the left to rotate the oval to the approximate position 
shown in the following illustration.

Create a “cut-out” with the duplicate

When you create one shape on top of another on the same layer, and the two shapes are different 
colors as well as ungrouped, the shape on top “cuts out” the area of the shape underneath. You’ll 
delete the duplicate oval to view the cut-out effect.

1 With the Free Transform tool guide around the duplicate oval, click anywhere on the Stage or 
canvas away from the shapes, then click the fill of the inner oval. Press Delete on your keyboard 
to delete the fill.

The oval now has an outer and an inner stroke. 
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2 With the Arrow tool, click the outermost stroke on the oval to select it, then Shift-click to 
select the innermost stroke as well. Drag the strokes slightly to the right of the fill, as shown in 
the following illustration.

Each area of fill color within the area bisected by the stroke now represents a discrete segment 
that you can color individually. 

3 Select an area of the shape fill, and use the Color Mixer to change the fill color to a brown 
shade with an R (red) value of 117, a G (green) value of 78, and a B (blue) value of 53. If 
desired, repeat this step to change another fill area to the lighter shade of brown, as shown in 
the following illustration:
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4 Select the Free Transform tool. Drag around the oval background shapes to select all the 
shapes, then drag the right corner handle of the guide to enlarge the shapes, as shown in the 
following illustration.

5 Drag the shapes on the Stage so that part of the curve shows on the upper left corner and right 
side of the Stage.

Note: As you complete the tutorial, remember to save your file frequently.
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Create a mask

The art that you created on the Shapes layer extends beyond the Stage, well into the canvas area. 
Although the area on the canvas won’t appear in your published movie, the art beyond the Stage 
can be distracting in the authoring environment. While you can erase the part of the shapes that 
extend into the canvas, a better solution is to apply a mask over the Stage so that only the area 
under the mask—the entire Stage, in this case—remains visible. This way, if you’d like to return 
to the shapes to modify them, they will be intact.

1 With the Shapes layer selected, add a new layer to the Timeline and name it Mask.

2 In the toolbox, select the Rectangle tool and draw a rectangle that extends from the upper left 
corner of the Stage to the lower right corner.

This rectangle is the shape of your mask. Anything under the rectangle will be visible. 
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3 Right-click (Windows) or Control-click (Macintosh) the Mask layer name in the Timeline and 
choose Mask from the context menu.

The layer is converted to a mask layer, indicated by a down arrow icon. The layer immediately 
below it is linked to the mask layer, and its contents show throughout the filled area on the 
mask. The masked layer name is indented, and its icon changes to a right-pointing arrow. The 
art on the canvas is no longer visible on the Stage.

Mask layers must be locked for the Mask effect to show. To edit the shapes, you can unlock the 
Mask and Background Shapes layers. When you finish editing the art, lock the layers again to 
invoke masking.

4 Save your file.
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Tween bitmap effects within a movie clip
In addition to creating vector art in Macromedia Flash, you can import bitmap images, which use 
pixels to display graphics, into your Flash movie and apply various color effects. In this section, 
you’ll complete the following tasks:

• Import bitmap images

• Modify bitmap compression

• Create and edit a movie clip symbol

• Tween bitmap effects to fade views of the car in and out

To complete this section, you can either continue to work on your mystiletto.fla file, or you can 
browse to your Flash application folder and open Tutorials/FlashIntro/stiletto3.fla. If you do use 
the stiletto3.fla file, save the file with a new name in your My_Stiletto folder to maintain an 
unadulterated version of the original file.

Import images into the library

When you import a file into Macromedia Flash, you can import it directly into the library.

1 On the Timeline, add a new layer and name it Images.

2 Choose File > Import to Library.

When you select Import to Library rather than Import, the images must be placed on the Stage 
before they will appear.

3 Browse to your Tutorials/FlashIntro/Assets folder within your Flash application folder and select 
view1.png, then Shift-click to add view2.png and view3.png to the selection. Click Open.

4 In the Fireworks PNG Import Settings dialog box, click Import as a Single Flattened Bitmap, 
then click OK. 

The three images are now in the library.
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Modify bitmap compression

When you import an image, you can check and modify settings that compress the image. While 
compressing images reduces the file size of your movie, compression can affect image quality; the 
goal is to strike a balance between compression settings and image quality.

1 If the Library panel isn’t open, choose Window > Library. Enlarge the window, if necessary, to 
see the three files you imported.

2 Double-click the view1.png file. 

JPEG compression is the default selection. 

3 In the Compression pop-up menu, select Lossless (PNG/GIF) for higher image quality.

4 To test how the image appears with the new setting, click Test. If necessary, drag the car into 
view in the preview window. When you finish previewing the image, click OK.

5 Return to the Library panel. Double-click view2.png and repeat step 3, then click OK.

6 In the Library panel, double-click view3.png and specify Lossless (PNG/GIF), then click OK.
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Create a movie clip symbol

In the finished file, three views of the electric car fade in and out in the opening scene. This effect 
is achieved by creating a movie clip symbol that has a Timeline independent of the main 
Timeline. Next, you tween the alpha transparency between three views of the car to create a fade 
in/fade out effect. To begin to create the effect, you’ll create the movie clip.

1 With the Images layer still selected in the Timeline, drag the view1.png object from the Library 
panel to the Stage, placing the car within the area where the gradient background is lightest. 

2 Choose Insert > Convert to Symbol, or press F8.

3 In the Convert to Symbol dialog box, name the symbol Car Animation. Verify that Movie Clip 
is selected and that the center square is selected in the Registration indicator, and click OK.

Bitmaps, like other Macromedia Flash objects, have registration points used for positioning 
and transformation. When you align the three views of the car within the movie clip, all three 
views should align relative to a center registration point.

Registration point
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Edit a symbol

To view the Timeline of the movie clip, you must be in symbol-editing mode. You can open 
symbol-editing mode by double-clicking the symbol either on the Stage or in the Library panel.

1 On the Stage, double-click the car to open symbol-editing mode.

The name of the symbol appears above the canvas area, along with a Scene 1 link that returns 
you to the main movie. 

In symbol-editing mode, you’re now viewing the Timeline for the movie clip rather than the 
Timeline for the main movie.

2 Rename Layer 1 View 1 Fade. 

3 The car that you see on the Stage is a bitmap image, not a symbol, within the Car Animation 
symbol. Make the car a symbol by selecting it on the Stage and pressing F8.

4 In the Convert to Symbol dialog box, name the symbol View 1 Car, then verify that Movie 
Clip is selected.

5 Verify that the center square is selected in the Registration indicator and click OK.

6 Scroll horizontally across the Timeline until you get to Frame 105. Select the frame and choose 
Insert > Keyframe, or press F6 to add a keyframe.

The Current Frame indicator displays the selected frame.

7 Add keyframes to Frames 25 and 35.

8 Add a keyframe to Frame 34, then click anywhere on the layer between Frames 36 and 104, 
and press Delete on your keyboard.

An empty keyframe appears in Frame 35, and the car does not appear on the Stage from 
frame 35 on.

Note: If you make an error in adding keyframes and want to delete them, select one or more frames and 
right-click (Windows) or Control-click (Macintosh), then choose Clear Keyframe from the context menu.

Current frame
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Tween bitmap effects

Creating a bitmap effect tween is similar to creating a straight motion tween: you specify settings 
for beginning and ending keyframes, then specify tweening for those frames and the frames in 
between. Macromedia Flash creates the transitional animation from the first keyframe in the 
animation to the last. 

1 In the Car Animation Timeline, select Frame 34, then click the View 1 Car on the Stage so 
that the Property inspector appears displaying movie clip properties. 

2 In the Color pop-up menu of the Property inspector, select Alpha. In the Alpha Amount 
pop-up menu, either type 0% in the text box and press Enter or Return, or use the pop-up 
slider to select 0%.

3 In the Timeline, select any frame between Frames 25 and 34. In the Property inspector, select 
Motion from the Tween pop-up menu.

An arrow with a solid line spans the tweened keyframes. A dashed line between keyframes 
indicates the tweening is not implemented correctly, which often occurs when a beginning or 
ending keyframe is missing.

Fade in the second car

As the View 1 Car fades out, another view of the car should fade in.

1 Add a new layer to the Car Animation Timeline and name it View 2 Fade.

2 On the View 2 Fade layer, add a keyframe to Frame 25.

3 With the playhead still on Frame 25, drag view2.png from the Library panel to the Stage.

4 If the Info panel isn’t open, choose Window > Info. Verify that the center square is selected in 
the Registration indicator, then type 0 in the X coordinate text box and type 0 in the Y 
coordinate text box. Press Enter or Return. 

The Property inspector also has X and Y text boxes; however, those coordinates are relative to a 
registration point in the upper left corner of the movie clip.

Bounding rectangle
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5 Select the view2.png on the Stage and press F8 to make it a symbol. In the Convert to Symbol 
dialog box, name the symbol View 2 Car. Verify that Movie Clip is selected, and click OK.

6 In the movie clip Property inspector, select Alpha in the Color pop-up menu and type 0% in 
the Alpha Amount text box.

7 Add a keyframe to Frame 35 of the View 2 Fade layer. 

8 On the Stage, click inside the bounding rectangle of the transparent car. In the movie clip 
Property inspector, enter 100% in the Alpha Amount text box.

9 On the View 2 Fade layer, select any frame between Frame 25 and Frame 34. In the Property 
inspector, select Motion from the Tween pop-up menu.

Fade out the second car

Now you’ll create the animation that fades out the second car.

1 On the View 2 Fade layer, add a keyframe to Frame 60.

2 On the View 2 Fade layer, add a keyframe to Frame 70, and another keyframe to Frame 69.

3 Select the keyframe in Frame 69 of the View 2 Fade layer. Select the View 2 Car on the Stage 
and use the Property inspector to select an alpha transparency of 0%.

4 On the View 2 Fade layer, select any frame between Frames 60 and 68. In the Property 
inspector, select Motion from the Tween pop-up menu.

5 Click any frame on the View 2 Fade layer between Frames 71 and 105, and press Delete.

Note: As you complete the tutorial, remember to save your work frequently.
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Fade in the third car

As the second car fades out, the third car fades in. You’ll create that animation now.

1 With the View 2 Fade layer selected, add a new layer to Timeline and name it View 3 Fade.

2 On the View 3 Fade layer, add a keyframe to Frame 60.

3 With Frame 60 still selected, drag the view3.png from the Library panel to the Stage. Use the 
Info panel (choose Window > Info if the panel is closed) to specify 0 for both the X and Y 
coordinates, and to verify the registration point is centered, as you did for the view2.png. 

4 Select view3.png on the Stage and press F8 to make it a symbol. In the Convert to Symbol 
dialog box, name the symbol View 3 Car. Verify that Movie Clip is selected, and click OK.

5 In the Property inspector, select Alpha in the Color pop-up menu and type 0% in the Alpha 
Amount text box.

6 Add a keyframe to Frame 70 of the View 3 Fade layer. 

7 On the Stage, select inside the bounding rectangle of the View 3 Car. In the Property inspector, 
enter 100% in the Alpha Amount text box.

8 On the View 3 Fade layer, select any frame between Frames 60 and 69. In the Property 
inspector, select Motion from the Tween pop-up menu.

Fade out the third car

You’ll now create the animation that fades out the third car.

1 On the View 3 Fade layer, add a keyframe to Frames 95 and 105.

2 With Frame 105 selected in the View 3 Fade layer, select the View 3 Car on the Stage and use 
the Property inspector to select an alpha transparency of 0%.

3 On the View 3 Fade layer, select any frame between Frames 95 and 104. In the Property 
inspector, select Motion from the Tween pop-up menu.

Fade in the first car

As the third car fades out, the first car must fade in to complete the animation.

1 On the View 1 Fade layer, add a keyframe to Frame 95.

2 With Frame 95 still selected, drag the View 1 Car movie clip (not view1.png) from the Library 
panel to the Stage.

3 In the Info panel, type 0 in the X coordinate text box and type 0 in the Y coordinate text box. 
Press Enter or Return. 
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4 In the Property inspector, select Alpha in the Color pop-up menu and enter 0% in the Alpha 
Amount text box.

5 Select Frame 104 of the View 1 Fade layer.

6 Click inside the bounding rectangle of the View 1 Car movie clip on the Stage. In the Property 
inspector, enter 100% in the Alpha Amount text box.

7 On the View 1 Fade layer, select any frame between Frames 95 and 104. In the Property 
inspector, select Motion from the Tween pop-up menu.

Note: As you complete the tutorial, remember to save your work frequently.

Test the movie

At any point during authoring, you can test how your movie will play as a SWF file.

1 Save your movie and choose Control > Test Movie.

Macromedia Flash exports a SWF copy of your movie.

In the SWF movie, the animation automatically plays in a continuous loop. 

2 When you finish viewing the movie, close the SWF file by clicking its close box. In your Flash 
document, choose Edit > Edit Document or click Scene 1 to return to the main Timeline.

Load dynamic text at runtime
In the lesson Adding and Editing Text, you practiced typing text directly on the Stage. You can 
also design your movie to include text from external files. One of the easiest ways to accomplish 
this is to use the loadVariables action to load text from a text file into a dynamic text field at 
runtime. In the FLA file, you can specify text attributes, such as font style, size, and color, for the 
dynamic text field. An advantage of keeping text in external files is that anyone who wants to 
modify the text can work with the text file rather than the FLA file.

In this section, you’ll learn how to accomplish the following tasks:

• Import and align a logo

• Create a dynamic text field

• Use the Property inspector to assign a text variable name

• Use the loadVariables action to load text from an external file

To complete this section, you can either continue to work on your mystiletto.fla file, or you can 
browse to your Flash application folder and open Tutorials/FlashIntro/stiletto4.fla. If you do use 
the stiletto4.fla file, save the file with a new name in your My_Stiletto folder to maintain an 
unadulterated version of the original file.
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Import the logo

Before creating the dynamic text field, you’ll import the logo, a Macromedia FreeHand file for 
which Macromedia Flash automatically adds a layer on the Timeline.

Note that if you want to edit the original document before bringing it into Flash, you can just 
copy and paste or drag and drop from Macromedia FreeHand. This might give a better workflow.

1 In the Timeline, select the Images layer and add a new layer above it. Name the new layer Copy.

2 With the Copy layer selected, choose File > Import.

Earlier in the tutorial, you imported objects into the library. Now you’ll import the logo so that 
it appears on the Stage.

3 Browse within your Flash application folder to the Tutorials/FlashIntro/Assets folder and click 
logo.fh10, then click Open.

4 In the FreeHand Import dialog box, verify that Scenes, Layers, and All are selected. Also verify 
that Include Background Layer and Maintain Text Blocks is selected, and then click OK.

5 In the Timeline, Flash created a layer named Logo. Drag the Logo name to move the layer 
below the Copy layer.

6 You can specify Stage coordinates for the logo. In the Property inspector, with the logo 
selected, type 10 in the X text box and 20 in the Y text box. Then press Enter or Return.

7 In the Timeline, lock the Logo layer.
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Create a dynamic text field

Now you’ll create a dynamic text field. Instead of typing text into the field, you’ll specify the 
variable text that loads into the field at runtime.

1 In the Timeline, select the Copy layer. In the toolbox, select the Text tool. In the Property 
inspector, select Dynamic Text from the Text Type pop-up menu.

2 In the Font pop-up menu, select _sans.

_sans is a device font appropriate for small text that appears on multiple computer platforms. 
For more information about device fonts, see Flash Help > Using Flash > Using device fonts 
(horizontal text only).

3 In the Point Size text box, type 12.

4 Click the Text (fill) Color box and select yellow, with a hexadecimal value of FFCC00.

5 In the Line Type pop-up menu, select Multiline, which is for multiple lines of text that will wrap.

6 On the Stage, click below the logo. Drag the pointer to create a text field the width of the logo 
text and the approximate depth of the vertical line that’s grouped with the logo, as shown in 
the following illustration.

Line Type pop-up menu

Text Type pop-up menu

Font pop-up menu
Point size text box
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7 In the Property inspector, type textField in the Var text box.

The text file that will load into the dynamic text field, as seen in the following illustration, 
includes text that names the variable: textField=. When you enter this name in the Var text 
box, you are naming the variable that the movie should load.

Use the loadVariables action to load text

The loadVariables action includes a parameter to specify the path to the variable text. The text 
is in a file named copy.txt, within your Tutorials/FlashIntro/Assets folder.

1 In the Timeline, add a new layer and name it Actions. If necessary, drag the Actions layer to 
the top of the Timeline.

A good practice is to keep actions on the top layer in a Timeline.

2 If the Actions panel is not open, choose Window > Actions. Enlarge the Actions panel, if 
necessary, by clicking the white arrow in the title bar to expand the window, and by dragging 
the lower right corner of the panel to view the Actions toolbox and Script pane. 

The type of Actions panel that is displayed depends on the object to which you’re adding an 
action. If you’ve selected a frame, for example, the Actions panel displays actions for frames. If 
you’ve selected a button, the Actions panel displays actions for buttons.
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3 Click the triangle in the upper right corner of the panel title bar to display the pop-up menu. 
Verify that normal mode, rather than expert mode, is selected.

Expert mode offers features useful to those experienced with ActionScript. In normal mode, 
parameter fields and controls guide you in creating ActionScript.

4 In the Actions toolbox, choose Actions > Browser/Network, then double-click 
loadVariables.

The ActionScript is added to the Script pane. Parameters for the action appear above the 
Script pane.

Options menu button

Actions toolbox Script pane
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5 In the URL text box, type the path to the text file: ../assets/copy.txt.

Test your movie

• Save your movie, then choose Control > Test movie. 

You can also press Control+Enter (Windows) or Command+Return (Macintosh).

Add animation and navigation to buttons
When you specify that a new symbol is a button, Macromedia Flash creates the Timeline for the 
button states. In the Creating Buttons lesson, you learned how to change the fill color of a shape 
within a button state. In this section, you’ll learn more about modifying buttons, including 
adding animation to a button.

Specifically, in this section you’ll learn how to complete the following tasks:

• Import a library from another FLA file

• Align buttons

• Add animation to a button state

• Add navigation to a button to link to a website

• Use the Enable Simple Buttons feature

• Add button navigation

To complete this section, you can either continue to work on your mystiletto.fla file, or you can 
browse to your application folder and open Tutorials/FlashIntro/stiletto5.fla. If you do use the 
stiletto5.fla file, save the file with a new name in your My_Stiletto folder to maintain an 
unadulterated version of the original file.
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Import the library of another FLA file

The buttons that you’ll use in your movie reside in the library of another FLA file. To use the 
buttons, you open the FLA file containing the buttons as a library.

1 With your Library panel open, choose File > Open as Library. Browse within your Flash 
application folder to the Tutorials/FlashIntro/Assets folder and double-click buttons.fla.

The library for the buttons.fla file appears in addition to the library for your document.

Align buttons

You can align the three buttons along horizontal and vertical axes using the Align panel.

1 In the Timeline, with the Copy layer selected, add a new layer and name it Buttons. Lock all 
the layers except the Buttons layer.

2 In the Stage View pop-up menu, on the right above the Stage, enter 150% to enlarge your view 
of the Stage. Then scroll to the lower right side of the Stage. 

3 Drag Button 1 from the buttons.fla Library panel and place it under the lower right corner of 
the dynamic text field.

When you drag a button from the buttons.fla Library panel, the button becomes part of the 
library for your document.
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4 Drag Button 2 and Button 3 from the buttons.fla Library panel, placing them to the left of 
Button 1. Use the approximate spacing shown in the following illustration:

5 With the Arrow tool, drag to select all three buttons. 

6 To open the Align panel, choose Window > Align. Verify that To Stage is not selected. You do 
not want to align the buttons relative to the Stage. Click Align Vertical Center, and then click 
Distribute Horizontal Center.

The buttons align on the Stage.

Enable simple buttons

When the Enable simple buttons feature is active, you can hear the sounds included with Buttons 
2 and 3, and you can view the colors used for the button states. More complex button design, 
such as animation, does not play.

1 Choose Control > Enable Simple Buttons, then roll over and click each button.

The right button, Button 1, is not finished. You will modify that button next.

2 When you finish testing the buttons, choose Control > Enable Simple Buttons to deselect 
that feature.

Align Vertical Center

Distribute Horizontal Center

To Stage
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Modify a button state

You’ll create a movie clip within the Over state of Button 1, then create a shape tween in the 
movie clip. The shape tween creates an effect that changes the color from gray to red.

1 On the Stage, double-click the right button, Button 1, to open symbol-editing mode.

2 In the Button 1 Timeline, hide all layers except the Color layer. In the Color layer, select the 
Over keyframe.

3 On the Stage, select the black oval shape for the right button. Press F8 to make the oval a 
symbol. In the Convert to Symbol dialog box, name the symbol Button Animation. Select 
Movie Clip, and click OK.

4 On the Stage, double-click the Button Animation symbol to open symbol-editing mode.

5 Rename Layer 1 Color Change, and add a keyframe to Frame 15. 

6 With the playhead still on Frame 15, select the button shape on Stage and choose a bright 
shade of red from the Fill Color pop-up menu in the toolbox.

7 In the Timeline, click any frame between Frames 1 and 13. In the Property inspector, select 
Shape from the Tween pop-up menu. 

Drag the playhead from frames 1 to 15 to see the color change.

Add actions to buttons

When the user clicks the button and the tweened animation plays, you want the playhead to 
move to the end of the Button Animation Timeline, then stop. You use ActionScript, the 
Macromedia Flash scripting language, to control playhead movement in a Timeline.

1 Add a new layer to the Button Animation Timeline and name it Actions.

2 On the Actions layer, add a keyframe to Frame 15.

3 If the Actions panel is not open, choose Window > Actions. Enlarge the panel, if necessary, to 
view both the Actions toolbox and the Script pane.
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4 With Frame 15 of the Actions layer selected, go to the Actions > Movie Control category of the 
Actions toolbox and double-click stop.

The stop action lets you specify that the playhead will stop when it reaches Frame 15.

In the Button Animation Timeline, Frame 15 of the Actions layer now displays a small a, 
which indicates that an action is attached to that frame.

Note: As you complete the tutorial, remember to save your work frequently.

Add button navigation

You use the getURL action to add navigation to a button that opens a website.

1 Choose Edit > Edit Document or click Scene 1 to return to the main movie.

2 On the Stage, click Button 1, the right button.

3 In the Actions panel, choose Actions > Browser/Network and double-click getURL.

4 In the URL text box, type any complete URL, such as http://www.macromedia.com.
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5 In the Window pop-up menu, select _blank to launch a new browser window when the user 
clicks Button 1.

6 Save your file, then choose Control > Test movie. Click Button 1 to go to the website you 
specified in step 4.

7 Close the browser and the SWF file, and then return to the Macromedia Flash authoring 
environment. If desired, you can select Button 2 on the Stage and repeat steps 3 through 7 to 
link it to a different website, then repeat the steps for Button 3. When you finish linking the 
buttons, close the Actions panel.

Add streaming and event sounds
When a movie is downloading from an Internet source, a streaming sound can begin to play as 
soon as the beginning of the sound file has downloaded. Such sounds are especially suited for 
continuous background sounds. 

Event sounds must download completely and load into RAM before playing; event sounds are 
useful for buttons. 

In this section, you’ll learn how to accomplish the following tasks:

• Add a streaming sound to your movie

• Add an event sound to a button
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To complete this section, you can either continue to work on your mystiletto.fla file, or you can 
browse to your Flash application folder and open Tutorials/FlashIntro/stiletto6.fla. If you do use 
the stiletto6.fla file, save the file with a new name in your My_Stiletto folder to maintain an 
unadulterated version of the original file.

Add a streaming sound

You can include sound in your movie by dragging the sound to the Stage. You’ll add background 
music that streams and plays for a specified number of times. 

1 In the Timeline, with the Buttons layer selected, add a new layer and name it Sounds.

2 Choose File > Import. Within your Flash application folder, browse to Tutorials/FlashIntro/
Assets and click track1.mp3. Control-click (Windows) or Command-click (Macintosh) to add 
ping.mp3 to the selection, then click Open.

The files are imported into the library.

3 With the Sounds layer selected, drag the track1.mp3 sound from the Library panel to the Stage.

In the Timeline, a small representation of sound waves appears in the frame.

4 In the Timeline, select the first frame of the Sounds layer. In the Property inspector, type 999 
in the Loop text box to specify the number of times the sound can play continuously.

Test the movie

1 Save your file, then choose Control > Test Movie to hear the sound. 

2 When you finish playing the movie, click the movie’s close box.

Add an event sound to a button

In addition to dragging a sound to the Stage, you can select a sound from the Property inspector. 
You will use this method to add an event sound to a button.

As you learned in the Creating Buttons lesson, when you create a button symbol, Macromedia 
Flash creates frames for the different button states in relation to the mouse pointer. The Over 
frame, for example, represents the button’s state when the pointer is over the button. Other 
button frames/states are Up, Down, and Hit.

Now you’ll add an event sound to a button, which causes the sound to play during the Over state. 
Because you’re adding the sound to the button symbol in the library, not just to an instance of the 
symbol, the sound will play for each instance of the button.

1 In the Library panel, double-click the Button 1 instance to open symbol-editing mode.

2 In the Timeline for Button 1, add a new layer and name the new layer Sound.

3 Select the Over frame (Frame 2) of the Sound layer and choose Insert > Keyframe or press F6. 

4 To define the sound properties, click Frame 2 of the Sound layer. In the Property inspector, 
select Ping.mp3 from the Sound pop-up menu. Verify that Event is selected in the Sync 
pop-up menu.

5 Save your document and choose Control > Test Movie to hear the button sounds. When you 
finish viewing the SWF file, close its window to return to the document.
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Organize your Library panel
You currently have quite a few assets in your Library panel. To keep these assets organized, easy to 
find, and categorized by type, you’ll create folders, then move the assets into the folders. 

Tip: Keeping your library panel organized is a good practice for any movie that you author, especially because others 
working on the same file can then locate assets easily.

1 If the Library panel is not open, choose Window > Library.

2 Expand and enlarge the window, as necessary, to view all the assets in the Library panel. At the 
bottom of the Library panel, click the New Folder button four times, to create four new folders.

3 Double-click the name of untitled folder 1, and rename it Car Animation Movie Clips.

4 Rename the other three folders Sounds, Artwork, and Buttons.

5 Drag View 1 Car, View 2 Car, View 3 Car, and Car Animation to the Car Animation Movie 
Clips folder.

6 Drag ping.mp3 and track1.mp3 to the Sounds folder.

7 Drag view1.png, view2.png, and view3.png to the Artwork folder.
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8 Drag Button 1, Button 2, and Button 3 to the Buttons folder. With the Buttons folder 
selected, click New Folder again to create a subfolder with the Buttons folder.

9 Name the new folder Button Movie Clips, then drag the remaining button movie clip assets 
to this folder.

10 Close the Library panel and save your document.
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Test download performance and publish the movie
To complete your document, you will use the Publish command to create a web-compatible 
movie with the .swf extension.

If you use the Publish command with the default settings, Macromedia Flash prepares your file 
for the web. Macromedia Flash will Publish the SWF file and create an HTML file with the tags 
necessary to display the SWF.

Once you define the necessary Publish Settings options, you can repeatedly export to all selected 
formats at once by simply choosing File > Publish. Macromedia Flash stores the publish settings 
you specify with the document, so each movie can have its own settings.

In this section, you’ll learn how to complete the following tasks:

• Use the Bandwidth Profiler to test movie download performance

• Publish your movie in one step

• Review and modify publish settings

• View your movie in a web browser

To complete this section, you can either continue to work on your mystiletto.fla file, or you can 
browse to your Flash application folder and open Tutorials/FlashIntro/stiletto7.fla. If you do use 
the stiletto7.fla file, save the file with a new name in your My_Stiletto folder to maintain an 
unadulterated version of the original file.

Test movie download performance

For a Macromedia Flash movie to play correctly over the Internet, a frame must download before 
the movie reaches that frame. If the movie reaches a frame that hasn’t downloaded yet, it pauses 
until the data arrives. The low bandwidth of Macromedia Flash files promotes fast downloads.

You can use the Bandwidth Profiler to test your movie and identify where pauses might occur. 
The Bandwidth Profiler graphically shows how much data is sent from each frame in the movie, 
according to the selected modem speed.

1 Save your document and choose Control > Test Movie.

2 From the Debug menu, select a modem speed to determine the download rate that 
Macromedia Flash will simulate.

You can also choose Customize to enter a download rate.
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3 Choose View > Bandwidth Profiler to see the SWF with a download performance chart.

The shaded bar represents the first and only frame in your main movie. Movies with multiple 
frames will have multiple shaded bars. The height of the bar represents the frame’s size in bytes 
and kilobytes. Bars that extend above the red line, especially if the bar represents a frame other 
than the first frame, indicate there could be delays in movie playback. You can optimize your 
movie for faster downloads. For details, see Flash Help > Using Flash > Optimizing movies.

4 When you finish viewing the Bandwidth Profiler, choose View > Bandwidth Profiler to 
deselect it. Close the SWF window to return to the authoring environment.

Use the Publish command

You can publish your Macromedia Flash document for web playback in one step.

• With your document saved, choose File > Publish.

Macromedia Flash publishes your movie by creating a SWF file, and possibly additional files, 
based on the attributes in the Publish Settings dialog box. You’ll find the published files, by 
default, in the same folder where you saved your FLA. 
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View publish settings

Using the Publish Settings dialog box, it’s easy to reconfigure the way your file publishes.

1 To view your publish settings, choose File > Publish Settings.

Macromedia Flash is configured, by default, to create a supporting HTML file that displays the 
Flash movie.

When you select a format that requires additional settings, a new tab appears.

2 On the Formats tab, verify that Flash (.swf ) and HTML (.html) are selected. Click the Flash tab.

By default, the movie publishes for the Flash Player. The publishing process also applies movie 
and JPEG compression.

3 Click the HTML tab.

By default, the publishing process creates an HTML document that inserts your SWF file in a 
browser window. Settings on the HTML tab of the Publish Settings dialog box determine how 
the movie appears in the browser.
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Change publish settings

By default, Macromedia Flash gives the SWF file the same name as the FLA file. You can tell 
Flash to change the name.

1 On the Formats tab of the Publish Settings dialog box, deselect Use Default Names. 

2 In the HTML (.html) text box, select the existing text and type a new name, such as 
stilettoElectric.html. Then click Publish. When the Publishing status window closes, click OK 
in the Publish Settings dialog box.

View your published movie in a browser

You can view the HTML file and SWF movie, which you just published, in your browser.

1 Open your browser, then open the HTML file that you created.

By default, the HTML file is in the same folder as your FLA file.

When you open the HTML file, the SWF movie plays within your browser.

2 In your browser, you can use a command such as View > Page Source or View > 
Source to view the HTML. 

OBJECT and EMBED tags ensure that the SWF movie is displayed within the browser.

For additional information about Macromedia Flash HTML templates, see Flash Help > 
Using Flash > About HTML publishing templates.
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The next steps
By completing all eight sections of the tutorial, you’ve learned much about creating Macromedia 
Flash movies, including how to complete the following tasks:

• Analyze a completed movie

• Define document properties and create a gradient

• Create and mask vector art

• Tween bitmap effects within a movie clip

• Load dynamic text

• Modify buttons and add navigation

• Add streaming and event sounds

• Test and publish a movie 

Continue learning more about Macromedia Flash capabilities by taking the Introduction to 
ActionScript Tutorial under Help > Tutorials. Designed for ActionScript novices, the tutorial 
introduces you to scripting concepts while allowing you to build a jigsaw puzzle with actions. 
Additionally, you can search for articles and Tech Notes about Flash in the Macromedia 
award-winning Support Center. To access the site, go to http://www.macromedia.com and 
click Support.
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CHAPTER 9

Macromedia Flash MX Integration with the

Macromedia Studio MX Product Family

The power and flexibility of Macromedia Flash MX extends to its capabilities in working within 
the Macromedia Studio MX family. Tasks from simple graphics production to complex 
applications projects and website development and deployment benefit from the ease with which 
you can use the strengths of the Studio MX products.

The following sections highlight the many features available for getting the most out of Studio 
MX family for streamlining workflows, creating interface elements, and seamlessly working with 
all the popular web graphics formats.

Macromedia Dreamweaver MX
Macromedia Dreamweaver MX offers everything you need to create a professional website, 
whether you prefer to work with familiar visual layout tools or demand the control of a robust 
text-editing environment. The intuitive Macromedia user interface makes it easy to create and 
manage your site. The combination of Macromedia Flash MX and Dreamweaver MX lets you 
easily create, deploy, and maintain engaging and dynamic websites and content.

Dreamweaver MX integration features with Flash MX

The following is a summary of features you can use to ensure an easy and successful integration of 
Macromedia Flash MX content into your Dreamweaver site.

Macromedia Flash MX buttons

You can add Macromedia Flash Buttons for navigation directly in Dreamweaver MX. Through 
the Insert bar you can select button styles, enter text, and specify a URL destination—all within 
Dreamweaver MX. You can create styles in Macromedia Flash MX or download them from the 
Dreamweaver Exchange.

Macromedia Flash MX text

You can enter anti-aliased text from Macromedia Flash MX directly into Dreamweaver MX. 
Your viewers’ browsers will display the font correctly, regardless of whether the font is installed 
on their computers.

Macromedia Flash MX custom objects and behaviors

The Dreamweaver Exchange offers more than a dozen custom Macromedia Flash objects and 
behaviors that let you provide specific options for your Macromedia Flash files in Dreamweaver MX.
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Macromedia Flash MX parameters

When you place a Macromedia Flash file in Dreamweaver MX, you can delineate any set of 
parameters for the file by using the Property inspector when you select the file on your 
Dreamweaver page. If you don’t see the option you need in the Property inspector, you can use the 
Parameters button on the lower right of the inspector to add any parameters and values you need.

Macromedia Flash MX name/value pairs

Macromedia Flash MX lets you dynamically pass name/value pairs to a movie by passing them 
through the URL loading the movie. For example, you could use this technique to create a movie 
that’s used as the navigational element for an HTML site. The variables passed to the movie tell 
the Macromedia Flash navigation movie where the user is in the site, and thus, which menu 
sections to highlight.

Macromedia Flash MX special characters

If you’re using special characters in your URLs to access Macromedia Flash, you can prevent 
Dreamweaver MX from converting the characters to URL-encoded strings. Just turn off the 
Encode Special Characters in URLs options in Preferences.

JavaScript Macromedia Flash Integration Kit

Available from the Dreamweaver Exchange, the JavaScript Macromedia Flash Integration Kit 
provides some essential functions:

Macromedia Flash Player controls provide VCR-like controls to Macromedia Flash animations. 
Dreamweaver behaviors let you easily add play, stop, fast-forward, rewind, and zoom controls to 
any HTML object on the page.

Advanced form validations let you use Dreamweaver MX to add 18 prewritten client-side form 
validations to your Macromedia Flash forms.

Browser scripts for Macromedia Flash let you easily reference a library of common JavaScript in 
Macromedia Flash ActionScript. Browser scripts for Macromedia Flash provide encapsulated 
JavaScript for working with cookies, interacting with HTML forms, opening new windows, and 
controlling images.

The Macromedia Flash Deployment Kit is a comprehensive tool set that lets you consistently and 
seamlessly deploy Macromedia Flash websites. Tools include examples, scripts, templates, and 
step-by-step instructions for implementing Macromedia Flash Player detection on any website.

The Macromedia Flash Dispatcher Behavior is a detection tool made up of several files, included 
in the Macromedia Flash Deployment Kit, that together detect whether a suitable version of the 
Macromedia Flash Player is installed in a user’s browser. You can then direct the user to the 
appropriate content based on that information.

Macromedia Flash MX file preview in Dreamweaver MX

You can play Macromedia Flash files in Dreamweaver MX as you author them. The Play/Stop 
button in the Macromedia Flash Property inspector lets you preview the Macromedia Flash object 
in the Dreamweaver MX document window at authoring time. Click the green Play button to see 
the object in Play mode; click the red Stop button to stop the movie and edit the object. 
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Macromedia Flash MX file preview with 
Control Shockwave or Flash Action

The Control Shockwave and Flash Action let you play, stop, rewind, or go to a frame in a 
Macromedia Flash movie. To apply the behavior, simply select an anchor or an image, then select 
the Control Shockwave or Macromedia Flash behavior from the Behaviors panel.

For more information on the integration between Macromedia Flash MX and Dreamweaver MX, 
see http://www.macromedia.com/software/flash/resources/integration/.

Updating Macromedia Flash MX movies for Dreamweaver MX

If you have Dreamweaver MX installed on your system, you can export Macromedia Flash movie 
(SWF) files directly to a Dreamweaver site. For more information on working with Dreamweaver 
MX, see .

In Dreamweaver MX, you can add the Macromedia Flash movie to your page. With a single click, 
you can update the Macromedia Flash document (FLA file) for the exported Flash movie in Flash 
and reexport the updated movie to Dreamweaver automatically.

To update a Macromedia Flash movie for Dreamweaver MX:

1 In Dreamweaver MX, open the HTML page that contains the Macromedia Flash movie.

2 Do one of the following:

• Select the Macromedia Flash movie and click Edit in the Property inspector.

• In Design view, Control-double-click (Windows) or Command-double-click (Macintosh) the 
Macromedia Flash movie. 

• In Design view, right-click (Windows) or Control-click (Macintosh) the Macromedia Flash 
movie and choose Edit with Flash from the context menu.

• In the Site panel, right-click (Windows) or Control-click (Macintosh) the Macromedia Flash 
movie in Design view and choose Open with Flash from the context menu.

The Macromedia Flash application is launched on your system.

3 If the Macromedia Flash document (FLA) for the exported movie does not open, a file locator 
dialog box appears. Navigate to the FLA file in the Open File dialog box and click Open.

4 If the user has used the Change Link Sitewide feature in Dreamweaver MX, a warning appears. 
Click OK to apply link changes to the Macromedia Flash movie. Click Don’t Warn Me Again to 
prevent the warning message from appearing when you update the Macromedia Flash movie.

5 Update the Macromedia Flash document (FLA) as needed in Macromedia Flash MX.

6 To save the Macromedia Flash document (FLA) and reexport the Macromedia Flash movie to 
Dreamweaver MX, do one of the following:

• To update the file and close Macromedia Flash MX, click the Done button above the upper left 
corner of the Stage.

• To update the file and keep Macromedia Flash MX open, choose File > Update for Dreamweaver.
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Macromedia FreeHand
The Macromedia Flash MX/FreeHand solution is designed to create beautiful printed materials 
and high-impact web experiences with minimal effort. Macromedia FreeHand and Macromedia 
Flash MX give you powerful, cross-media publishing tools to effectively convey your creative 
vision and communications.

Macromedia FreeHand integration features with Macromedia Flash MX

The following is a summary of features that allow easy and successful integration of Macromedia 
Flash MX with FreeHand.

Illustration in FreeHand

Storyboarding a Macromedia Flash site is an integral part of the design process that FreeHand 
makes possible through its tight integration with Macromedia Flash MX and its broad range of 
creative features. FreeHand provides all the traditional Bézier tools users expect in a professional 
drawing package. In addition, it has five essential features that expand the creative relationship 
with Macromedia Flash MX:

Vector Transparency lets you create beautiful effects in FreeHand that print reliably and 
transfer to Macromedia Flash as transparent objects. Starting your transparencies in FreeHand 
allows you to create high-quality printable artwork with a higher level of flexibility in choosing 
your output medium.

The Release to Layers feature quickly creates four different types of animations from blends, text, 
and groups on any FreeHand layer; these can be used to create Macromedia Flash animations. 
Releasing a blend to layers moves the blend steps to individual layers to create a frame-by-frame 
animation of the blend. Releasing text to layers moves each character to a separate layer. Releasing 
a group releases each object to a new layer based on its stacking order.

The Macromedia symbol library lets you store frequently used FreeHand objects in a symbol library 
in FreeHand, similar to the Macromedia Flash library. If you modify a library symbol, it 
automatically updates all the instances in the file, just as in Macromedia Flash. If you import or copy 
FreeHand files into Macromedia Flash, all the original symbols from the FreeHand symbol library 
are retained. This expedites workflow while optimizing the file size of the Macromedia Flash movie.

The Test Movie feature gives you a preview of how your illustrations and designs will look when 
exported to the Macromedia Flash file format. FreeHand uses the Macromedia Flash display 
engine for this mode.

Perspective grids offer limitless creative possibilities for creating and importing animated or static 
3D vector graphics directly into Macromedia Flash. Previously, designers had to draw their own 
grids on background layers and then draw their perspective objects on top of them, hiding the 
layers before final output.
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Flexible design with FreeHand

FreeHand is the ideal place to begin producing a Macromedia Flash site, thanks to its professional 
illustration tools and strong production capabilities, such as multiple pages, styles, and graphics 
find-and-replace features.

Multiple pages in FreeHand provide flexibility by letting you do the following:

• Storyboard an entire Macromedia Flash site.

• Create a design-intensive, multipage brochure and reuse it in Macromedia Flash MX.

• Experiment with different looks for scenes.

• Use styles for text and graphics to make lightning-fast changes.

• Run find-and-replace operations to make quick changes graphics and text in a document, 
based on your criteria.

Communication with FreeHand

FreeHand supports numerous output formats across several types of media, letting you present 
content to as many people as possible.

You can design print layouts and create print documents with FreeHand, then export them as 
Macromedia Flash files with the high-quality print option enabled for web-native print applications.

With the help of the following features, you can output a FreeHand storyboard as an interactive 
Macromedia Flash file, then e-mail it to a client or use it as part of a screen-based presentation:

• Using the FreeHand Navigation panel, you can create page links to add basic interactivity to 
your Macromedia Flash file.

• Transparent objects in FreeHand retain transparency in Macromedia Flash. 

• Repeated elements are intelligently converted to symbols to keep files small.

• FreeHand layers and pages can be converted into frame-by-frame animations.

With FreeHand, you can output high-quality PostScript print materials:

• You can print materials and easily adapt them for the web with Macromedia Flash.

• FreeHand is ideal for printing storyboards of Macromedia Flash sites.

• Professional print presentations that you create in FreeHand and can be used in Macromedia 
Flash MX after client approval.

The following features let you easily import your FreeHand work into Macromedia Flash MX:

• Pages can be mapped to scenes or frames.

• Layers are maintained or can be mapped to frames.

• Named symbols and instances are maintained to keep files organized and small.

• Transparent lenses convert to alpha color transparencies in Macromedia Flash MX.
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Importing FreeHand files into Macromedia Flash MX

You can import FreeHand files (version 10 or earlier) directly into Macromedia Flash MX. 
FreeHand is the best choice for creating vector graphics for import into Macromedia Flash MX, 
because you can preserve FreeHand layers, text blocks, library symbols, and pages, and choose a 
page range to import. If the imported FreeHand file is in CMYK color mode, Macromedia Flash 
MX converts the file to RGB.

Keep the following guidelines in mind when importing FreeHand files:

• When importing a file with overlapping objects that you want to preserve as separate objects, 
place the objects on separate layers in FreeHand, and choose Layers in the FreeHand Import 
dialog box in Macromedia Flash MX. (If overlapping objects on a single layer are imported 
into Macromedia Flash MX, the overlapping shapes will be divided at intersection points, just 
as with overlapping objects that you create in Macromedia Flash.)

• When you import files with gradient fills, Macromedia Flash MX can support up to eight 
colors in a gradient fill. If a FreeHand file contains a gradient fill with more than eight colors, 
Macromedia Flash MX creates clipping paths to simulate the appearance of a gradient fill. 
Clipping paths can increase file size. To minimize file size, use gradient fills with eight colors or 
fewer in FreeHand.

• When you import files with blends, Macromedia Flash MX imports each step in a blend as a 
separate path. Thus, the more steps a blend has in a FreeHand file, the larger the imported file 
size will be in Macromedia Flash MX.

• When you import files with strokes that have square caps, Macromedia Flash MX converts the 
caps to round caps.

• When you import files with placed grayscale images, Macromedia Flash MX converts the 
grayscale images to RGB images. This conversion can increase the imported file’s size.

• When importing files with placed EPS images, you must select the Convert Editable EPS 
when Imported option in FreeHand import preferences before you place the EPS into 
FreeHand. If you do not select this option, the EPS image will not be viewable when imported 
into Macromedia Flash MX. In addition, Macromedia Flash MX does not display information 
for an imported EPS image (regardless of the preferences settings used in FreeHand).

To import a FreeHand file:

1 Choose File > Import.

2 In the Import dialog box, choose FreeHand from the Files of Type (Windows) or 
Show (Macintosh) pop-up menu.

3 Navigate to a FreeHand file and select it.
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4 Do one of the following:

• In Windows or Mac OS X or later, click Open.

• In Mac OS 9.X or earlier, click Add to add the selected file to the Import list, and click Import 
to import the file or files in the Import list.

5 In the FreeHand Import Settings dialog box, for Mapping Pages, choose a setting:

Scenes converts each page in the FreeHand document to a scene in the Macromedia Flash 
document.

Keyframes converts each page in the FreeHand document to a keyframe in the Macromedia 
Flash document.

6 For Mapping Layers, select one of the following:

Layers converts each layer in the FreeHand document to a layer in the Macromedia Flash 
document.

Keyframes converts each layer in the FreeHand document to a keyframe in the Macromedia 
Flash document.

Flatten converts all layers in the FreeHand document to a single flattened layer in the 
Macromedia Flash document.

7 For Pages, do one of the following:

• Choose All to import all pages from the FreeHand document.

• Enter page numbers for From and To to import a page range from the FreeHand document.

8 For Options, choose any of the following options:

Include Invisible Layers imports all layers (visible and hidden) from the FreeHand document.

Include Background Layer imports the background layer with the FreeHand document.

Maintain Text Blocks preserves text in the FreeHand document as editable text in the 
Macromedia Flash document.

9 Click OK.
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Macromedia Fireworks MX
Macromedia Fireworks MX brings efficiency to web graphics production, allowing you to quickly 
create buttons, animations, and page comps. Everything remains editable, including files from leading 
graphics applications. You can save production time with the History panel, step-by-step button 
maker, and library. Only Fireworks lets you script the entire application to automate workflow.

Efficient web graphics production in Macromedia Fireworks MX

Macromedia Flash MX and Fireworks MX give developers and designers a roundtrip workflow 
between their bitmap production tool environment and Macromedia Flash MX. The tight 
integration between Macromedia Flash MX and Fireworks MX makes it the ideal production tool 
for combining optimized bitmap graphics into vector-based Macromedia Flash websites. 
Fireworks can also export HTML documents customized for many popular HTML editors.

The following Macromedia Flash MX capabilities make it even easier for customers to combine 
the power of the two tools.

Launching and editing with Fireworks From the context menu of a bitmap stored in the Flash 
library, you can directly launch and edit any bitmap within Fireworks. Once you edit the bitmap, 
saving it automatically updates the library item in Macromedia Flash MX. You can edit the 
graphic or the original source image.

Importing Fireworks PNG Files You can directly import native Fireworks PNG files into 
Macromedia Flash MX. Vectors shapes, lines, layers, and guides remain editable. You can also 
import flattened bitmaps. Once you import the files into Macromedia Flash MX, you can add 
sophisticated interactivity, effects, and animation. Adobe Photoshop PSD files can be imported 
into Fireworks and saved as layered PNG files for importing into Macromedia Flash MX.

Exporting Macromedia Flash movies from Fireworks Fireworks supports exporting native 
Macromedia Flash movies (SWF files), so you can publish Macromedia Flash movies directly 
from Fireworks. You can create animated ad banners and export them as Macromedia Flash 
movies for smaller, compact files.

Importing Fireworks PNG files into Macromedia Flash MX

You can import Fireworks PNG files into Macromedia Flash MX as flattened images or as 
editable objects. When you import a PNG file as a flattened image, the entire file (including any 
vector artwork) is rasterized, or converted to a bitmap image. When you import a PNG file as 
editable objects, vector artwork in the file is preserved in vector format. You can choose to 
preserve placed bitmaps, text, and guides in the PNG file when you import it as editable objects.

If you import the PNG file as a flattened image, you can launch Fireworks from within 
Macromedia Flash MX and edit the original PNG file (with vector data). See Flash Help > Using 
Flash > Editing bitmaps in an external editor. 

When you import multiple PNG files in a batch, you choose import settings one time. 
Macromedia Flash MX uses the same settings for all files in the batch.

Note: You can edit bitmap images in Macromedia Flash MX by converting the bitmap images to vector artwork or by 
breaking apart the bitmap images. See “Converting bitmaps to vector graphics” and “Breaking apart a bitmap” in 
Flash Help > Using Flash. 
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To import a Fireworks PNG file:

1 Choose File > Import.

2 In the Import dialog box, choose PNG Image from the Files of Type (Windows) or Show 
(Macintosh) pop-up menu.

3 Navigate to a Fireworks PNG image and select it.

4 Do one of the following:

• In Windows or Mac OS X or later, click Open.

• In Mac OS 9.X or earlier, click Add to add the selected file to the Import list, and click Import 
to import the file or files in the Import list.

5 In the Fireworks PNG Import Settings dialog box, select one of the following for File Structure:

Import as Movie Clip and Retain Layers imports the PNG file as a movie clip, with all its frames 
and layers intact inside the movie clip symbol.

Import into New Layer in Current Scene imports the PNG file into the current Macromedia 
Flash document in a single new layer at the top of the stacking order. The Fireworks layers are 
flattened into the single layer. The Fireworks frames are contained in the new layer.

6 For Objects, select one of the following:

Rasterize if Necessary to Maintain Appearance preserves Fireworks fills, strokes, and effects in 
Macromedia Flash MX.

Keep All Paths Editable keeps all objects as editable vector paths. Some Fireworks fills, strokes, 
and effects will be lost on import.

7 For Text, select one of the following:

Rasterize if Necessary to Maintain Appearance preserves Fireworks fills, strokes, and effects in 
text imported into Macromedia Flash MX.

Keep All Paths Editable keeps all text editable. Some Fireworks fills, strokes, and effects will be 
lost on import.

8 Select Import as a Single Flattened Image to flatten the PNG file into a single bitmap image. 
When this option is selected, all other options are dimmed. 

9 Click OK.
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Macromedia ColdFusion MX Server
Macromedia ColdFusion is the fastest way to build and deploy powerful Internet applications. Used 
by hundreds of thousands of developers worldwide, ColdFusion makes it easy to quickly develop 
content for publishing systems, business intelligence solutions, self-service applications, and more.

Macromedia Flash developers will find ColdFusion MX, including J2EE and Microsoft .Net 
application server support, to be both the easiest and the most powerful server-side environment 
for their rich applications.

Macromedia ColdFusion MX Server and Macromedia Flash MX

Macromedia ColdFusion MX, with its approachability and rapid development capabilities, its 
easy yet powerful integration with a broad variety of back-end systems, and its strong support for 
XML, is the ideal environment for creating Macromedia Flash MX applications.

In order for rich applications to be truly compelling, they must be able to exchange data with a 
wide variety of back-end systems. ColdFusion MX provides easy, built-in connectivity to a 
complete set of back-end systems, including all major databases, mail servers, file servers, 
enterprise directories, and cross-platform component interfaces. ColdFusion MX includes high-
performance database drivers for all leading databases and makes it easy to set up data sources in 
minutes through a simple web-based interface. ColdFusion developers can easily send and retrieve 
messages from e-mail servers, connect to enterprise directories, and exchange documents with file 
servers. ColdFusion also provides connectivity to existing applications using the COM, CORBA, 
or EJB component interfaces.

ColdFusion MX also supports XML-based data exchange with the Flash Player. By 
exchanging structured dynamic data with ColdFusion MX, Macromedia Flash MX rich 
application developers can harness all the logic-processing power and back-end connectivity that 
ColdFusion MX provides. 

Part VIII of this book gives you an overview of dynamic web development and an introduction to 
the Developer Edition of ColdFusion MX that can be installed from the Macromedia Studio MX 
CD-ROM or downloaded from the Macromedia website at http://www.macromedia.com.

To learn more about best practices for integration between ColdFusion MX and Macromedia 
Flash MX, see the Macromedia Flash and ColdFusion Resource Center at http://
www.macromedia.com/software/coldfusion/resources/flash_coldfusion/.
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Part V
Fireworks MX

The chapters in Part V introduce Macromedia Fireworks 
MX, present a tutorial, and describe how Fireworks MX 
works within the Macromedia Studio MX product family. 

The following chapters are in this part:

• Chapter 10, “Welcome to Macromedia Fireworks MX”

• Chapter 11, “Fireworks Tutorials”

• Chapter 12, “Fireworks MX Integration with the 
Macromedia Studio MX Product Family”





CHAPTER 10

Welcome to Macromedia Fireworks MX

Macromedia Fireworks MX is the solution for professional web graphics design and production. 
It is the first production environment to address and solve the special challenges facing web 
graphics designers and developers.

You can use Fireworks to create, edit, and animate web graphics, add advanced interactivity, and 
optimize images in a professional environment. In Fireworks, you can create and edit both bitmap 
and vector graphics in a single application. Everything is editable, all the time. And you can 
automate the workflow to meet the demands of time-consuming updates and changes.

Fireworks integrates with other Macromedia Studio MX products to provide a truly integrated 
web solution. You can easily export Fireworks graphics with HTML and JavaScript code 
customized for the HTML editor you’re using. 

What’s new in Fireworks MX
New features in Fireworks MX make it an increasingly approachable application with enhanced 
power to create graphics and interactivity for websites. Fireworks MX maximizes productivity for 
seasoned veteran web designers, HTML developers who also work with graphics, and emerging 
web developers who need to develop graphics-rich, interactive web pages with little or no coding 
or JavaScript knowledge.

Fireworks MX has undergone a major refinement, with a streamlined user interface, more 
powerful button and pop-up menu capabilities, and intuitive bitmap and vector tools. Integration 
with other Macromedia applications—as well as third-party applications—makes it easy to bring 
various file formats into Fireworks and send them to other applications smoothly as you work. 
Also new to Fireworks is the ability to create JavaScript commands with Macromedia Flash MX 
that appear in Fireworks MX as panels or dialog boxes.

Ease-of-use features in Fireworks MX

A comfortable, intuitive work environment—including a Property inspector and tools that work 
the way professionals would expect—make Fireworks MX an easy application to learn and get to 
work quickly. Fireworks MX has a new look that is better organized and more consistent with 
other applications in the Macromedia MX Studio.

Panel management enhancements include the ability to place panels in groups, then collapse the 
groups so that only the panel group title bar is visible until you need to use the panels. You can 
dock the panel groups in a panel docking area to organize your workspace or drag groups or 
individual panels anywhere in the workspace. For more information, see Fireworks Help > 
Using Fireworks > Organizing panel groups and panels.
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The Property inspector is a dynamic panel full of options that change as you do your work. Open 
a document, and the Property inspector displays document properties such as canvas color and 
size. Choose a tool from the Tools panel, and the Property inspector displays tool options. Select a 
vector object, and it displays stroke and fill information. 

You can change these and other options—including Live Effects, blending modes, and opacity—
directly from the Property inspector, instead of having to click to open or activate panel after 
panel. The Property inspector—familiar to Macromedia Flash and Dreamweaver users—
reduces the number of panels in the workspace. For more information, see Fireworks Help > 
Using Fireworks > Using the Property inspector.

Modeless bitmap and vector editing eliminates the need to constantly keep up with vector and 
bitmap modes. Choosing a tool or selecting an object type automatically determines whether you 
will be creating and editing bitmaps, vectors, or text.

Bitmap-editing enhancements give you intuitive capabilities to create bitmaps by cutting or 
copying and pasting, to move marquee selections among bitmaps, and to fine-tune images with a 
new group of image-retouching tools. Also, common selection commands are organized in a new 
Selection menu.

Tools panel sections that separate the tools used for creating and editing bitmaps, vectors, and 
web objects offer cues for intuitively choosing the proper tool and achieving predictable creative 
results. Other tools and tool features are separated into Select, Colors, and View categories. For 
more information, see Fireworks Help > Using Fireworks > Using the Tools panel.

The Quick Export button displays convenient options for exporting a variety of file formats or 
HTML styles, or launching other Macromedia products from the document window, eliminating 
setup time and streamlining the workflow. For more information, see Fireworks Help > 
Using Fireworks > Using the Quick Export button.

Onscreen text allows you to visually integrate text and graphics without having to use the Text 
Editor. Simply choose the Text tool, click the canvas, and start typing. In the Property inspector, 
you can either set text attributes for the Text tool before you begin typing or highlight existing 
text and format it. Fireworks MX has a range of new text and paragraph controls to format text. 
For more information, see Fireworks Help > Using Fireworks > Using Text.

Variable zooming lets you drag the Magnify tool to determine the precise magnification amount. 
After you drag to magnify your document, the magnification amount is displayed in the Set 
Magnification text box at the bottom of the document.

Windows XP and Mac OS X compatibility takes advantage of the latest operating systems. 
Fireworks MX is fully carbonized to support all the OS X user-interface improvements.

XHTML exporting allows you to export, update, and roundtrip XHTML in all the same styles 
Fireworks offers for HTML. You can roundtrip legacy documents that have been converted to 
XHTML in Dreamweaver MX.

The Answers panel, a new feature in Fireworks MX, Macromedia Dreamweaver MX, and 
Macromedia Flash MX, is an updatable link to web content, conveniently located in the 
Fireworks workspace. When you are online, you can click the Update button and download fresh 
reference information from Macromedia, or search online databases for documentation such as 
TechNotes.

The spell-checker searches every text block in your document for misspelled words. When it 
finds a word it doesn’t recognize, it offers suggestions for correcting it or allows you to add it to 
your dictionary.
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Cross-platform font caching makes it easy to share files among work groups and clients without 
worrying about cross-platform font issues. Fireworks maintains the appearance of all text in a 
document on systems that do not have the fonts in the document.

Power enhancement features in Fireworks MX

Fireworks MX has a series of powerful new creativity and automation features that emerging web 
designers will find easy to use and experienced developers will appreciate. These features make 
Fireworks an essential part of the web designer and developer process from concept to integration.

The Data-driven Graphics Wizard allows you to assign variables to text, images, hotspots, and 
slices, and then generate multiple documents based on the original, each with unique information 
taken from a comma-delimited or XML database file.

The Nav Bar Builder on the Commands menu automates the process of quickly creating 
navigation bars using convenient Fireworks MX button symbols. You can select an instance of a 
button symbol, and then choose the number of copies to make, choose vertical or horizontal 
orientation and spacing, and assign button labels and URLs in an integrated dialog box.

Pop-up Menu Editor enhancements have added creative control to the most popular new feature 
in Fireworks 4. Now you can create a horizontal or vertical pop-up menu, and determine border 
characteristics, cell spacing, and cell size independently from text size. You can also set placement 
of menus relative to the trigger object as well as placement of submenus relative to the trigger 
menu item or main pop-up menu. Fireworks automatically generates JavaScript code for you; 
exported menus are fully compatible with Dreamweaver MX. For more information, see 
Fireworks Help > Using Fireworks > Creating pop-up menus.

Instance-level button symbol editing lets you create a button symbol and then easily differentiate 
individual buttons with unique text, URLs, and targets using the Property inspector. Meanwhile, 
you can edit other graphical characteristics at the symbol level, and have the edits update across all 
button instances without affecting the instance-level properties. For more information, see 
Fireworks Help > Using Fireworks > Creating button symbols.

Open workflow features in Fireworks MX

You need not be confined by someone else’s workflow. Using Fireworks MX, you can integrate 
graphic production into your development process with an open, efficient workflow that 
recognizes and supports the file formats, applications, and standards you use.

JavaScript commands with SWF interface take JavaScript command creation to a higher level. 
Developers can create and execute complex commands to extend and automate Fireworks MX by 
combining the Fireworks JavaScript extensibility API with interfaces developed in Macromedia 
Flash MX using components and ActionScript. For more information, see Extending Fireworks 
MX, available .

Macromedia Exchange support means that users—even those who are not interested in creating 
JavaScript commands—can download user-created commands from the Exchange. The 
commands appear in the Fireworks MX workspace as easy-to-use panels or dialog boxes. 
Fireworks MX ships with several user-created commands in the Commands menu, as well as a 
user-created Align panel in the Window menu.

Slice table layout controls let you define and optimize slice table layouts by dragging slice guides. 
Fireworks automatically resizes attached slices, adding and deleting slices as needed. For more 
information, see Fireworks Help > Using Fireworks > Moving slice guides to edit slices.
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The Reconstitute Tables feature instantly builds a new Fireworks PNG source file when you 
point to any HTML file containing tables with image slices. Macromedia Fireworks and 
Dreamweaver behaviors such as image rollovers and pop-up menus are imported and attached to 
the appropriate slices.

This comes in handy when you are working on existing website projects and the only available 
files are the posted HTML pages. You can bring the HTML files into Fireworks and create 
PNG source files from them. For more information, see Fireworks Help > Using Fireworks > 
Creating Fireworks PNG files from HTML files.

Roundtrip Photoshop 6 text allows you to open a Photoshop 6 or 7 file with editable text intact, 
so the graphic can be edited and then exported back to the Photoshop format, while maintaining 
the correct text appearance and editability. For more information, see Fireworks Help > 
Using Fireworks > About importing text from Photoshop.

Roundtrip with Microsoft FrontPage is available with a click of the Quick Export button. Launch 
and Edit tables work on the original file in Fireworks; the tables are updated in Microsoft 
FrontPage without losing code changes that have been made in FrontPage. For more information, 
see Fireworks Help > Using Fireworks > Exporting Fireworks HTML to FrontPage.

Macromedia Sitespring integration puts best practices in production and client management in 
the Fireworks MX workspace. Simply choose Window > Sitespring to open the Sitespring 
window. For more information, consult the Sitespring documentation.

Learning Fireworks MX
A variety of resources are available in Macromedia Studio MX for learning Fireworks, including a 
help system you can launch from the application, a PDF version of the complete Fireworks 
documentation, and several web-based information sources.

Fireworks Help is available whenever the Fireworks application is active, and contains the 
complete Fireworks documentation. 

Fireworks tutorials provide an interactive introduction to the key features in Fireworks that you can 
complete in about an hour each. They include common Fireworks tasks such as using the drawing 
and editing tools, optimizing images, and creating interactive elements such as rollovers and 
navigation bars. The tutorials are available in Chapter 11, “Fireworks Tutorials,” on page 233.

The Answers panel is a central location where you can find tutorials, TechNotes, and the most 
up-to-date information about Fireworks, all in one place. The Answers panel is dynamic; with 
just the click of a button you can get the latest updates and information about Fireworks directly 
from Macromedia.

The Fireworks application itself contains many dialog boxes and tooltips designed to assist you in 
using the program. Tooltips appear when your pointer pauses over a user interface element.

The Using Fireworks MX PDF is a searchable, printable document containing the complete 
Fireworks documentation. The PDF is available on the installation CD and on the Macromedia 
website at http://www.macromedia.com.

The Macromedia website is updated regularly with the latest information on Fireworks in addition 
to advice from expert users, advanced topics, examples, tips, and updates. Check the Macromedia 
website for news on Fireworks and how to get the most out of the program at http://
www.macromedia.com
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The Fireworks discussion group provides a lively exchange for Fireworks users, technical support 
representatives, and the Fireworks development team. Use a newsgroup reader to go to news://
forums.macromedia.com/macromedia.fireworks. 

Extending Fireworks MX includes information about writing JavaScript to automate Fireworks 
tasks. Every command or setting in Fireworks can be controlled using special JavaScript commands 
that Fireworks can interpret. A PDF version of Extending Fireworks MX is available on the CD and 
on the Macromedia website at http://www.macromedia.com/support/fireworks/extend.html. 
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CHAPTER 11

Fireworks Tutorials

The two tutorials in this chapter will guide you through the basic tasks of designing graphics and 
adding interactive elements to a web page in Macromedia Fireworks MX. 

Fireworks tutorial 1: Graphic design basics
This tutorial will guide you through the basic tasks of designing graphics with Macromedia 
Fireworks MX. You’ll get hands-on experience using the industry’s leading web graphics 
application and learn basic graphic design concepts along the way. 

If you are already familiar with designing graphics in Fireworks, you may want to proceed to  
“Fireworks tutorial 2: Web design basics” on page 260, where you’ll learn about designing web 
pages with Fireworks.

What you’ll learn
By taking this tutorial, in less than an hour you’ll accomplish the tasks required to create an ad for 
classic rental cars using Fireworks. You will learn to do the following:

• Create and save a new document

• Explore the Fireworks work environment

• Create and edit vector objects

• Import a bitmap and select pixels

• Add and edit Live Effects

• Work with layers and objects

• Create and edit a mask

• Create and edit text

• Export the document

What you should know
Although this tutorial is designed for beginning Fireworks users, it covers many new features 
in Fireworks, so experienced Fireworks users can benefit from it too. You don’t need to be a 
graphic designer to perform this tutorial, but you should possess basic computer skills and be able 
to use common desktop applications. This includes knowing how to browse for files and folders 
on your hard disk.
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Copy the Tutorials folder
Before you begin, you’ll make a copy of the Tutorials folder, so that you can save the results of 
your work while allowing you or another user to complete the tutorial at a later time using the 
original files.

1 Navigate to the Fireworks application folder on your hard disk.

Note: If you are unable to view your Fireworks application folder, you may have limited access to files on your 
system. You can download the files you need for this tutorial from the Fireworks Support Center on the web at 
http://www.macromedia.com/support/fireworks/.

2 Drag a copy of the Tutorials folder to your desktop.

View the completed file
View the completed tutorial file to see what your finished project will look like.

1 Launch your web browser.

2 On your hard disk, navigate to the Tutorials folder you copied to your desktop, and browse to 
Tutorial1/Complete.

Note: Some versions of Microsoft Windows hide extensions for known file types by default. If you have not 
changed this setting, the files in the Complete folder won’t display extensions. When dealing with web graphics, it’s 
best to be able to see file extensions. See Windows Help for information about how to turn file extensions back on.

3 Select the final.jpg file and drag it to the open browser window.

For this tutorial, you will use Fireworks to design and export a copy of this ad for classic rental cars.

Note: The Complete folder also includes the Fireworks document from which this JPEG file was generated. To 
view the document, double-click final.png.

Create and save a new document
Now that you’ve viewed the final.jpg file, you’re ready to begin your project.

1 In Fireworks, choose File > New.

The New Document dialog box opens.
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2 Enter 480 for the width and 214 for the height. Ensure that both measurements are in pixels 
and that the canvas color is white, and click OK.

A document window opens, with a title bar that reads Untitled-1.png (Windows) or 
Untitled-1 (Macintosh).

3 If the document window isn’t maximized (that is, if it doesn’t fill the center of the screen), 
maximize it by clicking the maximize button (Windows) or the zoom box (Macintosh) at the 
top of the document window. This will give you plenty of room to work.

4 Choose File > Save As.

The Save As (Windows) or Save (Macintosh) dialog box opens.

5 Browse to the Tutorials/Tutorial1 folder on your desktop.

6 Name the file vintage.

7 Choose the Add Filename Extension option if it’s not already selected (Macintosh only).

8 Click Save.

The title bar displays the new filename with a .png extension. PNG is the native file format for 
Fireworks. The PNG file is your source file; it is where you’ll do all of your work in Fireworks. 
At the end of this tutorial, you’ll learn how to export your document to another format for use 
on the web.

As you complete the tutorial, remember to save your work frequently by choosing File > Save.

Note: While completing the tutorial, you may find it useful to undo a change you’ve made. Fireworks can undo 
several of your recent changes, depending on the number of undo steps you have set in Preferences. To undo the 
most recent change, choose Edit > Undo.
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Explore the Fireworks work environment
Before you continue, examine the elements that make up the Fireworks work environment: 

• In the center of the screen is the document window. In the center of the document window is 
the canvas. This is where the Fireworks document and any graphics you create are displayed.

• At the top of the screen is a menu bar. Most Fireworks commands are accessible from the 
menu bar.

• On the left side of the screen is the Tools panel. If the Tools panel isn’t visible, choose Window > 
Tools. The Tools panel is where you’ll find tools for selecting, creating, and editing a variety of 
graphic items and web objects.

• At the bottom of the screen is the Property inspector. If the Property inspector isn’t visible, 
choose Window > Properties. The Property inspector displays properties for a selected object 
or tool. You can change these properties. If no objects or tools are selected, the Property 
inspector displays document properties.

The Property inspector displays either two or four rows of properties. If the Property inspector 
is at half height, that is, displaying only two rows, you can click the expander arrow in the 
lower right corner to see all properties.

Expander arrow at half height state
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• On the right side of the screen are a variety of panels, such as the Layers panel and Optimize 
panel. You can open these and other panels from the Window menu.

• Move your pointer over the various interface elements. If you hold the pointer over an item on 
the interface long enough, a tooltip appears. Tooltips identify tools, menus, buttons, and other 
interface features throughout Fireworks. Tooltips disappear when you move the pointer away 
from the interface elements they identify.

You’ll learn more about each of these elements as you progress through the tutorial.

Create and edit vector objects
With Fireworks, you can create and edit two kinds of graphics: vector objects and bitmap images.

A vector object is a mathematical description of a geometric form. Vector paths are defined by 
points. Vector paths do not show a degradation in quality when you zoom in on them or scale 
them larger or smaller. The leaf in the illustration below is a collection of vector objects. Notice 
how smooth the leaf ’s edges appear even when you zoom in.

In contrast, a bitmap image is made up of a grid of colored pixels. Images with complex color 
variations, such as photographs, are most often bitmap images.

While many applications offer tools to edit either vector shapes or bitmap images, Fireworks lets 
you work with both types of graphics. You will work with vector graphics in this section.
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Create vector objects 

Now you’ll create two of the graphical elements for your document. First you’ll create a blue 
rectangle that will be positioned at the bottom of the document. Then you will create a rectangle 
that will act as a border for the contents of the canvas.

1 Choose the Rectangle tool in the Vector section of the Tools panel.  

2 In the Property inspector, click the Fill Color box. 

The Fill Color pop-up window opens. 

3 Type 333366 in the text box at the top of the window, then press Enter.

The Fill Color box changes to a dark blue color to reflect your color choice.

4 In the document window, position the cross-hair pointer over the canvas, and drag downward 
and to the right to create a rectangle. You can draw the rectangle anywhere on the canvas. 
You’ll resize and position it later in this procedure.

5 When you release the mouse button, a dark blue rectangle appears, selected, in the area 
you defined.

You can tell when an object is selected because it displays blue corner points. Most objects also 
have a blue highlight around their outer edges, but rectangles are an exception.
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6 In the lower left corner of the Property inspector, enter 480 in the width box and 15 in the 
height box, then press Enter. 

The rectangle is resized to fit the specified dimensions.

7 Choose the Pointer tool in the Select section of the Tools panel.

8 Drag the rectangle so that it is positioned at the bottom of the canvas, as shown below. Use the 
arrow keys for exact placement.

9 Choose the Rectangle tool again, and draw a second rectangle. Draw it anywhere on the canvas, 
and make it any size you want. You’ll change its properties and position in the next section.

Set object properties

Here, you’ll edit the second rectangle you created by changing its size, position, and color in the 
Property inspector.

1 With the rectangle still selected, click the Stroke Color box in the Property inspector and enter 
CCCCCC as the color value. Press Enter to apply the change.

2 Set the Tip Size to 1 by dragging the pop-up slider or typing in the text box.

3 Click the Fill Color box in the Property inspector and click the Transparent button.
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4 In the Property inspector, enter the following values in the width, height, and coordinate 
boxes. Then click outside the Property inspector to apply your changes.

• Width: 480

• Height: 215

• X: 0

• Y: 0

The rectangle becomes a gray border around the edge of the canvas. 

If your system uses gray as the color for the window background, it may be difficult for you to 
see the rectangle at this point. But don’t worry, it’s still there.

5 Choose the Pointer tool and click anywhere away from the rectangle to deselect it.

The properties change in the Property inspector. Because no objects are selected, you now see 
document properties instead of object properties.

Import a bitmap and select pixels
Next you will import a bitmap image and create a floating selection from its pixels.

Import an image

You will modify an image of a classic automobile. First you need to import the image.

1 Choose File > Import and navigate to the Tutorials folder on your desktop. Browse to the 
Tutorial1/Assets folder.

2 Select car.jpg and click Open.
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3 Align the insertion pointer with the upper left corner of the canvas and click, as shown in the 
following illustration.

The image appears, selected, on the canvas.

4 Click anywhere outside the selected image to deselect it.

Create a pixel selection 

Next you’ll select the pixels that make up the car in the image you imported, and copy and paste 
the pixels as a new object.

1 Choose the Zoom tool in the View section of the Tools panel.

2 Click once on the image.

The view is magnified to 150%. Zooming in allows you to better see what you are selecting 
and gives you finer control over your selection.

3 Click and hold down the mouse button on the Lasso tool in the Bitmap section of the Tools 
panel. Choose the Polygon Lasso tool from the pop-up menu that appears.

The Polygon Lasso tool allows you to draw a selection around pixels using a series of straight 
lines. You’ll use the Polygon Lasso tool to select the pixels that make up the car image.

4 In the Property inspector, set the Edge option to Anti-alias.

Zoom tool
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5 Click with the Polygon Lasso tool pointer on the top edge of the car, then click repeatedly 
around the edge of the car to continue the selection.

6 Complete the selection by moving the pointer over the spot where you started the selection. A 
small gray square appears beside the Polygon Lasso pointer to indicate you are about to 
complete the selection. Click to complete the selection.

A marquee border appears around the pixels you selected.

7 Choose Edit > Copy.

The selection is copied to the Clipboard.

8 Choose Edit > Paste. 

The car image is pasted into the document as a new bitmap object.

9 Choose the Pointer tool and double-click anywhere outside the bitmap to deselect it.

10 Click the Set Magnification pop-up menu at the bottom of the document window and return 
the view to 100%.
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Add and edit Live Effects
Next you’ll apply Live Effects to the original bitmap image. You’ll change the image’s hue and 
saturation and apply a blur.

1 Click anywhere on the desert image. (Be careful not to click on the car, however.)

2 In the Property inspector, click the Add Effects button (the button with the plus (+) sign).

3 Choose Adjust Color > Hue/Saturation from the Effects pop-up menu.

The Hue/Saturation dialog box opens. 

Delete Effects button

Add Effects button
Fireworks Tutorials 243



4 Choose the Colorize option and click OK.

The image becomes colorized on the canvas, and the effect is added to the Live Effects list in 
the Property inspector. Live Effects are editable; you can always add to this list, delete the 
effect, or edit the effect. 

5 Double-click the Hue/Saturation effect to edit it.

Tip: Alternatively, you can click the info button beside the effect. 

The Hue/Saturation dialog box opens again.

6 Change the Hue to 25 and the Saturation to 20, and click OK.

The image’s hue and saturation levels change to display a sepia appearance, as in an old photograph.

7 Click the Add Effects button again to add another Live Effect.

8 Choose Blur > Blur More from the Effects pop-up menu.

The pixels of the selected bitmap become blurred, and the new effect is added to the Live 
Effects list in the Property inspector. 

Work with layers and objects
Layers divide a Fireworks document into discrete planes. A document can be made up of many 
layers, and each layer can contain many objects. In Fireworks, the Layers panel lists layers and the 
objects contained in each layer. 

Using the Layers panel, you can name, hide, show, and change the stacking order of layers and 
objects, as well as merge bitmaps and apply bitmap masks. You can also add and delete layers 
using the Layers panel.

In this part of the tutorial, you’ll use the Layers panel to merge the two bitmap images. Then 
you’ll name the objects in your document. You’ll also use the Layers panel to change the stacking 
order of objects.

Later in the tutorial you’ll use the Layers panel to apply a mask to the merged image.
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Merge bitmaps 

Now that you’ve applied Live Effects to the background image, you will merge it with the 
grayscale car image to create a single bitmap.

1 If the Layers panel is minimized or isn’t visible, click its expander arrow or choose 
Window > Layers.

2 Click the thumbnail of the grayscale car image in the Layers panel.

3 With the car image selected, click the Options pop-up menu icon at the upper right of the 
Layers panel.

4 Choose Merge Down.

In the Layers panel, the two bitmap objects merge into one bitmap. 

In the Property inspector there are no longer any effects in the Live Effects list. This is because 
merging down combines the pixels of each bitmap and renders them uneditable as separate 
images. The Live Effects you apply to an object or bitmap are no longer editable after you 
perform a merge down with another bitmap.

Expander arrow

Options pop-up menu icon
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Name objects

It’s always a good idea to name your objects so you can easily identify them later. When a 
document gets large and contains many objects, it can be difficult to manage if your objects don’t 
have unique names. 

Here you’ll name the objects in your document using both the Layers panel and the 
Property inspector.

1 Double-click the word Bitmap beside the image thumbnail in the Layers panel.

A text box appears.

2 Type Classic Car in the text box and press Enter.

The new name is applied to the bitmap object.

3 In the document window, select the gray rectangle that borders the document. If it’s too hard 
to see on the canvas, select it in the Layers panel.

This time you’ll name an object using the Property inspector.

4 Type Border in the Object Name box of the Property inspector, and press Enter.

The name you enter is also displayed beside the object thumbnail in the Layers panel.

5 Enter a name for the remaining rectangle object using either the Layers panel or the Property 
inspector. Use any name you like, but choose a name that is meaningful so you can easily 
identify and manage objects in the document later.
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Change the object stacking order

The merged bitmap image overlaps the border object and the blue rectangle. The border and blue 
rectangle need to rest on top, so you’ll use the Layers panel to change the stacking order of objects 
in the document.

1 Click the thumbnail of the blue rectangle in the Layers panel to select it.

2 Drag it to the top of Layer 1, above the Classic Car thumbnail.

Note: The topmost layer in the Layers panel is always the Web Layer. You’ll learn more about the Web Layer in 
“Fireworks tutorial 2: Web design basics” on page 260.

As you drag, the pointer changes to reflect that you are dragging an object (Windows only). A 
dark line in the Layers panel indicates where the object will be dropped if you release the 
mouse button at that time.

3 Release the mouse button.

The blue rectangle is dropped just above the bitmap object in the Layers panel. The stacking 
order of objects also changes on the canvas. The blue rectangle now overlaps the bitmap object 
and the border object.

4 You want the border object to be the topmost object, so select its thumbnail and drag it to the 
top of the Layers panel, above the blue rectangle. 
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Create and edit a mask
Now that you’ve made various modifications to the classic car image, you’ll perform one last 
procedure to give it the appearance of becoming gradually transparent.

In Fireworks you can apply two kinds of masks: vector masks and bitmap masks. For this tutorial, 
you’ll apply a simple bitmap mask to the car image. You’ll then modify it by giving it a gradient fill. 
The pixels in the mask will either display or hide the car image, depending on their grayscale value.

Apply a mask

First you will apply an empty, white bitmap mask to the car image. A white mask shows a selected 
object or image, whereas black pixels in a mask hide a selected object or image.

You’ll also paint on the mask to make the car image appear to be fading into the background.

1 With the Pointer tool, select the bitmap image.

2 Click the Add Mask button at the bottom of the Layers panel.

An empty, transparent mask is added to the selected image. You can see the mask has been 
added by looking at the mask thumbnail in the Layers panel. The yellow highlight around the 
mask thumbnail indicates it is selected.

Edit the mask

Now you will give the bitmap image a transparent appearance by adding a gradient fill to the mask.

1 With the mask thumbnail selected in the Layers panel, click and hold down the mouse button 
on the Paint Bucket tool in the Bitmap section of the Tools panel. Choose the Gradient tool 
from the pop-up menu that appears. 

2 Click the Fill Color box in the Property inspector.

The Edit Gradient pop-up window opens.

Mask thumbnail

Mask object
Chapter 11248



3 Choose White, Black from the bottom of the Preset pop-up menu.

The color ramp and swatches change to reflect the new setting. The color swatches located just 
beneath the color ramp allow you to modify the colors in the gradient.

4 Drag the left (white) color swatch about 1/4 of the way to the right to adjust the gradient.

5 Click outside the Edit Gradient pop-up window to close it.

6 On the canvas, drag the Gradient pointer across the bitmap image, as shown in the following 
illustration. 

Visual feedback appears onscreen as you drag, allowing you to define the angle and distance in 
which the gradient will be applied.

7 Release the mouse button.

The mask is modified with the gradient fill you created. The mask affects the car image by 
giving it a gradiated transparent appearance.The mask thumbnail in the Layers panel displays 
the gradient fill you applied. 

Color ramp

Color swatches
Fireworks Tutorials 249



8 Choose the Pointer tool and click the mask thumbnail in the Layers panel.

The Property inspector shows that the mask was applied using its grayscale appearance. The 
darker pixels in the mask knock out the image of the car, while the lighter pixels in the mask 
show the car.

Create and edit text
Next you’ll add text to the document and apply text properties using the Property inspector. You’ll 
create four text blocks, two for the advertisement title and two for the body text.

Create the title text

First you’ll create the title text for the car rental advertisement.

1 Choose the Text tool in the Vector section of the Tools panel, and move the pointer over the 
document window.

The pointer changes to an I-beam, and the Property inspector displays text properties. 

2 In the Property inspector, do the following:

• Choose Times New Roman from the Font pop-up menu.

• Enter 85 as the font size.

• Click the Fill Color box. The pointer changes to the eyedropper pointer. Click the eyedropper 
pointer on the blue rectangle on the canvas.

The color pop-up window closes, and the Fill Color box changes to reflect the chosen color.

• Ensure that none of the style buttons (Bold, Italic, Underline) are selected.

• Click the Left Alignment button.

Font

Size

Fill Color

Style buttons

Alignment buttons

Leading

Horizontal Scale
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3 With the I-beam pointer, click once in the middle of the canvas. 

An empty text block is created. 

The hollow circle in the upper right corner of the text block indicates that the text block is 
auto-sizing. An auto-sizing text block in Fireworks adjusts its width based on the longest line of 
text in the block.

4 Type Vintage in the text block.

The width of the text block expands as you type.

5 Click once outside the text block to apply your text entry.

The text block remains selected, and the Text tool is still the selected tool. The hollow circle on 
the text block is no longer visible. This indicator is visible only when you are entering or 
editing text.

6 Choose the Pointer tool and drag the text to position it as shown in the following illustration. 

7 Click outside the text block to deselect it, and choose the Text tool again.

8 In the Property inspector, choose Arial as the font and 12 as the font size.

9 Click on the canvas again, somewhere beneath the text block you just created, and type 
CLASSIC RENTALS in uppercase letters.

10 Choose the Pointer tool to apply the text entry.

Switching to another tool in the Tools panel applies text entries and edits just like clicking 
outside a text block does. Pressing the Escape key will achieve the same result.

Auto-sizing indicator
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11 Drag the new text block to position it just beneath the Vintage text block, as shown in the 
following illustration.

12 Click outside the text block to deselect it.

Create the body text

Next you’ll create two text blocks that make up the body text for this ad.

1 Choose the Text tool.

2 This time, instead of just clicking on the canvas, drag to draw a marquee with the I-beam 
pointer, as shown in the following illustration.

A text block appears. The hollow square in the upper right corner indicates that the text block 
is a fixed-width text block, defined by the marquee you drew. Fixed-width text blocks retain 
the width you specify no matter how much text you type. The hollow corner handle is a toggle. 
Double-clicking it will toggle a text block between auto-sizing and fixed-width.
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3 Type the following text without entering any line breaks as you type:

Indulge yourself by traveling in a Vintage classic automobile, with a chauffeur to whisk you 
to any destination.

The text flows into the text block you created. The text block grows vertically but not horizontally.

4 Choose the Pointer tool and click outside the text block to deselect it. Then choose the 
Text tool again.

5 In the Property inspector, click the Fill Color box and choose white as the text color.

6 Click in the lower left corner of the canvas.

A new text block appears on top of the blue rectangle.

7 Type the following in uppercase letters without entering any line breaks:

SPORTS - LUXURY - CONVERTIBLE - LIMOUSINE - ANTIQUE - NEO-CLASSIC - 
EXOTIC - ROADSTER

8 Choose the Pointer tool and reposition the text block as shown below.

Any text you create in Fireworks can be edited as you would edit text in a word processor. To edit 
text, simply double-click a text block with the Pointer tool, highlight the text you want to change, 
and type over it. Or click the I-beam pointer anywhere in the text block to add new text.
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Set text properties

Now that the text blocks have been created, you’ll use the Property inspector to change various 
text properties.

1 Select the Vintage text block.

Properties for the text block appear in the Property inspector. These properties are similar to 
those displayed when the Text tool is selected.

2 In the Property inspector, do the following:

• Choose Smooth Anti-Alias from the Anti-Aliasing Level pop-up menu, if it’s not already selected. 
Anti-aliasing smooths text edges to make text characters appear cleaner and more readable.

In general, serif fonts such as Times New Roman look best if set to Smooth Anti-Alias when 
their size is greater than 45 points. Similarly, sans serif fonts such as Arial look best if set to 
Smooth Anti-Alias when their size is greater than 32 points.

Tip: The term serif refers to the tiny lines (often referred to as “feet”) attached to text characters of fonts such as 
Times New Roman. Arial is considered a sans serif font because its text characters do not contain serifs.

• Set the Horizontal Scale option in the Property inspector to 89%, and press Enter. 

The characters in the Vintage text block become thinner. Horizontal Scale stretches or shrinks 
the characters in selected text horizontally. The default setting is 100%. Anything greater will 
stretch text horizontally, and anything less will decrease its width. 

3 Drag the Vintage text block so that it is positioned as shown in the following illustration. 

4 Select the Classic Rentals text block.

5 In the Property inspector, do the following:

• Click the Fill Color box, enter FF6600 as the color value, and press Enter.

• Click the Bold button.

• Choose Crisp Anti-Alias from the Anti-Aliasing Level pop-up menu.

In general, sans serif fonts such as Arial look best if set to Crisp Anti-Alias when their size is 
between 12 and 18 points. Similarly, serif fonts look best if set to Crisp Anti-Alias when their 
size is between 24 and 32 points.
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6 Drag the text block to reposition it as shown below. 

7 Select the Indulge text block.

8 In the Property inspector, do the following:

• Set the font size to 13.

• Choose black as the text color.

• Click the Right Alignment button.

• Choose Crisp Anti-Alias from the Anti-Aliasing Level pop-up menu.

• Set the Horizontal Scale option to 88%.

• Set the Leading option to 150%, and press Enter. Leading sets the space between lines of text. 
Normal leading for text is 100%. Anything above 100% increases the space between lines, and 
anything lower moves lines closer together.

9 Drag one of the text block’s corner handles to resize it, so that the text flows as shown below. If 
necessary, drag the entire text block to reposition it as well. 

10 Select the text block at the bottom of the document.
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11 In the Property inspector, do the following:

• Set the font size to 13.

• Choose Crisp Anti-Alias from the Anti-Aliasing Level pop-up menu.

• Set the Horizontal Scale option to 75%, and press Enter.

12 Reposition the text block if necessary.

Add a drop shadow

You can apply Live Effects to text. Here you’ll add a drop shadow to the Vintage text using the 
Live Effects controls in the Property inspector.

1 Select the Vintage text block.

2 Click the Add Effects button in the Property inspector. Choose Shadow and Glow > 
Drop Shadow from the Effects pop-up menu.

Options for the new effect appear in a pop-up window.

3 Enter 5 for Distance and 60% for Opacity. Click outside the pop-up window to close it.

A drop shadow effect is added to the Vintage text block.

4 Click an empty area of the document window to deselect the text block.

Export the document
You’ve created a vector object and edited its properties, imported a bitmap image and made 
modifications to its pixels, and created and formatted text. You are ready to optimize and export 
the document.

Optimize the graphic

Before you export any document from Fireworks, you should always optimize it. Optimizing 
ensures that a graphic is exported with the best possible balance of compression and quality.

1 Do one of the following to open the Optimize panel if it isn’t already open:

• Choose Window > Optimize.

• If the panel is minimized on the right side of the screen, click the expander arrow to view the 
entire panel.
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2 Choose JPEG – Better Quality from the Settings pop-up menu.

The options in the panel change to reflect the new setting.

These settings can be changed, but for this tutorial you will use the default settings.

3 Click the Preview tab near the top of the document window.

The Preview tab displays your document as it will appear when exported with the current settings.

At the upper right of the window, Fireworks displays what the file size will be for the exported 
file and the estimated time it will take to display the graphic when it is viewed on the web.

File size

Download time
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Export the graphic

You’ve optimized your graphic, so now you’re ready to export it as a JPEG file.

1 Choose File > Export.

The Export dialog box opens.

The filename listed has a .jpg extension. Fireworks chose this file format because you selected it 
in the Optimize panel.

2 Navigate to the Tutorials folder on your desktop, and browse to Tutorial1/Export.

3 Ensure that the Save As Type (Windows) or Save As (Macintosh) pop-up menu reads Images 
Only, and click Save.

The JPEG file is exported to the location you specified.

Remember that the PNG file is your source file, or working file. Although you’ve exported 
your document in JPEG format, you also must save the PNG so any changes that you’ve made 
will be reflected in the source file as well.

4 Choose File > Save to save the changes to the PNG file.

5 Choose File > Close.
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View the exported document

The new file created during the export process is located in the folder you specified.

1 In Fireworks, choose File > Open and browse to the Export folder.

Fireworks created a file in this location called vintage.jpg.

2 Select vintage.jpg and click Open.

The graphic opens in a new document window in Fireworks. In the Layers panel, all your 
objects have been flattened. When objects are flattened, they merge into a single object and are 
uneditable as separate objects. 

The Property inspector displays properties for a bitmap. All the Live Effects and other attributes 
you applied using the Property inspector are no longer available for the selected bitmap.

The document looks this way because Fireworks had to flatten the image and all its properties 
when you chose to export it to JPEG format. However, you still have your source PNG file, so 
if you need to do more work on the design, you can always open the PNG file and all the 
objects will still be editable.

3 Choose File > Open and select vintage.png in the Tutorial1 folder. Click Open.

In the Layers panel, all your objects are again available as separate objects. Each object is 
editable, along with its properties.

4 Click on each object.

The Property inspector displays the various options for each object you select.

5 Select the Vintage text on the canvas. 

The Drop Shadow Live Effect for this text object appears in the Property inspector.

You can now see the benefit of using a Fireworks PNG as your source file. You can make 
changes to a document and it always remains editable, even if you choose to export the 
document to another format such as JPEG.
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Take the next steps
You’ve accomplished the tasks required to create graphics in Fireworks. You learned how to create 
and save a new document, and how to add both vector objects and bitmap graphics to your 
document. You also applied Live Effects, worked with layers, created a mask, and added text. 
Finally, you learned to export the completed graphic.

For detailed information about any of the features covered in this tutorial, and for information on 
additional Fireworks features, refer to the index of Using Fireworks or search the Fireworks Help 
topics. For more Fireworks tutorials, visit the Macromedia website at http://
www.macromedia.com. Also be sure to visit Macromedia’s award-winning Support Center at 
http://www.macromedia.com/support/fireworks.

To learn how you can use Fireworks to create interactive web pages, see the next tutorial. You’ll 
use the JPEG image you exported in this document and import it to a web page. You’ll also learn 
about creating web interactivity such as buttons, rollovers, and pop-up menus.

Fireworks tutorial 2: Web design basics
This tutorial will guide you through the basic tasks of designing web graphics and interactivity 
with Macromedia Fireworks MX. You’ll get hands-on experience using the industry’s leading web 
graphics application and learn web design concepts along the way. 

What you’ll learn
By taking this tutorial, you’ll replicate a typical Fireworks production workflow for designing a 
web page. You will learn to do the following:

• Open the source file

• Import a graphic

• Slice the document

• Create a drag-and-drop rollover

• Create and edit buttons to make a navigation bar

• Create and edit a pop-up menu

• Optimize the document

• Export HTML

• Test the completed file

What you should know
Before taking this tutorial, you should be familiar with designing graphics in Fireworks or other 
vector and bitmap graphics applications. You should possess the basic skills covered in Tutorial 1. 
Specifically, you should know how to accomplish the following tasks in Fireworks:

• Saving a document

• Selecting objects

• Editing object properties

• Displaying and using panels
Chapter 11260



• Working with layers and objects

• Creating and editing text

• Exporting a graphic

Copy the Tutorials folder
Before you begin, you’ll make a copy of the Tutorials folder so that you can save the results of your 
work while allowing you or another user to complete the tutorial at a later time using the original files.

Note: If you completed the Graphic Design Basics tutorial, you’ve already made a copy of the Tutorials folder, so you 
can skip this step.

1 Navigate to the Fireworks application folder on your hard disk.

Note: If you are unable to view your Fireworks application folder, you may have limited access to files on your 
system. You can download the files you need for this tutorial from the Fireworks Support Center on the web at 
http://www.macromedia.com/support/fireworks/.

2 Drag a copy of the Tutorials folder to your desktop.

View the completed web page
Next you’ll view the completed tutorial file to see how your finished project will appear after you 
export it as an HTML file.

1 Launch your web browser.

2 On your hard disk, navigate to the Tutorials folder you copied to your desktop, and browse to 
the Tutorial2/Complete folder.

Note: Some versions of Microsoft Windows hide extensions for known file types by default. If you have not 
changed this setting, the files in the Complete folder won’t display extensions. When dealing with web pages and 
web graphics, it’s best to be able to see file extensions. See Windows Help for information about how to turn file 
extensions back on.

3 Select the final.htm file and drag it to the open browser window.

For this tutorial, you will complete a partially finished version of this page for Global, a rental 
car company.

4 Move the pointer over the large Vintage image. 

When the pointer moves over the Vintage image, another image on the page changes. This is 
called a disjoint rollover.

5 Move the pointer across the navigation bar along the top of the web page. The buttons change 
in response to the pointer passing over them. Click the Rates button to test the link.

The link takes you to the Fireworks page at http://www.macromedia.com, but you will enter 
your own URL for this and other items as you complete the tutorial. 

6 Use your browser’s Back button to return to the final.htm page.

7 Move the pointer over the Worldwide Airports image. A pop-up menu appears. Roll over each 
item in the menu with the pointer, including the first item, which contains a submenu. 

8 Click United States to test the link, then return to the final.htm page.

9 When you finish viewing the web page, you can either close it or leave it open for reference as 
you take the tutorial.

Note: The Complete folder also includes the Fireworks document from which the HTML file is generated. To 
view this document, double-click final.png.
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Open the source file
You’ve viewed the final.htm file in a browser, so you’re ready to begin.

1 In Fireworks, choose File > Open.

2 Navigate to the Tutorials folder on your desktop. Browse to Tutorial2/Start and open 
global.png.

Note: As you perform the tutorial, remember to save your work frequently by choosing File > Save.

Import a graphic
Now that you’ve opened the unfinished design for the Global web page, you’ll import a graphic.

If you completed the Fireworks Graphic Design Basics tutorial, you will use the JPEG you 
created. If you did not take that tutorial, a completed image is provided for you.

1 Choose File > Import and do one of the following:

• If you completed the Graphic Design Basics tutorial, browse to the Tutorial1/Export folder.

• If you didn’t complete the Graphic Design Basics tutorial, browse to the Tutorial2/Assets folder.

2 Select vintage.jpg and click Open.

3 Click anywhere in the empty, white area of the canvas.

The image appears, selected.

4 Drag the image so that it is positioned as shown in the following illustration.
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Slice the document
Web designers use a process called slicing to cut web documents into smaller pieces, for a variety 
of reasons. Smaller images download more quickly over the web, so users can watch a page load 
progressively rather than waiting for one large image to download. In addition, slicing makes it 
possible to optimize various parts of a document differently. Slicing is also necessary for adding 
interactivity.

Here you’ll create slices for some of the graphic elements in the web page. Later you’ll add 
interactivity to these slices as well as set optimization and compression settings for them.

1 With the Vintage image still selected, choose Edit > Insert > Slice.

A slice is inserted on top of the image. Slices have a green overlay by default.

2 Click anywhere outside the slice to deselect it.

Red slice guides define the slice, spanning the width and height of the document. When you 
created the slice, Fireworks auto-sliced the rest of the document for you.

Note: If you don’t see the red slice guides, choose View > Slice Guides.

3 Shift-click the Worldwide Airports graphic and the Great Weekend Rates graphic on the left 
side of the document to select both at the same time.

4 Choose Edit > Insert > Slice. In the message box that appears, choose Multiple. This allows you 
to insert multiple slices at the same time.

Slices are inserted on top of each of the selected graphics. Adding additional slices changes the 
layout of auto-slices in the rest of the document.
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5 Click anywhere outside the slices to deselect them.

There is now a space between the Vintage slice and the Great Weekend Rates slice. This is a 
thin auto-slice. 

6 Place the pointer over the Vintage image’s left slice guide.

The pointer changes to the guide movement pointer, indicating you can grab the slice guide 
and drag it. By dragging a slice guide, you can change the shape of a slice.

7 Drag the slice guide to the left until it snaps with the right slice guide on the Great Weekend 
Rates graphic, as shown in the illustration below.

8 Release the mouse button.

The Vintage slice now extends all the way to the edge of the Great Weekend Rates slice, and 
the tiny auto-slice is deleted. Think of slices as table cells in a spreadsheet application or word 
processor. Dragging slice guides to resize a slice in Fireworks resizes other slices just like 
dragging cell borders in a table resizes other table cells. If you drag a slice guide over and 
beyond auto-slices, the slice guides merge and the unnecessary auto-slices are deleted.
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9 If the Layers panel is minimized or isn’t visible, click its expander arrow or choose 
Window > Layers.

At the top of the panel is the Web Layer. It contains all of a document’s web objects. The three 
slices you created are listed here. The Web Layer is always the topmost layer in any document. 
It can’t be moved, renamed, or deleted.

Create a drag-and-drop rollover
Now that you’ve sliced your document, you’re ready to add interactivity. You’ll use two of the 
slices you inserted in the previous step to create a drag-and-drop rollover.

There are two kinds of rollovers: simple rollovers and disjoint rollovers. A simple rollover displays 
a different image when the pointer moves over it in a web browser. A disjoint rollover causes 
another image to change in a different part of the screen when the pointer moves over it. You’ll 
create a disjoint rollover here.
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1 Select the slice covering the Vintage image.

The round icon in the center of the slice is called a behavior handle. It allows you to add 
behaviors, or interactivity, to a slice. If you are familiar with behaviors in Macromedia 
Dreamweaver, you’ll recognize many of the same behaviors in Fireworks.

Behaviors can also be applied using the Behaviors panel. But for simple interactivity like 
rollovers, a slice’s behavior handle is a faster and easier method of applying a behavior.

2 Drag the behavior handle onto the Great Weekend Rates slice, and release the mouse button.

A blue behavior line extends from the behavior handle to the corner of the slice, and the Swap 
Image dialog box appears.

3 Ensure that Frame 2 is selected in the Swap Image From pop-up menu, and click OK.

When the pointer moves over the Vintage slice in a browser, an image in Frame 2 will replace the 
Great Weekend Rates graphic. The Vintage image is considered the trigger for the rollover effect, 
and the image that replaces the Great Weekend Rates graphic is considered the swap image.

Behavior handle
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4 If the Frames panel is minimized or isn’t visible, click the expander arrow for the Frames and 
History panel group and click the Frames tab, or choose Window > Frames. 

The Frames panel lists the frames available in the current document. Currently there is only 
one frame in the document. The Frames panel is typically used for animation. In the case of 
rollovers, it is used to hold swap images.

5 Click the New/Duplicate Frame button at the bottom of the panel. 

A new frame is created in the Frames panel, named Frame 2. The workspace is now empty 
except for the slices you inserted. 

No objects are listed in the Layers panel, except the contents of the Web Layer. That’s because 
layers in Fireworks are not shared across all frames by default, with the exception of the Web 
Layer, which is always shared. Objects on the Web Layer appear in every frame of the 
document, so any changes you make to web objects, such as slices, affect all frames.

6 Choose File > Import and browse to the Tutorial2/Assets folder. Select the file named rates.gif 
and click Open.
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7 Place the insertion pointer over the slice where the Great Weekend Rates graphic was located in 
Frame 1. Align the pointer as best you can with the upper left corner of the slice.

8 Click to insert the graphic.

The Vintage Classic Rates graphic appears. 

9 Click the Preview tab at the top of the document window, and hide the slices in the document 
by clicking the Hide Slices and Hotspots button in the Web section of the Tools panel.

Move the pointer over the Vintage image. The Great Weekend Rates image changes when the 
pointer rolls over the Vintage image. 

Tip: If the image seems to jump a bit or the transition between graphics doesn’t look smooth, adjust the position 
of the swap image in Frame 2 while in Original view. For precise positioning, turn on Onion Skinning in the 
Frames panel or verify that the X and Y coordinates of the Vintage Classic Rates image are the same as those of 
the Great Weekend Rates image in the Property inspector. When you are finished, return to Frame 1 and turn off 
Onion Skinning if necessary. For more information about these options, refer to the index of Using Fireworks or 
search Fireworks Help. 

10 When you are finished, click the Original tab at the top of the document window to return to 
normal view, and turn slices back on by clicking the Show Slices and Hotspots button in the 
Tools panel.

You have successfully created a disjoint rollover. Simple rollovers are created in a similar manner: 
when dragging a slice’s behavior handle as you did in step 2, you simply drag it back onto the 
same slice.
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Generally, web designers add a rollover effect to an image to provide users with a visual cue that 
the graphic is clickable. If the Global website was an actual site on the Internet, you’d probably 
want the Vintage and Rates images to link to other pages that provide more information. For the 
purposes of this tutorial, you’ll leave the disjoint rollover as it is. You’ll get plenty of practice 
attaching links to other web objects in the following section.

Create and edit buttons to make a navigation bar
Buttons are web objects that link to other web pages. Their appearance typically changes 
depending on the user’s mouse movement or other action, such as clicking, as a visual cue 
indicating interactivity. For example, a button displays a different rollover effect when the pointer 
moves over it than when it has been clicked.

A navigation bar—also known as a nav bar—is a series of buttons that appears on one or more 
pages of a website. Typically, all the buttons within a nav bar look the same, except for their text.

Here you’ll create a nav bar for the Global website.

Create a button symbol

The initial graphic and text for one button has already been created for you. You’ll convert this 
graphic into a button symbol. 

1 In Fireworks, select the button graphic (labeled BUTTON TEXT) in the upper left corner of 
the document.

2 Choose Modify > Symbol > Convert to Symbol.

The Symbol Properties dialog box opens. 

3 Type My Button in the Name text box, choose Button as the symbol type, and click OK.

A slice appears on top of the button graphic, and a shortcut icon appears at the left of the slice. 
This indicates that the selection in the workspace is an instance of the symbol you just created. 
Symbols are like master copies of your graphics. When you change a symbol, all of the 
instances of that symbol in your document change automatically. Symbols reside in the library.
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4 If the Library panel is minimized or isn’t visible, click the Assets panel group’s expander arrow 
and click the Library tab, or choose Window > Library.

Your symbol is listed in the Library panel. 

Create button states

Next you’ll create various states for the button symbol. Button states are the different ways a 
button appears when rolled over or clicked in a web browser.

1 Double-click the button instance you created.

Tip: Alternatively, you can double-click the preview of the button in the Library panel or the symbol icon beside it 
in the Library panel’s symbol list.

The Button Editor opens with the button graphic displayed in the work area.
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2 Click the tabs at the top of the Button Editor.

The first four tabs represent the button states. The last tab, Active Area, represents the hot area 
on the button, or where a user must click or roll over to activate the button states. The active 
area is also the swap area for the button, or the area that changes with each button state. 
Currently there are no states for the button symbol other than the Up state, the state of the 
button before it is rolled over or clicked. 

3 Click the Over tab at the top of the Button Editor, then click the Copy Up Graphic button.

The button graphic is copied from the Up tab. The Over state of a button is its appearance 
when the pointer rolls over it. To give users visual feedback, you’ll change the color of the 
rectangle behind the text.

4 Select the rectangle. Be sure to select the rectangle and not the text; if you are unsure which one 
you are selecting, check the Layers panel to see which one is selected. 

5 Click the Fill Color box in the Property inspector and choose black as the color.

The rectangle is now black.

6 Click the Down tab at the top of the Button Editor, and click the Copy Over Graphic button.

The button graphic is copied from the Over tab. The Down state of a button is its appearance 
after a user clicks it. This time you won’t change the color of the rectangle; you’ll leave it as it is.

7 Click Done in the Button Editor to apply your changes to the button symbol.

8 Click the Preview tab in the document window and test the button’s states. Turn slices off if 
necessary. When you are finished, click the Original tab and turn slices back on.

Create multiple button instances

Next you’ll create more instances of the button symbol.

1 Select the button in the workspace if it isn’t already selected.

2 Choose Edit > Clone.

A new instance of the button appears on top of the original button. 
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3 Hold down Shift while pressing the Right Arrow key repeatedly to move the new instance 
to the right.

This moves the instance in 10-pixel increments. If necessary, use the arrow keys alone to move 
the selection one pixel at a time. Position the instance to the immediate right of the original 
instance, but not overlapping, as shown in the illustration below. 

4 Clone two more instances of the button, and position each to the right of the previous instance.

Tip: As a shortcut, press Alt (Windows) or Option (Macintosh) while dragging the selected instance with the 
pointer to make a copy of it. After positioning the new instance to the immediate right of the previous instance, 
choose Edit > Repeat Duplicate to automatically create and place another copy of the instance.

Change button instance text

Now that you’ve created all the buttons for your nav bar, you need to give each button unique 
text. You can easily change the text on a button instance using the Property inspector.

1 Select the button instance at the far left.

Properties for the button instance appear in the Property inspector. With the exception of the 
Export Settings pop-up menu, these properties apply to the selected instance only. Making 
changes here will not affect the original button symbol in the library.

2 In the Property inspector, replace the text in the Text box with the word HOME in uppercase 
letters. Then press Enter.

The text on the button changes to reflect your entry. 

3 For the remaining three buttons, change the button text to VEHICLES, RATES, and 
CONTACT US, respectively. 
Chapter 11272



Assign URLs to the buttons

Next you’ll assign a unique URL, or link, to each button instance. A URL, or Uniform Resource 
Locator, is the address or location of a page on the web. You can easily assign URLs to buttons 
using the Property inspector.

1 Select the button instance labeled Home.

2 Enter index.htm in the Link text box of the Property inspector.

When clicked in a web browser, the Home button will jump to a page called index.htm. You’ll 
discover later in the tutorial why you linked the Home button to this page.

3 Select the Vehicles button instance and enter your favorite URL in the Link text box of the 
Property inspector.

For the purposes of this tutorial, any working URL will do. If you were creating a real website, 
you would enter the URL that you wanted the Vehicles button to jump to.

Note: Be sure to enter the URL of an actual website, so that you can test your button links later.

4 Assign a URL to each of the remaining button instances. Once again, any working URL will do.

5 Choose File > Preview in Browser > Preview in [your preferred browser]. To test button links, 
you must preview the document in a browser.

Note: If your browser is not listed, you must first select a browser by choosing File > Preview in Browser > 
Set Primary Browser.

When the document opens in your browser, test the buttons you created. Except for the Home 
button, which links to a file you haven’t created yet, each button should jump to the link you 
specified in Fireworks. 

Edit the button symbol 

Next you will modify the original button symbol. The changes you make will be automatically 
applied to all the button instances in your navigation bar.

You may be wondering what the original button symbol looks like now that you’ve changed text 
on several of its instances.

1 Double-click any of the button instances in the workspace.

The Button Editor opens with the original button symbol and text displayed in the workspace. 
The original button symbol is still intact and displays the original text.

When you changed the text of each button in the workspace, you only edited each button instance. 
If you make any changes here to the rectangle or to text appearance, you will be editing the original 
symbol, so those changes will be reflected in all the instances in the workspace.

2 Click the Over tab.
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3 Select the black rectangle.

4 Click the Fill Color box in the Property inspector and enter FF6633 as the color value. Press 
Enter to apply the color change.

The rectangle is now orange. 

5 Click Done in the Button Editor to apply the change to the button symbol.

6 Click the Preview tab in the document window and test the buttons.

Each button’s Over state is now orange. You changed only the button symbol, but the change 
was applied to all the button instances in your nav bar.

7 Click the Original tab, and double-click any button instance in the workspace. This time you’ll 
change the text in the button symbol.

8 Select the button text in the Button Editor, and in the Property inspector choose Arial as the 
font. Do this for each button state.

9 Double-click the text block in the Button Editor, and delete the word BUTTON.

10 Click Yes in the message box that asks if you want to change the text in the other button states.

Examine the various button states in the Button Editor. The text changes in one state are 
reflected across all the button states. Compare this to when you changed the font; you had to 
change it in each state. That’s because you can apply different graphical and text attributes to 
each state of a button. This is useful if you want the text color to change when a user rolls over 
a button, for example.

11 Click Done to exit the Button Editor.

The font on each button instance changes to reflect the new font selection, but the text 
remains the same. Button instances reflect only the changes you make to a button symbol’s 
graphical appearance, including its text attributes, but not changes you make to the text itself.

Button symbols make it possible for you to change the graphical appearance of all button 
instances in a nav bar quickly, while preserving each instance’s unique text.
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Create and edit a pop-up menu
A pop-up menu is a menu that appears when you move the pointer over a trigger image in a 
browser. It contains a list of items that link to other web pages.

Here you’ll create and edit a pop-up menu that lists Global’s airport locations.

Create pop-up menu list items

First you’ll create the pop-up menu list items using the Pop-up Menu Editor.

1 Select the slice covering the Worldwide Airports graphic.

2 Choose Modify > Pop-up Menu > Add Pop-up Menu.

The Pop-up Menu Editor opens.

3 Double-click the text box in the upper left corner (Windows only).

4 Type North America in the text box and press Enter.

The next text box is highlighted, ready for you to create another entry.

5 Type Europe and press Enter.
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6 Create three more entries for Africa, Middle East, and Asia/Pacific. 

7 Double-click the Link text box for the North America entry.

8 Enter a working URL of your choice and press Enter. 

For the purposes of this tutorial, any URL will do. Be sure it’s an actual URL so that you’ll be 
able to test your links later.

9 Enter URLs for the remaining entries.

Note: There is always one extra line at the bottom of the entry list in the Pop-up Menu Editor. It’s there so you can 
easily add new entries without having to click the Add Menu button.

10 Click Done to close the Pop-up Menu Editor.

In the workspace, an outline of your pop-up menu appears attached to the slice.

11 To test your pop-up menu, choose File > Preview in Browser > Preview in [your preferred 
browser] to preview the document in a browser.

Note: Pop-up menus must be previewed in a browser; they aren’t visible using the Preview tab in Fireworks.

When the document opens in your browser, move the pointer over the Worldwide Airports 
graphic. The pop-up menu you created appears. Click each entry to test the links.
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Customize the pop-up menu

Next you’ll return to the Pop-up Menu Editor to modify the appearance of the pop-up menu.

1 In Fireworks, double-click the pop-up menu outline.

The Pop-up Menu Editor opens with your entries displayed.

2 Click the Next button.

The Appearance tab appears. This is where you can change the colors and fonts used in 
pop-up menus.

3 Choose HTML as the cell type and Vertical Menu as the alignment.

4 Choose Arial, Helvetica, sans-serif as the font and 12 as the font size.

5 In the Up State section, set the text color to black, if black is not already selected. Then click 
the Cell Color box. If CCCCCC is not already displayed in the text box at the top of the color 
pop-up window, enter CCCCCC and press Enter.

These color values are the default colors selected in the Pop-up Menu Editor if you’ve never 
created a pop-up menu before. Once you change these colors, they will be used every time you 
create a pop-up menu, until you choose other colors.
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6 In the Over State section, set the text color to White if it’s not already selected, and click the 
Cell Color box. Click the eyedropper pointer on the blue rectangle on the canvas that 
surrounds the Worldwide Airports graphic, as shown below.

7 Click the Next button.

The Advanced tab appears. The Advanced tab allows you to change various cell and border 
properties. Here you’ll increase the cell width, making the pop-up menu appear wider.

8 Choose Pixels from the Cell Width pop-up menu.

This activates the Cell Width box.

9 Enter 137 as the cell width.
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10 Choose Automatic from the Cell Height pop-up menu, and click the Next button.

The Position tab appears. This is where you can specify the position on the screen where the 
pop-up menu will appear. Coordinates of 0,0 mean that the upper left corner of the pop-up 
menu will align with the upper left corner of the slice that triggers it. There are also several 
preset positions you can choose from.

11 Enter 3 in the X and Y Menu Position boxes, then click Done.

Note: You can also reposition a pop-up menu by dragging its outline in the workspace.

12 Preview your pop-up menu changes in a browser.

Move the pointer over the Worldwide Airports graphic. The pop-up menu is positioned 
differently and appears wider. Roll over each entry in the menu to see your color changes.
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Edit the pop-up menu

Next you’ll use the Pop-up Menu Editor again to add another entry to the pop-up menu. You’ll 
also change the order of entries and add a submenu.

1 In Fireworks, double-click the pop-up menu outline.

2 Click the Europe entry to select it.

3 Click the Add Menu button above the entry list. 

A blank line is inserted.

4 Double-click the Text field of the new entry and enter Latin/South America. Click anywhere 
outside the Text field to apply the entry. 

The Americas are not together in the list.

5 Drag the Latin/South America entry up one line and release the mouse button. As you drag, a 
black line indicates where the entry will be dropped if you release the mouse button at that point.

The entry is dropped where you specified.

6 Select the North America entry and click the Add Menu button.

7 Double-click the Text field of the new entry and enter United States. Then click anywhere 
outside the entry fields, being careful not to select another entry.
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8 Select the United States entry if it’s not already selected, and click the Indent Menu button.

The entry is indented beneath the North America entry. 

9 Click the Add Menu button again, and create a new entry for Canada.

You’ve just created a submenu that will appear when you roll over the North America entry 
in a browser. 

10 Assign URLs to all the new entries. Optionally, you can delete the link for North America, 
because users will be choosing items from its submenu.

11 Click Done to close the Pop-up Menu Editor, and then preview the pop-up menu changes 
in a browser.
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Optimize the document
Your document is almost ready for the web. The only thing you need to do before exporting it is 
to optimize it. Before you export any document from Fireworks, you should always optimize it. 
Optimizing ensures that your graphics will be exported with the best possible balance of 
compression and quality.

When different kinds of graphics are in the same document, it’s a good idea to choose an 
appropriate file format and compression setting for each. The Global web page is composed of a 
variety of elements: bitmaps, vector objects, and text.

1 If the Optimize panel is minimized or isn’t visible, click its expander arrow or choose 
Window > Optimize.

Fireworks chooses GIF as the default export file format and Websnap Adaptive as the default 
color palette. Most of the graphics on the Global Rental Cars web page will be fine using these 
settings. The Vintage bitmap image, however, contains a photograph and a gradient. Because 
of its complex color variations, it will be best exported in another format.

2 Click the 2-Up preview tab in the document window. 

The 2-Up tab allows you to view the results of your optimization settings and compare them 
with the original. By now you’ve probably noticed the white slice overlay each time you view 
one of the Preview tabs. The overlay allows you to focus on just the area you want to optimize.
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3 Click the slice for the Vintage image in the preview on the right.

The slice overlay disappears so you can view the image beneath the slice. At the bottom of the 
preview, the export file format for the selected slice is displayed, as well as the estimated export 
file size, and the amount of time the graphic will take to download from the web.

Tip: Use the Hand tool in the View section of the Tools panel to view more of the image if it’s not entirely visible.

4 Hide the slices for a moment by clicking the Hide Slices and Hotspots button in the Web 
section of the Tools panel. 

This allows you to compare the preview with the original and see the difference between the 
two graphics. The preview on the right has bands in the gradient.

5 Turn slices back on again, and click the Vintage image with the Pointer tool.

6 In the Optimize panel, choose JPEG – Smaller File from the Settings pop-up menu.
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The gradient bands are now gone, and the file size has decreased significantly. That’s because 
photographs and images with complex color variations are better optimized and compressed as 
JPEGs than as GIFs.

Now that the file size has been decreased, the image has become fuzzy. 

7 To improve the appearance of the bitmap, drag the Quality slider in the Optimize panel to 77 
and set the Smoothing option to 0.

The bitmap is much clearer, but the file size has also increased. However, it is still an 
improvement over the file size when the image was optimized as a GIF. 

8 Click the Original tab to return to normal view.

Export HTML
HTML, or HyperText Markup Language, is the primary method used on the Internet to create 
and display web pages. You don’t need to understand HTML to use Fireworks, but it helps to 
keep in mind that Fireworks slices become cells in an HTML table when exported. 

Here you’ll export and view your finished document in a web browser. You’ll also examine the 
HTML code that Fireworks exports.
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Set HTML preferences

Before you export the document, you need to set HTML export preferences.

1 Choose File > HTML Setup.

The HTML Setup dialog box opens. The options you set in this dialog box will affect all future 
Fireworks documents you create, except the options on the Document Specific tab.

2 On the General tab, choose an HTML style.

If you use an HTML editor such as Macromedia Dreamweaver or Microsoft FrontPage, choose 
it from this pop-up menu. Doing so allows you to easily open and edit the exported file in that 
HTML editor. If you don’t use an HTML editor or you use one that’s not in this list, choose 
Generic HTML.

3 Choose .htm as the file extension.
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4 Click the Table tab.

The Table tab allows you to change HTML table properties.

5 In the Space With pop-up menu, choose 1-Pixel Transparent Spacer.

When this option is chosen, Fireworks exports a graphic file called spacer.gif, which is a 1-pixel 
transparent image. Spacers are used by web designers to aid in page layout. They hold empty 
HTML table cells open. Without them, empty HTML table cells collapse, altering your 
intended page layout. You’ll see the spacer.gif file later when you view your exported files.

You don’t need to understand spacers, but it’s useful to know about this option if you want to 
use them in the future.
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6 Click the Document Specific tab.

The Document Specific tab allows you to choose a variety of document-specific preferences, 
including a customized naming convention for your exported files. Remember that the options 
you set here apply only to the current Fireworks document.

Tip: You can apply the settings on the Document Specific tab to all new documents by clicking the 
Set Defaults button.

7 Click OK to accept the settings on the Document Specific tab and close the HTML Setup 
dialog box.
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Export the document to HTML format

Your document is now ready for export.

1 Choose File > Export.

The Export dialog box opens.

2 In the dialog box, navigate to the Tutorial2/Export folder.

3 Ensure that HTML and Images is selected as the file type, and enter index.htm as the filename. 
Naming the home page index.htm is a common convention used on the web. Many browsers will 
even automatically display the index.htm page when a URL lists a location but not a page name.

Additionally, earlier in the tutorial you assigned the Home button a URL of index.htm. 
Currently there is only a single page in the Global website, so linking this page to itself may not 
make much sense at this point. But if you create other pages for this site in the future, you can 
use this navigation bar on all its pages, providing users with a consistent navigation method.

4 Ensure that Export HTML File is chosen in the HTML pop-up menu and Export Slices is 
chosen in the Slices pop-up menu.
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5 Choose the following options, and leave all the others deselected:

• Include Areas Without Slices

• Put Images in Subfolder

When you choose this option, Fireworks allows you to choose a folder in which to store your 
exported graphic files. Fireworks creates the folder for you if it doesn’t exist. If you don’t choose 
a folder, Fireworks chooses a folder named images by default. For this tutorial, accept the 
default setting.

6 Click Save.

The files are exported to the location you specified.

7 Choose File > Save to save your PNG file.

Test the completed file
Your files have been exported, so it’s time to check out what you created.

View the list of exported files

First, you’ll examine the list of files that Fireworks exported. The new files created during the 
export process appear in your Export folder.

1 On your desktop, browse to the Export folder and open it.

Fireworks created an HTML file there called index.htm. This is the home page for the Global 
website. It also created a file called mm_menu.js, which contains the code necessary to display 
pop-up menus. 

2 Open the images subfolder.

Fireworks also exported graphics files for all your artwork. Each slice in Fireworks exports as its 
own separate graphic file. There are several GIF files and one JPEG file. The JPEG is the 
bitmap image you optimized earlier.The file called spacer.gif is the result of the spacing option 
you selected in the HTML Setup dialog box and will be used to aid in page layout.
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View the Fireworks HTML file in a browser

Now that you’ve examined the exported files, you’re ready to test the web page in a browser.

1 From the Export folder, drag the index.htm file to an open web browser.

2 In the browser, click the buttons you added to test the links, then return to the index.htm file.

3 Test the other features that you added.

4 Most web browsers let you view the source code with a command such as View > Source. Find 
and execute the command that lets you view the code. 

5 Scroll through the source code. If you know HTML and JavaScript, you will recognize the 
code that Fireworks created for you. If you don’t know HTML and JavaScript, you can 
appreciate that Fireworks gives you no compelling reason to have to learn either.

Take the next steps
You’ve accomplished the major tasks in the production workflow to create a web page with 
Fireworks. You learned how to open a document, import graphics into it, and slice the document. 
You also created a drag-and-drop rollover, created buttons, and created a pop-up menu. Finally, 
you learned to optimize and export your completed document.

For detailed information about any of the features covered in the tutorial, and for information on 
additional Fireworks features, refer to the index of Using Fireworks or search Fireworks Help. For 
more tutorials, visit http://www.macromedia.com. Also be sure to visit Macromedia’s award-
winning Support Center at http://www.macromedia.com/support/fireworks.
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CHAPTER 12

Fireworks MX Integration with the

Macromedia Studio MX Product Family

Whether you’re creating content for the web or multimedia, Macromedia Fireworks MX is an 
essential component of any designer’s toolbox. Fireworks offers a variety of powerful integration 
features with the other Macromedia Studio MX products to streamline the design process:

• Fireworks can be launched to edit selected graphics from inside Macromedia Dreamweaver, 
Macromedia Flash, Macromedia HomeSite, and Macromedia FreeHand.

• Fireworks behaviors are preserved upon export to many Macromedia applications, allowing 
you to export interactive elements such as buttons and rollovers.

• Dreamweaver and Fireworks share a tight integration known as Roundtrip HTML. Roundtrip 
HTML allows you to make changes in one application and have those changes seamlessly 
reflected in the other.

• Flash and Fireworks also share a tight integration. You can import Fireworks PNG source files 
directly into Flash without having to export to any other graphics format. Flash offers a variety 
of options that allow you to control how Fireworks objects and layers are imported.

Working with Macromedia Fireworks MX and 
Macromedia Dreamweaver MX

Unique integration features make it easy to work on files interchangeably in Macromedia 
Dreamweaver MX and Macromedia Fireworks MX. Dreamweaver and Fireworks recognize and 
share many of the same file edits, including changes to links, image maps, table slices, and more. 
Together, the two applications provide a streamlined workflow for editing, optimizing, and 
placing web graphics files in HTML pages.

If you want to modify Fireworks images and tables placed in a Dreamweaver document, you can 
launch Fireworks to make edits and then return to the updated document in Dreamweaver. If you 
want to make quick optimization edits to placed Fireworks images and animations, you can 
launch the Fireworks Export Preview dialog box and enter updated settings. In either case, 
updates are made to the placed files in Dreamweaver, as well as to the source Fireworks files, if 
those source files were launched.

To further streamline the web design workflow, you can create image placeholders in 
Dreamweaver for future Fireworks images. You can later select those placeholders and launch 
Fireworks to create desired graphics in the dimensions specified by the Dreamweaver placeholder 
images. Once in Fireworks, you can change the image dimensions if desired.
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Placing Fireworks MX images in Dreamweaver MX files

Fireworks graphics can be placed into a Dreamweaver document in a couple of ways. You can 
place a finished Fireworks graphic using the Insert menu in Dreamweaver, or you can create a new 
Fireworks document from a Dreamweaver image placeholder. 

Inserting Fireworks MX images into Dreamweaver MX

You can insert Fireworks-generated GIF or JPEG images directly in a Dreamweaver document. 
You must export the images from Fireworks first. For information on exporting GIF and JPEG 
images, see Fireworks Help > Using Fireworks > Exporting a single image.

To insert a Fireworks image into a Dreamweaver document:

1 Place the insertion point where you want the image to appear in the Dreamweaver 
Document window. 

2 Do one of the following:

• Choose Insert > Image.

• Click the Insert Image button in the Common category of the Insert bar. 

3 Navigate to the image you exported from Fireworks, and click Open.

If the image file is not in the current Dreamweaver site, a message appears asking whether you 
want to copy the file to the site folder.

Creating new Fireworks MX files from Dreamweaver MX placeholders

Image placeholders combine the power of Fireworks and Dreamweaver by allowing you to 
experiment with various web page layouts before creating the final artwork for your page. 
Image placeholders allow you to specify the size and position of future Fireworks images to be 
placed in Dreamweaver.

When you create a Fireworks image from a Dreamweaver image placeholder, a new Fireworks 
document is created with a canvas of the same dimensions as the selected placeholder. Inside 
Fireworks, you can use any Fireworks tools to create your graphic. You can even slice your 
document and add interactivity using buttons, rollovers, and other behaviors.

Note: All behaviors applied within Fireworks are preserved upon export back to Dreamweaver. Likewise, most 
Dreamweaver behaviors applied to image placeholders are also preserved during launch and edit with Fireworks. 
There is one exception, however: disjoint rollovers applied to image placeholders in Dreamweaver are not preserved 
when launched and edited in Fireworks.

Once the Fireworks session has ended and you’ve returned to Dreamweaver, the new Fireworks 
graphic you created takes the place of the image placeholder originally selected.

To create a Fireworks image from an image placeholder in Dreamweaver:

1 In Dreamweaver, save the desired HTML document to a location inside your Dreamweaver 
site folder.

2 Position the insertion point in the desired position in your document and choose Insert > 
Image Placeholder.
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An image placeholder is inserted into the Dreamweaver document.

3 Do one of the following:

• Select the image placeholder and click Create in the Property inspector.

• Control-double-click (Windows) or Command-double-click (Macintosh) the image 
placeholder.

• Right-click (Windows) or Control-click (Macintosh) and choose Create Image in Fireworks.

Dreamweaver launches Fireworks, if it is not already open. The document window indicates 
that you are editing an image from Dreamweaver.

4 Create an image in Fireworks, and click Done when you are finished.

5 Specify a name and location for the source PNG file in the Save As dialog box, and click Save. 

Note: If you entered a name for the image placeholder from the Property inspector in Dreamweaver, that name 
will be used as the default filename in Fireworks.

For more information on saving Fireworks PNG files, see Fireworks Help > Using Fireworks > 
Saving Fireworks files.

6 Specify a name for the exported image file or files in the Export dialog box. These are the 
JPEGs or GIFs that will be displayed in Dreamweaver. 

7 Specify a location for the exported image file or files. The location you choose should be within 
your Dreamweaver site folder.

For more information on exporting, see Fireworks Help > Using Fireworks > 
Exporting from Fireworks.

8  Click Save.

When you return to Dreamweaver, the image placeholder you originally selected is replaced 
with the new Fireworks image or table you created.
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Placing Fireworks MX HTML into Dreamweaver MX

There are a few ways to place Fireworks HTML into Dreamweaver. You can export HTML or 
you can copy Fireworks HTML to the Clipboard. You can also open an exported Fireworks 
HTML file in Dreamweaver and copy and paste selected sections of code. You can easily update 
code you’ve exported to Dreamweaver using the Update HTML command in Fireworks. You can 
even export HTML as a Dreamweaver library item.

Fireworks HTML can also be exported as Cascading Style Sheet (CSS) layers. For more 
information, see Fireworks Help > Using Fireworks > Exporting HTML.

Note: Before exporting, copying, or updating Fireworks HTML for use in Dreamweaver, be sure to choose 
Dreamweaver as the HTML type in the HTML Setup dialog box. For more information, see Fireworks Help > 
Using Fireworks > Setting HTML export options.

Exporting Fireworks MX HTML to Dreamweaver MX

Exporting Fireworks files to Dreamweaver is a two-step process. From Fireworks, you export files 
directly to a Dreamweaver site folder. This will generate an HTML file and the associated image 
files in the location you specify. You then place the HTML code into Dreamweaver using the 
Insert feature.

Note: Before exporting, be sure to choose Dreamweaver as the HTML type in the HTML Setup dialog box. For 
more information, see Fireworks Help > Using Fireworks > Setting HTML export options.

To export Fireworks HTML:

Export your document to HTML format. See Fireworks Help > Using Fireworks > 
Exporting Fireworks HTML.

To insert Fireworks HTML into a Dreamweaver document:

1 In Dreamweaver, save your document in a defined site. 

2 Place the insertion point in the document where you want the inserted HTML code to begin.

3 Do one of the following:

• Choose Insert > Interactive Images > Fireworks HTML.

• Click the Insert Fireworks HTML button in the Common category of the Insert bar.

4 In the dialog box that appears, click Browse to choose the desired Fireworks HTML file.

5 Choose Delete File After Insertion to move the HTML file to the Recycle Bin (Windows) or 
Trash (Macintosh) when the operation is complete. 

Use this option if you no longer need the Fireworks HTML file after inserting it. This option 
does not affect the source PNG file associated with the HTML file.

Note: If the HTML file is on a network drive, it is permanently deleted, not moved to the Recycle Bin or Trash.

6 Click OK to insert the HTML code, along with its associated images, slices, and JavaScript, 
into the Dreamweaver document.
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Copying Fireworks MX HTML to the Clipboard for use in 
Dreamweaver MX

A fast way to place Fireworks-generated HTML in Dreamweaver is to copy it to the Clipboard 
from Fireworks, and then paste it directly into a Dreamweaver document. All HTML and 
JavaScript code associated with the Fireworks document are copied into the Dreamweaver 
document, images are exported to a location you specify, and Dreamweaver updates the HTML 
with site-relative links to those images.

Note: Before copying to the Clipboard, be sure to choose Dreamweaver as the HTML type in the HTML Setup 
dialog box. For more information, see Fireworks Help > Using Fireworks > Setting HTML export options.

To copy Fireworks HTML to the Clipboard for use in Dreamweaver:

Copy HTML to the Clipboard in Fireworks, and then paste it into a Dreamweaver document. 
See Fireworks Help > Using Fireworks > Copying HTML to the Clipboard.

Copying code from an exported Fireworks file and pasting it into 
Dreamweaver MX

You can open an exported Fireworks HTML file in Dreamweaver and then manually copy and 
paste only the desired sections into another Dreamweaver document. 

Note: Before exporting from Fireworks, be sure to choose Dreamweaver as the HTML type in the HTML Setup 
dialog box. For more information, see Fireworks Help > Using Fireworks > Setting HTML export options.

To copy code from an exported Fireworks file and paste it into Dreamweaver:

Export a Fireworks HTML file, and then copy and paste the code into an existing Dreamweaver 
document. See Fireworks Help > Using Fireworks > Copying and pasting HTML from an 
exported Fireworks file.

Updating Fireworks MX HTML exported to Dreamweaver MX

The Update HTML command in Fireworks allows you to make changes to an HTML document 
you’ve previously exported to Dreamweaver.

Note: While Update HTML is a useful feature for updating HTML you’ve previously exported to Dreamweaver, 
Roundtrip HTML provides even more benefits. For more information, see “Editing Fireworks MX files from 
Dreamweaver MX” on page 297.

With Update HTML, you can edit a source PNG image in Fireworks and then automatically 
update any exported HTML code and image files placed in a Dreamweaver document. This 
command lets you update Dreamweaver files even when Dreamweaver is not running.

Note: Before updating HTML, be sure to choose Dreamweaver as the HTML type in the HTML Setup dialog box. 
For more information, see Fireworks Help > Using Fireworks > Setting HTML export options.
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To update Fireworks HTML placed in Dreamweaver:

1 Make changes to the desired PNG document in Fireworks.

2 Choose File > Update HTML, or click the Quick Export button and choose Update HTML 
from the Dreamweaver pop-up menu. 

3 Navigate to the Dreamweaver file containing the HTML you wish to update, and click Open.

4 Navigate to the folder destination where you want to place the updated image files, and click Open.

Fireworks updates the HTML and JavaScript code in the Dreamweaver document. Fireworks 
also exports updated images associated with the HTML and places the images in the specified 
destination folder.

If Fireworks cannot find matching HTML code to update, it gives you the option of inserting 
new HTML code into the Dreamweaver document. Fireworks places the JavaScript section of 
the new code at the beginning of the document and places the HTML table or link to the 
image at the end.

Exporting Fireworks MX files to Dreamweaver MX libraries

Dreamweaver library items simplify the process of editing and updating frequently used website 
components, such as company logos or other graphics that appear on every page of a site. A 
library item is a portion of an HTML file located in a folder named Library at your root site. 
Library items appear in the Dreamweaver Library panel. You can drag a copy from the Library 
panel to any page in your website.

You cannot edit a library item directly in the Dreamweaver document; you can edit only the 
master library item. Then, you can have Dreamweaver update every copy of that item as it is 
placed throughout your website. Dreamweaver library items are much like Fireworks symbols; 
changes to the master library (LBI) document are reflected in all library instances across your site.
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To export a Fireworks document as a Dreamweaver library item:

1 Choose File > Export.

2 Choose Dreamweaver Library from the Save as Type pop-up menu. 

Choose the Library folder in your Dreamweaver site as the location in which to place the files. 
If this folder does not exist, use the Select Folder dialog box to create or locate the folder. The 
folder must be named Library; the case is important, because Dreamweaver is case-sensitive.

Note:  Dreamweaver will not recognize the exported file as a library item unless it is saved into the Library folder.

3 In the Export dialog box, type a filename.

4 If your image contains slices, choose slicing options. For more information, see 
Fireworks Help > Using Fireworks > Exporting a sliced document.

5 Select Put Images in Subfolder to choose a separate folder for saving images.

6 Click Save.

Editing Fireworks MX files from Dreamweaver MX 

Roundtrip HTML is a powerful feature that tightly integrates Fireworks and Dreamweaver. It 
allows you to make changes in one application and have those changes seamlessly reflected in the 
other. With Roundtrip HTML, you use launch-and-edit integration to edit Fireworks-generated 
images and tables placed in a Dreamweaver document. Dreamweaver automatically launches the 
Fireworks source PNG file for the placed image or table, letting you make desired edits in 
Fireworks. The updates you make in Fireworks are applied to the placed image or table when you 
return to Dreamweaver.

Note: Before working with Roundtrip HTML, you should perform some preliminary tasks. For more information, see 
“Setting Fireworks MX launch-and-edit options” on page 302.
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About Roundtrip HTML

Fireworks recognizes and preserves most types of edits made to a document in Dreamweaver, 
including changed links, edited image maps, edited text and HTML in HTML slices, and 
behaviors shared between Fireworks and Dreamweaver. The Property inspector in Dreamweaver 
helps you identify Fireworks-generated images, table slices, and tables in a document.

Although Fireworks supports most types of Dreamweaver edits, radical changes made to a table’s 
structure in Dreamweaver can create irreconcilable differences between the two applications. If 
you make radical changes to a table layout in Dreamweaver and then attempt to launch and edit 
the table in Fireworks, a message appears warning you that changes you make in Fireworks will 
overwrite any edits previously made to the table in Dreamweaver. If you want to make 
considerable changes to a table layout, use the Dreamweaver launch-and-edit feature to edit the 
table in Fireworks.

Editing Fireworks MX images from Dreamweaver MX

You can launch Fireworks to edit individual images placed in a Dreamweaver document.

Note: Before editing Fireworks graphics from Dreamweaver, you should perform some preliminary tasks. For more 
information, see “Setting Fireworks MX launch-and-edit options” on page 302.

To launch and edit a Fireworks image placed in Dreamweaver:

1 In Dreamweaver, choose Window > Properties to open the Property inspector, if needed.

2 Do one of the following:

• Select the desired image. (The Property inspector identifies the selection as a Fireworks image 
and displays the name of the known PNG source file for the image.) Then click Edit in the 
Property inspector.

• Control-double-click (Windows) or Command-double-click (Macintosh) the image you 
want to edit.

• Right-click (Windows) or Control-click (Macintosh) the desired image, and choose Edit with 
Fireworks from the context menu.

Dreamweaver launches Fireworks, if it is not already open. 

3 If prompted, specify whether to locate a source Fireworks file for the placed image. For 
more information on Fireworks source PNG files, see Fireworks Help > Using Fireworks > 
Saving Fireworks files.

4 In Fireworks, edit the image. The document window indicates that you are editing an image 
from Dreamweaver.

Dreamweaver recognizes and preserves all edits applied to the image in Fireworks.

5 When you are finished making edits, click Done in the document window.

The image is exported using the current optimization settings, the GIF or JPEG file used by 
Dreamweaver is updated, and the PNG source file is saved if a source file was selected.

Note: When you open an image from the Dreamweaver Site panel, the Fireworks integration features described 
above are not in effect; Fireworks does not open the original PNG file. To use the Fireworks integration features, 
open images from within the Dreamweaver Document window. 
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Editing Fireworks MX tables

When you launch and edit an image slice that is part of a placed Fireworks table, Dreamweaver 
automatically launches the source PNG file for the entire table.

Note: Before editing Fireworks tables from Dreamweaver, you should perform some preliminary tasks. For more 
information, see “Setting Fireworks MX launch-and-edit options” on page 302.

To launch and edit a Fireworks table placed in Dreamweaver:

1 In Dreamweaver, choose Window > Properties to open the Property inspector if needed. 

2 Do one of the following: 

• Click inside the table, and click the TABLE tag in the status bar to select the entire table. (The 
Property inspector identifies the selection as a Fireworks table and displays the name of the 
known PNG source file for the table.) Then click Edit in the Property inspector. 

• Click the upper left corner of the table to select it, and then click Edit in the Property inspector.

• Select an image in the table, then click Edit in the Property inspector.

• Control-double-click (Windows) or Command-double-click (Macintosh) the image you 
want to edit.

• Right-click (Windows) or Control-click (Macintosh) the image, then choose Edit with 
Fireworks from the context menu.

Dreamweaver launches Fireworks, if it is not already open. The source PNG file for the entire 
table appears in the document window. 

Note: For more information on Fireworks source PNG files, see Fireworks Help > Using Fireworks > 
Saving Fireworks files.

3 In Fireworks, make the desired edits.

Dreamweaver recognizes and preserves all edits applied to the image in Fireworks.

4 When you are finished making edits, click Done in the document window.

The HTML and image slice files for the table are exported using the current optimization 
settings, the table placed in Dreamweaver is updated, and the PNG source file is saved.

About Dreamweaver MX behaviors

If a single, unsliced Fireworks graphic is inserted into a Dreamweaver document and a 
Dreamweaver behavior is applied, that graphic will have a slice on top of it when it is launched 
and edited in Fireworks. The slice initially won’t be visible because slices are automatically turned 
off when you launch and edit single, unsliced graphics to which Dreamweaver behaviors are 
applied. You can view the slice by turning on its visibility from the Web Layer in the Layers panel.

When you view properties for a slice in Fireworks that has a Dreamweaver behavior attached, the 
Link text box in the Property inspector may display javascript:;. Deleting this text is harmless. 
You can type over it to enter a URL if desired, and the behavior will still be intact when you 
return to Dreamweaver.
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Dreamweaver supports all behaviors applied in Fireworks, including those required for 
rollovers and buttons. The following Dreamweaver behaviors are supported by Fireworks 
during a launch-and-edit session:

• Simple Rollover

• Swap Image

• Swap Image Restore

• Set Text of Status Bar

• Set Nav Bar Image

• Pop-up Menu

Optimizing Fireworks MX images and animations placed in Dreamweaver MX

You can launch Fireworks from Dreamweaver to make quick export changes, such as resampling 
or changing the file type, to placed Fireworks images and animations. Fireworks lets you make 
changes to optimization settings, animation settings, and the size and area of the exported image.

To change optimization settings for a Fireworks image placed in Dreamweaver:

1 In Dreamweaver, select the desired image and choose Commands > Optimize Image in Fireworks.

2 If prompted, specify whether to launch a source Fireworks file for the placed image.

A dialog box opens. Although the title bar doesn’t display this name, this is actually the 
Fireworks Export Preview dialog box.
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3 Make the desired edits in the Export Preview dialog box:

• To edit optimization settings, click the Options tab. For more information, see Fireworks Help > 
Using Fireworks > Using Export Preview.

• To edit the size and area of the exported image, click the File tab and change the desired 
settings. If you change image dimensions in Fireworks, you’ll also need to reset the size of the 
image in the Property inspector when you return to Dreamweaver.

• To edit animation settings for the image, click the Animation tab and change the desired settings.

4 When you are finished editing the image, click Update. 

The image is exported using the new optimization settings, the GIF or JPEG placed in 
Dreamweaver is updated, and the PNG source file is saved if a source file was selected. 

If you changed the format of the image, Dreamweaver’s link checker prompts you to update 
references to the image. For example, if you changed the format of an image called my_image 
from GIF to JPEG, clicking OK at this prompt changes all references to my_image.gif in your 
site to my_image.jpg.

Resizing placed Fireworks MX images

When launching and optimizing a Fireworks image from Dreamweaver, you can resize the image 
and select a specific image area to be exported.

Note: If you change image dimensions in Fireworks, you’ll also need to reset the size of the image in the Property 
inspector when you return to Dreamweaver.

To specify exported image dimensions:

1 In Fireworks, in the Export Preview dialog box, click the File tab.

2 To scale the image as it is exported, specify a scale percentage or enter the desired width and 
height in pixels. Select Constrain to scale the width and height proportionally.

3 To export a selected area of the image, select the Export Area option and do one of the 
following to specify the export area:

• Drag the dotted border that appears around the preview until it encloses the desired export 
area. (Drag inside the preview to move hidden areas into view.)

• Enter pixel coordinates for the boundaries of the export area.
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Changing Fireworks MX animation settings

If you are launching and optimizing a placed Fireworks animation, you can also edit the 
animation settings. The animation options in the Export Preview dialog box are similar to those 
available in the Fireworks Frames panel.

Note: You cannot edit individual graphic elements within a Fireworks animation during an optimizing session 
launched from Dreamweaver. To edit the graphic elements in an animation, you must launch and edit the Fireworks 
animation. For more information, see “Editing Fireworks MX files from Dreamweaver MX” on page 297.

To edit an animated image:

1 In Fireworks, in the Export Preview dialog box, click the Animation tab. 

2 Use the following techniques to preview animation frames at any time:

• To display a single frame, select the desired frame in the list on the left side of the dialog box, 
or use the frame controls in the lower right area of the dialog box.

• To play the animation, click the Play/Stop control in the lower right area of the dialog box.

3 Make edits to the animation:

• To specify the frame disposal method, select the desired frame in the list and choose an option 
from the pop-up menu (indicated by the trash can icon).

• To set the frame delay, select the desired frame in the list and enter the delay time in 
hundredths of a second. 

• To set the animation to play repeatedly, click the Looping button and choose the desired 
number of repetitions from the pop-up menu.

• Choose the Auto-Crop option to crop each frame as a rectangular area, so that only the image 
area that differs between frames is output. Selecting this option reduces file size.

• Choose the Auto-Difference option to output only pixels that change between frames. 
Selecting this option reduces file size.

Setting Fireworks MX launch-and-edit options

To effectively use Roundtrip HTML, you should perform some preliminary tasks, such as setting 
Fireworks as your primary image editor in Dreamweaver and specifying launch-and-edit 
preferences in Fireworks.

Note: You should also define a local site in Dreamweaver prior to working with Roundtrip HTML. For more 
information, 
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Designating Fireworks MX as the primary external image editor for 
Dreamweaver MX

Dreamweaver provides preferences for automatically launching specific applications to edit 
specific file types. To use the Fireworks launch-and-edit features, make sure that Fireworks is set as 
the primary editor for GIF, JPEG, and PNG files in Dreamweaver. 

Although you can use earlier versions of Fireworks as external image editors, these versions offer 
limited launch-and-edit capabilities. When working with Roundtrip HTML, Fireworks 4 does 
not fully support edits made to cell properties in Dreamweaver tables, nor does it support 
behaviors applied in Dreamweaver. Fireworks 3 does not fully support the launch and edit of 
placed tables and slices within tables, while Fireworks 2 does not support the launch and edit of 
source PNG files for placed images.

To set Fireworks as the primary external image editor for Dreamweaver:

1 In Dreamweaver, choose Edit > Preferences and then choose File Types/Editors. 

2 In the Extensions list, select a web image file extension (.gif, .jpg, or .png).

3 In the Editors list, if Fireworks appears in the list, select it. If Fireworks is not in the list, click 
the Plus (+) button, locate the Fireworks application on your hard disk, and click Open.

4 Click Make Primary.

5 Repeat steps 2 through 4 to set Fireworks as the primary editor for other web image file extensions.
Fireworks MX Integration with the Macromedia Studio MX Product Family 303



About Fireworks MX Design Notes and source files

Whenever you export a Fireworks file from a saved PNG source to a Dreamweaver site, Fireworks 
writes a Design Note that contains information about the file. For example, when you export a 
Fireworks table, Fireworks writes a Design Note for each exported image. These Design Notes 
contain references to the source PNG file that spawned the exported files.

When you launch and edit a Fireworks image from within Dreamweaver, Dreamweaver uses the 
Design Note to locate a source PNG for that file. For best results, always save your Fireworks 
source PNG file and exported files in a Dreamweaver site. This ensures that any user sharing the 
site will be able to locate the source PNG when launching Fireworks from within Dreamweaver.

Specifying launch-and-edit preferences for Fireworks MX source files

The Fireworks launch-and-edit preferences let you specify how to handle source PNG files when 
launching Fireworks files from another application.

Dreamweaver recognizes the Fireworks launch-and-edit preferences only in certain cases in which 
you launch and optimize a Fireworks image. Specifically, you must be launching and optimizing 
an image that is not part of a Fireworks table and that does not contain a correct Design Note 
path to a source PNG file. In all other cases, including all launch-and-edit cases of Fireworks 
images, Dreamweaver automatically launches the source PNG file, prompting you to locate the 
source file if it cannot be found.

To specify launch-and-edit preferences for Fireworks:

1 In Fireworks, choose Edit > Preferences.

Note: On Mac OS X, choose Fireworks > Preferences.

2 Click the Launch and Edit tab (Windows) or choose Launch and Edit from the pop-up menu 
(Macintosh).

3 Specify the preference options to use when editing or optimizing Fireworks images placed in an 
external application:

Always Use Source PNG automatically launches the Fireworks PNG file that is defined in the 
Design Note as the source for the placed image. Updates are made to both the source PNG and 
its corresponding placed image.

Never Use Source PNG automatically launches the placed Fireworks image, whether or not a 
source PNG file exists. Updates are made to the placed image only.

Ask When Launching lets you specify each time whether or not to launch the source PNG file. 
When you edit or optimize a placed image, Fireworks displays a message prompting you to 
make a launch-and-edit decision. You can also specify global launch-and-edit preferences from 
this prompt. 
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Working with Macromedia Fireworks MX and 
Macromedia HomeSite

You can use Fireworks and HomeSite together to create and edit web pages. Exporting and 
opening Fireworks HTML in HomeSite is simple, and inserting Fireworks graphics into 
HomeSite documents is just as easy. But even more important, Fireworks and HomeSite share a 
powerful integration that allows you to launch Fireworks from HomeSite to edit web graphics.

Placing Fireworks MX images into HomeSite

You can insert Fireworks-generated GIF or JPEG images into a HomeSite document. You must 
export the images from Fireworks first. For information on exporting GIF and JPEG images, see 
Fireworks Help > Using Fireworks > Exporting a single image. 

To insert a Fireworks image into a HomeSite document:

1 In HomeSite, save your document. 

Note: HomeSite creates relative paths to images, but it cannot do so unless your document is saved.

2 In the Resources window, navigate to the Fireworks image you exported.

3 Do one of the following to create a link to the Fireworks image in your document:

• Drag the file from the Resources window to the desired location within the HTML code on 
the Edit tab of the Document window.

• On the Edit tab of the Document window, place the insertion point where you want to insert the 
Fireworks image, then right-click the file in the Resources window and choose Insert as Link.

A link to the Fireworks image is created in the HTML code. 

4 Click the Browse tab to preview your image within the document.

Placing Fireworks MX HTML into HomeSite

There are a few ways to place Fireworks HTML into HomeSite. You can export Fireworks 
HTML, or you can copy HTML to the Clipboard. You can also open an exported Fireworks 
HTML file in HomeSite and copy and paste selected sections of code. In addition, you can easily 
update code you’ve exported to HomeSite using the Update HTML command in Fireworks.

Note: Before exporting, copying, or updating Fireworks HTML for use in HomeSite, be sure to set the HTML 
type to Generic in the HTML Setup dialog box. For more information, see Fireworks Help > Using Fireworks > 
Setting HTML export options.

Exporting Fireworks MX HTML to HomeSite

Exporting HTML from Fireworks generates an HTML file and the associated image files in the 
location you specify. You can then open the HTML file in HomeSite for further editing.

Note: Before exporting, be sure to set the HTML type to Generic in the HTML Setup dialog box. For more 
information, see Fireworks Help > Using Fireworks > Setting HTML export options.

To export Fireworks HTML to HomeSite:

Export your document to HTML in Fireworks, and then open the exported file in HomeSite 
by choosing File > Open. For more information, see Fireworks Help > Using Fireworks > 
Exporting Fireworks HTML.
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Copying Fireworks MX HTML to the Clipboard for use in HomeSite

A fast way to place Fireworks-generated HTML in HomeSite is to copy it to the Clipboard from 
Fireworks, and then paste it directly into a HomeSite document. When you copy Fireworks 
HTML to the Clipboard, the required images are exported to a location you specify.

Note: Before copying to the Clipboard, be sure to set the HTML type to Generic in the HTML Setup dialog box. For 
more information, see Fireworks Help > Using Fireworks > Setting HTML export options.

To copy Fireworks HTML for use in HomeSite:

Copy HTML to the Clipboard in Fireworks, and then paste it into an new HomeSite document. 
For more information, see Fireworks Help > Using Fireworks > Copying HTML to the Clipboard.

Copying code from an exported Fireworks MX file and 
pasting it into HomeSite

You can open an exported Fireworks HTML file in HomeSite and then manually copy and paste 
only the desired sections into another HomeSite document. 

Note: Before exporting, be sure to set the HTML type to Generic in the HTML Setup dialog box. For more 
information, see Fireworks Help > Using Fireworks > Setting HTML export options.

To copy code from an exported Fireworks file and paste it into HomeSite:

Export a Fireworks HTML file, and then copy and paste the desired code into an existing 
HomeSite document. For more information, see Fireworks Help > Using Fireworks > 
Copying and pasting HTML from an exported Fireworks file.

Updating Fireworks MX HTML exported to HomeSite

The Update HTML command allows you to make changes to a Fireworks HTML document 
you’ve previously exported to HomeSite. 

Note: Before updating HTML, be sure to set the HTML type to Generic in the HTML Setup dialog box. For more 
information, see Fireworks Help > Using Fireworks > Setting HTML export options.

To update Fireworks HTML exported to HomeSite:

Use the Update HTML command in Fireworks. For more information, see Fireworks Help > 
Using Fireworks > Updating exported HTML.

Editing Fireworks MX images in HomeSite

You can use launch-and-edit integration to edit images in a HomeSite document. HomeSite 
automatically launches Fireworks, letting you make the desired edits to the image. When you 
exit Fireworks, the updates you made are automatically applied to the placed image in HomeSite. 
Together, the two applications provide a streamlined workflow for editing web graphics in 
HTML pages.
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To launch and edit Fireworks images placed in HomeSite:

1 In HomeSite, save your document.

2 Do one of the following:

• Right-click the image file on one of the Files tabs in the Resources window.

• Right-click the image on the Thumbnails tab of the Results window.

• Right-click the associated <img> tag in the HTML code on the Edit tab of the 
document window.

3 Choose Edit in Macromedia Fireworks from the pop-up menu.

HomeSite launches Fireworks, if it is not already open.

4 If prompted, specify whether to locate a Fireworks source file for the placed image. For 
more information on Fireworks source PNG files, see Fireworks Help > Using Fireworks > 
Saving Fireworks files.

5 In Fireworks, edit the image. 

The document window indicates that you are editing a Fireworks image from another application.

6 When you are finished making edits, click Done in the document window. 

The updated image is exported back to HomeSite, and the PNG source file is saved if a source 
file was selected.

Working with Fireworks MX and Macromedia Flash MX
Fireworks MX integrates well with Macromedia Flash MX. You can easily export Fireworks 
vectors, bitmaps, animations, and multistate button graphics for use in Flash. Launch-and-edit 
functionality also makes it easy to edit Fireworks graphics from within Flash.

Note: Fireworks button behaviors and other types of interactivity are not imported into Flash.

Placing Fireworks MX files into Flash MX

You can place Fireworks graphics into Flash MX in a number of ways. The best way is to import a 
Fireworks PNG file. This method gives you the most control over how graphics and animations 
are imported into Flash.

You can also import JPEGs, GIFs, PNGs, and SWFs that have been exported from Fireworks, 
although this method offers you less control than importing Fireworks PNGs. You can also 
manually copy graphics from Fireworks and paste them directly into Flash.

Importing Fireworks MX PNG files into Flash MX

You can import Fireworks PNG source files directly into Flash MX, without having to export to 
any other graphics format. All Fireworks vectors, bitmaps, animations, and multistate button 
graphics can be imported into Flash. 

Note: Fireworks button behaviors and other types of interactivity are not imported into Flash.
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When you import a Fireworks PNG file into Flash, you can choose from a variety of import 
options. You can import all layers and objects as a library symbol, or you can import all content 
onto a single, new layer. With vector and text objects, you can maintain their editability 
completely, or choose to maintain appearance only when objects have effects applied or other 
properties that aren’t available in Flash. Or you can forgo all editability and choose to import the 
Fireworks PNG file as a single, flattened bitmap image.

To import a Fireworks PNG into Flash:

1 Save the desired document in Fireworks.

For information on saving files, see Fireworks Help > Using Fireworks > Saving Fireworks files.

2 Switch to an open document in Flash.

3 (Optional) Click the keyframe and layer onto which you want to import the Fireworks 
content. This is necessary only if you plan to import the PNG as a library symbol (movie clip).

4 Choose File > Import. 

5 Navigate to and select the desired PNG file from the Import dialog box, and click OK.

The Fireworks PNG Import Settings dialog box appears.

6 Choose a File Structure option:

The Import as Movie Clip and Retain Layers option imports the Fireworks file as a movie clip 
that contains all the layers and frames from the original Fireworks file. The movie clip is 
inserted into the current layer and keyframe. If a keyframe wasn’t selected before import, the 
movie clip is placed in the previous keyframe.

The Import into New Layer in Current Scene option imports the Fireworks file onto a single, 
new layer, with all its frames intact.

7 Choose the way you’d like vector objects and text imported:

The Rasterize if Necessary to Maintain Appearance option preserves the editability of vector 
objects, unless they have special fills, strokes, or effects that Flash does not support. To preserve 
the appearance of such objects, Flash converts them to non-editable bitmap images.

The Keep All Paths Editable option preserves the editability of all vector objects. If objects have 
special fills, strokes, or effects that Flash does not support, those properties are lost.
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8 Choose the way you’d like text imported:

The Rasterize if Necessary to Maintain Appearance option preserves the editability of text, 
unless it has special fills, strokes, or effects that Flash does not support. To preserve the 
appearance of such text, Flash converts it to a non-editable bitmap image.

The Keep all Text Editable option preserves the editability of all text. If text objects contain 
special fills, strokes, or effects that Flash does not support, those properties are lost.

9 Choose the Import as a Single, Flattened Bitmap option if you want to import the file as a 
single bitmap image and lose all editability.

Note: If this option is selected, none of the other options in the dialog box are available.

10 Click OK.

The Fireworks PNG file is imported into Flash using the import options you chose.

Copying and pasting Fireworks MX graphics into Flash MX

A quick way to place Fireworks graphics into Flash MX is to copy and paste them. 

Note: To copy graphics into previous versions of Flash, you must choose Edit > Copy Path Outlines.

When Fireworks graphics are copied and pasted into Flash, some attributes are lost, such as Live 
Effects and textures. In addition, Flash supports only solid fills, gradient fills, and basic strokes. 

To copy and paste graphics in Flash:

1 Select the object or objects to copy.

2 Choose Edit > Copy or click the Quick Export button and choose Copy from the 
Macromedia Flash pop-up menu.

3 In Flash, create a new document and choose Edit > Paste.

Note: You may have to ungroup the objects using Modify > Ungroup so that they will be editable as separate 
vector objects in Flash.

About exporting Fireworks MX graphics to other formats for use in 
Flash MX

You can export Fireworks graphics as JPEGs, GIFs, and PNGs, and then import them into Flash. 

For information on exporting JPEGs and GIFs, see Fireworks Help > Using Fireworks > 
Exporting a single image. For information on exporting to PNG format, see Fireworks Help > 
Using Fireworks > Exporting PNGs with transparency. For information on importing any of these 
formats into Flash, see Fireworks Help > Using Fireworks > Importing exported Fireworks graphics.

Note: Although PNG is the native file format for Fireworks, PNG graphic files exported from Fireworks are 
different from source PNG files you save in Fireworks. Exported PNG files are no different than GIFs or JPEGs; 
they only contain image data and don’t contain any additional information like slicing, layers, interactivity, Live 
Effects, or other editable content. For more information on PNG source files, see Fireworks Help > Using Fireworks > 
Saving Fireworks files.
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Exporting Fireworks MX graphics and animations as SWF files

Fireworks graphics and animations can be exported as Flash SWF files. You can make several 
choices about how objects are exported.

Some formatting is lost unless you choose Maintain Appearance in the Flash SWF Export 
Options dialog box. Stroke size and stroke color are maintained. Formatting lost during export to 
SWF format includes the following:

• Live Effects

• Fill and stroke categories, textures, and feathered edges

• Anti-aliasing on objects (the Flash Player applies anti-aliasing at the document level, so 
anti-aliasing is applied to the document when you export)

• Opacity and blending modes (objects with opacity become symbols with an alpha channel)

• Layers

• Masks

• Slice objects, image maps, and behaviors

• Some text formatting options, such as kerning and bitmap strokes 

To export a Fireworks graphic or animation as a SWF file:

1 Choose File > Export or click the Quick Export button and choose Export SWF from the 
Macromedia Flash pop-up menu.

2 In the Export dialog box, type a filename and choose a destination folder.

3 Choose Macromedia Flash SWF from the Save As pop-up menu.

4 Click the Options button.

The Flash SWF Export Options dialog box appears.
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5 In the Objects section, choose one of the following:

Maintain Paths allows you to maintain path editability. Effects and formatting are lost.

Maintain Appearance converts vector objects to bitmap objects and preserves the appearance of 
applied strokes and fills. Editability is lost.

6 In the Text section, choose one of the following:

Maintain Editability allows you to maintain text editability. Effects and formatting are lost.

Convert to Paths converts text to paths, preserving any custom kerning or spacing you entered 
in Fireworks. Editability as text is lost.

7 Set the quality of JPEG images using the JPEG Quality pop-up slider.

8 Select the frames to be exported and the frame rate in seconds.

9 Click OK.

10 Click Save in the Export dialog box. 

For information on importing an exported SWF file into Flash, see “Importing exported 
Fireworks MX graphics and animations into Flash MX” on page 311.

Exporting Fireworks MX PNGs with transparency

The PNG format allows for transparency with 32-bit color images. The Fireworks PNG, the 
source file format for Fireworks, also supports transparency with 32-bit color images. You can 
import Fireworks PNG source files directly into Flash.

You can also create transparency with an 8-bit PNG. You can export Fireworks 8-bit PNG 
graphics with transparency for insertion into Flash.

To export an 8-bit PNG with transparency:

1 In Fireworks, choose Window > Optimize to open the Optimize panel if it isn’t already open.

2 Choose PNG 8 as the Export file format and Alpha Transparency from the Transparency 
pop-up menu.

3 Choose File > Export.

4 Select Images Only from the Save as Type pop-up menu. Name the file, then click Save.

For information on importing exported PNG files into Flash, see “Importing exported Fireworks 
MX graphics and animations into Flash MX” on page 311.

Importing exported Fireworks MX graphics and animations into Flash MX

You use the Import command in Flash to import graphics and animations that were exported 
from Fireworks.

To import Fireworks graphics and animations into Flash:

1 Create a new document in Flash.

2 Choose File > Import and locate the graphic or animation file.

3 Click Open to import the file.
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Using Fireworks MX to edit graphics imported into Flash MX

With launch-and-edit integration, you can use Fireworks to make changes to a graphic that you 
previously imported into Flash. You can edit any imported graphic this way, even if the graphic 
wasn’t exported from Fireworks. 

Note: Fireworks native PNG files imported into Flash are an exception, unless you imported the PNG as a flattened 
bitmap image. 

If the graphic was exported from Fireworks, and you saved the original PNG file along with the 
exported graphic file, you can launch the original PNG file in Fireworks from inside Flash to make 
your changes. When you return to Flash, both the PNG file and the graphic in Flash are updated.

1 In Flash, right-click (Windows) or Control-click (Macintosh) the graphic file in the Library panel.

2 Choose Edit with Fireworks from the pop-up menu.

Note: If Edit with Fireworks does not appear in the pop-up menu, choose Edit With and locate your 
Fireworks application.

3 Click Yes in the Find Source box if you want to locate the original PNG file for your Fireworks 
graphic, and click Open.

Note: If you have changed Fireworks launch-and-edit preferences, this dialog box might not appear.

The file opens in Fireworks and the document window indicates that you are editing a 
file from Flash.

4 Make changes to the image, and click Done when finished.

Fireworks exports a new graphic file to Flash, and if you edited the original PNG file, it is also saved.

About extending Fireworks MX with custom commands created in Flash MX

With Flash, you can create SWF movies that contain JavaScript code. These movies can be used 
as Fireworks commands, accessible from the Commands menu in Fireworks, or as panels, 
accessible from the Window menu.

For more information, see Extending Fireworks MX, available as a PDF on the Macromedia 
Fireworks installation CD.
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Working with Fireworks MX and Macromedia FreeHand
Because both applications support vectors, vector graphics can be easily shared between Fireworks 
and Macromedia FreeHand. The appearance of objects may differ between applications, however, 
because Fireworks and FreeHand do not share all the same features. 

Placing FreeHand graphics into Fireworks MX

You can place FreeHand graphics into Fireworks in a number of ways. You can import them, copy 
and paste them, or drag and drop them. Fireworks MX supports FreeHand 7 graphics or later.

Importing FreeHand graphics into Fireworks MX

Fireworks can import vector graphics that were created in FreeHand. You can set the following 
options when importing a FreeHand graphic:

Scale specifies the scale percentage for the imported file.

Width and Height specify the width and height of the imported file in pixels, inches, 
or centimeters.

Resolution specifies the resolution of the imported file.

Anti-Alias smooths imported objects to avoid jagged edges. You can choose this option separately 
for paths or text.

Note: To change selected objects to Anti-Alias or Hard Edge, use Modify > Alter > Hard Fill, Anti-Alias Fill, or Feather 
Fill after importing.

File Conversion specifies how multipage documents are handled when imported:

• The Open a Page option imports only the specified page.

• The Open Pages as Frames option imports all the pages from the document and places each in 
a separate frame.

• The Ignore Layers option imports all objects on a single layer.

• The Remember Layers option maintains the layer structure of the imported file.

• The Convert Layers to Frames option places each layer of the imported document into a 
separate frame.

Include Invisible Layers imports objects on layers that have been turned off. Otherwise, invisible 
layers are ignored.

Include Background Layers imports objects from the document’s background layer. Otherwise, 
the background layer is ignored.

Render as Images rasterizes complex groups, blends, or tiled fills and places each as a single 
bitmap object in a Fireworks document. Enter a number in the text box to determine how many 
objects a group, blend, or tiled fill can contain before it is rasterized during import.
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To import vector graphics from a FreeHand file:

1 In Fireworks, choose File > Open to navigate to the desired FreeHand file, and click Open.

The Vector File Options dialog box appears.

2 Choose the desired options.

3 Click OK.

Copying and pasting or dragging and dropping FreeHand graphics into 
Fireworks MX

You can quickly place FreeHand graphics into Fireworks by copying and pasting or dragging and 
dropping them.

To copy and paste a selected FreeHand graphic into Fireworks:

1 In FreeHand, choose Edit > Copy.

2 Create a new document in Fireworks or open an existing one.

3 Choose Edit > Paste.

To drag and drop a FreeHand graphic into Fireworks:

Drag the graphic from FreeHand into an open document in Fireworks.
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Placing Fireworks MX graphics into FreeHand

You can export vector paths from Fireworks to FreeHand. You can also copy and paste Fireworks 
vector graphics into FreeHand.

To export a vector graphic to FreeHand:

1 In Fireworks, choose File > Export or click the Quick Export button and choose Export to 
FreeHand from the FreeHand pop-up menu.

2 In the Export dialog box, type a filename and choose a destination folder. 

3 Choose Illustrator 7 from the Save As pop-up menu.

Note: Illustrator 7 is the graphics file format you use when exporting from Fireworks to any other vector graphics 
application, including Macromedia FreeHand. Most vector applications can read the Illustrator 7 file format.

4 Click the Options button.

5 In the Illustrator Export Options dialog box, choose one of the following:

Export Current Frame Only preserves layer names and exports only the current frame.

Convert Frames to Layers exports each Fireworks frame as a layer.

6 Choose FreeHand Compatible to export the file for use in FreeHand.

Choosing FreeHand Compatible omits bitmaps and converts gradient fills to solid fills.

7 Click OK.

8 Click Save in the Export dialog box. 

Note: Upon export, Fireworks sets object edges to Hard.

9 Switch to an open document in FreeHand.

10 Choose File > Open or File > Import to navigate to the file you exported from Fireworks, 
and click Open.

Copying and pasting Fireworks MX vectors into FreeHand

You can use the Copy Path Outlines command to copy selected Fireworks paths to FreeHand. 
Copy Path Outlines copies only Fireworks paths.

Note: The copy-and-paste method of placing Fireworks vectors into other applications works not only with 
FreeHand but also with Illustrator, CorelDraw, and Adobe Photoshop.

To copy selected Fireworks paths:

1 Choose Edit > Copy Path Outlines or click the Quick Export button and choose Copy Path 
Outlines from the FreeHand pop-up menu.

2 Switch to an open document in FreeHand.

3 Choose Edit > Paste to paste the paths.
Fireworks MX Integration with the Macromedia Studio MX Product Family 315



Fireworks MX features that are unsupported in FreeHand

Because Fireworks and other vector graphic editors do not always share the same features, the 
appearance of objects will differ between applications.

Most other vector graphic editors, including Macromedia FreeHand, do not support the 
following Fireworks features:

• Live Effects

• Blending modes

• Texture, pattern, web dither fills, and gradient fills 

• Slice objects and image maps

• Many text formatting options

• Guides, grids, and canvas color

• Bitmap images

• Some strokes

Note: Because these features are not supported by most other vector graphics applications, Fireworks does not 
include them upon export to those applications.
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The chapters in Part VI introduce Macromedia FreeHand, 
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the Macromedia Studio MX product family. 

The following chapters are in this part:

• Chapter 13, “Welcome to Macromedia FreeHand”

• Chapter 14, “FreeHand Tutorial”

• Chapter 15, “FreeHand Integration with the 
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CHAPTER 13

Welcome to Macromedia FreeHand

Macromedia FreeHand makes it easy to design, create, and publish illustrations and graphics-rich 
documents across multiple media. It’s also a great tool to build and quickly revise website 
storyboards and graphic elements. With FreeHand you can create vector graphics, which can be 
scaled and printed at any resolution, without losing detail or clarity.

Using the new FreeHand Navigation panel, you can produce and test high-quality Macromedia 
Flash movies without ever leaving the FreeHand environment.

What’s new in FreeHand
In addition to new and improved tools and panels that enhance your work experience, FreeHand 
offers a new array of features that allow you to move seamlessly from print to web. You can now 
use FreeHand with other applications more smoothly and efficiently than ever.

FreeHand Navigation panel

Using the Navigation panel, you can assign URL links to objects or create notes that export with 
your document. You can also assign Macromedia Flash actions to FreeHand objects, to create 
interactive Macromedia Flash movies that you can export as SWF files. For more information, see 
“Adding names and notes to objects,” “Attaching URLs to objects and text,” and “Assigning Flash 
actions” in FreeHand Help > Using FreeHand.

FreeHand master pages

Master pages are special nonpasteboard pages that can contain any object or graphic symbol that 
ordinary pages can contain except for page numbers. They provide a method of easily creating 
objects and setting page attributes shared by a range of pages in a document. You can change a 
master page at any time, and the changes you make are reflected in each child page. Master pages 
are saved with the document and can be imported or exported as library items. For more 
information on master pages, see FreeHand Help > Using FreeHand > Working with master pages.

FreeHand Pen tool features

The enhanced Pen tool features in FreeHand let you make changes to your illustration mid-path. 
The Pen tool, in addition to conforming with Macromedia Flash MX and Fireworks MX 
functionality, adds compatibility with the Adobe Illustrator pen tool without changing how the 
tool works in FreeHand. For more information, see FreeHand Help > Using FreeHand > 
Drawing with the Pen tool and Bezigon tool.
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The Pen tool includes the following functionality:

• The new Show Solid Points preference lets you display points as a solid shape for easier editing.

• New smart cursors similar to those used in Illustrator show what action will happen if you click 
at the Pen tool’s location in the drawing.

• FreeHand remembers the last active end point of a path, allowing you to perform other actions 
and then easily return to editing the path.

• You can now click on a selected path to insert a new point.

• In FreeHand you can click on a point to retract its handles. If the handles are retracted, 
clicking on a point with the Pen tool deletes the point.

• You can now use the Shift key to temporarily disable certain Pen tool functions, allowing 
greater flexibility when working with multiple paths.

Enhanced Tools panel in FreeHand

The Subselect and Hand tools are now available on the Tools panel. The icons for the Freeform, 
Zoom, and Line tools have changed to match those in Fireworks. For more information on these 
and other tools, see FreeHand Help > Using FreeHand > FreeHand Basics.

FreeHand Brush Stroke feature

Using the Brush Stroke feature, you can now create a graphic element, save it as a symbol, then 
use it as a brush stroke to stretch, repeat, or stack multiple times along the length of a path. Using 
this feature reduces file size and eliminates excessive redraw time. For more information on the 
Brush Stroke feature, see FreeHand Help > Using FreeHand > Using brush strokes.

FreeHand Library panel

Formerly known as the Symbols panel, the Library panel now stores symbols and master pages. 
For more information on the Library panel, see FreeHand Help > Using FreeHand > 
Using the Library panel.

Editing symbols in FreeHand 

When you edit a symbol, FreeHand updates all instances of that symbol within your document. 
This functionality is particularly useful for graphics that need to be updated often. For more 
information on editing symbols, see FreeHand Help > Using FreeHand > Editing symbols.

FreeHand integration with Macromedia Flash MX

New features in FreeHand allow you to assign Macromedia Flash actions to FreeHand objects, 
preview and test a Macromedia Flash movie in FreeHand, and export a FreeHand document as a 
SWF file. For more information, see “Assigning Macromedia Flash MX actions to FreeHand 
artwork” on page 365 and “Using the FreeHand Controller or Control menu with Flash MX 
SWF files” on page 369.

File Info dialog box in FreeHand 

The File Info dialog box lets you enter optional information such as dates, filenames, captions, 
headline slugs, author/photographer names, and copyright information. FreeHand uses the 
International Press Telecommunications Council (IPTC) protocol standard to store this information.
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Contour gradients in FreeHand

With the Contour Gradient feature on the Fill inspector’s Gradient panel, you can now blend 
color in two dimensions (both horizontally and vertically). For more information on contour 
gradients, see FreeHand Help > Using FreeHand > Applying gradient fills.

Print area in FreeHand

In FreeHand you can define a print area within the work space to send to your printer. You can 
resize or delete the new print area, which is treated as part of your document’s attributes. For more 
information on the print area, see FreeHand Help > Using FreeHand > Defining a print area.

FreeHand unsaved document indicator

In FreeHand, you can track the revision of your working documents. When a document needs to 
be saved, an asterisk (*) appears at the end of the filename in the document title bar (similar to 
Macromedia Dreamweaver and Fireworks 4 functionality). For more information on the unsaved 
document indicator, see FreeHand Help > Using FreeHand > The Document window.

FreeHand color boxes

The Tools panel now contains color boxes that allow you to select from an array of standard 
color chips or swatches. This functionality is similar to that found in Macromedia Flash MX, 
Fireworks MX, and Dreamweaver MX. For more information on the color boxes, see 
FreeHand Help > Using FreeHand > Color, Strokes, and Fills.

Learning about FreeHand
The FreeHand package contains a variety of media to help you learn the program quickly and 
become proficient in creating your own FreeHand illustrations. The package includes a printed 
book, online help that appears in your web browser, interactive lessons, and a tutorial. In 
addition, Macromedia provides a regularly updated website at http://www.macromedia.com/
support/freehand.

FreeHand lessons and tutorial

If you are new to FreeHand, or if you have used only a limited set of its features, start with the 
lessons. The lessons introduce you to the main features of FreeHand, letting you practice on 
isolated examples.

To view the lessons, choose Help > Lessons > Introduction.

The tutorial, in both the Help menu and Chapter 14, “FreeHand Tutorial,” on page 323, 
introduces the FreeHand workflow by showing you how to create a basic illustration. The tutorial 
assumes an understanding of the topics covered in the lessons.

Using FreeHand

The Using FreeHand manual contains instructions and information for using all FreeHand tools 
and commands. It is provided in both online help and in Adobe Acrobat (PDF) format on the 
Studio MX CD-ROM.
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FreeHand Help

FreeHand Help contains all the information in Using FreeHand, but it is optimized for online 
viewing. FreeHand Help is available any time the FreeHand application is active. For the best 
experience when using FreeHand Help, Macromedia strongly recommends that you use Netscape 
Navigator 4.0 or later or Microsoft Internet Explorer 4.0 or later on Windows. For the 
Macintosh, Macromedia recommends that you use Netscape Navigator 4.0 or later or Microsoft 
Internet Explorer 4.5 or later. For either platform, your browser must contain Macromedia Flash 
plug-ins. If you use the 3.0 version of either browser, all the content of the movies and FreeHand 
Help is still accessible, but some features (such as Search) will not work. Running FreeHand and 
FreeHand Help simultaneously on a Macintosh may require more than 64 MB of memory, 
depending on your browser’s memory needs.

FreeHand Support Center

The FreeHand Support Center website contains the latest information on FreeHand, plus 
tutorials, advice from expert users, examples, tips, updates, and information on advanced topics. 
For the latest news on FreeHand and how to get the most out of the program, check the website 
often at http://www.macromedia.com/support/freehand.
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CHAPTER 14

FreeHand Tutorial

This tutorial demonstrates how to use the sophisticated illustration tools in Macromedia 
FreeHand to create professional documents for both print and the web. By completing the 
tutorial, you’ll design a document that publicizes a museum exhibit dedicated to the artifacts of 
ancient Egypt. When the document is complete, you’ll select an area of the pages in your 
document for printing. You’ll also export two pages that will comprise a Macromedia Flash 
movie, complete with navigation buttons.

Specifically, you will complete the following tasks:

• Create and edit vector shapes

• Import objects

• Organize objects in libraries

• Work with objects on layers

• Work with colors, including contour gradient fills

• Align objects along a path and on the perspective grid

• Select the print area for your document

• Preview the file in the Macromedia Flash Playback window

• Export the file into the Macromedia Flash movie format (SWF)

The tutorial takes approximately 1 1/2 hours or less to complete, depending upon your experience.

What you should know
Although the tutorial is designed for beginning FreeHand users, before completing it you need 
the basic skills covered in five lessons found in FreeHand Help. These interactive lessons cover the 
following topics:

• Introduction to FreeHand

• Working with Paths

• Working with Layers

• Using Layers to create Macromedia Flash Animation

• Creating a Master Page

To take a lesson, choose Help > Lessons within the FreeHand application, then select from the 
list. To promote a greater understanding of the tutorial, be sure you’re comfortable with the 
concepts presented in the lessons before starting the tutorial.
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View the tutorial files
Before you start to work on your own FreeHand file, view a completed version of the tutorial to 
understand how your completed file will appear.

1 In FreeHand, choose File > Open. In your FreeHand application folder, browse to the Tutorial 
folder, and open the file named Tutorial_finished.fh10.

2 The completed tutorial file contains 2 pages. To see both of the pages at once, choose Fit All 
from the Magnification pop-up menu.

Pages 1 and 2 are designed to display in a web browser; both pages include navigation buttons 
that link the pages to each other when the pages are exported into the Macromedia Flash movie 
format (SWF).

3 To turn from one page to another, select the desired page from the Go to Page pop-up menu.

Note: Throughout the tutorial, you will be instructed to turn to a particular page in your FreeHand document. Use 
the Go to Page pop-up menu to turn to another page quickly.

Go to Page pop-up menu
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4 To change the page magnification, select a different magnification from the Magnification 
pop-up menu.

5 When you finish viewing the file, you can either keep it open for reference, or close it by 
choosing File > Close.

If you’ve made any changes to the document, don’t save them when you close the file.

Open the starting file

1 Choose File > Open. In your FreeHand application folder, browse to the Tutorial folder and 
open Tutorial_start.fh10.

You see a partially completed version of the tutorial file that you viewed earlier. Page 1 of this file 
includes an artist’s sketch, which is in the background of the document. Objects that you place 
on the page will appear on top of the background art, and you will use the background art as a 
guide when placing objects. When you no longer need the background art, you will hide it.

Additionally, the file includes a guide, along one of the eyes, that will assist you in drawing.

2 Choose File > Save As and save the file with a new name, in the same folder as 
Tutorial_start.fh10.

Making a copy of the file lets you save the results of your work while keeping the starting file 
intact for reuse at a later time.

Note: While completing the tutorial, you may find it useful to undo a change you’ve made. FreeHand can undo 
several of your recent changes, depending on the number of undo levels you have set in Preferences. To undo, 
chose Edit > Undo.
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As you complete the tutorial, remember to save your work frequently. An asterisk in your document 
title bar indicates that you have modified the document but have not yet saved the changes.

Create objects
FreeHand offers a variety of tools for drawing and modifying objects. You’ll work with some of 
these tools now, as you create the art that completes the eye on the sarcophagus.

Zoom in on your document

Before you begin, you’ll want to zoom in on your document to have a larger area on which to draw.

1 In the Tools panel, click the Zoom tool. 

2 On page 1 of your FreeHand document, click the eye of the sarcophagus on the left side of the 
document repeatedly, until the Magnification pop-up menu indicates a magnification of 800%.

Note: You can also type a value in the Magnification text box.

Select stroke and fill colors

To specify the color of the path that you will draw, you use the Stroke inspector.

1 To open the Stroke inspector, choose Window > Inspectors > Stroke.

2 In the Stroke Type pop-up menu, verify that Basic is selected.

3 In the Stroke Width pop-up menu, select Hairline.

4 Click the Stoke Color pop-up menu and select Lapis.

5 To open the Fill inspector, choose Window > Inspectors > Fill, or click the Fill tab.

The Fill inspector lets you specify a color that appears within the boundaries of your path.

Stroke Type pop-up menu

Stroke Width pop-up menu

Stroke Color pop-up menu
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6 In the Fill Type pop-up menu, verify that Basic is selected.

7 Click the Fill Color pop-up menu and select Lapis.

The Tools panel displays the selected stroke and fill colors.

Draw a path with the Pen tool

With the Pen tool, you can create and modify precise paths easily. To draw a curved path with the 
Pen tool, you create points, then drag tangent handles to shape the curves. 

The paths that you create in FreeHand are vectors, which define shapes mathematically to 
produce graphics that maintain their resolution and smooth lines even when enlarged.

1 In the Tools panel, click the Pen tool. 

2 To create the first point, click the number 1 dot on the background art, along the outside 
corner of the eye.

Fill Type pop-up menu

Fill Color pop-up menu

Stroke

Fill
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3 Click the number 2 dot and continue to hold down the mouse button. Drag the number 2 
point. As you drag, a handle appears. Drag the handle so the curved line follows the guide that 
outlines the eyeliner.

4 Click the number 3 dot. The line will not follow the curve, but you will modify this line 
segment shortly.

5 Click the number 4 dot and continue to hold down the mouse button. Drag the handle of the 
number 4 dot so the curve follows the guide.

6 Click the number 5 dot and continue to hold down the mouse button. Drag the handle of the 
number 5 dot to create the next curved line.

7 Click the number 6 dot. 
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8 Click the number 7 dot and continue to hold down the mouse button. Drag the handle of the 
number 7 dot to create another curved line that follows the guide. Repeat this step for the 
number 8 dot.

9 Draw a straight line segment by clicking (without dragging) the number 9 dot.

10 Position the Pen tool over the first point that you created on the number 1 dot. A small circle 
appears next to the pen tip when it is positioned correctly. This circle indicates that a click here 
will complete the path. Click the point.

When you close the path, the fill color appears within the outline.
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Modify the path

The line segment between the number 2 and 3 dots does not follow the curve. You will use the 
Object inspector to modify the path. The Object inspector displays the attributes of a selected object.

1 In the Tools panel, click the Pointer tool. With the path on page 1 selected, click the number 2 
point so that its handle appears.

2 Choose Window > Inspectors > Object.

3 In the Object inspector, select the Corner Point button to change the curved point to a 
corner point.

Moving a curve point handle can affect adjacent path segments. Corner point handles move 
independently of each other, which lets you adjust adjacent path segments one at a time.

4 Drag the handle for the number 2 point until the line segment follows the guide.

Note: For more information about modifying your shape, refer to the steps you learned in the Working with Paths 
lesson (additionally, see FreeHand Help > Using FreeHand > Reshaping a path).

Corner Point button
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Use the Pencil tool

While the Pen tool lets you create a path by placing points, the Pencil tool lets you draw a 
freeform path. To compare the two tools, you will use the Pencil tool to draw another path that 
creates the eyeliner effect underneath the eye.

1 In the Tools panel, click the Pencil tool. 

2 Drag from the inner corner of the eye, along the eyeliner background art, to create another 
path underneath the eye, as shown in the following illustration.

Use the brush attribute

Brush strokes are an easy-to-manage attribute that you can apply to any FreeHand path to create 
two different effects: 

• The paint effect extends a graphic symbol across the length of the path and lets you create lines 
that look like paintbrush strokes.

• The spray effect repeats a graphic symbol across the length of the path. 

You will first add the paintbrush stroke attribute to the FreeHand line to complete the eyeliner 
effect. Later in the tutorial, you’ll have the opportunity to use the spray brush stroke.

1 With the pencil line selected, choose Window > Inspectors > Stroke.

2 In the Stroke inspector, choose Brush from the Stroke Type pop-up menu.

3 In the Brush pop-up menu, select Eye Brush.

You are using a predefined brush stroke. Later in the tutorial, you’ll learn how to create a 
custom brush stroke.
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4 In the Scale text box, change the percentage to 10%, and press Enter (Windows) or 
Return (Macintosh).

The path looks as though it has been applied with a brush; the stroke tapers at the ends.

Use the Ellipse tool

Another method of drawing in your FreeHand document is to select a shape tool in the Tools 
panel, drag in your document with the tool to create the shape, and allow FreeHand to 
automatically place the points. You’ll use this method now to complete the eye.

1 In the Tools panel, click the Ellipse tool.

2 Click the upper left edge of the oval on the background art, as shown in the following 
illustration, and drag to the opposite edge of the oval.

3 To size the ellipse precisely, in the Object inspector type 12.12 in the W text box, which 
indicates the width of the object.

Begin dragging here.
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4 To specify the height of the ellipse, type 8.5 in the H text box and press Enter (Windows) or 
Return (Macintosh).

5 If you need to move the ellipse, use the Pointer tool to drag it (being careful not to drag the 
points) so the ellipse is over the oval on the background art.

When you move the ellipse, the values in the X and Y coordinate text boxes in the Object 
inspector change to reflect the current location of the ellipse.

Note: You can also move the ellipse using keyboard arrow keys. With the ellipse selected, press the arrow keys 
to move the ellipse one pixel at a time in the direction of the arrow.

6 To change the color of the ellipse, verify that it’s selected and select Black from the Stroke 
Color pop-up menu in the Stroke panel. 

7 Select Black from the Fill Color pop-up menu in the Fill panel.

Combine shapes

Now that you’ve created three separate objects, you will group them. Grouping objects retains 
their placement relative to one another while letting you manipulate them as a single object. 

1 With the ellipse selected, Shift-click the two “eyeliner” paths with the Pointer tool so that all 
three shapes are selected.

2 Choose Modify > Group.
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Create a mirror image with the Reflect tool

The Reflect tool offers a way to create a mirror copy of a selected object. Rather than drawing the 
second eye, you’ll use the Reflect tool to create it from the eye you’ve already drawn.

1 Verify that the eye is selected and choose Edit > Duplicate.

2 With the copy of the eye selected, choose the Reflect tool from the Tools panel, and then click 
the copy of the eye. 

3 Use the Pointer tool to drag the mirror copy of the eye into position over the eye on the 
background art.

4 With the Pointer tool, click anywhere on the page, away from the eyes so that the eyes are 
not selected.

Note: As you complete the tutorial, remember to save your work frequently.
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Use the Tools panel to apply different stroke and fill colors
Earlier in the tutorial, you used the Stroke and Fill inspectors to determine the colors of your 
objects. You’ll now use the Stroke and Fill color boxes in the Tools panel to select colors for the 
polygons you’re about to draw.

As you work on a FreeHand file, you can take colors that you’ve mixed, or colors that you use 
frequently, and add them to a list of swatches that save with the document. Later in the tutorial 
you will mix and add a color to your swatches. Now, however, you will work with colors already 
included in your list of swatches.

1 In the Tools panel, click the Stroke color box to view the color palette.

2 If None is not selected in the Stroke Type pop-up menu, click the None button.

The shape that you’re about to draw will not need a stroke color.

3 In the Tools panel, click the Fill color box to view the color palette.

Triangle

Swatches

None button
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4 Click the triangle in the upper right corner of the palette and select Swatches.

As you move the eyedropper over a color on the color list, a tooltip appears that indicates the 
name of the color.

5 Click Gold Mid-Tone in the list of colors to select it.

Draw a polygon

A polygon is another shape that you can select from the Tools panel. You’ll create two polygons in 
two different colors as the first step in creating ornamentation for the headdress.

1 Turn to page 3 and use the Zoom tool to magnify the path along the headband to 400%.

2 In the Tools panel, double-click the Polygon tool to display the Polygon Tool dialog box.

3 In the Number of Sides text box, type 7, or move the Number of Sides slider to 7.

4 Verify that Polygon is selected under Shape, then click OK.

Path
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5 Drag to create a small polygon close to the left side of the headpiece path, which has already 
been created for you, as shown in the following illustration:

6 Choose Edit > Duplicate, and use the Pointer tool to drag the duplicate polygon to the other 
end of the path.

7 With the duplicate polygon still selected, select Gold Highlight from the Fill color box in the 
Tools panel.
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Create a blend along a path
You can select two path objects and combine them, creating a transition between the two in 
incremental steps; this effect is known as a blend. You can blend both shapes and colors. In this 
part of the tutorial, you’ll blend the two polygons along a path.

1 With the duplicate polygon still selected, Shift-click to select the first polygon that you drew.

2 Choose Modify > Combine > Blend.

3 If the Object inspector is not visible, choose Window > Inspectors > Object.

4 In the Steps text box, type 6 and press Enter (Windows) or Return (Macintosh).

The transition between the two polygons occurs over 6 steps.
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5 With the polygon blend selected, hold down Shift and click the curved path on the headdress 
to add it to the selection. 

Note: If necessary, move the polygon blend to see the path.

6 Choose Modify > Combine > Join Blend to Path or click the Attach to Path button.  
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Add special effects
You can apply the emboss special effect to your polygons to make them appear three-dimensional 
on the headdress:

1 Choose Modify > Ungroup.

2 Choose Modify > Ungroup again.

All of the polygons are selected, except the first and last one along the path.

3 Taking care to not select the path, Shift-click the first and last polygon to add them to the selection.

4 Choose Xtras > Create > Emboss.

5 In the Emboss dialog box, verify that the Emboss button is selected.

6 Either type 1 in the Depth text box or move the Depth slider to 1.

The Depth value controls the distance by which the effect appears raised.

7 Type 135 in the Angle text box and click OK.

The angle specifies the direction of the highlight and shadow.

8 Click anywhere away from an object to deselect the selected objects, then click the path for the 
headdress to select it. 

Emboss button
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9 Press Backspace (Windows) or Delete (Macintosh) to delete the path.

Note: As you complete the tutorial, remember to save your work frequently.

Work with objects in layers
Using layers, as you learned in the Working with Layers lesson, is an integral part of working in 
FreeHand. Layers are analogous to transparent sheets of acetate, or tracing paper, stacked on top 
of each other. Layers offer a logical way to organize objects—for instance, you might place all text 
on one layer and all navigation buttons on another. Each object in your FreeHand document 
resides on a layer, and it can be edited only when its layer is visible and unlocked.

View and hide layers

The FreeHand tutorial document has 12 layers, including the default Foreground, Guides, and 
Background layers. Objects on the Foreground layer, as the name suggests, appear by default in 
front of objects on the Guides and Background layers. To manage layers in your document, as you 
learned in the Working with Layers lesson, you use the Layers panel.

1 To view the Layers panel, choose Window > Panels > Layers.

The objects that you’ve created in the tutorial so far are on the Foreground Layer. 
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Move your layered artwork

Page 3 of your document includes objects on four different layers: the Foreground layer, the Head 
and hands layer, the Beads layer, and the Body layer. You’ll copy the layered artwork to page 1.

1 To reduce your page view to see the entire page, choose View > Fit to Page. 

2 With the Pointer tool, click any object on page 3.

3 Choose Edit > Select > All.

4 Choose Edit > Cut.

5 Turn to page 1 and choose Edit > Paste.
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6 Drag the art to the right edge of the page until the right alignment triangle appears.

The alignment triangle indicates the objects are in alignment with the right edge of the page.

7 Keeping the art aligned to the right edge of the page, drag the objects to align with the bottom 
edge of the page. Again, an alignment triangle, this time pointing downward, appears when the 
objects are aligned against the bottom edge of the page. 

The objects that you copied are still on their respective layers.

Right 
alignment 
triangle

Bottom 
alignment 
triangle
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8 Click anywhere away from the sarcophagus to deselect the objects.

Because the Foreground layer is on top of the three layers that contain the sarcophagus art, the 
eyes and headdress art that you created on the Foreground layer appear on top of the other layers.

9 In the Layers panel, click the check mark next to the Background layer to hide it.

To show a hidden layer, you can click to the left of the unchecked layer name.

Note: As you complete the tutorial, remember to save your work frequently.

Import objects
You’ll now import a graphic of a bead, which you’ll use to create a necklace. To bring graphics or 
text into your document, you have three options, all of which are probably familiar to you: 
dragging and dropping, using the Import command, and cutting and pasting. For this tutorial 
you’ll use the Import command.

1 In the Layers panel, click the padlock icon to the left of the Head and Hands and Body layer 
names to lock those layers.

2 On page 1, magnify your document view to 200%.

3 Choose File > Import.

4 In the Import Document dialog box (Windows) or Open dialog box (Macintosh), browse to 
the Tutorial folder inside your FreeHand application folder and double-click Bead.fh10.

5 Click the Import pointer next to the sarcophagus, as shown in the following illustration.

Precise placement of the bead isn’t necessary.
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Work with symbols and instances
Symbols and instances let you manage repeating graphics while minimizing file size. Instances are 
copies of an original FreeHand object, which is stored as a symbol. When you modify the symbol, 
all instances of that symbol automatically change to reflect the modification.

You store symbols in the library for reuse throughout the document. To keep symbols organized 
in the library, you can place them in groups.

1 Choose Window > Library to display the Library panel.

2 Click the folder icon to create a new group. In the Library list, double-click the Group-01 
name and rename the group Necklace.

3 If necessary, select the bead you placed on page 1 of your document. Choose Modify > Symbol 
> Convert to Symbol.

The bead on the page is now an instance of the bead symbol in the Library panel. The name of 
the symbol is Graphic-01.

4 In the Library list, rename the Graphic-01 symbol Teardrop and drag it to the Necklace group.

Folder icon
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Use the spray brush
Earlier in the tutorial, you used the paintbrush attribute to extend a graphic symbol along a path. 
Now you’ll use the spray brush attribute to repeat a graphic symbol—in this case, the bead—
along a path.

1 With the bead on page 1 selected, choose Modify > Brush > Create Brush.

2 In the Edit Brush dialog box, name the brush Necklace.

3 Select Spray.

4 In the Min. percentage text box to the right of Spacing, type 85, then click OK. 

5 On page 1, select the path, which is already created for you next to the existing necklaces.

6 In the Stroke inspector, select Brush from the Stroke Type pop-up menu.

Path
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7 In the Brush pop-up menu, select Necklace—the name of the custom brush you created. 

Instances of the bead symbol repeat along the path.

8 Type 60 in the Width text box in the Stroke panel, then press Enter (Windows) or 
Return (Macintosh).

Note: You can move the points on the path, as you learned earlier, to change the shape and length of the necklace.

Width text box
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Use colors and tints
You can use the Color Mixer to mix colors from CMYK (Cyan, Magenta, Yellow, Black), RGB 
(Red, Green, Blue), and other color modes to create specific colors. The CMYK mode uses 
process colors that represent inks in four-color print, and RGB mode uses colors that appear 
onscreen, such as on a web page. 

The tutorial document, which is designed both to be printed and for export as a Macromedia 
Flash movie, uses RGB colors. Here you’ll use the RGB color mode to create a shade of gold for 
the beads, and you’ll add the color to your document’s list of color swatches. Later in the tutorial, 
you’ll print pages using CMYK colors.

1 If the Color Mixer panel is not visible, choose Window > Panels > Color Mixer.

2 Click the RGB button. For the color red, either type 255 in the text box or move the slider to 255.

3 For green and blue, either type 0 or move the slider to 0. 

4 In the Tints panel, click the 90% tint box, and then click the Add to Swatches button.

5 In the Add to Swatches dialog box, type Ruby in the text box to name the color, then click Add.

Note: When you add a tint to your list of swatches, FreeHand automatically adds the base color for the tint to 
your list of swatches as well.

RGB button

Add to Swatches button
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6 On page 1, select the bead instance (not the beads along the path) and choose Modify > 
Symbol > Edit Symbol.

7 In the symbol-editing window, magnify the symbol to 400%.

8 If the Swatches panel is not visible, choose Window > Panels > Swatches. Drag the Ruby 
swatch to the middle of the teardrop on the left (not the blue teardrop).

9 Close the symbol-editing window.

The beads along the path update to include the ruby color that you added.

10 On page 1, select and delete the bead instance.

The symbol remains in the library.

Note: As you complete the tutorial, remember to save your work frequently.

Select this bead 
to modify.

Delete the 
original bead 
instance.
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Add a contour gradient to text
A gradient displays subtle variations of a color or transitions between two or more colors. In 
FreeHand, you can create multicolor gradients that follow the contour of a path. In this tutorial, 
you’ll use the contour gradient feature to add a bit of polish to ordinary text.

1 Turn to page 4 and select the text that reads “egyptian.”

2 In the Fill panel, select Gradient from the Fill Type pop-up menu.

3 Click the Contour Gradient button and click the swatch on the left of the color ramp.

Contour Gradient 
button

Color ramp
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4 In the list of swatches, select Gold Base-Tone.

5 Drag the swatch slightly to the right, as shown in the following illustration.

6 Click the second swatch, which you just created, and select Gold Low-Tone from the list 
of swatches.

7 Drag the first swatch to the halfway mark of the color ramp. Click it and select Gold Mid-Tone 
from the list of swatches.

8 Click the swatch on the right and select Gold Highlight.
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9 Drag the swatch on the right toward the left, about a quarter of the length of the color ramp, as 
shown in the following illustration.

10 Drag the taper slider to 20.

The taper slider controls the ramp of the gradient.

11 Drag the center-point control toward the upper left corner, as shown in the following illustration.

The “egyptian” text in your document displays all of the colors you specified in the Fill panel 
applied as a contour gradient.

Center-point control
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Note: You can use the Subselect tool in the Tools panel to select an individual letter within the “egyptian” text. 
You can then adjust the taper slider for that letter to produce a more even gradient effect. The 
Tutorial_finished.fh10 file shows how the contour gradient appears when adjusted for individual letters.

12 To move the objects on this page to page 1, choose Edit > Select > All.

13 Choose Edit > Cut.

14 Turn to page 1 and choose Edit > Paste.

Remove pages from your document
Pages 3 and 4 in your document are now unnecessary, because they contain no objects. To delete 
the pages, you can use the Document inspector.

1 Turn to page 3, and choose Window > Inspectors > Document.

2 Click the triangle in the upper right corner of the Document inspector to display the Options 
pop-up menu, and choose Remove.

3 Turn to what is now page 3 and repeat step 2 to remove the next blank page.

Note: As you complete the tutorial, remember to save your work frequently.
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Use the perspective grid
By attaching objects to the perspective grid, you can orient the objects in relation to a vanishing 
point that adds depth to your art. Although you’ll use just one vanishing point in this tutorial, 
FreeHand lets you create custom grids with up to three vanishing points.

Define the perspective grid

Before displaying the perspective grid, you can define how the grid should appear.

1 Turn to page 2. In the Page Size Magnification text box, type 39 and press Enter (Windows) or 
Return (Macintosh).

2 In the Layers panel, lock the Tomb Walls layer.

3 Choose View > Perspective Grid > Define Grids.

4 In the Define Grids dialog box, double-click Grid 1 and type Wall to rename the grid.

5 Verify that Vanishing Point is set to 1.

6 In the Grid Cell Size text box, type 100, and click OK.

7 Still on page 2, choose View > Perspective Grid > Show.
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8 In the Tools panel, select the Perspective tool. 

9 Position the Perspective tool pointer on the horizon line, which is the top border of the 
horizontal grid, and drag the horizon up to the horizontal guide line supplied for you.

10 Drag the vanishing point to the right until the vertical lines align with the vertical guide.

Vanishing point

Horizon

Horizontal grid

Vertical grid

Guide

Guide
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11 Drag the horizontal grid line at the bottom of the perspective grid down to meet the horizontal 
guide below page 2.

Attach an object to the perspective grid

Once you’ve defined the perspective grid, you’re ready to align objects along the grid.

1 With the Perspective tool still selected, click the larger hieroglyphic art from the pasteboard 
above page 2. Drag the art down to cover page 2 and press the Left Arrow key while holding 
down the mouse button.

The art aligns along the perspective grid.

Guide
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2 Drag to align the left edge of the hieroglyphics with the left edge of the page, and release the 
mouse button. 

3 Drag the smaller hieroglyphic art from the pasteboard below page 2 to the left wall, and press 
the Left Arrow key while holding down the mouse button.
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4 Drag to align the left edge of hieroglyphics with the left edge of the page, and place the art in 
the blank area of the wall that does not have hieroglyphics.

5 To hide the grid, choose View > Perspective Grid > Show.

6 In the Layers panel, unlock the Tomb Walls layer and hide the Drawing Guides layer.

Note: As you complete the tutorial, remember to save your work frequently.
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Define the print area
You’ve now drawn, imported, and placed all of the objects in your FreeHand file. This is often an 
appropriate stage in the design process to print your pages for review. With the FreeHand print 
area feature, you can define an area that incorporates selected areas of the pasteboard and selected 
areas of pages within the document. 

1 Set your page magnification view to 25%.

2 Choose File > Print Area.

3 Drag the print area pointer to select page 1 and page 2. You can include the pasteboard area 
around the two pages, as shown in the following illustration.

You’re now in Print Area mode.

Note: You can resize or delete the print area; print area attributes save with the document. For more information, 
see FreeHand Help > Using FreeHand > Defining a print area.

4 Click inside the print area to open the Print Area dialog box.

5 In the Printer pop-up menu, select the printer you wish to print to.

6 Verify that Printer is in the Destination field (Macintosh).

7 In the Options pop-up menu, select FreeHand (Macintosh).

8 In the Scale % pop-up menu, select Fit on paper, then click OK (Windows) or Print 
(Macintosh) to print the area that you specified.

Note: By default, the RGB colors in your document print as CMYK colors. For more information on using color, 
see FreeHand Help > Using FreeHand > Color management overview.

9 To exit Print Area mode, click outside the print area.
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Add navigation to buttons
With FreeHand, you can add buttons to your document that link to other pages or URLs after 
export to a web-based format. You use the Navigation panel to assign links, and you can preview 
the document as a Macromedia Flash movie inside FreeHand. 

1 Set the magnification on page 1 to 100%. Select the Next button and choose Window > 
Panels > Navigation.

2 In the Name text box, type Hieroglyphics.

3 In the Link pop-up menu, select Page 2, then close the Navigation panel.

When users click the Navigation button in the SWF file that you’ll create from this FreeHand 
file, they will go to page 2.

Preview the file in the Macromedia Flash Player window
To test the button navigation that you created, you can preview your document in a Macromedia 
Flash Playback window that opens directly in FreeHand. The Movie Settings dialog box lets you 
specify how you want the Macromedia Flash movie to play.

1 If the Controller is not visible, choose Window > Toolbars > Controller.

2 Click the Movie Settings button on the Controller.

3 In the Frames section, select From and verify that 1 appears in the From text box. Type 2 in the 
To text box.

Movie Settings button
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4 In the Animation pop-up menu, select None, then click OK.

5 In the Controller, click the Test Movie button. 

FreeHand creates a temporary SWF of your document. Page 1 appears in a Macromedia Flash 
Playback window, similar to how it will appear if you export the file as a SWF using the current 
movie settings.

6 Move the pointer to the Next button. The pointer changes to a pointing finger, which 
indicates the button is navigable. Click the button to go to page 2 of your document.

7 Click the Back button to return to the first page.

Export the document
Now that you’ve previewed your document in the Macromedia Flash Playback window, you can 
export your file as a SWF. When you export a movie, it saves with the current settings specified in 
the Movie Settings dialog box.

1 With the Macromedia Flash Playback window still open, click the Export button in the 
Controller, or choose Control > Export Movie.

2 In the Export Movie dialog box, enter a name for the movie and browse to a location in which 
to save the movie, then click Save.

You can open the SWF file in the Macromedia Flash Player to view pages 1 and 2.

To learn more
Congratulations on learning how to complete the following tasks:

• Creating and editing vector shapes

• Importing objects

• Organizing objects in libraries
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• Working with objects on layers

• Working with colors, including contour gradient fills

• Aligning objects along a path and on the perspective grid

• Selecting the print area for your document

• Previewing the file in the Macromedia Flash Playback window

• Exporting the file into the Macromedia Flash movie format (SWF)

To learn more about any topic covered in the tutorial, and to become familiar with topics outside 
the scope of the tutorial, refer to the Using FreeHand manual and FreeHand Help. Additionally, 
visit Macromedia’s award-winning Support Center at http://www.macromedia.com.
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CHAPTER 15

FreeHand Integration with the

Macromedia Studio MX Product Family

Macromedia FreeHand and Macromedia Flash MX work together in the following ways:

• The Animate Xtra lets you convert a FreeHand document for display as a Macromedia 
Flash animation.

• You can assign actions to objects in FreeHand documents, to create interactive movies for 
web display.

• FreeHand art can be exported in Macromedia Flash (SWF) file format to use in creating 
dynamic vector art for display on the web.

• Macromedia Flash movies can be tested from within FreeHand using the Macromedia Flash 
Player Window.

Animating objects and text in FreeHand
To animate objects for display in the Macromedia Flash Player, you place the objects on layers 
using the Release to Layers Xtra. You can animate blends or groups, as well as objects attached to 
a path. To animate a text block, you first convert the text to paths.

The Release to Layers Xtra ungroups blends, groups, or objects attached to a path, creates a new 
layer for each object, and assigns each ungrouped object to a new layer in consecutive order (New 
Layer, New Layer-1, New Layer-2, and so on). The Xtra places the first object (or object in a 
group) on the current layer, and the last object on the top layer. Releasing text to layers converts 
each letter in the text block to paths and places each letter on a separate layer.

You will achieve the best results by designing the frames of your movie to animate upward from 
the bottom layer to the top layer. 

You can preview or export your animation as a SWF file using commands in the Controller or the 
Control menu. For more information, see “Using the FreeHand Controller or Control menu with 
Flash MX SWF files” on page 369.

You can also create your animation by placing objects on separate pages and selecting Animate 
Pages or Animate Pages and Layers when you export the FreeHand document as a SWF.
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To prepare a text block for animation:

1 Select the text block containing the text that you want to animate, and position the text block 
where you want the animation to begin.

2 Choose Text > Convert to Paths. For more information on converting text to paths, see 
FreeHand Help > Using FreeHand > Converting text to paths.

3 With the text block still selected, choose Modify > Join.

4 Choose Edit > Copy and Edit > Paste to create a copy of the converted text block.

5 Use the Pointer tool to drag the copy of the converted text block to the position where you 
want the animation to end.

6 With the Pointer tool, Shift-select the original and the copy of the converted text block.

7 Choose Xtras > Create > Blend.

For information on animating the blend, see the following procedure.

To animate objects:

1 Select the objects that you want to animate. A nested object included in a group behaves as a 
single object. 

2 Choose Window > Panels > Layers to display the Layers panel.

The Layers panel will display new layers as you create them in the following steps.

3 Choose Xtras > Animate > Release to Layers.

4 For Animate, choose animation effects to determine how objects are released to layers:

 objects in sequence to separate layers.

Build creates a stacking effect by copying objects in sequence to subsequent layers. For 
example, if you have a group of two objects, the first object is placed on Layer 1, and a copy of 
the first and second objects are placed on Layer 2.

Drop copies objects to all layers but omits one object in sequence from each layer. For example, 
if you select a group of three objects, the second and third objects are placed on Layer 1, the 
first object and a copy of the third object are placed on Layer 2, and copies of the second and 
third objects are placed on Layer 3.

Trail copies and releases objects to the number of layers you specify. Objects are copied 
incrementally to the specified number of layers. Enter a number for Trail By to specify the 
number of layers on which objects will be copied. For example, enter 4 for Trail By to copy 
each object in the 4 layers following the layer that contains the object.

5 Select Reverse Direction to release the objects in reverse stacking order and animate the 
sequence in the opposite direction.

6 Select Use Existing Layers to release objects to existing layers, beginning with the current layer. 
Deselect the option to release objects to new layers created by the Xtra.

7 If you chose Use Existing Layers, select Send to Back to release the objects to the back of the 
stacking order. 

8 Click OK.
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Assigning Macromedia Flash MX actions to FreeHand artwork
You can assign Macromedia Flash actions to artwork you create in FreeHand in order to use the 
FreeHand artwork in interactive Macromedia Flash movies. You export the FreeHand document 
with Macromedia Flash actions as a SWF file, for display in the Macromedia Flash Player.

In an interactive movie, your audience uses the keyboard, the mouse, or both to jump to different 
parts of a movie, move objects, and perform many other interactive operations. 

To assign Macromedia Flash actions in FreeHand, you use the Action area of the Navigation 
panel. The Action area lists a subset of actions from ActionScript, the Macromedia Flash 
programming language. The following actions are available for use in FreeHand:

The Go To action jumps to a frame or scene. (Frames or scenes are created from layers when you 
export an animation to Macromedia Flash MX.)

The Play and Stop actions play and stop movies.

The Print action specifies which frames in a movie users can print directly from the 
Macromedia Flash Player.

The Full Screen action displays the movie in the Macromedia Flash Player in full-screen mode, 
rather than normal mode.

The Start/Stop Drag action makes a specified movie clip draggable when a specified event occurs, 
and stops the draggable behavior when the opposite action occurs. For example, if you assign On 
Press as the Start Drag event, FreeHand will automatically assign On Release as the Stop Drag event.

The Load Movie and Unload Movie actions load and unload additional movies when the current 
movie is playing (available only with documents that have two or more pages).

The Tell Target action controls other movies and movie clips that were loaded into the current movie 
with the Load Movie action (available only with documents that have two or more pages). FreeHand 
allows only one level of loaded movies; thus you can assign only one movie to load at a time.

When you assign an action, you also select an event that will cause the action to run when the 
movie is played. Events that can trigger an action during movie playback are the user clicking the 
mouse button or the movie playhead reaching a specified frame.

For some actions, including Go To, Print, Load/Unload Movie, and Tell Target, you also select 
parameters that define how the action is to be applied.

To assign actions to artwork in FreeHand:

1 In the Document window, select the object or objects to which you want to assign actions.

2 Choose Window > Panels > Navigation.

3 For Action, select an action from the pop-up menu.

4 For Event, from the pop-up menu select the event that will trigger the action. 

Note: For Start/Stop Drag, the Frame Action event is disabled.
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5 If you selected Go To, Print, Load/Unload Movie, or Tell Target, select Parameters:

• For all actions, select an option from the list of current document pages in the first Parameter 
pop-up menu. 

• For the Go To or Print action, select from the current document layers in the second Parameter 
pop-up menu, to specify which part of the document the playhead will move to or which part 
of the document will be printed when the trigger event is performed.

• For the Tell Target action, select an action from the second Parameter pop-up menu to control 
playback of another movie: GoTo, Play, Stop, or Print. If you selected GoTo or Print, select 
from the current layers in the third Parameter pop-up menu to specify which part of the 
document the playhead will move to or which part of the document will be printed.

6 Repeat steps 3 through 5 to assign additional actions.

Exporting FreeHand documents as 
Macromedia Flash MX movies

You can export any FreeHand document in Macromedia Flash (SWF) format, for display in the 
Macromedia Flash Player plug-in in a web browser, such as Netscape Navigator or Microsoft 
Internet Explorer, or in a stand-alone Macromedia Flash Player. 

You can export still graphics in SWF format, to preserve vector artwork attributes while reducing 
file size. You can choose to export layers, pages, or both in FreeHand documents as separate 
frames in a SWF file, or as separate SWF files. If you export layers as frames, all the layers below 
the separator bar in the Layers panel become one background layer in all frames in the SWF file. 

If you have added Macromedia Flash actions to a file, the actions are enabled in the exported SWF.

You can export a FreeHand file in SWF format using the Export command, as described in the 
following procedure. You can also export a file in SWF format using commands in the Controller 
or the Control menu. For more information, see “Using the FreeHand Controller or Control 
menu with Flash MX SWF files” on page 369.

Note: To display anti-aliased artwork on the screen as it will appear when exported to Macromedia Flash SWF 
format, test the SWF file using the Controller or Control menu. For more information, see “Using the FreeHand 
Controller or Control menu with Flash MX SWF files” on page 369.

To export a FreeHand file in SWF format:

1 Choose File > Export. 

2 Choose Macromedia Flash (SWF) from the Save As Type (Windows) or Format (Macintosh) 
pop-up menu. 

3 Click Setup.
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4 In the Movie Settings dialog box, choose a Path Compression option to control how precisely 
to convert FreeHand paths to Macromedia Flash paths—from None (no compression and the 
greatest number of points) to Maximum (for the most compression but lowest quality and 
fewest points).

5 If the artwork contains dashed lines, select Trace Dashed Strokes to convert each dash segment 
to a separate object. This option increases export time and file size.

6 For Image Compression, choose the image quality and compression for converting bitmap 
images to JPEG format—None (highest quality, lowest compression) to Maximum (lowest 
quality, highest compression).

7 Choose a Text option to control how to export text:

Maintain Blocks keeps all the text together in a FreeHand text block for editing in 
Macromedia Flash 3 or later. 

Convert to Paths converts text to vector paths, so the text is no longer editable as text. Text 
attached to a path or text flowing inside a path is automatically converted to paths and 
therefore is not editable in Macromedia Flash. (This option yields a smaller file size than 
Maintain Text Blocks.)

None omits all text from the exported file. 

8 Select the pages to export.
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9 Choose an Animation option to export layer-based frames, page-based frames, or both:

Layers and Pages exports one SWF file that contains all the FreeHand document content. All 
layers of the first page are exported as a sequence of frames, followed by all layers of the second 
page, and so on. Each page can be used as a scene.

Layers exports each page as a separate SWF file, with the layers of each page becoming frames 
in the respective SWF file. The frames are sequenced from the bottom layer to the top layer. 
Objects on layers below the separator bar in the Layers panel are exported as one background 
layer that appears in each frame in the SWF file. However, the Guides layer and hidden layers 
are not exported.

Pages exports each page as a Macromedia Flash frame in one SWF file. The layers of each page 
make up the image for that page (or frame, in Macromedia Flash).

None exports each page of the FreeHand file as a separate SWF file. The layers of each page 
make up a still image for that page.

Note: If you choose Layers and Pages or Pages, each frame is the same size as the first page exported. If you 
choose Layers or None, each page is a separate SWF, and the movie size is the same as the page size.

10 Specify a frame rate for the Macromedia Flash movie in frames per second (fps). As in 
Macromedia Flash, choose a frame rate from 0.01 fps to 120 fps, in increments of 0.01. For the 
smoothest animations, use 12 fps.

11 Select Autoplay to begin the animation automatically at the specified frame rate in the 
stand-alone Macromedia Flash Player. Deselect the option to stop the animation at Frame 1 in 
the stand-alone Macromedia Flash Player; choose Control > Play to start the animation.

12 Select FullScreen Playback to play the entire animation at full screen until you press Esc.This 
option has no affect on Macromedia Flash animations played in a web browser. 

13 For Compatibility, choose the Macromedia Flash version format to which to export the file.

14 Select Protect from Import to prevent a SWF file exported by FreeHand from being imported 
by other users.

15 Select High Quality Printing to print each frame in the SWF animation at high resolution 
from the stand-alone Macromedia Flash Player, version 4.0 or later, or browser plug-in. When 
this option is deselected, the file prints using the browser’s screen resolution (72 dpi). 

16 Click OK, and then click Save (Windows) or Export (Macintosh).

To test your movie, see the procedure in the following section.
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Using the FreeHand Controller or Control menu with 
Flash MX SWF files

You can use the Controller or the Control menu to test, change movie settings for, and export 
SWF movie files.

To test movies, you can play, stop, rewind, step forward, and step backward through frames. 
When you test a movie, FreeHand creates a temporary SWF file and displays it in a Macromedia 
Flash Playback window. The temporary file is deleted when you close the window, unless you 
choose to export the file.

You can drag the Controller to reposition it in the application. 

To display the Controller:

Choose Window > Toolbars > Controller.

To test a movie, do one of the following:

• To launch the Macromedia Flash Playback window and play the movie, click the Test Movie 
button in the Controller, choose Control > Test Movie, or press Control+Enter (Windows) or 
Command+Return (Macintosh).

• To step through the frames of the movie, use the Step Forward and Step Backward buttons in 
the Controller, choose Control > Step Forward or Control > Step Backward, or use the Right 
Arrow and Left Arrow keys.

• To go to the first or last frame in a movie, use the Rewind and Fast Forward buttons in the 
Controller. To go to the first frame, you can also choose Control > Rewind.

• To stop playback, click the Stop button in the Controller, choose Control > Stop, or press 
Enter (Windows) or Return (Macintosh).

• To resume playing the movie if it has stopped, click the Play button in the Controller, choose 
Control > Play, or press Enter or Return again.

To change movie settings:

1 Click the Movie Settings button in the Controller, or choose Control > Movie Settings.

2 In the Movie Settings dialog box, select options to format the movie, as described in 
“Exporting FreeHand documents as Macromedia Flash MX movies” on page 366.

Step Forward

Last Frame

Test MoviePlay

Step Backward

First Frame

Stop

Export Movie

Movie Settings
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To export a movie:

1 To launch the Macromedia Flash Playback window and create a SWF file of the FreeHand 
document, click the Test Movie button in the Controller, choose Control > Test Movie, or 
press Control+Enter (Windows) or Command+Return (Macintosh).

2 Click the Export button in the Controller, or choose Control > Export Movie.

3 In the Export Movie dialog box, enter a name for the movie and choose a location where it 
will be saved. 

4 Click Save.

The movie is saved with the current settings specified in the Movie Settings dialog box.
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II
Part VII
ColdFusion MX Server

The chapters in Part VII introduce the Macromedia 
ColdFusion MX Server and guide you through the 
installation of the Developer Edition of the server. They 
also provide information on Macromedia resources. 

The following chapters are in this part:

• Chapter 16, “Installing the Developer Edition of 
Macromedia ColdFusion MX Server”

• Chapter 17, “Welcome to Macromedia ColdFusion MX”





CHAPTER 16

Installing the Developer Edition of

Macromedia ColdFusion MX Server

The Developer Edition is a free, non-expiring version of Macromedia ColdFusion MX Server 
that you can install from the Macromedia Studio MX for Windows CD-ROM. The Developer 
Edition is fully functional, and you can use it with the Studio MX tools to evaluate the 
ColdFusion server scripting environment. 

The Developer Edition is licensed for use on the local host machine and on one remote IP 
address. It is not licensed for deployment.

Macintosh users can download the Developer Edition from www.macromedia.com for 
installation on any supported Windows systems.

After completing the installation, you can take a quick tutorial on building a ColdFusion 
application in Macromedia Dreamweaver MX. See “Dreamweaver tutorial 3: Building a web 
application” on page 118.

ColdFusion MX system requirements for Windows
The following hardware and software are required to run the ColdFusion MX Developer Edition:

• A Pentium processor with 128 MB of RAM (256 recommended), 650 MB of free hard disk 
space, and a CD_ROM drive

• Microsoft Windows 98, ME, NT 4.0, 2000, or XP
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Installing Macromedia ColdFusion MX Server on Windows
The following steps guide you through the installation.

To install Macromedia ColdFusion MX on Windows:

1 Open the Macromedia Studio MX CD-ROM.

2 Select ColdFusion MX on the installer screen to open the Install Wizard.

3 Follow the prompts to complete the License and Customer Installation screens.

4 Select either Complete or Custom installation.

5 Select a web server from the Web Server screen.

The screen lists all web servers detected on your system. Macromedia recommends installing 
the stand-alone web server that comes with ColdFusion MX.

6 Accept the default webroot folder location or browse to select a different folder.

7 Complete the entries in the Select Password screen to secure the ColdFusion Administrator.

8 Click Install on the Ready to Install screen to copy the files and configure the system. 

After the installation finishes, you are prompted to restart your system. 
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Confirming the installation of and administering 
ColdFusion MX Server

After installation, ColdFusion MX runs as a service in Windows. 

To check the status of the server:

In the Windows Start menu, select Settings > Control Panel > Administrative Tools > Services. 
You can select Macromedia ColdFusion MX Application Server from the list to stop, start, or set 
a startup option for the server.

To open the ColdFusion Administrator:

Choose Start > Macromedia ColdFusion MX > Administrator.

The browser-based Administrator gives you access to all the server features and configuration 
settings, plus documentation and developer resources. 

To uninstall Macromedia ColdFusion MX:

Choose Start > Settings > Control Panel > Add/Remove Programs > 
Macromedia ColdFusion MX Server.
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CHAPTER 17

Welcome to Macromedia ColdFusion MX

Macromedia ColdFusion MX Server is a rapid server scripting environment that lets you quickly 
create robust sites and Internet applications without a long learning curve. ColdFusion MX does 
not require coding in traditional programming languages (for example, C/C++, Java, and XML), 
although it supports these traditional programming languages.

The Developer Edition of ColdFusion MX for Windows can be installed for evaluation purposes. 
You can develop and test web applications on the local host and on one remote IP address. This 
edition is not licensed for deployment. For information on installing this edition, see Chapter 16, 
“Installing the Developer Edition of Macromedia ColdFusion MX Server,” on page 373.

If you want to take a quick tutorial on building a ColdFusion application in Macromedia 
Dreamweaver MX, see “Dreamweaver tutorial 3: Building a web application” on page 118.

Macromedia ColdFusion MX consists of the following core components: 

• ColdFusion MX Server

• ColdFusion Markup Language (CFML) and erver-side ActionScript

• ColdFusion Administrator

The following sections describe these core components in more detail.

The ColdFusion MX Server
ColdFusion MX is a server software program that resides on the same machine as your web server 
software. It is the program that parses (reads and interprets) and processes supplied instructions. 
These instructions are passed to ColdFusion through ColdFusion pages, which use a .cfm or .cfc 
file extension. A ColdFusion page looks like an HTML page but contains special tags that 
instruct the ColdFusion server to perform specific operations.

The ColdFusion Markup Language
ColdFusion Markup Language (CFML) is a tag-based language, similar to HTML, that uses special 
tags and functions to interact with back-end resources and dynamically generate pages. With CFML, 
you can enhance your standard HTML files with database commands, conditional operators, and 
high-level formatting functions, and rapidly produce easy-to-maintain web applications.

CFML looks similar to HTML: it includes start and end tags, and each tag is enclosed in angle 
brackets. All ending tags are preceded with a forward slash (/) and all tag names are preceded with 
cf. The following is an example:

<cfstarttagname> </cfendtagname>
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Building ColdFusion applications with CFML

You build ColdFusion applications as a series of pages that use CFML. Developers can extend this 
language by creating their own custom tags or user-defined functions (UDF), or by integrating 
COM, C++, and Java components (such as JSP tag libraries). 

Building ColdFusion applications with erver-side ActionScript

ColdFusion MX connects to Macromedia Flash Player 6, providing the ideal environment for 
integrating Macromedia Flash interfaces with back-end data and applications. Support for server-
side ActionScript enables Macromedia Flash developers to easily integrate their work with that of 
application developers or to develop entire dynamic solutions on their own.

ColdFusion interaction with data sources

ColdFusion applications can interact with any database that supports a JDBC technology-based 
driver. A JDBC technology-based driver uses an Application Programming Language (API) to 
execute SQL statements to databases on most platforms. However, ColdFusion is not limited to 
JDBC data sources. You can also interact with existing Open Database connectivity (ODBC) 
data sources by using ODBC Socket, a driver that interacts with an existing ODBC driver. 

ColdFusion development tools

While you can code your ColdFusion application with NotePad or any HTML editor, 
Macromedia recommends that you build your applications using Macromedia Dreamweaver MX. 
Dreamweaver MX offers features and wizards that enhance ColdFusion development.

How ColdFusion processes pages

The following steps explain how the ColdFusion server processes a ColdFusion page:

1 The ColdFusion server looks at the content of the page and searches for the following 
ColdFusion instructions: 

• Tags that begin with cf

• Variables and functions that are always surrounded by pound signs (#) 

2 If the ColdFusion server finds any HTML or plain text in the page, the ColdFusion server 
returns it to the web server untouched. 

3 The ColdFusion server processes all the ColdFusion instructions found and returns any 
remaining results to the web server. The web server then sends the entire output to the browser.
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The ColdFusion Administrator
You use the ColdFusion Administrator to configure and maintain the ColdFusion application 
server. It is a web-based application that you can access using any web browser, from any 
computer with an Internet connection.

You can manage the following configuration options with the ColdFusion Administrator:

• ColdFusion data sources

• Debugging output

• Server settings 

• Application security
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Key benefits and features of ColdFusion 
With ColdFusion MX, it’s easy to develop applications in record time. ColdFusion MX delivers 
powerful Internet capabilities within an easy-to-learn and highly productive server-scripting 
environment.

• Intuitive tag-based language requires fewer lines of code by handling low-level programming 
tasks automatically and simplifying code reuse.

• New server-side ActionScript enables Macromedia Flash developers to use the same scripting 
language for both client and server logic.

• Complete support for new ColdFusion MX features within the Dreamweaver MX 
development environment includes powerful visual layout and prototyping, enhanced code 
editing and development capabilities, and integrated debugging.

ColdFusion MX lets you deliver a more compelling user experience. It provides a robust 
architecture and rich set of built-in capabilities that deliver high performance and scalability and 
enhance your applications with advanced functionality.

• Fully integrated application services let you add full-text search, dynamic charting, and 
high-performance connectivity to Macromedia Flash clients to your applications.

• An innovative architecture delivers the scalability, reliability, and power of the Java platform 
without the complexity.

• Custom tag libraries, reusable components, Java/C++, and thousands of available third-party 
add-ons allow for complete extensibility.

ColdFusion MX supports industry standard protocols and common platforms, and easily 
integrates with your existing technology infrastructure. 

• ColdFusion MX provides highly approachable integration with all of the major Internet standards 
and component models, including XML, web services, Java, .NET/COM, and CORBA.

• With ColdFusion MX, you can develop and deploy applications on a stand-alone ColdFusion 
MX server or on leading Java application servers such as IBM WebSphere.

• ColdFusion MX provides support for the leading server operating systems, web server software, 
mail servers, directory servers, file systems, and relational database management systems.

What’s new in ColdFusion MX Server
ColdFusion MX introduces a set of innovations that will speed your development and allow you 
to access and use powerful new technologies easily.

Some of the exciting features in ColdFusion MX include the following:

• Native CFML support for parsing, manipulating, and creating XML 

• ColdFusion Components for better organizing your applications and reusing code 

• Simple creation and consumption of web services 

• Increased integration with Java, Macromedia Flash MX, and Microsoft .NET 

• Ability to create ActionScript files that reside on the server 

• UNICODE support and expanded support for non-U.S. locales 

• Increased flexibility in deployment 
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For details on these and other exciting features and enhancements, see http://
www.macromedia.com/software/coldfusion/.

ColdFusion MX integration features
This release greatly advances the ability of ColdFusion to work more productively within the 
MX family of products. In addition, the application also extends its reach into standards-based 
Internet platforms.

Using ColdFusion MX with Dreamweaver MX

ColdFusion MX provides tighter integration with Dreamweaver MX for building and debugging 
dynamic websites and applications with CFML and HTML. For information on building a 
website using Dreamweaver and ColdFusion, see “Dreamweaver tutorial 3: Building a web 
application” on page 118.

Using ColdFusion MX with Flash MX

ColdFusion MX also provides better integration with Macromedia Flash MX for building 
high-performance Internet applications that take advantage of the interactivity and portability 
of the Macromedia Flash Player in building next-generation Internet user interfaces

ColdFusion MX provides native Flash connectivity, which lets you create Internet applications 
using Macromedia Flash MX and ColdFusion MX. This native capability ensures that visual 
applications created with Flash MX can easily interact with ColdFusion MX in an efficient, 
secure, and reliable way. Flash uses the Action Message Format (AMF) over HTTP, which 
provides fast, lightweight, binary transfer of data between the Flash client and ColdFusion MX.

To create ColdFusion applications with a Flash interface, you must use Flash MX and 
ActionScript. Flash MX includes ActionScript commands that connect ColdFusion components 
(CFC) and ColdFusion pages. Using the Flash MX application debugger, you can trace your 
application logic as it executes between Flash and ColdFusion. This new capability lets developers 
build complete, data-driven applications in ActionScript. These applications run on the Flash 
client and the ColdFusion server. For more information about using Flash MX, see Flash Help.

ColdFusion MX integration with web technologies

ColdFusion MX introduces the ability to easily publish and consume standards-based XML web 
services from within the ColdFusion MX environment. Web services play a central role Microsoft’s 
.NET initiative. They are also being strongly backed by other leading vendors, including Sun 
Microsystems through the Sun ONE initiative and IBM through IBM Web Services. 

Developers using ColdFusion MX can now integrate CFML more closely with Java components 
and applications. As a result, ColdFusion MX simplifies collaboration between Java developers 
and CFML developers and enables users to more easily partition their application logic between 
components written in CFML and additional components written in Java. This tighter 
integration with Java platform technologies also enables ColdFusion MX to take full advantage of 
the integration services offered by third-party application servers, such as legacy connectors or 
messaging middleware.
Welcome to Macromedia ColdFusion MX 381



ColdFusion Components

ColdFusion MX features a new technology that empowers application developers to easily create 
component-based applications that can be used from rich clients, as web services, and enable a 
more scalable development and deployment model. ColdFusion Components (CFCs) provide a 
simple yet powerful model for rapid development of web components. The CFC model is 
immediately approachable to developers familiar with scripting languages such as ColdFusion 
Markup Language, JavaScript, and PHP. 

Within a local application running on the server, CFCs let developers package functionality in a 
reusable way, enabling better-structured code, easier team development, and more maintainable 
systems. They also provide a means for developers to encapsulate complex functionality for use by 
other developers. The component method can easily accommodate complex processes for 
accessing customer data.

Learning ColdFusion MX
Macromedia is committed to setting the standard for customer support in developer education, 
documentation, technical support, and professional services. The Macromedia website is designed 
to give you quick access to the entire range of online resources. The following table shows the 
locations of these resources.

Resource Description URL

Macromedia 
website

General information about Macromedia 
products and services

http://www.macromedia.com

Information on 
ColdFusion

Detailed product information on ColdFusion 
and related topics

http://www.macromedia.com/coldfusion

Macromedia 
ColdFusion 
Support Center

Professional support programs that 
Macromedia offers

http://www.macromedia.com/support/
coldfusion

ColdFusion Online 
Forum

Access to experienced ColdFusion 
developers through participation in the 
Online Forums, where you can post 
messages and read replies on many 
subjects relating to ColdFusion

http://webforums.macromedia.com/coldfusion/

Installation support Support for installation-related issues for all 
Macromedia products

http://www.macromedia.com/support/
coldfusion/installation.html

Training Information about classes, on-site training, 
and online courses offered by Macromedia

http://www.macromedia.com/support/training

Developer 
resources

All the resources that you need to stay on 
the cutting edge of ColdFusion 
development, including online discussion 
groups, Knowledge Base, technical papers, 
and more

http://www.macromedia.com/desdev/
developer/

Reference Desk Development tips, articles, documentation, 
and white papers

http://www.macromedia.com/v1/developer/
TechnologyReference/index.cfm

Macromedia 
Alliance

Connection with the growing network of 
solution providers, application developers, 
resellers, and hosting services creating 
solutions with ColdFusion

http://www.macromedia.com/partners/
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