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art I
Part I
Getting Started

Familiarize yourself with Dreamweaver MX visual design, 
hand-coding, and application development tools by 
creating a simple but functional website.

This part contains the following chapters:

• Chapter 1, “Introduction”

• Chapter 2, “Creating Your First Website in 
Dreamweaver”

• Chapter 3, “Editing code in Dreamweaver”

• Chapter 4, “Understanding Web Applications”

• Chapter 5, “Developing a Web Application in 
Dreamweaver MX”

• Chapter 6, “Installing a Web Server in Windows”

• Chapter 7, “Setup for Sample ColdFusion Site”

• Chapter 8, “Setup for Sample ASP.NET Site”

• Chapter 9, “Setup for Sample ASP Site”

• Chapter 10, “Setup for Sample JSP Site”

• Chapter 11, “Setup for Sample PHP Site”

• Chapter 12, “Troubleshooting Database Connections”





CHAPTER 1

Introduction

This guide is designed to introduce you to using Macromedia Dreamweaver MX if you’re 
unfamiliar with any major aspect of it. The lessons in this guide lead you through the process of 
creating a simple but functional website.

Macromedia Dreamweaver MX is a professional HTML editor for designing, coding, and 
developing websites, web pages, and web applications. Whether you enjoy the control of hand-
coding HTML or prefer to work in a visual editing environment, Dreamweaver provides you with 
helpful tools to enhance your web creation experience. 

The visual editing features in Dreamweaver let you quickly create pages without writing a line of 
code. If you prefer to code by hand, however, Dreamweaver also includes many coding-related 
tools and features. And Dreamweaver helps you to build dynamic database-backed web 
applications using server languages such as ASP, ASP.NET, ColdFusion Markup Language 
(CFML), JSP, and PHP.

Note: This guide is not a comprehensive manual for all of the features of Dreamweaver MX, nor is it an introduction 
to web design. For more detailed information about Dreamweaver, see Dreamweaver Help (choose Using 
Dreamweaver from the Help menu).

Learning Dreamweaver basics
To begin learning to use Dreamweaver, start with this Getting Started guide. Then proceed to 
other resources, such as the tutorials, the help system, and the Support Center.

How to use this guide

The guide is divided into several chapters. You can read the chapters in order, or you can read the 
rest of this introduction and then start with the chapter that best suits your interests and 
experience. Within each chapter, we recommend following the lessons in order; the order of the 
lessons is designed to roughly imitate a common workflow for creating a website.

The following list describes each chapter’s contents:

• This introduction explains how to install Dreamweaver and introduces the Dreamweaver 
workspace. Read this chapter first; then read whichever of the other chapters interests you most.

Note: Many aspects of the workspace have changed in this version of Dreamweaver, so you may want to read 
this introduction even if you’ve used Dreamweaver before.

• Chapter 2, “Creating Your First Website in Dreamweaver,” on page 19 is for people who have 
created web pages but have never used Dreamweaver before. It shows you the basics of how to 
create a small but functional static website using Dreamweaver’s visual authoring tools.
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• Chapter 3, “Editing code in Dreamweaver,” on page 49 is aimed primarily at hand-coders (such 
as Macromedia HomeSite users), but it is also for anyone who has used visual tools and would 
like to start editing code. It shows you the basics of using Dreamweaver’s code-editing tools.

• Chapter 4, “Understanding Web Applications,” on page 59 provides conceptual background 
about web applications. 

• Chapter 5, “Developing a Web Application in Dreamweaver MX,” on page 69 is aimed at 
anyone who has created static pages before (whether using Dreamweaver or not) and would 
like to learn to create database-driven web applications using Dreamweaver. It guides you 
through the process of building a simple web application.

• A set of setup instructions provide information on installing a web server and on setting up 
dynamic sites using various server languages.

• A set of tutorials provide detailed instructions on accomplishing some common tasks.

The lessons in this guide use page layouts and sample content provided with Dreamweaver. If 
you’d prefer to create your first Dreamweaver site using your own layouts and content instead, 
you can do so, but the lessons are easier to follow if you use the sample content provided.

Other resources 

Dreamweaver includes a variety of resources to help you learn the program quickly and become 
proficient in creating your own websites and pages. These resources include the following:

• A set of tutorials provide further lessons on particular topics, giving more information in 
specific areas than the rest of the Getting Started guide.

• Dreamweaver Help includes comprehensive information about using all aspects of 
Dreamweaver, as well as an HTML version of Getting Started and the tutorials. Dreamweaver 
Help is displayed in the help viewer provided by your operating system: Microsoft HTML 
Help (Windows) or Apple Help (Macintosh).

• Using Dreamweaver is a PDF version of the contents of Dreamweaver Help (excluding Getting 
Started and the tutorials), providing information on using Dreamweaver commands and 
features. Certain reference topics are not included in the PDF version; for information on 
those topics, see Dreamweaver Help. The PDF file is available on your Dreamweaver CD.

In addition, you can find regularly updated tips, TechNotes, examples, tutorials, and information, 
at the Dreamweaver Support Center (http://www.macromedia.com/support/dreamweaver/).

For information about other informational and instructional resources for Dreamweaver, see 
Dreamweaver Help.

Typographical conventions 

The following typographical conventions are used in this guide:

• Menu items are shown in this format: menu name > menu item name. Items in submenus are 
shown in this format: menu name > submenu name > menu item name.

• Code font indicates HTML tag and attribute names as well as literal text used in examples.

• Italic code font indicates replaceable items (sometimes called metasymbols) in code. 

• Bold roman text indicates text for you to enter verbatim.
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Installing and running Dreamweaver
This section describes the system requirements for running Dreamweaver and explains how to 
install Dreamweaver. It also explains how you can customize Dreamweaver to suit your own 
preferences in a multiuser operating system such as Windows XP or Mac OS X.

System requirements 

The following hardware and software is required to run Dreamweaver.

System requirements for Microsoft Windows: 

• An Intel Pentium II Processor or equivalent, 300 MHz or faster

• Windows 98, Windows 2000, Windows NT (with Service Pack 3 or later), Windows ME, or 
Windows XP

• Version 4.0 or later of Netscape Navigator or Microsoft Internet Explorer

• 96 MB of available random-access memory (RAM) (128 MB recommended)

• 275 MB of available disk space

• A 256-color monitor capable of 800 x 600 pixel resolution (millions of colors and 
1024 x 768 pixel resolution recommended)

• A CD-ROM drive

System requirements for Apple Macintosh: 

• A Power Macintosh G3 or later

• Mac OS 9.1, Mac OS 9.2.1, or Mac OS X 10.1 or later

• Mac OS Runtime for Java (MRJ) 2.2 or above (included on the Dreamweaver MX CD)

• Version 4.0 or later of Netscape Navigator or Microsoft Internet Explorer

• 96 MB of random-access memory (RAM) (128 MB recommended)

• 275 MB available disk space

• A 256-color monitor capable of 800 x 600 pixel resolution (millions of colors and 
1024 x 768 pixel resolution recommended)

• A CD-ROM drive

Installing Dreamweaver 

Follow these steps to install Dreamweaver on either a Windows or a Macintosh computer.

Note: In certain operating systems, you can install or uninstall Dreamweaver only if you have administrative privileges 
on your computer. For more information, see “Using Dreamweaver in a multiuser environment” on page 14.

To install Dreamweaver:

1 Insert the Dreamweaver CD into the computer’s CD-ROM drive.

2 Choose from the following options:

• In Windows, choose Start > Run. Click Browse and choose the Dreamweaver MX Installer.exe file 
on the Dreamweaver CD. When the Run dialog box appears, click OK to begin the installation.

• On the Macintosh, double-click the Dreamweaver MX Installer icon.
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3 Follow the onscreen instructions.

4 If prompted, restart your computer.

Using Dreamweaver in a multiuser environment

In a multiuser operating system such as Windows NT, Windows 2000, Windows XP, or 
Mac OS X, applications are generally installed into a folder from which all users can run them, 
such as C:\Program Files (Windows) or the Applications folder (Macintosh). Only users with 
administrative privileges can install applications into such folders in a multiuser operating system.

You can customize Dreamweaver in many ways. Dreamweaver prevents any user’s customized 
configuration from affecting any other user’s customized configuration. To accomplish this goal, 
the first time you run Dreamweaver in one of the multiuser operating systems that it recognizes, 
the application creates copies of a variety of configuration files for you. These user configuration 
files are stored in a folder belonging to you.

Note: In older operating systems (Windows 98, Windows ME, and Mac OS 9.x), a single set of Dreamweaver 
configuration files is shared by all users, even if the operating system is configured to support multiple users.

If you reinstall or upgrade Dreamweaver after installing Dreamweaver MX, Dreamweaver 
automatically makes backup copies of existing user configuration files, so that if you’ve 
customized those files by hand, you still have access to the changes you made. For information 
about customizing configuration files by hand, see “Customizing Dreamweaver” on the 
Macromedia Support Center at http://www.macromedia.com/go/customizing_dreamweaver.

When you uninstall Dreamweaver from a multiuser system, Dreamweaver can remove each user 
configuration folder for you.

Registering Dreamweaver MX

To get additional Macromedia support, it’s a good idea to register your copy of Macromedia 
Dreamweaver MX, electronically or by mail.

When you register, you can sign up to receive up-to-the-minute notices about upgrades and new 
Macromedia products. You can also sign up for timely e-mail notices about product updates and new 
content appearing on both the www.macromedia.com and the www-euro.macromedia.com websites.

To register Macromedia Dreamweaver MX, do one of the following: 

• Choose Help > Online Registration and fill out the electronic form.

• Choose Help > Print Registration, print the form, and mail it to the address shown on the form.

A first look at the Dreamweaver workspace
In Windows, Dreamweaver MX provides two workspace layouts to choose between: an 
all-in-one-window integrated layout and a floating layout much like that of Dreamweaver 4.

On the Macintosh, only the floating layout is available.

This section explains how to choose an initial workspace layout in Windows. This section also 
describes the primary elements of the workspace in both Windows and Macintosh.
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Choosing a workspace layout (Windows only)

In Windows, the first time you start Dreamweaver, a dialog box appears that lets you choose a 
workspace layout. If you change your mind later, you can switch to a different workspace using 
the Preferences dialog box.

To choose a workspace layout:

Select one of the following layouts:

Dreamweaver MX Workspace is an integrated workspace using MDI (Multiple Document 
Interface), in which all Document windows and panels are integrated into one larger application 
window, with the panel groups docked on the right. Recommended for most users.

Note: Most of this guide assumes that you’re using the integrated Dreamweaver MX workspace.

Dreamweaver MX Workspace, HomeSite/Coder-Style is the same integrated workspace, but with 
the panel groups docked on the left, in a layout similar to that used by Macromedia HomeSite 
and Macromedia ColdFusion Studio, and with Document windows showing Code view by 
default. Recommended for HomeSite or ColdFusion Studio users and other hand-coders who 
want a familiar workspace layout. To choose this layout, select the Dreamweaver MX Workspace 
option, then select the HomeSite/Coder-Style option.

Note: You can dock panel groups on either side of the workspace in either of the integrated workspace layouts.

Dreamweaver 4 Workspace is a workspace layout similar to the one used in Dreamweaver 4, with 
each document in its own separate floating window. Panel groups are docked together, but are not 
docked into a larger application window. Recommended only for Dreamweaver 4 users who 
prefer to use a more familiar workspace.
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Windows and panels overview

The following are brief descriptions of the windows and other elements in Dreamweaver’s 
workspace. Some specifics on how to use these windows appear later in this guide; for more 
detailed information, see Dreamweaver Help (Help > Using Dreamweaver).

The Welcome window provides tips on setting up your workspace for various purposes, and 
information on new features for those who have used previous versions of Dreamweaver.

The Insert bar contains buttons for inserting various types of “objects,” such as images, tables, and 
layers, into a document. Each object is a piece of HTML code that allows you to set various 
attributes as you insert it. For example, you can insert an image by clicking the Image icon in the 
Insert bar. If you prefer, you can insert objects using the Insert menu instead of the Insert bar.

The Document toolbar contains buttons and pop-up menus that provide different views of the 
Document window (such as Design view and Code view), various viewing options, and some 
common operations such as previewing in a browser.

The Document window displays the current document as you create and edit it.

The Property inspector lets you view and change a variety of properties for the selected object or 
text. Each kind of object has different properties.

Document toolbar

Property inspector

Tag selector

Welcome window Panel groups

Site panel

Document window

Insert bar
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Panel groups are sets of related panels docked together under one heading. To expand a panel 
group, click the expander arrow at the left of the group’s name; to undock a panel group, drag the 
gripper at the left edge of the group’s title bar.

The Site panel allows you to manage the files and folders that make up your site. For more 
information, see “Set up a local site” on page 20. It also provides a view of all the files on your 
local disk, much like Windows Explorer (Windows) or the Finder (Macintosh).

Dreamweaver provides many other panels, inspectors, and windows not shown here, such as the 
History panel and the Code inspector. To open Dreamweaver panels, inspectors, and windows, 
use the Window menu.

Menus overview

This section provides a brief overview of the menus in Dreamweaver.

The File menu and Edit menu contain the standard menu items for File and Edit menus, such as 
New, Open, Save, Cut, Copy, and Paste. The File menu also contains various other commands for 
viewing or acting on the current document, such as Preview in Browser and Print Code. The Edit 
menu includes selection and searching commands, such as Select Parent Tag and Find and 
Replace, and provides access to the Keyboard Shortcut Editor and the Tag Library Editor. The 
Edit menu also provides access to Preferences, except on the Macintosh in Mac OS X, where 
Preferences are in the Dreamweaver menu.

The View menu allows you to see various views of your document (such as Design view and Code 
view) and to show and hide various kinds of page elements and various Dreamweaver tools.

The Insert menu provides an alternative to the Insert bar for inserting objects into your 
document.

The Modify menu allows you to change properties of the selected page element or item. Using this 
menu, you can edit tag attributes, change tables and table elements, and perform various actions 
for library items and templates.

The Text menu allows you to easily format text.

The Commands menu provides access to a variety of commands, including one to format code 
according to your formatting preferences, one to create a photo album, and one to optimize an 
image using Macromedia Fireworks.

The Site menu provides menu items to create, open, and edit sites, and (on the Macintosh) to 
manage files in the current site.

The Window menu provides access to all of the panels, inspectors, and windows in Dreamweaver.

The Help menu provides access to Dreamweaver documentation, including help systems for using 
Dreamweaver, creating extensions to Dreamweaver, and reference material for a variety of languages.

In addition to the menu-bar menus, Dreamweaver provides many context menus, which give you 
easy access to useful commands pertaining to the current selection or area. To display a context 
menu, right-click (Windows) or Control-click (Macintosh) an item in a window. All items in 
context menus can also be found in menu-bar menus.
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View the sample site
The examples used in this guide are drawn from a small sample site for a fictional company called 
Global Car Rentals. Before beginning the lessons, view the sample site in a browser to get an idea 
of what you’ll be creating as you work through the lessons.

To view the sample site in a browser:

1 Open the Samples folder in the Dreamweaver application folder. Then open the 
GettingStarted folder, then the FinalSite folder.

2 Double-click the index.htm file in the FinalSite folder to view the site in a browser.

3 When you’re done viewing the sample site, proceed to whichever chapter of this guide interests 
you the most.
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CHAPTER 2

Creating Your First Website in Dreamweaver

This chapter provides a series of brief lessons that guide you through the process of creating a 
simple static website using the visual authoring tools in Macromedia Dreamweaver MX. For 
information on using the hand-coding tools in Dreamweaver, see Chapter 3, “Editing code in 
Dreamweaver,” on page 49; for information on creating a database-driven dynamic web 
application, see Chapter 4, “Understanding Web Applications,” on page 59.

The order of lessons in this chapter follows one possible workflow for creating a site. When 
creating your own sites, you can follow whatever workflow is most comfortable for you.

To create a static website:

1 Plan and prepare (see “Set up a local site” on page 20 and “Add assets to your site” on page 25).

2 Create pages (see “Create and save a new page” on page 26).

3 Lay out and set up the pages (see “Adjust the layout” on page 29 and “Set a page title” on page 
35).

4 Add content to your pages (see “Add styled text” on page 35 and “Add images” on page 39).

5 Link pages together (see “Add text links between pages” on page 44 and “Create rollovers for 
graphical links” on page 44).

6 Publish your site (see “Preview in browser” on page 46 and “Set up a remote site, then publish” 
on page 47).
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Set up a local site
The most common approach to creating a website using Dreamweaver is to create and edit pages 
on your local disk, and then upload copies of those pages to a remote web server to make them 
publicly available. It’s possible to use Dreamweaver in other ways (such as running a web server on 
your local computer, or uploading files to a staging server, or using a mounted disk as if it were 
your local disk), but the lessons in this guide assume that you’re working locally and then 
uploading to a remote server.

In Dreamweaver, the word site is used as shorthand to refer to any of the following things:

• A website: a set of pages on a server, to be viewed by a visitor to the site using a web browser.

• A remote site: the files on the server that make up a website, from your (the author’s) point of 
view rather than a visitor’s point of view.

• A local site: the files on your local disk that correspond to the files in the remote site. You edit 
the files on your local disk, then upload them to the remote site.

• A Dreamweaver site definition: a set of defining characteristics for a local site, plus 
information on how the local site corresponds to a remote site.

Normally, you would start creating a website by planning it: figuring out how many pages to 
create, what content appears on each page, and how the pages are connected to each other. In this 
lesson, though, the site you’re creating is a very simple one, so it doesn’t take much planning: it 
will consist of only two web pages, with links between them. So for this site, you can skip the 
planning, and proceed to creating a site definition.

You’ll create a site definition using the Site Definition dialog box. You can fill in this dialog box in 
either of two views: Basic or Advanced. The Basic approach guides you through site setup step by step. 
If you’d rather edit site information without guidance, you can click the Advanced tab at any time.

The following procedure describes how to set options in the Basic version of the dialog box, 
which is also known as the Site Definition Wizard. For details of how to set options in the 
Advanced version, click the Advanced tab and then click the Help button.

To define a site:

1 Choose Site > New Site. (That is, choose New Site from the Site menu.)

The Site Definition dialog box appears.

2 If the dialog box is showing the Advanced tab, click Basic.

The first screen of the Site Definition Wizard appears, asking you to enter a name for your site.
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3 In the text box, enter a name to identify the site within Dreamweaver. The name can be 
anything you want. For example, you could name the site Global Car Rental. 

4 Click Next to proceed to the next step.

The next screen of the wizard appears, asking if you want to work with a server technology.
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5 Select the No option to indicate that for now, this site is a static site, with no dynamic pages.

To set up a site to create a web application, you would need to choose a dynamic document 
type—such as Macromedia ColdFusion, Microsoft Active Server Pages (ASP), Microsoft 
ASP.NET, Sun JavaServer Pages (JSP), or PHP: Hypertext Preprocessor (PHP)—and then 
supply information about your application server (For more information, see Chapter 5, 
“Developing a Web Application in Dreamweaver MX,” on page 69).

6 Click Next to proceed to the next step.

The next screen of the wizard appears, asking how you want to work with your files.

7 Select the option labeled “Edit local copies on my machine, then upload to server when ready 
(recommended).”

There are a variety of ways that you can work with files during site development, but for the 
purposes of this lesson, choose this option.

8 The text box allows you to specify a folder on your local disk where Dreamweaver should store 
the local version of the site’s files. It’s easier to specify an accurate folder name if you browse to 
the folder rather than typing the path, so click the folder icon next to the text box.

The Choose Local Root Folder for Site dialog box appears.

9 In the Choose Local Root Folder for Site dialog box, start by navigating to a folder on your 
local disk where you can store all of your sites. Don’t click OK yet.
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Note: This sites folder will eventually contain multiple sites, so don’t choose the sites folder as the local root 
folder. You will soon create a local root folder for this particular site inside the sites folder.

If you don’t already have a sites folder, create one now (using the folder-creation button in the 
Choose Local Root Folder for Site dialog box). Name the folder Sites. The recommended 
location for the sites folder depends on your operating system:

• In Windows, if you don’t already have a place to store sites, create a folder at the top level of 
your C drive, and name the folder Sites. That is, the path to the folder is C:\Sites.

• In Mac OS 9, if you don’t already have a place to store sites, create a folder at the top level of 
your disk drive named Sites.

• In Mac OS X, your home folder (/Users/your_user_name) contains a folder named 
Documents. Navigate to that folder, and create a folder named Sites inside it.

10 Still in the Choose Local Root Folder for Site dialog box, create a new folder inside your Sites 
folder. Name the new folder GettingStarted, and click OK to dismiss the Choose Local Root 
Folder for Site dialog box.

This new folder is the local root folder for your site.

11 Click Next to proceed to the next step.

The next screen of the wizard appears, asking how you connect to your remote server.
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12 For now, choose None from the pop-up menu. Click Next to proceed to the next step.

The next screen of the wizard appears, showing a summary of your settings.

13 Click Done to finish.

You can set up information about your remote site later (see “Set up a remote site, then publish” 
on page 47); for now, the local site information is all you need to start creating a page.

An alert appears to tell you that Dreamweaver will create a site cache. The site cache is a way 
for Dreamweaver to store information about the site, to make various site operations faster.

14 Click OK to allow Dreamweaver to create the site cache.

The Site panel now shows the new local root folder for your current site, and an icon to let you 
view all of your local disks in a hierarchical tree view. The icon is labeled Desktop (Windows) or 
Computer (Macintosh).

The Site panel normally shows all the files and folders in your site, but right now your site doesn’t 
contain any files or folders. When there are files in a site, the file list in the Site panel acts as a file 
manager, allowing you to copy, paste, delete, move, and open files just as you would on a 
computer desktop.

If you already have a set of local HTML files that you want to use to create a website, you can use 
the file browser in the Site panel to copy those files into your newly created site’s folder. However, 
you may want to complete the lessons in this guide using the files provided with Dreamweaver 
before you start using your own files.

If you already have a website on a remote server and you want to edit that site using 
Dreamweaver, see Dreamweaver Help (Help > Using Dreamweaver).
Chapter 224



Add assets to your site

After creating a local site, if you have already created assets (images or other pieces of content) for 
the site, place the assets in a folder inside the local site’s root folder. Then when you’re ready to 
add content to your pages, the assets will be ready to use.

The images and text files for the Global Car Rental site are provided with Dreamweaver. If you’re 
creating the Global Car Rental pages, you must copy the images for the site into your site’s local 
root folder. You can do this using the Site panel.

The assets are inside a folder called Design. For simplicity and consistency with the rest of this 
Getting Started guide, you’ll copy the entire Design folder into your site, then work inside that folder.

To copy a folder of images into your site’s local root folder:

1 If the Site panel isn’t already open, open it by choosing Window > Site.

The Site panel appears. (If the Site panel was already open, it may not appear at this step. If the 
Site panel does not appear, choose Window > Site again to display it.)

2 In the Site panel, expand the Desktop (Windows) or Computer (Macintosh) icon to see your 
available disks.

3 Expand folders as necessary to reach the Dreamweaver application folder.

4 Expand the Samples folder.

5 Expand the GettingStarted folder in the Samples folder.

6 Select the Design folder in the GettingStarted folder and press Control+C (Windows) or 
Command+C (Macintosh) to copy it.

The Design folder contains a folder named Assets, which contains various assets related to the 
site, including an images subfolder.

7 Still in the Site panel, scroll to your site’s local root folder (the folder that you created when you 
defined the site) and select that folder. Then press Control+V (Windows) or Command+V 
(Macintosh) to paste a copy of the Design folder into your site.
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Create and save a new page
Now that your site is set up, you can create web pages to populate it.

When you started Dreamweaver, a blank HTML document was automatically created. Before 
you proceed, close that document.

To close the default blank document:

Choose File > Close.

To create a new page:

1 Choose File > New.

The New Document dialog box appears.

2 In the category list on the left, select the Page Designs category.

The list in the middle column of the dialog box is relabeled Page Designs. A list of 
pre-designed page designs appears.

3 Scroll down in the Page Designs list and choose the item named Text: Article D with 
Navigation.
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Note: There is another item with a similar name. Be careful not to choose the item named Text: Article D, which 
has no navigation bar.

A small preview of the page appears on the right side of the dialog box.

If you prefer, you can create a page using any of the other provided page designs, or create a 
page with no preset design by choosing an item from the Basic Page category. The rest of this 
lesson assumes that you’re using the Text: Article D with Navigation page design.

4 Make sure the Document radio button is selected at the lower right of the dialog box.
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5 Click Create.

A new page appears, using the layout you chose, in a new Document window. The page is 
filled with placeholder “Lorem ipsum” text to show how the page design will look when real 
text is added to it. 

6 Save your document.

To save your new page:

1 Choose File > Save. 

2 In the Save As dialog box, browse to the Design folder inside the site root folder.

Reminder: the site root folder is the folder you created when you set up the site in “Set up a 
local site” on page 20.

3 Enter the filename index.htm.

4 Click Save.

The filename now appears in the title bar of the Document window, in parentheses, after the 
words “Untitled Document.”
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Adjust the layout
The predesigned pages provide a starting point, but they’re unlikely to exactly match the layout 
you need for your own pages.

To modify the layout of a page, use Dreamweaver’s layout tools. This guide touches on some of 
the tools, but for more information, see Dreamweaver Help (Help > Using Dreamweaver).

First, remove the layout elements that you don’t need. To create the Global Car Rental page 
layout, remove several unnecessary tables and cells.

Then add image placeholders and adjust the widths of table columns (using Dreamweaver’s 
Layout view) to make everything fit nicely.

Remove unnecessary elements

In any predesigned page design, there are likely to be elements that you don’t need for your final 
page. You can select such elements and delete them.

If you’re creating the Global Car Rental page, the following elements in the standard page design 
are unnecessary:

• Two of the navigation links at the top of the page

• The title and header area above the main text column

• A small box next to the title in the sidebar column

• The copyright bar at the bottom of the page

The general procedure for removing an element is to select it and then to press Backspace 
(Windows) or Delete (Macintosh). The following procedures show how to select and delete each 
unnecessary element. When you’re done, check to make sure you’ve removed everything you 
intended to remove, then save the document.

To remove unnecessary navigation links:

1 Choose View > Table View > Standard View to ensure that you’re viewing tables in Standard view.

2 In the document’s navigation bar, drag from the table cell with the “Sic Amet” link to the table 
cell with the “Consectetur” link. 

Both table cells are highlighted to indicate that they’re selected.

3 Press Backspace (Windows) or Delete (Macintosh).

The table cells are removed. The other table cells (the “Lorem,” “Ipsum,” and “Dolor” links) 
automatically expand to fill the width of the table.
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To remove the unnecessary text-column title:

1 At the top of the text columns, click the word Title. 

2 In the tag selector at the bottom of the Document window, click the leftmost <table> tag, the 
one that appears immediately to the right of the <body> tag. (If you can’t see the <body> tag in 
the floating workspace, widen the Document window.)

3 Press Backspace (Windows) or Delete (Macintosh) to remove the table containing the title.

Note: There are two <table> tags in the tag selector, because the title area is a table nested inside another 
table. In this case, you should delete the outer table, indicated by the leftmost <table> tag.

To remove the unnecessary box in the sidebar header:

1 In the right column, to the left of the word News, click in the box containing the exclamation 
point.

2 In the tag selector, click the rightmost <td> tag to select the box around the exclamation mark.

3 Press Backspace (Windows) or Delete (Macintosh).
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To remove the unnecessary copyright bar:

1 Scroll to the bottom of the page. Click anywhere in the copyright bar at the bottom.

2 In the tag selector, click the leftmost <table> tag, the one that appears immediately to the right 
of the <body> tag. Then press Delete to remove the table containing the copyright information.

To check and save your page:

1 Look at your page to make sure you’ve removed unnecessary elements.

Your page should now look similar to the following image:

2 Save your document.
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Add an image placeholder

Now create a placeholder to stand in for the image that you’ll add later.

To add an image placeholder:

1 Click at the beginning of the main text column, at the top left of the text, just before the first 
boldface word of the text. Then press Enter (Windows) or Return (Macintosh) to put a blank 
line before the text. Then click in the new blank line.

The insertion point should now be on a line by itself. If it isn’t, place the insertion point on the 
blank line.

2 Choose Insert > Image Placeholder.

3 In the Image Placeholder dialog box, enter a name for the placeholder (such as SplashImage) and 
a width and height. For the Global Car Rental page, enter 523 for width and 220 for height.

Note: Placeholder names must start with a letter and can contain only letters and numbers.
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4 Click OK.

A gray box with the specified dimensions appears. This is a placeholder for an image, used to 
help you lay out pages without having to have the final images on hand.

5 You may need to widen your document window to see the column of text on the right.

Make a column autostretch

The sidebar column of text on the right in the index.htm page is a fixed width. To make it change 
its width as the visitor resizes the browser window, make the column autostretch. Then adjust the 
width of the wide column containing the image placeholder. 

To make the left column autostretch:

1 If the Insert bar is not showing, choose Window > Insert to display it.

2 In the Insert bar, click the Layout tab.

3 Click the Layout View button to switch to Layout view.

4 Read the informational dialog box, then click OK.

For each table in your page, a green tab appears at the table’s upper left corner. The tab is 
labeled “Layout Table.”

5 In the Document window, click the Layout Table tab above and to the left of the image 
placeholder you inserted, to select the table that contains both text columns.

A column header appears over each of the two text columns, showing the width of each column.
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6 If the Document window is too narrow to show all of the column on the right, widen your 
Document window.

Even after you widen your Document window, other Layout Table tabs may obscure the 
number showing the width in the column header on the right. Don’t click those other Layout 
Table tabs.

7 Carefully click the column header over the right column. (Be sure to click above the top of the 
green Layout Table tabs in the right column.)

A pop-up menu appears.

8 In the pop-up menu, choose Make Column Autostretch.

A dialog box appears, titled Choose Spacer Image, to prompt you to choose a spacer image.

Note: If you have already chosen a spacer imager at some point, this dialog box does not appear; in that case, the 
right column is now set to Autostretch. If the dialog box does not appear, skip the rest of this procedure.

9 In the Choose Spacer Image dialog box, select the Use an existing spacer image file option 
and click OK.

Another dialog box appears, titled Select Spacer Image File.

10 In the Select Spacer Image File dialog box, browse to your local root folder and open the 
Assets folder. Then open the Images folder and select spacer.gif, and click OK (Windows) or 
Open (Macintosh).

The right column is now set to Autostretch; in a browser, the right column will be as wide as 
possible after the left column is drawn at its fixed width.

To adjust the width of the main text column:

1 Click the column header over the left column and choose Make Cell Widths Consistent from 
the pop-up menu that appears.

The left column is now set to a fixed width (equal to the width of the image plus the cell 
padding and cell spacing amounts).

2 Click the Standard View button in the Insert bar to switch back to Standard view.

3 Save your document.
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Set a page title
You can set a variety of properties for a page, including its title, background color, text color, and so 
on. (To set page properties, choose Modify > Page Properties.) But if you just want to set the page 
title (the title that appears in the browser’s title bar), you can do that in the Document toolbar.

To set a page title for your document:

1 If the Document toolbar isn’t already visible, choose View > Toolbars > Document.

Dreamweaver’s Document toolbar appears. In the integrated workspace, it appears at the top of the 
document area by default; in the floating workspace, it appears as part of the Document window.

2 In the Title text box, where it says “Untitled Document,” type a title for the page, such as 
Global Car Rental Home Page. Then press Enter (Windows) or Return (Macintosh) to see the 
page title update in the Document window’s title bar.

3 Save your document.

Add styled text
You can type text into the Document window, or copy and paste it from another source (such as a 
Microsoft Word file). Then you can format the text using the CSS Styles panel. 

Before entering text, make sure you’re in Design view by choosing View > Design.

Add text

As you enter and format text in Design view, Dreamweaver creates the underlying HTML code. 
To enter code directly, use Code view. For information on Code view, see Chapter 3, “Editing 
code in Dreamweaver,” on page 49.

The predesigned pages provided with Dreamweaver contain placeholder “Lorem ipsum” text; if 
you’re basing your page on a predesigned page, you’ll have to replace the placeholder text with 
your own text when you’re ready to start adding content. It can be useful to leave the placeholder 
text in place until you’re done with design and layout, though, so that you or your client can look 
at the layout without being distracted by the text.

To add text to your page:

1 Triple-click in the bold placeholder text at the top of the left column (under the image 
placeholder) to select the entire bold paragraph.

2 Type Safety Tips (or your own heading text if you prefer).

Show Code View

Show Design View

Document Title

Refresh Design View

Reference

Code Navigation

View Options

Preview/Debug in Browser

File Management

Live Data View

Show Code and Design Views
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3 Select the three paragraphs of placeholder text below the horizontal rule.

4 Type the following text (or your own text if you prefer):

The safety of our loyal customers is important to us. Read these safety tips to ensure that 
your next trip goes off without a hitch!

5 In the right column, triple-click the word “News” and type Globe-Trotter Promotions to 
replace it.

6 In the Site panel, locate the promotions.txt file in your Assets folder. Double-click the file’s 
icon to open it.

This file contains copy for Global Car Rentals special promotions.

Note: In this sample site, the file containing the copy is a text file. For other sites, you may be given HTML 
documents generated by Microsoft Word; you can import that HTML and clean it up using Dreamweaver’s 
Import Word HTML command. For more information, see Dreamweaver Help (Help > Using Dreamweaver). 

Note that the text file appears in a new Document window with a dark bar down the left side. 
This window is in Code view, and can’t be switched to Design view because the file is not an 
HTML file.

Note: If you prefer, use your own text on the page instead of using the provided text.

7 In the promotions.txt Document window, press Control+A (Windows) or Command+A 
(Macintosh) to select all the text, then choose Edit > Copy to copy the text.

8 In the index.htm Document window, select all of the placeholder text in the lower cell of the 
right-hand column, and choose Edit > Paste.

The text is pasted into the table.

9 Click just before the word “Rent” (the second paragraph of text you just pasted), and choose 
Insert > Horizontal Rule to put a horizontal line between the two promotions.

10 Save your document.

11 Switch to the promotions.txt file. Close that file by choosing File > Close.
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Add styles to the text

There are several ways to style text in HTML. One approach is to use Cascading Style Sheets 
(CSS) to define specific HTML tags as being formatted in specific ways.

This lesson shows how to create a simple CSS style sheet from a predesigned style sheet, then 
apply the new style sheet to text and modify the styles.

To create a CSS style sheet:

1 Choose File > New.

2 In the New Document dialog box, select the CSS Style Sheets category from the category list 
on the left.

The list in the middle column of the dialog box is relabeled CSS Style Sheets. A list of 
pre-designed style sheets appears.

3 In the CSS Style Sheets list, select a style sheet. For the Global Car Rental site, select Basic: 
Verdana, which redefines the body, td, and th tags by specifying fonts for them. Then click Create 

Dreamweaver creates a new text file containing a small set of predefined CSS styles.

4 Choose File > Save to save the new CSS file. Save it in the site’s assets folder; name it text.css 
(or any other name you like).

5 Choose File > Close to close the CSS file.
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To style your text using CSS styles:

1 In the Window menu, choose an HTML file (such as index.htm).

Note: If your system preferences are set to not show file extensions, the index.htm file appears in the Window 
menu with the name index.

2 Choose Window > CSS Styles to display the CSS Styles panel.

3 At the top of the CSS Styles panel, click the Edit Styles radio button to show available styles.

If you haven’t previously defined styles for this document, no styles are available.

4 At the bottom of the CSS Styles panel, click the Attach Style Sheet button.

The Link External Style Sheet dialog box appears.

5 In the Link External Style Sheet dialog box, click Browse to locate a style sheet.

6 In the Select Style Sheet File dialog box, browse to and select the new style sheet you created in 
the assets folder, then click OK (Windows) or Choose (Macintosh) to attach the style sheet. 

7 In the Link External Style Sheet dialog box, click OK to attach the style sheet.

The style sheet’s name and contents appear in the CSS Styles panel. The styles defined in the style 
sheet are applied to the text in the HTML document. For example, body text appears in Verdana.

8 Save your document.

To edit the styles in the style sheet:

1 At the top of the CSS Styles panel, click the Edit Styles radio button to show available styles.

2 Select the name of the CSS file in the CSS Styles panel and click the Edit Style Sheet button at 
the bottom of the CSS Styles panel.

A dialog box appears showing the names of the styles in the style sheet. 

3 Select one of the styles, such as body, and click Edit.

The CSS Style Definition dialog box appears.
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4 Enter a size for the text, such as 13 pixels. Adjust other options as you like.

5 Click OK to redefine the style.

6 Edit the other styles. To create the styles used in the Global Car Rental site, set the body, td, 
and th styles to a size of 13 pixels.

7 When you’re done editing styles, click the Save button to save your changes and close the 
stylesheet dialog box.

The changed styles are applied to your document. For example, body text appears in 
13-pixel Verdana.

Add images
In this lesson, you can add images to the page you’re working on. If you have your own images, 
you can use them instead, but the first time you try adding an image, we recommend using one 
supplied with Dreamweaver’s sample site.

If you haven’t already followed the procedure in “Add assets to your site” on page 25 for copying 
the Global Car Rental site’s assets into your site’s local root folder, do so now.

To add an image to your document:

1 Save your document if you haven’t already done so.

You can insert an image into an unsaved document, but if you do, a dialog box will appear, 
informing you that the URL used for the image will be the full local path to the image. If you 
take this approach, Dreamweaver fixes the URLs when you do save the document, but it’s 
easiest to save the document before adding images.

2 To insert an image in place of an existing image placeholder, double-click the placeholder. For 
example, to insert the company logo at the top left of the Global Car Rental page, double-click 
the small placeholder that’s labeled “image (100 x 50).”

The Select Image Source dialog box appears.

3 Near the bottom of the dialog box, make sure that the Relative To pop-up menu is set to 
Document.

For information on document-relative and root-relative URLs, see Dreamweaver Help (Help > 
Using Dreamweaver).

4 Browse to an image in your assets folder (such as logo.jpg).

5 Click OK or Select (Windows) or Open or Choose (Macintosh) to insert the image.

In the Document window, the image appears where the placeholder was.

6 Click the large image placeholder that you created in “Add an image placeholder” on page 32 
to select it. (Don’t double-click it.)

You can use the same approach that you used for the other placeholder to replace this 
placeholder with an image, but the following instructions provide an alternate approach.

7 Make sure the Site panel and the Property inspector are showing (choose Window > Site Files 
and Window > Properties if they aren’t visible).
Creating Your First Website in Dreamweaver 39



8 In the Property inspector, drag from the Src text box’s Point-to-File icon to the Site panel. 
(Make sure to drag from the Point-to-File icon next to the Src text box, not the one next to the 
Link text box.) Continue to hold the mouse button down as you point to the assets folder (if 
the folder is closed); the folder opens. Continue to hold the button down as you point to the 
images folder; that folder opens as well. Continue to hold the button down until the pointer is 
over the vintage.jpg file. Release the mouse button to select vintage.jpg.

In the Document window, the image appears where the placeholder was. If the wrong image 
appears, look at the filename in the Src text box; if you selected the wrong file, drag the 
Point-to-File icon again.

9 To insert images in places where you don’t already have placeholders, click in the Design view 
to place the insertion point where you want the image, then choose Insert > Image.

If you insert an image for which the image file isn’t inside your site’s local root folder, 
Dreamweaver provides the option to automatically copy the image into the site.

10 Save your document.

Set background colors
In the predesigned pages provided with Dreamweaver, the background colors of table cells are 
mostly set to gray; for most sites, you’ll have to change the colors to match your site’s color scheme.

To set the background color of a table cell:

1 If the Property inspector isn’t open, choose Window > Properties to open it.

2 If the Property inspector is collapsed (showing only its title bar), click the expander arrow in 
the title bar to expand it.

3 If the Property inspector isn’t showing all properties, click the expander arrow at the lower right 
corner of the Property inspector to view all properties.

4 Control-click (Windows) or Command-click (Macintosh) a cell to select the cell. For example, 
in the Global Car Rental sample page, there’s now a table cell that contains the logo image for the 
car rental company; Control-click or Command-click the cell that contains that logo image.

The lower half of the Property inspector shows cell properties. If the lower half of the Property 
inspector isn’t visible, click the expander arrow at the lower right corner of the Property 
inspector to view all properties.
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5 In the Property inspector, click the Background Color button that appears next to the lower of 
the two Bg labels.

The color picker appears and the pointer changes to an eyedropper.

6 Select a color. You can either select a color in the color picker’s palette, or click anywhere on 
your display to select the color of the pixel you clicked. For example, click the background of 
the Global logo image to make the background color of the table cell match the image 
background color.

The table cell’s background color changes to the color you picked.

7 Repeat that procedure for each table cell that you want to change the background color of. In the 
Global Car Rental sample page, change the background colors of all of the navigation-bar table 
cells and of the header cell in the second column of text (the cell that now contains the text 
“Globe-Trotter Promotions”), to make them all match the background color of the Global logo.

8 Save your document.

Look at the code
Take a quick time-out for a look at what Dreamweaver is doing when you add content to a page. 
As you add text, images, and other content, Dreamweaver generates HTML code.

Dreamweaver lets you view your document in either of two ways: Design view (where the 
document looks much like it would look in a browser), and Code view (where you can see the 
underlying HTML code). You can also use a split view that shows both Code and Design views.
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To view the HTML code for your document:

1 If the Document toolbar isn’t already visible, choose View > Toolbars > Document.

2 In the Document toolbar, click the Code and Design view button. 

The window splits, showing the underlying HTML code.

You can edit the code in Code view. Changes you make to the code don’t appear in Design 
view until you refresh the view.

To make code changes appear in Design view, do one of the following:

• Click anywhere in Design view.

• Click the Refresh button in the Document toolbar. 

Dreamweaver provides many advanced features to help you code in Code view; see Chapter 3, 
“Editing code in Dreamweaver,” on page 49 for more information.

When you’re working on your own pages, you can whichever view is most comfortable for you. 
We’ll assume for the rest of this chapter that you’re using Design view.

To show Design view only:

1 If the Document toolbar isn’t already visible, choose View > Toolbars > Document.

2 In the Document toolbar, click the Design view button.

Create a second page
In this lesson, you’ll create a second page for your site; in the next lesson, “Add text links between 
pages” on page 44, you’ll create links between the pages.

There are several possible ways to create a second page. In this lesson, you’ll create a second page 
by making a copy of the first one, so that the second page will have the same layout as the first.

Note: If you want to create a layout of your own from scratch instead, you can either use the Dreamweaver 
table-editing tools or Layout view. Other layout options include frames and layers. None of these options are 
covered in this lesson, however.
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In a more complex site, the best way to make sure all your pages have the same layout would be to 
use a template. For information about where to read about table editing, Layout view, frames, 
layers, and templates, see “Further reading” on page 48.

The second page to create in the Global Car Rental site is the customer service page. You’ll create 
the customer service page by making a copy of the main (index.htm) page, then removing content 
that shouldn’t appear on the customer service page, then adding new content.

For more information on how to add and format text, see “Add styled text” on page 35.

To create a copy of your first page (index.htm):

1 In the Site panel, right-click (Windows) or Control-click (Macintosh) the filename of the first 
page you created, index.htm (or whatever name you gave the file).

2 From the context menu, choose Duplicate.

A copy of the file appears.

Tip: If the copy doesn’t appear immediately, click the Refresh button in the Site panel to make it appear.

3 Select the new duplicated file. Pause for a moment, then click it again to make the filename 
editable (this is the same technique used in Windows Explorer and in the Finder).

4 Give the new file a new name, such as customerService.htm.

To remove unnecessary material from the new page:

1 Open the new customerService.htm page by double-clicking it in the Site panel.

Look at the Document window’s title bar to be sure that you’re looking at the 
customerService.htm file. The title bar should say “Global Car Rental Home Page” and then a 
folder name and a filename; the filename should be customerServe.htm (or whatever you 
named it in the previous procedure).

2 In the customerService.htm page, select the large image (the image showing the car in the main 
text column) by clicking it.

3 In the tag selector, click the <td> tag.

4 Press Backspace (Windows) or Delete (Macintosh).

Everything in the table cell, including the image and the text, is deleted.

5 Save your document.

To add text to the new page:

1 In the Site panel, locate the custServInfo.htm file in your Assets folder. Double-click the file’s 
icon to open it.

This file contains content to be added to the customer service page. If you were creating your 
own site, you would add your own content here, but for the purposes of this lesson, this 
content is provided for you.

2 In the custServInfo.htm Document window, choose View > Code to view the HTML code.
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3 Still in the custServInfo.htm Document window, press Control+A (Windows) or 
Command+A (Macintosh) to select everything in the file.

If you’re not in Code view when you do this, you may have to press Control+A or Command+A 
several times to select everything; if the insertion point is inside a table cell, Select All initially 
selects only that cell. For simplicity, switch to Code view before selecting everything.

4 Press Control+C (Windows) or Command+C (Macintosh) to copy everything.

5 Switch back to the customerService.htm document. Click inside the now-empty main text 
column (the wide column on the left).

6 Choose Edit > Paste HTML.

The HTML code that you copied from the custServInfo.htm file is pasted into this document. 
(If you choose Edit > Paste instead of Edit > Paste HTML, the HTML code is pasted into 
Design view as if it’s text. If HTML code appears in your Design view at this step, choose 
Edit > Undo and try again.)

The text.css style sheet is already attached to this page, so text is formatted automatically.

Add text links between pages
You can create links at any stage of the site-creation process. If you’re following the lessons of this 
guide in order, then you’ve already created your pages and placed content in them; so in this 
lesson you’ll create links between the pages you’ve created.

The following are two other general approaches to creating links for a site:

• Create a set of dummy pages first, then add links between them, and then add content to the pages.

• As you create a page, specify links to pages that don’t exist yet; later, create pages that have the 
filenames you linked to. 

To create a link from the customer service page to index.htm:

1 Switch to the customer service page if it’s not the current page. (If the page is not open, open it 
by double-clicking its icon in the Site panel.)

2 In the bottom of the wide text column on the left side, select the words “Home Page”.

If you didn’t add text to the left column of the customer service page when you created it, enter 
the words Home Page in that text column and select those words.

3 If the Property inspector isn’t open, open it by choosing Window > Properties. 

4 Click the folder icon next to the Link text box in the Property inspector. Browse to the 
index.htm file in your site’s local root folder.

Create rollovers for graphical links
A rollover image is an image that appears to change when a visitor to your site points to the image 
with the pointer. For example, a button on a page may appear to light up when the visitor points to it.

A rollover image consists of two images: the image displayed when the page first loads in the 
browser, and the image displayed when the pointer moves over the original image.

Note: When creating a rollover, make sure to use two images that have the same dimensions.
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To create a rollover:

1 Switch to the main (index.htm) page if it’s not the current page. (If the page is not open, open 
it by double-clicking its icon in the Site panel.)

2 In the Document window, place the insertion point where you want the rollover image to 
appear. On the Global Car Rental main page, for example, double-click in the navigation-bar 
table cell that says “Lorem” and press Backspace (Windows) or Delete (Macintosh) to delete 
the text, leaving the insertion point in the cell.

3 Choose Insert > Interactive Images > Rollover Image. 

4 In the Insert Rollover Image dialog box, type a name for the image, such as home-image, in the 
Image Name text box.

This gives the image a unique name, and makes it easily identifiable in the HTML code.

5 In the Original Image text box, click Browse; then navigate to the btnHome.jpg file in your 
site’s images folder (inside the assets folder). Make sure the Relative To pop-up menu is set to 
Document; then click OK or Select (Windows) or Open or Choose (Macintosh).

The Original Image text box indicates which image to display when the page first appears in 
the browser.

6 In the Rollover Image text box, click Browse; then navigate to btnHome_on.jpg in your site’s 
images folder. Make sure the Relative To pop-up menu is set to Document; then click OK or 
Select (Windows) or Open or Choose (Macintosh).

The Rollover Image text box indicates which image to display when the pointer is pointing to 
the image in the browser.

7 Make sure the Preload Rollover Image option is selected so the rollover images load when the 
page opens in the browser, ensuring a quick transition between images when a user moves the 
pointer over the original image.

8 In the When Clicked, Go To URL text box, click the Browse button and browse to index.htm.

The index.htm file is the file that you’re editing, so this step causes the rollover image to link to 
the page that you’re placing the rollover image on. It might seem unnecessary to have a link to 
the page that the link is on, but you’ll be using the same set of navigation rollovers on other 
pages as well, so this link will allow visitors to return to the index.htm page from other pages 
that contain this navigation bar.

9 Click OK to close the dialog box.

The specified original image appears in the document.

10 Save your document.
Creating Your First Website in Dreamweaver 45



Note: Rollover images don’t change when you point to them with the pointer in the Dreamweaver Document 
window; rollover images work only in a browser. To make sure your rollovers work, you have to preview your 
document in a browser.  

For the Global Car Rental site, create two more rollovers in the other two navigation-bar table 
cells (the ones that say “Ipsum” and “Dolor”): one rollover that uses the btnCustomerService.jpg 
and btnCustomerService_on.jpg images, and is linked to customerService.htm, and another 
rollover that uses the btnLocations.jpg and btnLocations_on.jpg images, and is linked to 
locations.htm. Note that you haven’t yet created the locations.htm file; just type the filename into 
the When Clicked, Go To URL text box in the Insert Rollover Image dialog box.

Copy the navigation bar
Now that you’ve created a working navigation bar, you can reuse it in all of your pages. In this 
lesson, you’ll copy the navigation-bar table cells and paste them into your second page.

There are a variety of other ways to reuse content in Dreamweaver, including library items, 
templates, and snippets. 

To copy the navigation bar into another page:

1 In the index.htm file, click in the table cell that contains the Home rollover image.

2 In the tag selector, select the rightmost <tr> tag.

The table row containing the three navigation-bar rollovers is selected.

3 Choose Edit > Copy.

4 Switch to the customerService.htm file.

5 Click in the navigation-bar table cell that says “Lorem.”

6 In the tag selector, select the rightmost <tr> tag.

7 Choose Edit > Paste.

The navigation-bar rollover images are pasted in place of the existing table cells.

8 Save your document.

Preview in browser
The Design view gives a rough idea of what your page will look like in a browser, but the only way 
to be sure how it will look is to preview it in a browser. Each version of each browser has its own 
quirks; Dreamweaver strives to produce HTML that will look as similar as possible from one 
browser to another, but sometimes differences can’t be avoided. (That’s why Dreamweaver doesn’t 
display a preview directly; there’s no way for Dreamweaver to mimic all the different behaviors of 
all the different browsers.)

Preview in Browser shows how the pages will look when you’ve published them.

To preview your pages:

1 If index.htm isn’t the current document, switch to it. (If it’s not open, open it.)

2 Press the F12 key.

Your primary browser starts if it’s not running already. It displays the index page.
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Note: Dreamweaver should automatically detect your primary browser and use that for previewing. If the preview 
doesn’t appear, or if it doesn’t appear in the browser you expect, switch back to Dreamweaver (if necessary) and 
choose File > Preview in Browser > Edit Browser List. The Preview in Browser Preferences dialog box appears; 
add the correct browser to the list. For more information, click the Help button in the Preferences dialog box.

3 Move the pointer to point to the rollover images to see the images change. Click links to make 
sure they work.

Set up a remote site, then publish
You’ve now created a small but functional website. The next step is to publish it by uploading the 
files to a remote web server.

Before you can proceed, you must have access to a remote web server (such as your ISP’s server, or 
a server owned by the client you’re working for, or an intranet server within your company, or an 
IIS or PWS server on a Windows computer). If you don’t already have access to such a server, 
contact your ISP, your client, or your system administrator.

The following procedure works best if your remote root folder is empty. If your remote site 
already contains files, then create an empty folder in your remote site (on the server), and use that 
empty folder as your remote root folder.

The following procedure assumes that you have set up a local site. For more information, see “Set 
up a local site” on page 20.

To connect to a remote site:

1 Choose Site > Edit Sites.

2 Select a site (such as Global Car Rental) and click Edit.

3 Click the Basic tab at the top of the dialog box.

4 You’ve already filled in the first few steps in the Basic tab, when you set up your local site, so 
click Next a few times, until the Sharing Files step is highlighted at the top of the wizard. 
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5 In the pop-up menu labeled “How do you connect to your remote server?”, choose a method 
for connecting to the remote site.

The most common method for connecting to a server on the Internet is FTP; the most 
common method for connecting a server on your intranet is Local/Network. If you aren’t sure 
what to choose here, ask the server’s system administrator.

6 If you choose FTP, enter the following options:

• Enter the hostname of the server (such as ftp.macromedia.com).

• In the text box that asks what folder contains your files, enter the path on the server from the ftp 
root folder to the remote site’s root folder. If you’re not sure, consult your system administrator.

In many cases, this text box should be left blank.

• Enter your user name and password in the appropriate text boxes and click Test Connection.

• If the connection is unsuccessful, consult your system administrator.

7 If you choose Local/Network, then click the folder icon next to the text box and browse to the 
remote site’s root folder.

8 Click Next.

9 Don’t enable check-in and check-out for this site.

If you and your co-workers are working together on a larger site, check-in and check-out help to 
prevent you from overwriting each others’ files. For this site, though, you don’t need this feature.

10 Click Next.

11 Click Done to finish setting up the remote site.

12 Click Done again to finish editing the site.

To upload your pages to a remote site:

1 In the Site panel, select the site’s local root folder.

2 Click the Put Files button.

All of the site’s files are uploaded to the remote site.

3 Open your remote site in a browser to make sure everything uploaded correctly.

Further reading
Dreamweaver is a big application, with dozens of powerful features. This guide only touches 
on the basics.

This chapter of Getting Started focused on using Design view to create a static site. For 
information on Code view and hand-coding in Dreamweaver, see Chapter 3, “Editing code in 
Dreamweaver,” on page 49. For information about the basics of creating a database-driven web 
application, see Chapter 4, “Understanding Web Applications,” on page 59 and Chapter 5, 
“Developing a Web Application in Dreamweaver MX,” on page 69.

For more detailed information on topics covered in this chapter of Getting Started, see 
Dreamweaver Help (Help > Using Dreamweaver).

In addition to information on specific topics, Dreamweaver Help provides information about 
other resources, such as the Macromedia Support Center and online discussion forums.
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CHAPTER 3

Editing code in Dreamweaver

While web developers can benefit from the rich visual tools offered by Macromedia 
Dreamweaver MX, many developers also use coding tools to get the job done. Dreamweaver 
has many new features to give you the professional coding environment you need.

This chapter gives you a quick view of Dreamweaver’s new professional coding environment. For 
more information, see Dreamweaver Help (Help > Using Dreamweaver).

Switch to the coding workspace
If you didn’t do so during installation, you can make your workspace look and feel like the 
popular coding environments of HomeSite and ColdFusion Studio.

Note: Macintosh users cannot change the workspace.
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To adopt the new coding workspace: 

1 Choose Edit > Preferences, then choose General from the list of categories on the left.

The General category appears. 

2 Click the Change Workspace button.

The Workspace Setup dialog box appears. 

3 Select the Dreamweaver MX Workspace option, then select the Homesite/Coder-Style option.
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4 Click OK twice to close the Preferences dialog box.

5 Close Dreamweaver, and then restart it.

Copy a Folder to Your Site
Before you start the lessons, you need to set up a site and copy a folder into the site. The 
integrated file browser in the Site panel enables you to view your local disk and network. This 
is useful for working with files that are not in the current site showing in the Site panel.

To copy pages to your site:

1 Choose Window > Site to open the Site panel, if it’s not already open.

2 In the Site panel, from the Site pop-up menu, select the name of the site you defined in the 
previous chapter.

If you have not defined a site, see “Set up a local site” on page 20. You need to define a site 
before you continue.

When you select the site name from the pop-up menu, Dreamweaver displays the files in the site.

3 Expand the Desktop (Windows) or Computer (Macintosh) icon to see your available disks.

4 Expand folders as necessary to reach the Dreamweaver application folder, and then expand the 
Samples folder.

5 In the Samples folder, expand the GettingStarted folder, then select the Code folder, and press 
Control+C (Windows) or Command+C (Macintosh) to copy it.

6 Scroll back to the top of the Site panel, and select the site folder. 

7 Press Control+V (Windows) or Command+V (Macintosh) to paste a copy of the folder in 
your site.

View the finished pages
Before you start, you can view finished pages to see how your pages might look. Of course, your 
pages may vary.

To view the finished pages:

1 Choose Window > Site to open the Site panel, if it’s not already open.

2 Expand the Desktop (Windows) or Computer (Macintosh) icon to see your available disks.

3 Expand folders as necessary to reach the Dreamweaver application folder, and then expand the 
Samples folder.

4 In the Samples folder, expand the GettingStarted folder, then expand the FinalSite folder.

5 In the FinalSite folder, double-click index.htm to open it, then double-click 
location_comp.htm.

Dreamweaver displays the pages in the Document window.

6 Close the pages when you are finished.
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Open multiple pages
Use the Site panel to open the pages you need for this lesson.

To open pages:

1 Choose Window > Site to open the Site panel, if it’s not already open.

2 In your site, expand the Code folder.

3 Double-click index.htm to open it, then double-click location_start.htm.

These are the two files you’ll need for this lesson.

4 In the Document window, click the Show Code View button on the toolbar or choose View > 
Code to switch to Code view and see the file’s source code.

5 To switch between the pages quickly, press Control+Tab or click the tab at the bottom of the 
page (Windows only).

Note: You must maximize the page to see the tabs.

Add an image by dragging it
In this lesson you’ll add a button to the home page for a Locations page, similar to the buttons for 
Home and Customer Service. You can enter the code directly on the page, click the image icon on 
the Insert bar, or use the image (IMG) tag editor (select the image, right-click in Windows or 
Control-click in Macintosh, then select Edit Tag).

Another option is to drag the image from its folder.

To add an image by dragging it:

1 Open index.htm in Code view, if it’s not already open.

2 In the Files panel group, open the Assets panel (Windows > Assets).

3 Select the image file for btnLocations.jpg.

4 Drag the image file to the page code, and then drop it in the code for the third cell in the first table.

Tip: Look for the code for the Home and Customer Service buttons. Drop the Locations image before the 
closing </td> tag for the table cell that follows the two cells for those buttons.

Dreamweaver inserts the code at the insertion point to create the image.

5 Choose File > Save.
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Add a link with the Tag Chooser 
Now you’ll make the button you added link to the Locations page. In addition to manually 
entering code for a link and using the Insert bar to add a link, you can use the Tag Chooser.

To write code with the help of the Tag Chooser:

1 Open index.htm in Code view, if it’s not already open.

2 In the code for the first table, find and select the code for the Location button you inserted in 
the last section.

Note: Make sure you highlight the entire <img> tag.

3 Right-click (Windows) or Control-click (Macintosh) the selected text, and then select Insert 
Tag from the popup menu. 

The Tag Chooser appears.

4 Choose HTML Tags, Page Elements, General, and then select A in the right pane.

Note: You can also choose HTML Tags, and then select the A tag in the right pane, without first selecting Page 
Elements, General.

5 Click Insert.

A tag editor for the anchor tag (<a>) appears. 

6 In the HREF text box, enter location_start.htm or click the Browse button to browse to the file.

Note: If you want to link to a web page, enter the page’s URL.

7 Click OK to close the tag editor.

8 Click Close to close the Tag Chooser.

Dreamweaver inserts the code in your page to create the link.

9 In the Document window, choose File > Save.
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Edit a tag
Next, you’ll use the Tag Inspector to find a specific tag in the Locations page and quickly make 
changes to it. 

To edit a tag using the Tag Inspector:

1 Open location_start.htm in Code view, if it’s not already open.

2 Do one of the following to open the Tag Inspector, if it’s not already open:

• Choose Window > Tag Inspector.

• In the Code panel group, click the Tag Inspector tab. 

The Tag Inspector gives you a structured view of all the tags in your page. It also displays the 
attributes of each tag.

3 In the Document window Code view, find the text for the heading “Rental Locations.”

4 Select the non-breaking space entity (&nbsp;) between the paragraph tags that follow the 
heading:

<p><FONT SIZE="+2" COLOR="#FF6600">Rental Locations</FONT></p>
<p>
&nbsp;</p>
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5 Choose Insert > Table, then click OK in the Insert Table dialog box to accept the default values.

Dreamweaver inserts table code.

6 Click the Refresh button on the toolbar.

The Tag Inspector panel updates so that focus is on the Table tag you just inserted. A list of 
attributes appears below the tag.

7 In the Document window, click a few different tags to see how the Tag Inspector updates the 
tag and attributes it displays, then click the Table tag again so that its attributes appear in the 
Tag Inspector.

8 In the Tag Inspector panel, click in the empty text box beside the align attribute.

An arrow for a pop-up menu appears.

9 Click the pop-up menu arrow, and select center.

Dreamweaver changes the code in the Document window.

10 Click the Show Design View button on the toolbar or choose View > Design to see the table.

11 In the Document window, choose File > Save.

Look up information about a tag
If you need help with a tag’s attributes and attribute values, you can look up reference information 
within Dreamweaver.

To look up information about a tag:

1 Open location_start.htm in Code view, if it’s not already open.

2 In the Document window, select the text “bgcolor” in the body tag.

3 Right-click (Windows) or Control-click (Macintosh) the selected text, and then choose 
Reference from the popup menu.

The Reference panel opens and displays information about the bgcolor attribute.

Note: You can also choose Window > Reference to access the Reference panel. This panel is integrated in the 
development environment in the Code group panel.
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4 For information about a specific tag attribute, select the attribute from the pop-up menu.

Add an image with Code Hints
In this lesson you’ll add a logo to the Locations page. 

To add code to the page manually, simply click in the Document window and start typing. You 
can also use the new Code Hints feature in Dreamweaver to speed up your work. 

To write code with the help of Code Hints:

1 Open location_start.htm in Code view, if it’s not already open.

2 Find the code for the table row that contains the text “The International Car Rental 
Specialists”; select the non-breaking space entity (&nbsp;) in the code for the cell that comes 
before that text:

<td rowspan="2" bgcolor="#424973">&nbsp;</td>

3 Type the opening bracket (<) of the image tag.

A list of tags appears at the insertion point. 

Note: You can set the length of the delay by selecting Edit > Preferences or Dreamweaver > Preferences 
(Mac OS X), and then selecting Code Hints from the category list on the left. You can open Code Hints by 
pressing the Spacebar, and you can close Code Hints at any time by pressing Escape. 

4 Select the img tag from the list, and then press Enter (Windows) or Return (Macintosh) to 
insert the tag.

Tip: To quickly scroll to a tag, type the first letter of the tag.

5 Press the Spacebar to display a list of attributes for the tag.

6 Type src, and then press Enter (Windows) or Return (Macintosh).

A Browse button appears below the code you just typed.

7 Select the browse button to navigate to the image file or enter the image file path, Assets/
images/logo.jpg.
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8 Press the spacebar, select the alt attribute, and then press Enter (Windows) or Return 
(Macintosh).

9 Type Logo, then move the cursor to the right of the quotation mark that appears after the 
word Logo.

10 Press the spacebar, select the align attribute, and then press Enter (Windows) or Return 
(Macintosh).

A list of known values for the align attribute appears.

11 Select top from the list, and then press Enter (Windows) or Return (Macintosh).

12 Type a closing bracket (>) to complete the tag.

13 In the Document window, choose File > Save.

To add an attribute to an existing tag, place the insertion point just before the tag’s closing 
bracket (>) and press the Spacebar. A list of attributes appears. Add the attribute and specify its 
value, if any.

Check your changes
After making any change to your code, you can get immediate visual feedback.

To see a visual representation of your code, do either of the following:

• Click the Show Design View button on the toolbar or select View > Design.

• View the page in a web browser by pressing F12. To close the browser and return to your code, 
press Alt-F4 (Windows only).

Add a link with the Insert bar
Now, you’ll add a link to the logo image you inserted so that when the user clicks it, the home 
page opens.

One way you can create the link is by simply placing an anchor tag (<a>) around the image tag in 
the code and setting the anchor tag’s attributes—with or without the help of Code Hints. 
Another way to add the link is to use the Insert bar.

To write code with the help of the Insert bar:

1 Open location_start.htm in Code view, if it’s not already open.

2 Highlight the code for the logo.jpg image you inserted.

Note: Make sure you highlight the entire <img> tag.
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3 In the Common tab of the Insert bar, click the Hyperlink button.

The Hyperlink dialog box appears with the image tag already entered.

4 In the Link text box, enter index.htm or click the folder icon to browse to it.

Note: To link to a web page, enter the page’s URL.

5 Click OK.

Dreamweaver inserts the code in your page to create the link around the image.

6 Choose File > Save.

Printing your code
You can print your code to edit it offline, archive it, or distribute it.

To print the code:

1 Open a page in Code view.

2 Choose File > Print Code.

Tip: To print with line numbers, choose View > Code View Options > Line Numbers before you print.

Further reading
For information on the hand-coding features in Dreamweaver, see Dreamweaver Help (Help > 
Using Dreamweaver). 

For information on accessing your code while working in Dreamweaver’s visual design 
environment, see Dreamweaver Help (Help > Using Dreamweaver). 
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CHAPTER 4

Understanding Web Applications

A web application is a collection of web pages that interact with the user, with each other, and 
with various resources on a web server, including databases. Before you start building your own 
web applications, you should be familiar with the concepts discussed in this chapter. 

The chapter contains the following topics:

• “What is a web application?” on page 59

• “How a web application works” on page 60

• “Accessing a database” on page 63

• “Authoring dynamic pages” on page 65

• “Choosing a server technology” on page 66

• “Frequently used terms” on page 66

What is a web application? 
A web application is a website that contains pages stored on a web server with partly or entirely 
undetermined content. The final content of a page is determined only when the user requests a 
page from the web server. Because the final content of the page varies from request to request 
based on the user’s actions, this kind of page is called a dynamic page.

Web applications are built to address a variety of challenges and problems. This section describes 
common uses for web applications and gives a simple example. 
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Common uses for web applications 

Web applications have many uses for both users and developers, including the following: 

• Let users find information quickly and easily on a content-rich website. 

This kind of web application gives users the ability to search, organize, and navigate 
content as they see fit. Examples include company intranets, Microsoft MSDN (http://
www.msdn.microsoft.com), and Amazon.com (http://www.amazon.com).

• Collect, save, and analyze data provided by users. 

In the past, data entered in HTML forms was sent as e-mail messages to employees or CGI 
applications for processing. A web application can save form data directly into a database and 
also extract the data and create web-based reports for analysis. Examples include online 
banking pages, store check-out pages, surveys, and user-feedback forms.

• Update websites that have constantly changing content.

A web application frees the web designer from continually updating the site’s HTML. 
Content providers such as news editors provide the web application with content and the 
web application updates the site automatically. Examples include the Economist (http://
www.economist.com) and CNN (http://www.cnn.com).

Web application example

Clay is a professional web designer and long-time Dreamweaver user responsible for maintaining 
the intranet and Internet sites of a medium-sized company of 1000 employees. One day, Jill from 
Human Resources comes to him with a problem. HR administers an employee fitness program 
that gives employees points for every mile walked, biked, or run. Each employee must report his 
or her monthly mile totals in an e-mail to Jill. At the end of the month, Jill gathers all the e-mail 
messages and awards employees small cash prizes according to their point totals. 

Jill’s problem is that the fitness program has grown too successful. So many employees now 
participate that Jill is inundated with e-mails at the end of each month. Jill asks Clay if a 
web-based solution exists. 

Clay proposes an intranet-based web application that performs the following tasks:

• Lets employees enter their mileage on a web page using a simple HTML form

• Stores the employees’ mileage in a database

• Calculates fitness points based on the mileage data

• Lets employees track their monthly progress

• Gives Jill one-click access to point totals at the end of each month

Clay gets the application up and running before lunchtime using Dreamweaver MX, which has 
the tools he needs to build this kind of application quickly and easily.

How a web application works
A web application is a collection of regular and dynamic web pages. A regular web page is one that 
does not change when a user requests it: the web server sends the page to the requesting web 
browser without modifying it. In contrast, a dynamic web page is modified by the server before it 
is sent to the requesting browser. The changing nature of the page is why it’s called dynamic. 
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For example, you could design a page to display fitness results and leave certain information (such 
as employee name and results) to be determined when the page is requested by an employee. 

Processing regular web pages

A regular website comprises a set of related HTML pages and files hosted on a computer running 
a web server.

A web server is software that serves web pages in response to requests from web browsers. A page 
request is generated when a user clicks a link on a web page, chooses a bookmark in a browser, or 
enters a URL in a browser’s Address text box and clicks Go. 

The final content of a regular web page is determined by the page designer and doesn’t change 
when the page is requested. Here’s an example:

<html>
<head>
<title>Call Department</title>
</head>
<body>
<strong>Call Department</strong><br>
Talk to someone in Sales.
</body>
</html>

Every line of the page’s HTML code is written by the designer before the page is placed on the server. 
Because the HTML doesn’t change once it’s on the server, this kind of page is called a static page.

Note: Strictly speaking, a “static” page may not be static at all. For example, a rollover image or a Flash movie can 
make a static page come alive. However, this guide refers to a page as static if it is sent to the browser without 
modifications.

When the web server receives a request for a static page, the server reads the request, finds the 
page, and sends it to the requesting browser, as shown in the following figure:  
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In the case of web applications, certain lines of code are undetermined when the user requests the 
page. These lines must be determined by some mechanism before the page can be sent to the 
browser. The mechanism is discussed in the following section.

Processing dynamic pages

When a web server receives a request for a regular web page, the server sends the page to the 
requesting browser without further ado. The web server reacts differently when it receives a 
request for a dynamic page: it passes the page to a special software extension responsible for 
finishing the page. This special software is called an application server. 

The application server reads the code on the page, finishes the page according to the instructions 
in the code, then removes the code from the page. The result is a static page that the application 
server passes back to the web server, which then sends the page to the requesting browser. All the 
browser gets when the page arrives is pure HTML. Here’s a view of the process: 
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Accessing a database

An application server lets you work with server-side resources such as databases. For example, a 
dynamic page may instruct the application server to extract data from a database and insert it into 
the page’s HTML. For more information, see “Beginner’s Guide to Databases” in Help (Help > 
Using Dreamweaver).

The instruction to extract data from a database is called a database query. A query consists of 
search criteria expressed in a database language called SQL (Structured Query Language). The 
SQL query is written into the page’s server-side scripts or tags.

An application server cannot communicate directly with a database because the database’s 
proprietary format renders the data undecipherable in much the same way that a Word document 
opened in Notepad is undecipherable. The application server can communicate only through the 
intermediary of a database driver. A database driver is software that acts like an interpreter 
between the application server and the database. 

After the driver establishes communication, the query is executed against the database and a 
recordset is created. A recordset is a subset of data extracted from one or more tables in a database. 
The recordset is returned to the application server and the data used in the dynamic page.

Here’s a simple database query written in SQL:

SELECT lastname, firstname, fitpoints
FROM employees

This statement creates a three-column recordset and fills it with rows containing the last name, 
first name, and fitness points of all employees in the database. For more information, see “SQL 
Primer” in Help (Help > Using Dreamweaver).
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Here’s an illustration of the process of querying a database and returning data to the browser:    

You can use almost any database with your web application, as long as you have the appropriate 
database driver for it.

If you plan to build small low-cost applications, you can use a file-based database, such as one 
created in Microsoft Access. If you plan to build robust, business-critical applications, you can use 
a server-based database, such as one created in Microsoft SQL Server, Oracle 9i, or MySQL. 

If your database is located on a system other than your web server, make sure you have a fast 
connection between the two systems so that your web application can operate quickly and efficiently.
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Authoring dynamic pages
Authoring a dynamic page consists of writing the HTML first, then adding the server-side 
scripts or tags to the HTML to make the page dynamic. When you view the resulting code, the 
language appears embedded in the page’s HTML. Accordingly, these languages are known as 
HTML embedded programming languages. The following example uses ColdFusion Markup 
Language (CFML):

<html>
<body>
<b>Call Department</b><br>
<!--- embedded instructions start here --->
<cfset department="Sales">
<cfoutput>

Talk to someone in #department#.
</cfoutput>
<!--- embedded instructions end here --->
</body>
</html>

The embedded instructions on this page perform the following actions: 

1 Create a variable called department and assign the string “Sales” to it.

2 Write the variable’s string value, “Sales”, in the HTML code. 

The application server returns the following page to the web server:

<html>
<body>
<b>Call Department</b><br>
Talk to someone in Sales.
</body>
</html>

The web server sends the page to the requesting browser, which displays it as follows:

Call Department
Talk to someone in Sales.

The scripting or tag-based language used depends on the server technology. Here are the most 
popular languages for the five server technologies supported by Dreamweaver MX:  

For more information, see “Choosing a server technology” on page 66.

Dreamweaver can write the server-side scripts or tags necessary to make your pages work, or you 
can write them by hand in the Dreamweaver coding environment.

Server technology Language 

ColdFusion ColdFusion Markup Language (CFML)

ASP.NET Visual Basic
C#

Active Server Pages (ASP) VBScript
JavaScript

JavaServer Pages (JSP) Java

PHP PHP
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Choosing a server technology
You can use Dreamweaver MX to build web applications using five server technologies: 
ColdFusion, ASP.NET, ASP, JSP, or PHP. Each of these technologies corresponds to a document 
type in Dreamweaver. Choosing one for your web application depends on several factors, including 
your level of comfort with various scripting languages and the application server you plan to use.

If you’re new to web application development or to application development in general, you’ll 
probably prefer ColdFusion because it provides an easy-to-learn server scripting environment 
that’s also tightly integrated with Dreamweaver. If you’re familiar with other server technologies, 
such as JSP, PHP, ASP, or ASP.NET, Dreamweaver offers great support for these as well.

Your choice of server technology also depends on the application server you plan to use for your 
web application. An application server is software that helps a web server process web pages 
containing server-side scripts or tags. For example, if you have the ColdFusion MX, you can 
choose ColdFusion as your server technology. If you have access to a server running Microsoft 
Internet Information Server 5 (IIS) with the .NET Framework, you can choose ASP.NET. PHP is 
an option if you have access to a web server with a PHP application server; JSP is an option if you 
have access to a web server with a JSP application server (such as Macromedia JRun).

A developer edition of ColdFusion MX is available on the Dreamweaver MX CD (Windows version 
only) and on the Macromedia website at http://www.macromedia.com/software/coldfusion/.

For more information, see “Setting up an application server” in Help (Help > 
Using Dreamweaver).

To learn more about ColdFusion, see the ColdFusion documentation in Dreamweaver (Help > 
Using ColdFusion) or visit the Macromedia website at http://www.macromedia.com/software/
coldfusion/.

To learn more about ASP.NET, visit the Microsoft website at http://asp.net/.

To learn more about ASP, visit the Microsoft website at http://msdn.microsoft.com/library/
default.asp?URL=/library/psdk/iisref/aspguide.htm.

To learn more about JSP, visit the Sun website at http://java.sun.com/products/jsp/.

To learn more about PHP, visit the PHP website at http://www.php.net/. 

Frequently used terms
This section lists frequently used terms.

An application server is software that helps a web server process web pages containing server-side 
scripts or tags. When such a page is requested from the server, the web server hands the page off to 
the application server for processing before sending the page to the browser. For more 
information, see “How a web application works” on page 60. 

Common application servers include Macromedia ColdFusion, Macromedia JRun Server, the 
Microsoft .NET Framework, IBM WebSphere, and Apache Tomcat. 
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A database is a collection of data stored in tables. Each row of a table constitutes one data record 
and each column constitutes a field in the record, as follows. 

A database driver is software that acts as an interpreter between a web application and a database. 
Data in a database is stored in a proprietary format. A database driver lets the web application 
read and manipulate data that would otherwise be undecipherable.

A database management system (DBMS, or database system) is software used to create and 
manipulate databases. Common database systems include Microsoft Access, Oracle 9i, and MySQL.

A database query is the operation that extracts a recordset from a database. A query consists of 
search criteria expressed in a database language called SQL. For example, the query can specify 
that only certain columns or only certain records be included in the recordset.

A dynamic page is a web page customized at runtime by an application server before the page is 
sent to a browser. For more information, see “How a web application works” on page 60. 

A recordset is a subset of data extracted from one or more tables in a database, as in the 
following example: 

Number LastName FirstName Position Goal

Records
(rows)

Fields (columns)

Number

Database table

LastName FirstName Position Goals

Recordset table

LastName FirstName Position
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A relational database is a database containing more than one table, and the tables share data. The 
following database is relational because two tables share the DepartmentID column. 

A server technology is the technology that an application server uses to modify dynamic pages 
at runtime. 

The Dreamweaver MX development environment supports the following server technologies:

• Macromedia ColdFusion

• Microsoft ASP.NET

• Microsoft Active Server Pages (ASP)

• Sun JavaServer Pages (JSP)

• PHP Hypertext Preprocessor (PHP) 

You can also use Dreamweaver’s coding environment to develop pages for any other server 
technology not listed above.

A static page is a web page that is not modified at runtime by an application server before the 
page is sent to a browser. For more information, see “Processing regular web pages” on page 61. 

A web application is a website that contains pages stored on a web server with partly or entirely 
undetermined content. The final content of these pages is determined only when the user 
requests a page from the web server. Because the final content of the page varies from request to 
request based on the user’s actions, this kind of page is called a dynamic page.

A web server is software that serves web pages in response to requests from web browsers. A page 
request is generated when a user clicks a link on a web page open in the browser, chooses a 
bookmark in the browser, or enters a URL in a browser’s Address text box and clicks Go. 

Popular web servers include Microsoft Internet Information Server, Microsoft Personal Web 
Server, Apache HTTP Server, Netscape Enterprise Server, and iPlanet Web Server. 
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CHAPTER 5

Developing a Web Application in

Dreamweaver MX

In this chapter, you’ll see how to use Dreamweaver MX to quickly begin developing dynamic 
database-driven web applications. A powerful aspect of dynamic web applications development is 
the ability to present database stored information in a web format.

As you complete this lesson, you’ll learn how to incorporate database information in your website. 
You’ll develop web applications for the Global Car Rental site, using an existing database 
containing three tables of data—locations, comments, and regions. You’ll also use Dreamweaver 
to create a simple SQL query to extract data from the database. 

In this lesson, you’ll build the following dynamic pages:

• An insert page that allows site visitors to send comments to the company

• A detail page which lists the customer’s comments and contact information

Before you begin
The handy setup guides, located at the end of the Getting Started guide, walk you through the 
steps for setting up your Dreamweaver work environment for creating dynamic pages. 

See the appropriate setup guide for your application server.

Chapter 7, “Setup for Sample ColdFusion Site,” on page 89

Chapter 8, “Setup for Sample ASP.NET Site,” on page 99

Chapter 9, “Setup for Sample ASP Site,” on page 109

Chapter 10, “Setup for Sample JSP Site,” on page 121

Chapter 11, “Setup for Sample PHP Site,” on page 133

Complete the following tasks: 

• Configure your system

• Configure Dreamweaver to work with your chosen application server

• Define a connection to the database

The screen examples in this chapter show Macromedia ColdFusion dialog boxes. However, 
you can complete the lessons in this chapter in all other server models supported by 
Dreamweaver MX: ColdFusion, PHP, ASP.NET, ASP, and JSP.
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Open a document to work in
A good starting point for developing a database application is to create a list of the records stored 
in the database. In the application you’re building in this chapter, you will list information in the 
customer comments table of the database. Later, you’ll create a dynamic web page which lets a 
customer insert comments or questions directly to the database.

Let’s start by locating the documents you’ll work with as you create these pages.

1 Do one of the following to open the Site panel:

• In the Files panel group, click the expander arrow to display the Site panel. 

• Choose Window > Site.

• Press F8.

The Site panel opens. 

2 In the Site pop-up menu, select the Global Car site you defined for your server pages. 

3 In the Site panel, double-click the customerComment file to open it.

The document opens in the Document window.

4 If you are currently viewing the document in Code view, click the Show Design View 
button or the Show Code and Design Views button in the Document toolbar, so you can 
use the screen examples provided as checkpoints while you complete the lesson.

You will edit the partially completed page. 
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Define a recordset
Now you’ll create a recordset to select the data you want to display. A recordset is a subset of 
information extracted from a database by a database query. (In ASP.NET, a recordset is known as 
a DataSet.) A database query consists of search criteria, which defines what’s included in the 
recordset. You then use the information extracted as a source of content for your dynamic pages.

Dreamweaver MX provides an easy-to-use interface for creating simple SQL queries—you don’t 
need to know SQL to create a recordset in Dreamweaver.

You’ll create a recordset that selects all of the values from the COMMENTS table in the 
Global database.

1 In Dreamweaver, open the Recordset or DataSet (ASP.NET) dialog box by doing one of 
the following:

• In the Insert bar’s Application tab, click the Recordset or DataSet (ASP.NET) button.

• Choose Window > Bindings to open the Bindings panel, then click the plus (+) button and 
select Recordset or DataSet (ASP.NET).

• Click the Application panel group’s expander arrow, then in the Bindings panel click the plus 
(+) button and select Recordset or DataSet (ASP.NET). 

The Recordset or DataSet dialog box appears. If the dialog box you see looks more complex 
than the dialog box below, click the Simple button.

2 In the Name text box, enter rsComments. 
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3 In the Data Source pop-up menu (ColdFusion) or Connection pop-up menu (other server 
page types), select connGlobal.

The Recordset or DataSet dialog box updates with data from the database.

4 In the Table pop-up menu, COMMENTS is already selected.

5 In Columns, All is selected.

You will accept the default value to request the complete recordset.

6 In the Sort pop-up menu, select LAST_NAME, and in the second pop-up menu, select Ascending.

The retrieved records list data in alphabetical order by customer last name. 
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7 Click Test to test the recordset or dataset. 

The records from the database that match your recordset or dataset selection criteria are 
displayed in the Test SQL Statement window. 

8 Click OK to close the Test SQL Statement window.

9 Click OK to close the Recordset or DataSet dialog box.

The recordset appears in the Bindings panel.

Tip: If you do not see all of the recordset fields, click the plus (+) button in front of Recordset (rsComments) to 
expand the recordset display. 
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Display the database records
Next, you’ll create a page which lists the records that currently exist in the COMMENTS table. 
You will dynamically generate the page rather than manually enter the information. 

You’ll start by creating a table to structure the data list. 

1 In the customerComment document, place the insertion point after “Customer Comments”, 
then press Enter (Windows) or Return (Macintosh) to set where the table will be inserted.

2 Insert a table by doing one of the following:

• In the Insert bar, click the Common tab, then click the Table button or drag it to the 
document. 

• In the Insert bar, click the Layout tab, then click the Table button or drag it to the document. 

• Select Insert > Table.

The Insert Table dialog box appears.

3 In the dialog box, set the following options:

In Rows, enter 2.

In Cell Padding enter 2.

In Columns, enter 4.

In Cell Spacing, enter 2.

In Width, enter 80.

The completed dialog box should look like this:
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4 Click OK.

The table inserts in the document.

5 In the top row of the table add labels for the table entries:

In the first cell of the table, enter First Name.

In the next cell, enter Last Name.

In the next cell, enter E-mail Address.

In the last cell, enter Comments.

6 Save your document (File > Save).

Add dynamic fields to the table
You’re now ready to add the recordset fields to the table. 

1 Open the Bindings panel, if it isn’t already open, by doing one of the following. 

• Choose Window > Bindings.

• Click the Application panel group’s expander arrow, then select the Bindings panel. 

2 Add the FIRST_NAME field to the table, by doing one of the following:

• Place the insertion point in the table cell below the First Name label, then in the Bindings 
panel select FIRST_NAME, and click Insert.

• Drag FIRST_NAME from the Bindings panel to the table cell.

3 Repeat step 2 to add LAST_NAME, EMAIL, and COMMENTS to the table.

Your page should look like this:

4 Save your document.
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Set a repeated region
The table you created only contains one row for data. To see all the records you’ll set the table row 
as a repeated region. The page will repeat with date records for each record that matches the 
recordset search requirements.

1 In the Document window, select the bottom table row by doing one of the following:

• Place the pointer in the first cell, then drag to the right to select all of the cells in the row.

• Click in one of the cells, then in the tag selector, click the <tr> tag.

• Position the pointer to the left of the table row, when it changes to an arrow click the table row 
border to select the row.

2 Set a repeated region, by doing one of the following: 

• In the Server Behaviors panel, click the plus (+) button, then select Repeat Region. 

• In the Insert bar’s Application tab, click the Repeated Region button. 

• Select Insert > Application Objects > Repeated Region.

The Repeat Region dialog box appears.

3 In the dialog box, accept the default setting, click OK.

The table row appears in a tabbed outline.

4 Save your document.

View your pages
Next, you’ll save the pages, then you’ll view the pages to see how the application you developed 
works. To view pages as they would look when processed by the server, you can use Live Data view.

1 With customerComment still selected, do one of the following to view the data in your pages:

• In the Document toolbar, click the Live Data View button.
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• Select View > Live Data.

The page updates with a list of customer data extracted from the database.

Create a record insert form
The next page you’ll create for the Global website is a customer comment page. You want 
customers to enter comments and insert them directly in the database. You’ll connect this page to 
the Comments table in the Global database. 

Dreamweaver includes several application objects that help you create web application pages 
quickly and easily. You’ll use an application object to create the insert page. The Insert Record 
application object creates an HTML form, data fields that link (or bind) to the database, and the 
necessary server scripts to create a dynamic page.

Add a Record Insertion Form application object

You can use a Record Insertion Form application object to create a form which links to the fields 
of a database. The application object lets you select which fields to include in the form, label 
fields, and select the type of form objects to insert. When a user enters data in the form fields and 
clicks the submit button, a new record is inserted in a database. You can also set a page to open 
after a record has successfully been submitted so the submitter knows the database was updated.

1 In the Site panel, locate the file named customerInsert, then double-click the file to open it.

The document opens in the Document window.

2 Place the insertion point in the document after the word “possible”, then press Enter or Return 
to set where the application object will be inserted. 

3 Do one of the following to insert a record insertion object:

• In the Insert bar’s Application tab, click the Record Insertion Form button. 
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• Choose Insert > Application Objects > Record Insertion Form.

The Record Insertion Form dialog box appears. 

4 In the Data Source (ColdFusion) or Connection pop-up menu, choose connGlobal.

5 In the Table pop-up menu, make sure COMMENTS is selected.

6 In the After Inserting, Go To or On Success, Go To (ASP.NET) text box, click Browse.

7 In the dialog box that appears, select the file named insertOK, then click OK to close the 
dialog box.

You’ve selected a page to display to a site visitor to acknowledge receipt of the information 
they’ve submitted. 

Create the insert form

In the Form Fields section of the Record Insertion Form dialog box, you define the form a visitor 
enters data into.

1 In the Record Insertion Form dialog box, remove the fields you don’t want included in the 
form by doing the following:

Select COMMENT_ID, then click the minus (-) button.

Select TELEPHONE, then click the minus (-) button.

Select SUBMIT_DATE, then click the minus (-) button.

Select ANSWERED, then click the minus (-) button.

2 If you are creating a page for ASP.NET, change the alphabetical order of the form fields by 
doing the following:

In the Column list, select COMMENTS, then click the Down arrow button to position 
COMMENTS below LAST_NAME.

In the Column list, select EMAIL, then click the Down arrow button to position it below 
LAST_NAME.
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3 In the Form Fields list, select FIRST_NAME to specify how the field will be displayed in the form.

4 In the Label field, enter First Name. 

This is the label that will appear in the HTML form next to the text field.

5 Set the type of form object for the field by doing one of the following:

• If you are using ASP.NET, in Display As accept the default value Text Field and in the Submit 
As pop-up menu, change the default value WChar to VARCHAR.

• If you are using other server page types, in Display As accept the default value Text Field and in 
Submit As accept the default value Text. 

6 In the Default Value field, type Enter your first name to set initial text for the field which lets 
the user know the type of information to provide.

The FIRST_NAME entry should look similar this when you are done.

7 Repeat steps 3–6 for the LAST_NAME and EMAIL form fields. 

In the Default Value text box, enter the initial text you want to appear in the field when it is 
displayed in the form.

8 Select COMMENTS to set values for this field.

9 In the Label field, enter Comments. 

10 Set values for the Comments form field by doing one of the following:

• If you are using ASP.NET, in the Display As pop-up menu select Text Area, then in the Submit 
As pop-up menu, select VARCHAR.

• If you are using other server page types, in the Display As pop-up menu, select Text Area, and 
in the Submit As pop-up menu accept the default value Text. 
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11 In Default Value text box, enter text that will initially appear in this field in the form or leave 
this field blank.

The dialog box should look similar to this when you are done:

12 Click OK to close the dialog box.

The Record Insertion Form application object is inserted in the document. 

13 Save your document.
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Copy files to the server
Next, you’ll save your changes, and copy the files you’ve updated to your server. After you copy 
the files, you’ll view the insert record page, add a comment or question, and submit the data to 
test the application.

1 In the Site panel, select customerInsert, then click the Put File(s) button (blue up arrow) to 
copy the local file to your server.

2 Dreamweaver asks whether you want to copy dependent files to the server, select Yes.

Note: With some server models, Dreamweaver creates a Connections folder in your local folder. You must also 
copy that folder to your remote server for the web application to work. In the Site panel, select the Connections 
folder, then click the Put File (s) button to copy the folder to your server.

3 With customerInsert selected, choose File > Preview in Browser or press F12 (Windows) to 
view your document. 

4 Enter test data in the form, then click the Insert Record button in the document to submit 
your data.

Information updates in the database, and the insertOK page appears.

View the update

Let’s view the changes you made to the database. You can view the changes by opening the 
customerComment document you created in the first part of this lesson, or you can view the 
changes by viewing the database.

• In Dreamweaver, in the Site panel, double-click the document named customerComment, 
then select File > Preview in Browser, and select a browser to view the page in.

The record you entered appears in the Customer Comments list. 

• In Dreamweaver, in the Database panel (Window > Database), locate the connGlobal database 
icon, click the plus (+) button in front of Tables to view the list of tables in the database. Right-
click (Windows) or Control-click (Macintosh), the COMMENTS table and select View Data.

A list of the records in the database appears; the comment you just entered appears as the last 
entry in the table. 

Further reading
The Getting Started guide touches on a small set of tools you can work with to create dynamic, 
data-driven pages. You learned how to create recordsets to define the data you want to use in your 
website. You also used a Dreamweaver application object to create an effective web application 
that allows you to interact with database-stored data.

For information on building a website in Dreamweaver, see Chapter 2, “Creating Your First 
Website in Dreamweaver,” on page 19. For information about using Dreamweaver coding 
features, see Chapter 3, “Editing code in Dreamweaver,” on page 49.

For more detailed information about topics covered in this part of the Getting Started with 
Dreamweaver MX guide, see the following topics in the online guide, Using Dreamweaver MX 
(Help > Using Dreamweaver MX):

• Storing and Retrieving Data for Your Page

• Defining Sources of Dynamic Data
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• Adding Dynamic Content to Web Pages

• Creating recordset navigation links

• Building an insert page rapidly

• Building an insert page block by block
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CHAPTER 6

Installing a Web Server in Windows

To develop and test dynamic web pages, you need a functioning web server. This chapter describes 
how most Windows users can install and use a Microsoft web server on their local computer.

Macintosh users can use a web server on a network computer or a web hosting company. Mac OS 
X 10.1 users can use the Apache web server on their local computer. For more information on the 
Apache server, visit the Apache website at http://httpd.apache.org/. Please note, however, that the 
root folder of the Apache server differs from the root folder of the Microsoft servers discussed in 
this guide (Inetpub\wwwroot). 

This chapter contains the following sections:

• “Getting started” on page 84

• “Installing Personal Web Server” on page 84

• “Installing Internet Information Server” on page 85

• “Testing the web server” on page 85

• “Web server basics” on page 86

Note: Macromedia does not provide technical support for third-party software such as Microsoft Personal Web 
Server. If you need assistance, please contact Microsoft technical support.
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Getting started
If you’re a Windows user, you can install and run the following web servers on your computer: 
Microsoft Personal Web Server (PWS) or Internet Information Server (IIS), a full-featured 
version of PWS. You can also install the web server on a networked Windows computer so other 
developers on your team can use it.

Note: Windows Millennium Edition (Me) does not support any version of PWS or IIS. For more information, see the 
Microsoft website at http://support.microsoft.com/default.aspx?scid=kb;EN-US;q266456. 

PWS or IIS may already be installed on your computer. Check your folder structure to see if it 
contains a C:\Inetpub or D:\Inetpub folder. PWS and IIS create this folder during installation. 

If the folder does not exist, do one the following:

• Windows 98: Copy the PWS setup file from the Windows 98 CD to your hard disk. The file is 
located in the Add-Ons/PWS folder. Next, install the web server. For instructions, see 
“Installing Personal Web Server” on page 84.

• Windows NT Workstation: Download the NT 4.0 Option Pack from the Microsoft website at 
http://www.microsoft.com/ntserver/nts/downloads/recommended/nt4optpk/default.asp. The 
Option Pack includes the PWS setup file. Next, install the web server. For instructions, see 
“Installing Personal Web Server” on page 84. 

Note: Service Pack 6 or higher must be installed on your computer to install the NT 4.0 Option Pack. Download 
the Service Pack from the Microsoft website at http;//www.microsoft.com/ntserver/nts/downloads/default.asp.

• Windows NT Server: IIS should be installed and running on your system. If not, install it or 
ask your system administrator to install it for you.

• Windows 2000: IIS might be installed on your system. If not, you need to install it. For more 
information, see “Installing Internet Information Server” on page 85.

• Windows XP Professional: IIS might be installed on your system. If not, you need to install it. 
For more information, see “Installing Internet Information Server” on page 85.

Installing Personal Web Server
Windows 98 and NT Workstation users should install PWS. If you’re a Windows NT Server, 
Windows 2000, or Windows XP Professional user, install IIS instead. For more information, see 
“Installing Internet Information Server” on page 85.

Note: Windows Millennium Edition (Me) does not support any version of PWS. For more information, see the 
Microsoft website at http://support.microsoft.com/default.aspx?scid=kb;EN-US;q266456.

You can install PWS on the same Windows system that runs Dreamweaver MX. Make sure 
Microsoft Internet Explorer 4.01 or later is installed on the system or PWS won’t install.

To install PWS:

1 Double-click the PWS installation file on the Windows 98 CD or the file you downloaded 
from the Microsoft website.

2 Follow the installation wizard.

3 When asked for your default web publishing home directory, accept the default directory:

C:\Inetpub\wwwroot

4 Click Finish to end the installation process.

You can test the web server after installing it. See “Testing the web server” on page 85.
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Installing Internet Information Server
Windows NT Server, Windows 2000, and Windows XP Professional users should install IIS. If 
you’re a Windows 98 or NT Workstation user, install PWS instead. For more information, see 
“Installing Personal Web Server” on page 84.

If you’re a Windows NT Server user, IIS should be installed and running on your system. If not, 
install it or ask your system administrator to install it for you.

If you’re a Windows 2000 or Windows XP Professional user, make sure IIS is installed and 
running on your system. The way to do this is to look for the C:\Inetpub folder. If it doesn’t exist, 
IIS is probably not installed on your system.

To install IIS on Windows 2000 and XP Professional:

1 In Windows 2000, choose Start > Settings > Control Panel > Add/Remove Programs; in 
Windows XP, choose Start > Control Panel > Add/Remove Programs.

2 Choose Add/Remove Windows Components.

3 Select the IIS box and follow the installation instructions.

You can test the web server after installing it. 

Testing the web server
To test the web server, create a simple HTML page with an .htm or .html file extension and save 
it in the Inetpub\wwwroot folder on your computer. The HTML page can consist of a single line, 
such as:

<p>My web server is working.</p> 

Save the page as myTestFile.htm. Next, open the test page in a web browser with an HTTP request. 
If PWS or IIS is running on your local computer, enter the following URL in your web browser:

http://localhost/myTestFile.htm

If PWS or IIS is running on a networked computer, use the networked computer’s name as the 
domain name. For example, if the name of the computer running PWS or IIS is kojak-pc, enter 
the following URL in your browser:

http://kojak-pc/myTestFile.htm

Note: For more information on computer names, see “Web server basics” on page 86. 

If the browser displays your page, the web server is running normally. 

If the browser fails to display the page, make sure the server is running. Double-click the web server 
icon in the system tray (the icon looks like a hand holding a web page). The Personal Web Manager 
dialog box appears. If the Publishing panel tells you web publishing is off, click the Start button.

If the page still fails to open, make sure your test page is located in the Inetpub\wwwroot folder 
and has an .htm or .html file extension.
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Web server basics
A web server is software that serves web pages in response to requests from web browsers. A web 
server is sometimes called an HTTP server.

Suppose you want to use PWS to develop web applications. If the server is started, an icon appears 
in the system tray on the lower right corner of your desktop telling you PWS is running. (The icon 
depicts a hand holding a web page.) Double-clicking this icon launches Personal Web Manager, 
which you can use to administer your web pages. The following shows Personal Web Manager: 

The default name of your web server is the name of your computer (cnadeau_pc1, in this 
example). You can change the server name by changing the name of your computer. If your 
computer has no name, the server uses the word localhost. 

The server name stands for (or is an alias for) the server’s root folder, which is most likely 
C:\Inetpub\wwwroot. You can open any web page stored in the root folder by entering the 
following URL in a browser running on your computer:

http://myServerName/myFileName 

For example, if the server name is mer_noire and a web page called soleil.htm is stored in 
C:\Inetpub\wwwroot\, you can open the page by entering the following URL in a browser 
running on the local computer:

http://mer_noire/soleil.htm
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You can also open any web page stored in any subfolder of the root folder by specifying the 
subfolder in the URL. For example, suppose the soleil.htm file is stored in a subfolder called 
gamelan, as follows:

C:\Inetpub\wwwroot\gamelan\soleil.htm

You can open this page by entering the following URL in a browser running on your computer:

http://mer_noire/gamelan/soleil.htm

When the web server is running on your computer, you can replace the server name with 
localhost. For example, the following URLs open the same page in a browser:

http://mer_noire/gamelan/soleil.htm

http://localhost/gamelan/soleil.htm

Note: Another expression you can use instead of the server name or localhost is 127.0.0.1 (for example, http://
127.0.0.1/gamelan/soleil.htm).
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CHAPTER 7

Setup for Sample ColdFusion Site

Macromedia Dreamweaver MX comes with sample ColdFusion pages to let you build a small web 
application. This chapter describes one way to set up the sample application if you’re using 
ColdFusion with Microsoft Internet Information Server (IIS) or Personal Web Server (PWS). For 
more information on these web servers, see “Installing a Web Server in Windows” on page 83. If 
you’re using ColdFusion MX with a different web server, see “Setting Up a Web Application” in 
Dreamweaver Help (Help > Using Dreamweaver).

Setting up a web application is a three-step process. First, configure your system. Second, define a 
Dreamweaver site. Third, connect the application to your database. This setup guide follows this 
three-step process. 

This chapter contains the following sections:

• “Setup checklists for ColdFusion developers” on page 89

• “Configuring your system” on page 90

• “Defining a Dreamweaver site” on page 92

• “Connecting to the sample database” on page 96

Setup checklists for ColdFusion developers
To set up a web application, you must configure your system, define a Dreamweaver site, and 
connect to a database. This section provides checklists for each task. The procedures are described 
in the rest of the chapter.

Configure your system:

1 Make sure you have a web server.

2 Install the ColdFusion application server.

3 Create a root folder. 

Define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk.

2 Define the folder as a Dreamweaver local folder.

3 Define a web server folder as a Dreamweaver remote folder.

4 Specify a folder to process dynamic pages.

5 Upload the sample files to the web server.
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Connect to the database:

1 If you have a remote server configuration, copy the sample database to the remote computer.

2 Create a ColdFusion data source in ColdFusion Administrator.

3 View the connection in Dreamweaver.

Configuring your system
This section provides instructions for two common system configurations—one where Microsoft 
IIS or PWS is installed on your hard disk, and one where IIS or PWS is installed on a remote 
Windows computer. If you don’t want to use these configurations, see “Setting Up a Web 
Application” in Help (Help > Using Dreamweaver). 

The following illustration shows the two configurations described in this section: 

To configure your system:

1 Make sure you have a web server (see “Checking for a web server” on page 91).

2 Install the ColdFusion application server (see “Installing ColdFusion MX” on page 91).

3 Create a root folder (see “Creating a root folder” on page 92). 

Note: Installing the web server and application server are one-time-only tasks.
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Checking for a web server

To develop and test dynamic web pages, you need a web server. A web server is software that 
serves web pages in response to requests from web browsers.

Make sure Microsoft IIS or PWS is installed and running on your hard disk or on a remote 
Windows computer. (Macintosh users need to install Microsoft IIS or PWS on a remote 
Windows computer.) A quick way to check whether PWS or IIS is installed on a system is to look 
at the folder structure. Does it contain a c:\Inetpub or d:\Inetpub folder? PWS and IIS create this 
folder during installation.

If PWS or IIS is not installed on the system, install it now. For instructions, see “Installing a Web 
Server in Windows” on page 83.

After installing the web server, install the application server. 

Installing ColdFusion MX 

To process dynamic web pages, you need an application server. An application server is software 
that helps a web server process web pages containing server-side scripts or tags. When such a page 
is requested from the server, the web server hands the page off to the application server for 
processing before sending the page to the browser. 

Make sure the ColdFusion MX application server is installed and running on the system running 
PWS or IIS. (PWS or IIS may be located on your hard disk or on a remote Windows computer.)

You can download and install a fully functional, developer edition of ColdFusion MX from the 
Macromedia website at http://www.macromedia.com/software/coldfusion/. A copy of 
ColdFusion MX Server Developer Edition is also available on the Dreamweaver CD (Windows 
version only). 

To install ColdFusion MX:

1 Close all open applications.

2 If applicable, log into the Windows system using the Administrator account.

3 Double-click the ColdFusion MX installer file.

4 Follow the installation instructions.

For more information, see the ColdFusion documentation in Dreamweaver (Help > 
Using ColdFusion).

After installing and starting ColdFusion, create a root folder for your web application. 
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Creating a root folder

After the server software is installed, create a root folder for your web application on the system 
running Microsoft PWS or IIS, and make sure the folder has the necessary permissions. 

To create a root folder for your web application:

1 Create a folder called MySampleApp on the system running PWS or IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By default, your PWS or IIS web 
server is set up in the Inetpub\wwwroot folder. The web server will serve any page in this folder 
or in any of its subfolders in response to a HTTP request from a web browser.

2 Make sure the Read and Scripts permissions are enabled for the folder.

If you’re using PWS, launch Personal Web Manager by double-clicking the web server icon in 
the system tray. (The icon depicts a hand holding a web page.) In Personal Web Manager, click 
the Advanced icon. The Advanced Options dialog box appears. Select Home and click Edit 
Properties. The Edit Directory dialog box appears. Make sure the Read and Scripts options are 
selected. For security reasons, you should not select the Execute option. 

If you’re using IIS, launch the IIS administrative tool (in Windows XP, select Start > 
Control Panel > Performance Maintenance > Administrative Tools > Internet Information 
Services). Under Web Sites > Default Web Site, right-click your MySampleSite folder and choose 
Properties from the pop-up menu. In the Execute Permissions text box, make sure the Scripts 
option is selected. For security reasons, do not select the “Scripts and Executables” option.

The web server is now configured to serve web pages in your root folder in response to HTTP 
requests from web browsers.

After configuring your system, you must define a Dreamweaver site. 

Defining a Dreamweaver site
After configuring your system, you must copy the sample files to a local folder and define a 
Dreamweaver site to manage the files. 

Note: Macromedia HomeSite and ColdFusion Studio users can think of a Dreamweaver site as a HomeSite or 
Studio project. 

To define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk (see “Copying the sample files” on page 93).

2 Define the folder as a Dreamweaver local folder (see “Defining a local folder” on page 93).

3 Define your root folder on the web server as a Dreamweaver remote folder (see “Defining a 
remote folder” on page 94).

4 Specify a folder to process dynamic pages (see “Specifying where dynamic pages can be 
processed” on page 94).

5 Upload the sample files to the web server (see “Uploading the samples files” on page 95).
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Copying the sample files

If not already done, copy the sample files from the Dreamweaver application folder to a folder on 
your hard disk.

To copy the sample files:

1 Create a new folder called Sites on your hard disk.

For example, create C:\Sites (Windows) or Hard Drive:Documents:Sites (Macintosh).

2 Locate the GettingStarted folder in the Dreamweaver application folder on your hard disk.

The path to the folder is as follows:

\Macromedia\Dreamweaver MX\Samples\GettingStarted\

3 Copy the GettingStarted folder into the Sites folder.

After copying the GettingStarted folder, define the folder as a Dreamweaver local folder.

Defining a local folder

After copying the GettingStarted folder, define the folder containing the ColdFusion sample files 
as a Dreamweaver local folder. 

To define the Dreamweaver local folder:

1 In Dreamweaver, select Site > New Site.

The Site Definition dialog box appears. 

2 If the wizard is showing, click Advanced.

3 In the Site Name text box, enter GlobalCar - ColdFusion.

The name identifies your site within Dreamweaver. 

4 In the Local Root Folder text box, specify the folder in the GettingStarted folder that contains 
the ColdFusion sample files.

You can click the folder icon next to the text box to find and select the folder. In Windows, the 
folder should be as follows:

C:\Sites\GettingStarted\Develop\coldfusion

On the Macintosh, the folder should be as follows:

Hard Drive:Documents:Sites:GettingStarted:Develop:coldfusion

Leave the Site Definition dialog box open. You need to define a web server folder as a 
Dreamweaver remote folder next. 
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Defining a remote folder

After defining a local folder, define a web server folder as a Dreamweaver remote folder. 

To define the Dreamweaver remote folder:

1 In the advanced Site Definition dialog box, click Remote Info in the Category list. 

The Remote Info screen appears.

2 In the Access text box, choose how you want to move your files to and from the server—
directly (the Local/Network option) or FTP. 

3 Enter the path or FTP settings to the web server folder you created in “Creating a root folder” 
on page 92.

The folder may be on your hard disk or on a remote computer. Even if you created the folder 
on your hard disk, that folder is still the valid “remote” folder. Here’s an example if you chose 
Local/Network access:

Remote Folder: c:\Inetpub\wwwroot\MySampleApp

For more information on FTP, see “Setting Remote Info options for FTP access” in Help 
(Help > Using Dreamweaver).

Leave the Site Definition dialog box open. You need to define a folder to process dynamic pages next.

Specifying where dynamic pages can be processed

After defining the Dreamweaver remote folder, specify a folder to process dynamic pages as 
described in this section. Dreamweaver uses this folder to display dynamic pages and connect to 
databases while you work. 

To specify the folder to process dynamic pages:

1 In the advanced Site Definition dialog box, click Testing Server in the Category list.

The Testing Server screen appears. Dreamweaver needs the services of a testing server to 
generate and display dynamic content while you work. The testing server can be your local 
computer, a development server, a staging server, or a production server. As long as it can 
process ColdFusion pages, the choice doesn’t matter. In this case, you can use the same settings 
as the Remote Info category (see “Defining a remote folder” on page 94) because they point to 
a server capable of processing ColdFusion pages.

2 Select ColdFusion as your server technology.

3 In the Access text box, choose the method (Local/Network or FTP) you specified for accessing 
your remote folder.

Dreamweaver enters the settings you specified in the Remote Info category. Leave the 
settings unchanged.
Chapter 794



4 In the URL Prefix text box, enter the root URL you would enter in a web browser to request a 
page in your web application.

To display live data in your pages while you work, Dreamweaver creates a temporary file, 
copies it to the website’s root folder, and attempts to request it using the URL prefix. 

Dreamweaver makes a best guess at the URL prefix based on the information you provided in 
the Site Definition dialog box. For example, if the folder specified in the Remote Folder text 
box is c:\Inetpub\wwwroot\MySampleApp, then the URL prefix should be as follows:

http://localhost/MySampleApp/

Tip: The URL prefix should never specify a particular page on the site. 

However, the suggested URL prefix may be incorrect. Correct or enter a new URL prefix if 
Dreamweaver’s suggestion is incorrect. For more information, see “About the URL prefix” in 
Help (Help > Using Dreamweaver).

5 Click OK, then Done.

After specifying a folder to process dynamic pages, upload the sample files to the web server.

Uploading the samples files 

After specifying a folder to process dynamic pages, upload the sample files to the web server as 
described in this section. You must “upload” the files even if the web server is running on your 
local computer. 

If you don’t upload the files, features such as Live Data view and Preview in Browser may not work 
properly with dynamic pages. For example, image links might be broken in Live Data view because 
the image files are not on the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing from the server.

To upload the samples files to the web server:

1 In the Site panel (Window > Site), select the root folder in the Local Files pane.

The root folder should be the first folder in the list.

2 Click the blue up arrow on the toolbar. 

Dreamweaver copies all the files to the web server folder you defined in “Defining a remote 
folder” on page 94. 

The Dreamweaver site is defined. The next step is to connect to the sample database installed 
with Dreamweaver.
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Connecting to the sample database
During installation, Dreamweaver copies a sample Microsoft Access database to your hard disk. 
This section describes how to create a connection to the sample database.

Note: If you want to connect to another database, see “Database Connections for ColdFusion Developers” in Help 
(Help > Using Dreamweaver).

To create a database connection:

1 If you have a remote server configuration, copy the sample database to the remote computer 
(see “Setting up the database (remote server configuration)” on page 96).

2 Create a ColdFusion data source in ColdFusion Administrator (see “Creating a ColdFusion 
data source” on page 96).

3 View the connection in Dreamweaver (see “Connecting to the database” on page 97).

Setting up the database (remote server configuration)

This section applies only if you have a remote server configuration—that is, if your web server is 
running on a remote computer. If your web server is running on the same computer as 
Dreamweaver, skip to “Creating a ColdFusion data source” on page 96.

Before attempting to connect to the sample database, copy the database to the remote computer’s 
hard disk. The database file, global.mdb, is located in the following folder on your local hard disk:

\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

You can place the file in any folder on the remote computer, or you can create a new folder for it.

After the database is in place, create a ColdFusion data source in ColdFusion Administrator. 

Creating a ColdFusion data source

Create a ColdFusion data source called connGlobal in ColdFusion Administrator pointing to the 
sample database file. 

To create a ColdFusion data source:

1 In Dreamweaver, open a ColdFusion page.

2 In the Databases panel (Window > Databases), click the Modify Data Sources icon (the second 
icon from the right on the panel toolbar).

ColdFusion Administrator opens in a browser. 

3 Log in to ColdFusion Administrator and create a data source called connGlobal pointing to 
the global.mdb database file. 

If ColdFusion is running on your local computer, create a data source that points to the 
database file in the following folder:

c:\Program Files\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

If ColdFusion is running on a remote computer, create a data source that points to the 
database file you placed on the remote computer in “Setting up the database (remote server 
configuration)” on page 96.

For more information, see the ColdFusion documentation in Dreamweaver (Help > 
Using ColdFusion). 

After creating the ColdFusion data source, you can connect to the database in Dreamweaver. 
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Connecting to the database

After creating the ColdFusion data source, you can use it to connect to the database in Dreamweaver.

Open any ColdFusion page in Dreamweaver, then open the Databases panel (Window > 
Databases). Your ColdFusion data sources appear in the panel.

If the data source you created does not appear in the panel, do one of the following:

• Double-check the connection parameters in ColdFusion Administrator. 

• Check the settings for the folder Dreamweaver uses to process dynamic pages (see “Specifying 
where dynamic pages can be processed” on page 94).

• Consult “Troubleshooting Database Connections” on page 145.

If the data source called connGlobal appears in the panel, the sample ColdFusion application is 
set up for the Getting Started guide and the tutorials. See “Developing a Web Application in 
Dreamweaver MX” on page 69 and the tutorials in Dreamweaver Help (Help > Tutorials).
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CHAPTER 8

Setup for Sample ASP.NET Site

Macromedia Dreamweaver MX comes with sample ASP.NET pages to let you build a small web 
application. This chapter describes one way to set up the sample application.

This chapter applies to ASP.NET developers. If you want to explore ASP, see “Setup for Sample 
ASP Site” on page 109.

Setting up a web application is a three-step process. First, configure your system. Second, define a 
Dreamweaver site. Third, connect the application to your database. This setup guide follows this 
three-step process. 

This chapter contains the following sections:

• “Setup checklist for ASP.NET developers” on page 99

• “Configuring your system” on page 100

• “Defining a Dreamweaver site” on page 102

• “Connecting to the sample database (local configuration)” on page 105

• “Connecting to the sample database (remote server configuration)” on page 106

Setup checklist for ASP.NET developers
To set up a web application, you must configure your system, define a Dreamweaver site, and 
connect to a database. This section provides checklists for each task. The procedures are described 
in the rest of the chapter.

Configure your system:

1 Make sure you have a web server.

2 Install the Microsoft .NET Framework.

3 Create a root folder. 

Define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk.

2 Define the folder as a Dreamweaver local folder.

3 Define a web server folder as a Dreamweaver remote folder.

4 Specify a folder to process dynamic pages.

5 Upload the sample files to the web server.
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Connect to the database (local configuration):

Create the connection in Dreamweaver.

Connect to the database (remote server configuration):

Copy the database to the remote computer and create the connection in Dreamweaver.

Configuring your system
This section provides instructions for two common system configurations—one where Windows 
2000 or Windows XP Professional is installed on your hard disk, and one where Windows 2000 
or Windows XP Professional is installed on a remote computer. If you don’t want to use these 
configurations, see “Setting Up a Web Application” in Help (Help > Using Dreamweaver).

The following illustration shows the two configurations described in this section:  
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To configure your system:

1 Make sure you have a web server (see “Checking for a web server” on page 101).

2 Install the .NET Framework (see “Installing the .NET Framework” on page 101).

3 Create a root folder (see “Creating a root folder” on page 102). 

Note: Installing the web server and the .NET Framework are one-time-only tasks.

Checking for a web server 

To develop and test dynamic web pages, you need a web server. A web server is software that 
serves web pages in response to requests from web browsers.

ASP.NET pages only work with one web server: Microsoft IIS 5 or higher. PWS is not supported. 
Also, because IIS 5 is a service of the Windows 2000 and Windows XP Professional operating 
systems, you can only use these two versions of Windows to run ASP.NET applications. Windows 
98, ME, or NT are not supported.

Make sure IIS 5 is installed and running on a Windows 2000 or Windows XP Professional 
computer. IIS 5 can be installed on your hard disk if you have Windows 2000 or Windows XP 
Professional, or on a remote computer. If you’re a Windows 98, Windows ME, Windows NT, 
Windows XP Home Edition, or Macintosh user, you must run IIS 5 on a remote Windows 2000 
or Windows XP Professional computer. 

A quick way to check whether IIS is installed on your system is to look at the folder structure. 
Does it contain a c:\Inetpub or d:\Inetpub folder? IIS creates this folder during installation.

If IIS is not installed, install it now. For instructions, see “Installing Internet Information Server” 
on page 85.

After installing the web server, install the .NET Framework. 

Installing the .NET Framework 

To process dynamic web pages, you need an application server. An application server is software 
that helps a web server process web pages containing server-side scripts or tags. When such a page 
is requested from the server, the web server hands the page off to the application server for 
processing before sending the page to the browser.

In ASP.NET, the application server is called the .NET Framework. Make sure the .NET 
Framework is installed and running on the Windows 2000 or Windows XP Professional system 
running IIS 5 or higher. (IIS may be located on your hard disk or on a remote computer.) 

To install the .NET Framework, download the Framework from the Microsoft website at http://
www.asp.net/download.aspx and follow the installation instructions on the website. If you’re a 
Windows 98, Windows ME, Windows NT, Windows XP Home Edition, or Macintosh user, 
then you must install the .NET Framework on a remote Windows 2000 or Windows XP 
Professional computer running IIS 5. 

After installing the .NET Framework, create a root folder for your web application. 
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Creating a root folder

After the server software is installed, create a root folder for your web application on the system 
running Microsoft IIS, and make sure the folder has the necessary permissions. 

To create a root folder for your web application:

1 Create a folder called MySampleApp on the system running IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By default, your IIS web server is 
set up in the Inetpub\wwwroot folder. The web server will serve any page in this folder or in 
any of its subfolders in response to a HTTP request from a web browser.

2 Make sure the Scripts permission is enabled for the folder.

Launch the IIS administrative tool (in Windows XP, select Start > Control Panel > 
Performance Maintenance > Administrative Tools > Internet Information Services). Under 
Web Sites > Default Web Site, right-click your MySampleSite folder and choose Properties 
from the pop-up menu. In the Execute Permissions text box, make sure the Scripts option is 
selected. For security reasons, do not select the “Scripts and Executables” option. 

The web server is now configured to serve web pages in your root folder in response to HTTP 
requests from web browsers.

After configuring your system, you must define a Dreamweaver site. 

Defining a Dreamweaver site
After configuring your system, you must copy the sample files to a local folder and define a 
Dreamweaver site to manage the files. 

Note: Macromedia HomeSite and ColdFusion Studio users can think of a Dreamweaver site as a HomeSite or 
Studio project. 

To define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk (see “Copying the sample files” on page 102).

2 Define the folder as a Dreamweaver local folder (see “Defining a local folder” on page 103).

3 Define a web server folder as a Dreamweaver remote folder (see “Defining a remote folder” 
on page 103).

4 Specify a folder to process dynamic pages (see “Specifying where dynamic pages can be 
processed” on page 104).

5 Upload the sample files to the web server (see “Uploading the samples files” on page 105).

Copying the sample files

If not already done, copy the sample files from the Dreamweaver application folder to a folder on 
your hard disk.

To copy the sample files:

1 Create a new folder called Sites on your hard disk.

For example, create C:\Sites (Windows) or Hard Drive:Documents:Sites (Macintosh).
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2 Locate the GettingStarted folder in the Dreamweaver application folder on your hard disk.

The path to the folder is as follows:

\Macromedia\Dreamweaver MX\Samples\GettingStarted\ 

3 Copy the GettingStarted folder into the Sites folder.

After copying the GettingStarted folder, define the folder as a Dreamweaver local folder.

Defining a local folder

After copying the GettingStarted folder, define the folder containing the ASP.NET sample files as 
a Dreamweaver local folder. 

To define the Dreamweaver local folder:

1 In Dreamweaver, select Site > New Site.

The Site Definition dialog box appears. 

2 If the wizard is showing, click Advanced.

3 In the Site Name text box, enter GlobalCar - ASP.NET.

The name identifies your site within Dreamweaver. 

4 In the Local Root Folder text box, specify the folder in the GettingStarted folder that contains 
the ASP.NET sample files.

You can click the folder icon next to the text box to find and select the folder. In Windows, the 
folder should be as follows:

C:\Sites\GettingStarted\Develop\aspnet

On the Macintosh, the folder should be as follows:

Hard Drive:Documents:Sites:GettingStarted:Develop:aspnet

Leave the Site Definition dialog box open. You need to define a web server folder as a 
Dreamweaver remote folder next. 

Defining a remote folder

After defining a local folder, define a web server folder as a Dreamweaver remote folder as 
described in this section. 

To define the Dreamweaver remote folder:

1 In the advanced Site Definition dialog box, click Remote Info in the Category list. 

The Remote Info screen appears.

2 In the Access text box, choose how you want to move your files to and from the server—
directly (the Local/Network option) or FTP. 
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3 Enter the path or FTP settings to the web server folder you created in “Creating a root folder” 
on page 102.

The folder may be on your hard disk or on a remote computer. Even if you created the folder 
on your hard disk, that folder is still the valid “remote” folder. Here’s an example if you chose 
Local/Network access:

Remote Folder: c:\Inetpub\wwwroot\MySampleApp

For more information on FTP, see “Setting Remote Info options for FTP access” in Help 
(Help > Using Dreamweaver).

Leave the Site Definition dialog box open. You need to define a folder to process dynamic pages next.

Specifying where dynamic pages can be processed

After defining the Dreamweaver remote folder, specify a folder to process dynamic pages as 
described in this section. Dreamweaver uses this folder to display dynamic pages and connect to 
databases while you work. 

To specify the folder to process dynamic pages:

1 In the advanced Site Definition dialog box, click Testing Server in the Category list.

The Testing Server screen appears. Dreamweaver needs the services of a testing server to 
generate and display dynamic content while you work. The testing server can be your local 
computer, a development server, a staging server, or a production server. As long as it can 
process ASP.NET pages, the choice doesn’t matter. In this case, you can use the same settings as 
the Remote Info category (see “Defining a remote folder” on page 103) because they point to a 
server capable of processing ASP.NET pages.

2 Select ASP.NET VB or ASP.NET C# as your server technology.

3 In the Access text box, choose the method (Local/Network or FTP) you specified for accessing 
your remote folder.

Dreamweaver enters the settings you specified in the Remote Info category. Leave the 
settings unchanged.

4 In the URL Prefix text box, enter the root URL you would enter in a web browser to request a 
page in your web application. 

To generate and display dynamic content while you work, Dreamweaver creates a temporary 
file, copies it to the website’s root folder, and attempts to request it using the URL prefix. 

Dreamweaver makes a best guess at the URL prefix based on the information you provided in 
the Site Definition dialog box. For example, if the folder specified in the Remote Folder text 
box is c:\Inetpub\wwwroot\MySampleApp, then the URL prefix should be as follows:

http://localhost/MySampleApp/

Tip: The URL prefix should never specify a particular page on the site. 

However, the suggested URL prefix may be incorrect. Correct or enter a new URL prefix if 
Dreamweaver’s suggestion is incorrect. For more information, see “About the URL prefix” in 
Help (Help > Using Dreamweaver).

5 Click OK, then Done.

After specifying a folder to process dynamic pages, upload the sample files to the web server.
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Uploading the samples files 

After specifying a folder to process dynamic pages, upload the sample files to the web server as 
described in this section. You must “upload” the files even if the web server is running on your 
local computer. 

If you don’t upload the files, features such as Live Data view and Preview in Browser may not work 
properly with dynamic pages. For example, image links might be broken in Live Data view because 
the image files are not on the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing from the server.

To upload the samples files to the web server:

1 In the Site panel (Window > Site), select the root folder in the Local Files pane.

The root folder should be the first folder in the list.

2 Click the blue up arrow on the toolbar. 

Dreamweaver copies all the files to the web server folder you defined in “Defining a remote 
folder” on page 103. 

The Dreamweaver site is defined. The next step is to connect to the sample database installed 
with Dreamweaver. If your web server runs on your local computer, see “Connecting to the 
sample database (local configuration)” on page 105. If your web server runs on a remote 
computer, see “Connecting to the sample database (remote server configuration)” on page 106.

Connecting to the sample database (local configuration)
During installation, Dreamweaver copies a sample Microsoft Access database to your hard disk. 
This section describes how to create a connection to the sample database if you have a local 
configuration—that is, if your web server is running on the same computer as Dreamweaver. If 
your web server is running on a remote computer, see “Connecting to the sample database 
(remote server configuration)” on page 106. 

Note: If you want to connect to another database, see “Database Connections for ASP.NET Developers” in 
Dreamweaver Help (Help > Using Dreamweaver).

To create a connection with a local configuration:

1 Open any ASP.NET page in Dreamweaver, then open the Databases panel (Window > 
Databases).

2 Click the plus (+) button on the panel and select OLE DB Connection from the 
pop-up menu.

The OLE DB Connection dialog box appears.

3 Enter connGlobal as the connection name.

4 Click the Templates button.

The Connection String Template dialog box appears.

5 From the list of templates, choose Microsoft Access 2000 (Microsoft Jet 4.0 Provider) and 
click OK.

Dreamweaver adds a connection string template in the OLE DB Connection dialog box. The 
template contains placeholders for missing information in the connection string.
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6 For the Data Source value, enter the full path to the sample database file on your hard disk. 

For example, during installation Dreamweaver places the sample database file, global.mdb, in 
the following folder on your local hard disk:

c:\Program Files\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

Note: The path may vary depending on where you installed Dreamweaver. 

Enter this path as the value of Data Source:

Data Source=c:\Program Files\Macromedia\Dreamweaver MX\Samples\Database\glo
bal.mdb;

7 Delete the User ID and the Password lines.

The Access database does not require a user ID or password.

8 Click Test.

Dreamweaver attempts to connect to the database. If the connection fails, do the following:

• Double-check the path to the database. 

• Check the settings for the folder Dreamweaver uses to process dynamic pages (see “Specifying 
where dynamic pages can be processed” on page 104).

• Consult “Troubleshooting Database Connections” on page 145.

9 Click OK.

The new connection appears in the Databases panel.

The sample ASP.NET application is set up for the Getting Started guide and the tutorials. See 
“Developing a Web Application in Dreamweaver MX” on page 69 and the tutorials in 
Dreamweaver Help (Help > Tutorials).

Connecting to the sample database (remote server 
configuration)

During installation, Dreamweaver copies a sample Microsoft Access database to your hard disk. 
This section describes how to create a connection to the sample database if you have a remote 
server configuration—that is, if your web server is running on a remote computer. If your web 
server is running on the same computer as Dreamweaver, see “Connecting to the sample database 
(local configuration)” on page 105. 

Note: If you want to connect to another database, see “Database Connections for ASP.NET Developers” in 
Dreamweaver Help (Help > Using Dreamweaver).

To create a connection with a remote server configuration:

1 Copy the sample database file to the remote computer.

The database file, global.mdb, is located in the following folder on your local hard disk:

\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

You can place the file in any folder on the remote computer, or you can create a new folder for 
it. In either case, write down the full path to the database file on a piece of paper.

2 Open any ASP.NET page in Dreamweaver, then open the Databases panel (Window > 
Databases).
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3 Click the plus (+) button on the panel and select OLE DB Connection from the 
pop-up menu.

The OLE DB Connection dialog box appears.

4 Enter connGlobal as the connection name.

5 Click the Templates button.

The Connection String Template dialog box appears.

6 From the list of templates, choose Microsoft Access 2000 (Microsoft Jet 4.0 Provider) 
and click OK.

Dreamweaver adds a connection string template in the OLE DB Connection dialog box. The 
template contains placeholders for missing information in the connection string.

7 For the Data Source value, enter the full path to the sample database file on the remote computer.

Enter the path you noted in step 1. For example, the path on the network computer could be 
as follows: 

Data Source=c:\users\Denman\Sites\data\global.mdb;

8 Delete the User ID and the Password lines.

9 Click Test.

Dreamweaver attempts to connect to the database on the network computer. If the connection 
fails, do the following:

• Double-check the path to the database. 

• Check the settings for the folder Dreamweaver uses to process dynamic pages (see “Specifying 
where dynamic pages can be processed” on page 104).

• Consult “Troubleshooting Database Connections” on page 145.

10 Click OK.

The new connection appears in the Databases panel.

The sample ASP.NET application is set up for the Getting Started guide and the tutorials. See 
“Developing a Web Application in Dreamweaver MX” on page 69 and the tutorials in 
Dreamweaver Help (Help > Tutorials).
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CHAPTER 9

Setup for Sample ASP Site

Macromedia Dreamweaver MX comes with sample Microsoft Active Server Pages (ASP) to let 
you build a small web application. This chapter describes one way to set up the sample 
application using Microsoft Internet Information Server (IIS) or Personal Web Server (PWS). For 
more information on these web servers, see “Installing a Web Server in Windows” on page 83. If 
you’re using a different web server, see “Setting Up a Web Application” in Help (Help > Using 
Dreamweaver).

This chapter applies to ASP developers only. If you want to explore ASP.NET, see “Setup for 
Sample ASP.NET Site” on page 99.

Setting up a web application is a three-step process. First, configure your system. Second, define a 
Dreamweaver site. Third, connect the application to your database. This setup guide follows this 
three-step process. 

This chapter contains the following sections:

• “Setup checklist for ASP developers” on page 109

• “Configuring your system” on page 110

• “Defining a Dreamweaver site” on page 114 

• “Connecting to the sample database (local configuration)” on page 117

• “Connecting to the sample database (remote server configuration)” on page 118

Setup checklist for ASP developers
To set up a web application, you must configure your system, define a Dreamweaver site, and 
connect to a database. This section provides checklists for each task. The procedures are described 
in the rest of the chapter.

Configure your system:

1 Make sure you have a web server.

2 Install an application server.

3 Test your installation.

4 Create a root folder. 
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Define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk.

2 Define the folder as a Dreamweaver local folder.

3 Define a web server folder as a Dreamweaver remote folder.

4 Specify a folder to process dynamic pages.

5 Upload the sample files to the web server.

Connect to the database (local configuration):

1 Create the connection in Dreamweaver.

Connect to the database (remote server configuration):

1 Set up the sample database on the computer running your web server.

2 Create the connection in Dreamweaver.

Configuring your system
This section provides instructions for two common system configurations—one where Microsoft 
IIS or PWS is installed on your hard disk, and one where IIS or PWS is installed on a remote 
Windows computer. If you don’t want to use these configurations, see “Setting Up a Web 
Application” in Help (Help > Using Dreamweaver).
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The following illustration shows the two configurations described in this section: 

To configure your system:

1 Make sure you have a web server (see “Checking for a web server” on page 111).

2 If necessary, install an application server (see “Installing an ASP application server” on page 112).

3 Test your installation (see “Testing the installation” on page 112).

4 Create a root folder (see “Creating a root folder” on page 114). 

Note: Installing the web server and application server are one-time only tasks.

Checking for a web server

To develop and test dynamic web pages, you need a web server. A web server is software that 
serves web pages in response to requests from web browsers.

Make sure Microsoft IIS or PWS is installed and running on your hard disk or on a remote 
Windows computer. (Macintosh users need to install Microsoft IIS or PWS on a remote 
Windows computer.) A quick way to check whether PWS or IIS is installed on a computer is to 
look at the folder structure. Does it contain a c:\Inetpub or d:\Inetpub folder? PWS and IIS create 
this folder during installation.
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If PWS or IIS is not installed, install it now. For instructions, see “Installing a Web Server in 
Windows” on page 83.

After installing the web server, you normally need to install an application server. 

Installing an ASP application server

To process dynamic web pages, you need an application server. An application server is software 
that helps a web server process web pages containing server-side scripts or tags. When such a page 
is requested from the server, the web server hands the page off to the application server for 
processing before sending the page to the browser.

If you installed PWS or IIS on a Windows computer, then you don’t need a separate ASP 
application server. PWS and IIS also function as ASP application servers. For more information 
on installing and testing PWS or IIS, see “Installing a Web Server in Windows” on page 83.

You can test the server to make sure it works properly. 

Testing the installation

You can test the ASP engine of PWS or IIS by running a test page, as described in this section.

To test the ASP engine of PWS or IIS: 

1 In Dreamweaver or any text editor, create a plain text file called timetest.asp.

2 In the file, enter the following code:

<p>This page was created at <b>
<%= Time %>
</b> on the computer running ASP.</p>

This code displays the time the page was processed on the server.

3 Copy the file to the Inetpub\wwwroot folder of the Windows computer running PWS or IIS. 

4 In your web browser, enter the URL of your test page, then press Enter.

If PWS or IIS is running on your local computer, you can enter the following URL:

http://localhost/timetest.asp
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The test page should open and display a time of day, as follows: 

The time specified is known as dynamic content because it changes every time you request the 
page. Click Refresh on your browser to generate a new page with a different time. 

Note: Looking at the source code (View > Source in Internet Explorer) will confirm that the page does not use any 
client-side JavaScript to achieve this effect.

If the page doesn’t work as expected, check for the following possible errors: 

• The file does not have an .asp extension.

• The page’s file path (c:\Inetput\wwwroot\timetest.asp), not its URL (for example, http://
localhost/timetest.asp), is entered in the browser’s Address text box. 

If you type a file path in the browser (as you might be used to doing with normal HTML 
pages), you bypass the web server and the application server. As a result, your page never gets 
processed by the server.

• The URL contains a typing mistake. Check for errors and make sure the filename is not 
followed by a slash, such as http://localhost/timetest.asp/.

• The page code contains a typing mistake. 

After installing and testing the server software, create a root folder for your web application. 
Setup for Sample ASP Site 113



Creating a root folder

After the server software is installed, create a root folder for your web application on the system 
running Microsoft PWS or IIS, and make sure the folder has the necessary permissions. 

To create a root folder for your web application:

1 Create a folder called MySampleApp on the system running PWS or IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By default, your PWS or IIS web 
server is set up in the Inetpub\wwwroot folder. The web server will serve any page in this folder 
or in any of its subfolders in response to an HTTP request from a web browser.

2 Make sure the Read and Scripts permissions are enabled for the folder.

If you’re using PWS, launch Personal Web Manager by double-clicking the web server icon in 
the system tray. (The icon depicts a hand holding a web page.) In Personal Web Manager, click 
the Advanced icon. The Advanced Options dialog box appears. Select Home and click Edit 
Properties. The Edit Directory dialog box appears. Make sure the Read and Scripts options are 
selected. For security reasons, you should not select the Execute option. 

If you’re using IIS, launch the IIS administrative tool (in Windows XP, select Start > 
Control Panel > Performance Maintenance > Administrative Tools > 
Internet Information Services). Under Web Sites > Default Web Site, right-click your 
MySampleSite folder and choose Properties from the pop-up menu. In the Execute 
Permissions text box, make sure the Scripts option is selected. For security reasons, do 
not select the “Scripts and Executables” option. 

The web server is now configured to serve web pages in your root folder in response to HTTP 
requests from web browsers.

After configuring your system, you must define a Dreamweaver site. 

Defining a Dreamweaver site
After configuring your system, you must copy the sample files to a local folder and define a 
Dreamweaver site to manage the files. 

Note: Macromedia HomeSite and ColdFusion Studio users can think of a Dreamweaver site as a HomeSite or 
Studio project.

To define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk (see “Copying the sample files” on page 115).

2 Define the folder as a Dreamweaver local folder (see “Defining a local folder” on page 115).

3 Define a web server folder as a Dreamweaver remote folder (see “Defining a remote folder” on 
page 116).

4 Specify a folder to process dynamic pages (see “Specifying where dynamic pages can be 
processed” on page 116).

5 Upload the sample files to the web server (see “Uploading the samples files” on page 117).
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Copying the sample files

If you have not already done so, copy the sample files from the Dreamweaver application folder to 
a folder on your hard disk.

To copy the sample files:

1 Create a new folder called Sites on your hard disk.

For example, create C:\Sites (Windows) or Hard Drive:Documents:Sites (Macintosh).

2 Locate the GettingStarted folder in the Dreamweaver application folder on your hard disk.

The path to the folder is as follows:

\Macromedia\Dreamweaver MX\Samples\GettingStarted\

3 Copy the GettingStarted folder into the Sites folder.

After copying the GettingStarted folder, define the folder as a Dreamweaver local folder.

Defining a local folder

After copying the GettingStarted folder, define the folder containing the ASP sample files as a 
Dreamweaver local folder. 

To define the Dreamweaver local folder:

1 In Dreamweaver, select Site > New Site.

The Site Definition dialog box appears. 

2 If the wizard is showing, click Advanced.

3 In the Site Name text box, enter GlobalCar - ASP.

The name identifies your site within Dreamweaver. 

4 In the Local Root Folder text box, specify the folder in the GettingStarted folder that contains 
the ASP sample files.

You can click the folder icon next to the text box to find and select the folder. In Windows, the 
folder should be as follows:

C:\Sites\GettingStarted\Develop\asp

On the Macintosh, the folder should be as follows:

Hard Drive:Documents:Sites:GettingStarted:Develop:asp

Leave the Site Definition dialog box open. You need to define a web server folder as a 
Dreamweaver remote folder next. 
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Defining a remote folder

After defining a local folder, define a web server folder as a Dreamweaver remote folder, as 
described in this section. 

To define the Dreamweaver remote folder:

1 In the advanced Site Definition dialog box, click Remote Info in the Category list. 

The Remote Info screen appears.

2 In the Access text box, choose how you want to move your files to and from the server—
directly (the Local/Network option) or FTP. 

3 Enter the path or FTP settings to the web server folder you created in “Creating a root folder” 
on page 114.

The folder may be on your hard disk or on a remote computer. Even if you created the folder 
on your hard disk, that folder is still the valid “remote” folder. Here’s an example if you chose 
Local/Network access:

Remote Folder: c:\Inetpub\wwwroot\MySampleApp

For more information on FTP, see “Setting Remote Info options for FTP access” in Help 
(Help > Using Dreamweaver).

Leave the Site Definition dialog box open. You need to define a folder to process dynamic pages next 

Specifying where dynamic pages can be processed

After defining the Dreamweaver remote folder, specify a folder to process dynamic pages as 
described in this section. Dreamweaver uses this folder to display dynamic pages and connect to 
databases while you work. 

To specify the folder to process dynamic pages:

1 In the advanced Site Definition dialog box, click Testing Server in the Category list.

The Testing Server screen appears. Dreamweaver needs the services of a testing server to 
generate and display dynamic content while you work. The testing server can be your local 
computer, a development server, a staging server, or a production server. As long as it can 
process ASP pages, the choice doesn’t matter. In this case, you can use the same settings as the 
Remote Info category (see “Defining a remote folder” on page 116) because they point to a 
server capable of processing ASP pages.

2 Select ASP JavaScript or ASP VBScript as your server technology.

3 In the Access text box, choose the method (Local/Network or FTP) you specified for accessing 
your remote folder.

Dreamweaver enters the settings you specified in the Remote Info category. Leave the 
settings unchanged.
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4 In the URL Prefix text box, enter the root URL you would enter in a web browser to request a 
page in your web application. 

To display live data in your pages while you work, Dreamweaver creates a temporary file, 
copies it to the website’s root folder, and attempts to request it using the URL prefix. 

Dreamweaver makes a best guess at the URL prefix based on the information you provided in 
the Site Definition dialog box. For example, if the folder specified in the Remote Folder text 
box is c:\Inetpub\wwwroot\MySampleApp, then the URL prefix should be as follows:

http://localhost/MySampleApp/

Tip: The URL prefix should never specify a particular page on the site. 

However, the suggested URL prefix may be incorrect. Correct or enter a new URL prefix if 
Dreamweaver’s suggestion is incorrect. For more information, see “About the URL prefix” in 
Help (Help > Using Dreamweaver).

5 Click OK, then Done.

After specifying a folder to process dynamic pages, upload the sample files to the web server.

Uploading the samples files 

After specifying a folder to process dynamic pages, upload the sample files to the web server as 
described in this section. You must “upload” the files even if the web server is running on your 
local computer. 

If you don’t upload the files, features such as Live Data view and Preview in Browser may not work 
properly with dynamic pages. For example, image links might be broken in Live Data view because 
the image files are not on the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing from the server.

To upload the samples files to the web server:

1 In the Site panel (Window > Site), select the root folder in the Local Files pane.

The root folder should be the first folder in the list.

2 Click the blue up arrow on the toolbar. 

Dreamweaver copies all the files to the web server folder you defined in “Defining a remote 
folder” on page 116. 

The Dreamweaver site is defined. The next step is to connect to the sample database installed 
with Dreamweaver. If your web server runs on your local computer, see “Connecting to the 
sample database (local configuration)” on page 117. If your web server runs on a remote 
computer, see “Connecting to the sample database (remote server configuration)” on page 118.

Connecting to the sample database (local configuration) 
During installation, Dreamweaver copies a sample Microsoft Access database to your hard disk. 
This section describes how to create a connection to the sample database if you have a local 
configuration—that is, if your web server is running on the same computer as Dreamweaver. If 
your web server is running on a remote computer, see “Connecting to the sample database 
(remote server configuration)” on page 118. 

Note: If you want to connect to another database, see “Database Connections for ASP Developers” in Help 
(Help > Using Dreamweaver).
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With a local configuration, you can use the data source name (DSN) that Dreamweaver created 
during installation to quickly connect to the sample database. To learn more about DSNs, see 
“Understanding DSNs” in Help (Help > Using Dreamweaver).

To create a connection with a local configuration:

1 Open any ASP page in Dreamweaver, then open the Databases panel (Window > Databases).

2 Click the plus (+) button on the panel and select Data Source Name (DSN) from the 
pop-up menu.

The Data Source Name (DSN) dialog box appears. 

3 Enter connGlobal as the connection name.

4 Select the Using Local DSN option.

5 Select GlobalCar from the list of DSNs. 

During installation, Dreamweaver created a DSN called GlobalCar pointing to the Microsoft 
Access database in the Samples\Database folder in the Dreamweaver MX application folder.

6 Click Test.

Dreamweaver attempts to connect to the database. If the connection fails, do the following:

• Double-check the DSN. 

• Check the settings for the folder Dreamweaver uses to process dynamic pages (see “Specifying 
where dynamic pages can be processed” on page 116).

• Consult “Troubleshooting Database Connections” on page 145.

7 Click OK.

The new connection appears in the Databases panel.

The sample ASP application is set up for the Getting Started guide and the tutorials. See 
“Developing a Web Application in Dreamweaver MX” on page 69 and the tutorials in Help 
(Help > Tutorials).

Connecting to the sample database (remote server 
configuration)

During installation, Dreamweaver copies a sample Microsoft Access database to your hard disk. 
This section describes how to create a connection to the sample database if you have a remote 
server configuration—that is, if your web server is running on a remote computer. If your web 
server is running on the same computer as Dreamweaver, see “Connecting to the sample database 
(local configuration)” on page 117. 

Note: If you want to connect to another database, see “Database Connections for ASP Developers” in Help (Help > 
Using Dreamweaver).

To create a database connection with a remote server configuration:

1 Set up the sample database on the computer running your web server (see “Setting up the 
database on the remote computer” on page 119)

2 Create the connection in Dreamweaver (see “Creating a database connection” on page 119).
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Setting up the database on the remote computer 

Before creating a connection to the sample database, perform the following tasks on the remote 
computer running your web server: copy the sample database to the computer’s hard disk and 
create a DSN on the computer that points to the database.

To set up the sample database on the remote computer: 

1 Copy the sample database file to the remote computer.

The database file, global.mdb, is located in the following folder on your local hard disk:

\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

You can place the file in any folder on the remote computer, or you can create a new folder for it.

2 Make sure the Microsoft Access Driver, version 4.0 or higher, is installed on the remote computer.

To find out whether the driver is already installed, see “Viewing the ODBC drivers installed on 
a Windows system” in Help (Help > Using Dreamweaver). 

If the driver is not installed, download and install the Microsoft Data Access Components 
(MDAC) 2.5 and 2.6 packages on the remote computer. You can download MDAC for free 
from the Microsoft website at http://www.microsoft.com/data/download.htm. These packages 
contain the latest Microsoft drivers, including the Microsoft Access Driver.

Note: Install MDAC 2.5 before installing MDAC 2.6.

3 Set up a DSN called GlobalCar pointing to the sample database on the remote computer. 

For instructions, see “Setting Up a DSN in Windows” in Help (Help > Using Dreamweaver).

After the database, database driver, and DSN are in place, create a database connection 
in Dreamweaver 

Creating a database connection 

After setting up the sample database on the remote computer, create a database connection 
in Dreamweaver.

To create a database connection in Dreamweaver:

1 Open any ASP page in Dreamweaver, then open the Databases panel (Window > Databases).

2 Click the plus (+) button on the panel and select Data Source Name (DSN) from the 
pop-up menu.

The Data Source Name (DSN) dialog box appears. 

3 Enter connGlobal as the connection name.

4 Select the Using DSN On Testing Server option.

Macintosh users can ignore this step because all database connections use DSNs on the 
testing server.

5 Click on the DSN button and select the DSN you set up on the remote computer.

6 Click Test.

Dreamweaver attempts to connect to the database. If the connection fails, do the following:

• Double-check the DSN. 
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• Check the settings for the folder Dreamweaver uses to process dynamic pages (see “Specifying 
where dynamic pages can be processed” on page 116).

• Consult “Troubleshooting Database Connections” on page 145.

7 Click OK.

The new connection appears in the Databases panel.

The sample ASP application is set up for the Getting Started guide and the tutorials. See 
“Developing a Web Application in Dreamweaver MX” on page 69 and the tutorials in 
Dreamweaver Help (Help > Tutorials).
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CHAPTER 10

Setup for Sample JSP Site

Macromedia Dreamweaver MX comes with sample JavaServer Pages (JSP) to let you build a small 
web application. This chapter describes one way to set up the sample application using Microsoft 
Internet Information Server (IIS) or Personal Web Server (PWS). For more information on these 
web servers, see “Installing a Web Server in Windows” on page 83. If you’re using a different web 
server, see “Setting Up a Web Application” in Help (Help > Using Dreamweaver).

Setting up a web application is a three-step process. First, configure your system. Second, define a 
Dreamweaver site. Third, connect the application to your database. This setup guide follows this 
three-step process. 

This chapter contains the following sections:

• “Setup checklist for JSP developers” on page 121

• “Configuring your system” on page 122

• “Defining a Dreamweaver site” on page 124

• “Connecting to the sample database (local configuration)” on page 127

• “Connecting to the sample database (remote server configuration)” on page 129

Setup checklist for JSP developers
To set up a web application, you must configure your system, define a Dreamweaver site, and 
connect to a database. This section provides checklists for each task. The procedures are described 
in the rest of the chapter.

Configure your system: 

1 Make sure you have a web server.

2 Install the JSP application server.

3 Create a root folder. 

Define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk.

2 Define the folder as a Dreamweaver local folder.

3 Define a web server folder as a Dreamweaver remote folder.

4 Specify a folder to process dynamic pages.

5 Upload the sample files to the web server.
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Connect to the database (local configuration):

1 Install a JDBC-ODBC bridge driver.

2 Create the connection in Dreamweaver.

Connect to the database (remote server configuration):

1 Set up the sample database on the computer running your web server.

2 Create the connection in Dreamweaver.

Configuring your system
This section provides instructions for two common system configurations—one where 
Microsoft IIS or PWS is installed on your hard disk, and one where IIS or PWS is installed on a 
remote Windows computer. If you don’t want to use these configurations, see “Setting Up a Web 
Application” in Help (Help > Using Dreamweaver).

The following illustration shows the two configurations described in this section: 
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To configure your system:

1 Make sure you have a web server (see “Checking for a web server” on page 123).

2 Install the JSP application server (see “Installing the JSP application server” on page 123).

3 Create a root folder (see “Creating a root folder” on page 124). 

Note: Installing the web server and application server are one-time only tasks.

Checking for a web server 

To develop and test dynamic web pages, you need a web server. A web server is software that 
serves web pages in response to requests from web browsers.

Make sure Microsoft IIS or PWS is installed and running on your hard disk or on a remote 
Windows computer. (Macintosh users need to install Microsoft IIS or PWS on a remote 
Windows computer.) A quick way to check whether PWS or IIS is installed on a computer is to 
look at the folder structure. Does it contain a c:\Inetpub or d:\Inetpub folder? PWS and IIS create 
this folder during installation.

If PWS or IIS is not installed, install it now. For instructions, see “Installing a Web Server in 
Windows” on page 83.

After installing the web server, install the application server. 

Installing the JSP application server 

To process dynamic web pages, you need an application server. An application server is software 
that helps a web server process web pages containing server-side scripts or tags. When such a page 
is requested from the server, the web server hands the page off to the application server for 
processing before sending the page to the browser.

Make sure a JSP application server is installed and running on the system running PWS or IIS. 
(PWS or IIS may be located on your hard disk or on a remote computer.)

If you do not have a JSP application server, you can download and install a trial version of 
Macromedia JRun, a full-featured JSP application server, from the Macromedia website at http://
www.macromedia.com/software/jrun/.

To install JRun: 

1 Close all open applications.

2 If applicable, log into your Windows system using the Administrator account.

3 Double-click the JRun trial version installer file.

The splash screen appears.

4 If you do not have a Java Runtime Environment (JRE) on your system, select the option on the 
splash screen to install it.

Because the JRun application server relies on Java, a JRE must first be installed on the system 
that will run your application server. Once the JRE is installed, you can install the JRun 
application server.

5 Select the option on the splash screen to install JRun.
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6 Follow the onscreen instructions to finish installing and testing the program. 

7 Create a JRun connector to your IIS or PWS web server. 

For instructions, see the JRun documentation.

After installing and starting JRun, create a root folder for your web application. 

Creating a root folder 

After the server software is installed, create a root folder for your web application on the system 
running Microsoft PWS or IIS, and make sure the folder has the necessary permissions. 

To create a root folder for your web application:

1 Create a folder called MySampleApp on the system running PWS or IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By default, your PWS or IIS web 
server is set up in the Inetpub\wwwroot folder. The web server will serve any page in this folder 
or in any of its subfolders in response to a HTTP request from a web browser.

2 Make sure the Read and Scripts permissions are enabled for the folder.

If you’re using PWS, launch Personal Web Manager by double-clicking the web server icon in 
the system tray. (The icon depicts a hand holding a web page.) In Personal Web Manager, click 
the Advanced icon. The Advanced Options dialog box appears. Select Home and click Edit 
Properties. The Edit Directory dialog box appears. Make sure the Read and Scripts options are 
selected. For security reasons, you should not select the Execute option. 

If you’re using IIS, launch the IIS administrative tool (in Windows XP, select Start > 
Control Panel > Performance Maintenance > Administrative Tools > Internet Information 
Services). Under Web Sites > Default Web Site, right-click your MySampleSite folder and choose 
Properties from the pop-up menu. In the Execute Permissions text box, make sure the Scripts 
option is selected. For security reasons, do not select the “Scripts and Executables” option.

The web server is now configured to serve web pages in your root folder in response to HTTP 
requests from web browsers.

After configuring your system, you must define a Dreamweaver site. 

Defining a Dreamweaver site
After configuring your system, you must copy the sample files to a local folder and define a 
Dreamweaver site to manage the files. 

Note: Macromedia HomeSite and ColdFusion Studio users can think of a Dreamweaver site as a HomeSite or 
Studio project.

To define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk (see “Copying the sample files” on page 125).

2 Define the folder as a Dreamweaver local folder (see “Defining a local folder” on page 125).

3 Define a web server folder as a Dreamweaver remote folder (see “Defining a remote folder” on 
page 126).

4 Specify a folder to process dynamic pages (see “Specifying where dynamic pages can be 
processed” on page 126).

5 Upload the sample files to the web server (see “Uploading the samples files” on page 127).
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Copying the sample files

If you have not already done so, copy the sample files from the Dreamweaver application folder to 
a folder on your hard disk.

To copy the sample files:

1 Create a new folder called Sites on your hard disk.

For example, create C:\Sites (Windows) or Hard Drive:Documents:Sites (Macintosh).

2 Locate the GettingStarted folder in the Dreamweaver application folder on your hard disk.

The path to the folder is as follows:

\Macromedia\Dreamweaver MX\Samples\GettingStarted\ 

3 Copy the GettingStarted folder into the Sites folder.

After copying the GettingStarted folder, define the folder as a Dreamweaver local folder.

Defining a local folder

After copying the GettingStarted folder, define the folder containing the JSP sample files as a 
Dreamweaver local folder. 

To define the Dreamweaver local folder:

1 In Dreamweaver, select Site > New Site.

The Site Definition dialog box appears. 

2 If the wizard is showing, click Advanced.

3 In the Site Name text box, enter GlobalCar - JSP.

The name identifies your site within Dreamweaver. 

4 In the Local Root Folder text box, specify the folder in the GettingStarted folder that contains 
the JSP sample files.

You can click the folder icon next to the text box to find and select the folder. In Windows, the 
folder should be as follows:

C:\Sites\GettingStarted\Develop\jsp

On the Macintosh, the folder should be as follows:

Hard Drive:Documents:Sites:GettingStarted:Develop:jsp

Leave the Site Definition dialog box open. You need to define a web server folder as a 
Dreamweaver remote folder next. 
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Defining a remote folder

After defining a local folder, define a web server folder as a Dreamweaver remote folder, as 
described in this section. 

To define the Dreamweaver remote folder:

1 In the advanced Site Definition dialog box, click Remote Info in the Category list. 

The Remote Info screen appears.

2 In the Access text box, choose how you want to move your files to and from the server—
directly (the Local/Network option) or FTP. 

3 Enter the path or FTP settings to the web server folder you created in “Creating a root folder” 
on page 124.

The folder may be on your hard disk or on a remote computer. Even if you created the folder 
on your hard disk, that folder is still the valid “remote” folder. Here’s an example if you chose 
Local/Network access:

Remote Folder: c:\Inetpub\wwwroot\MySampleApp

For more information on FTP, see “Setting Remote Info options for FTP access” in Help 
(Help > Using Dreamweaver).

Leave the Site Definition dialog box open. You need to define a folder to process dynamic pages next.

Specifying where dynamic pages can be processed

After defining the Dreamweaver remote folder, specify a folder to process dynamic pages. 
Dreamweaver uses this folder to display dynamic pages and connect to databases while you work. 

To specify the folder to process dynamic pages:

1 In the advanced Site Definition dialog box, click Testing Server in the Category list.

The Testing Server screen appears. Dreamweaver needs the services of a testing server to 
generate and display dynamic content while you work. The testing server can be your local 
computer, a development server, a staging server, or a production server. As long as it can 
process JSP pages, the choice doesn’t matter. In this case, you can use the same settings as the 
Remote Info category (see “Defining a remote folder” on page 126) because they point to a 
server capable of processing JSP pages.

2 Select JSP as your server technology.

3 In the Access text box, choose the method (Local/Network or FTP) you specified for accessing 
your remote folder.

Dreamweaver enters the settings you specified in the Remote Info category. Leave the 
settings unchanged.
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4 In the URL Prefix text box, enter the root URL you would enter in a web browser to request a 
page in your web application. 

To display live data in your pages while you work, Dreamweaver creates a temporary file, 
copies it to the website’s root folder, and attempts to request it using the URL prefix. 

Dreamweaver makes a best guess at the URL prefix based on the information you provided in 
the Site Definition dialog box. For example, if the folder specified in the Remote Folder text 
box is c:\Inetpub\wwwroot\MySampleApp, then the URL prefix should be as follows:

http://localhost/MySampleApp/

Tip: The URL prefix should never specify a particular page on the site. 

However, the suggested URL prefix may be incorrect. Correct or enter a new URL prefix if 
Dreamweaver’s suggestion is incorrect. For more information, see “About the URL prefix” in 
Help (Help > Using Dreamweaver).

5 Click OK, then Done.

After specifying a folder to process dynamic pages, upload the sample files to the web server.

Uploading the samples files 

After specifying a folder to process dynamic pages, upload the sample files to the web server as 
described in this section. You must “upload” the files even if the web server is running on your 
local computer. 

If you don’t upload the files, features such as Live Data view and Preview in Browser may not work 
properly with dynamic pages. For example, image links might be broken in Live Data view because 
the image files are not on the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing from the server.

To upload the samples files to the web server:

1 In the Site panel (Window > Site), select the root folder in the Local Files pane.

The root folder should be the first folder in the list.

2 Click the blue up arrow on the toolbar. 

Dreamweaver copies all the files to the web server folder you defined in “Defining a remote 
folder” on page 126. 

The Dreamweaver site is defined. The next step is to connect to the sample database installed 
with Dreamweaver. If your web server runs on your local computer, see “Connecting to the 
sample database (local configuration)” on page 127. If your web server runs on a remote 
computer, see “Connecting to the sample database (remote server configuration)” on page 129.

Connecting to the sample database (local configuration)
During installation, Dreamweaver copies a sample Microsoft Access database to your hard disk. 
This section describes how to create a connection to the sample database if you have a local 
configuration—that is, if your web server is running on the same computer as Dreamweaver. If 
your web server is running on a remote computer, see “Connecting to the sample database 
(remote server configuration)” on page 129. 

Note: If you want to connect to another database, see “Database Connections for JSP Developers” in Help (Help > 
Using Dreamweaver).
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To create a database connection with a local configuration:

1 Install the Sun JDBC-ODBC Bridge driver (see “Installing the bridge driver” on page 128).

2 Create the connection in Dreamweaver (see “Creating a database connection” on page 128).

Installing the bridge driver

Before creating a connection to the sample database, install the Sun JDBC-ODBC Bridge driver 
on the computer running your web server. The bridge driver lets you use Windows data source 
names (DSNs) to create connections. The driver comes with the Sun Java 2 SDK, Standard 
Edition, for Windows.

To find out if you already have the Java 2 SDK with the driver, check your hard disk for either of 
the following directories:

c:\jdk1.2.x

c:\jdk1.3.x

Note: Java 1.2.2 and 1.3 are the same as Java 2.

If you don’t have the SDK, download it from the Sun website at http://java.sun.com/j2se/. After 
downloading the installation file, double-click it to run the installer. Follow the onscreen 
instructions and make sure the Java 2 Runtime Environment component is selected from the 
Select Component dialog box. It should be selected by default. The driver is installed 
automatically when you install the SDK.

Although it is adequate for development use with lower-end database systems such as Microsoft 
Access, the Sun JDBC-ODBC Bridge driver is not intended for production use. For example, it lets 
only one JSP page connect to the database at a time (in other words, it does not support concurrent 
use by multiple threads). For more information on the driver’s limitations, see article 12409 on the 
Macromedia support center at http://www.macromedia.com/go/jdbc-odbc_problems.

After installing the bridge driver, create a database connection in Dreamweaver. 

Creating a database connection

After the Sun JDBC-ODBC Bridge driver is installed on the computer running your web server, 
create a database connection in Dreamweaver. 

To create a database connection in Dreamweaver:

1 Open any JSP page in Dreamweaver, then open the Databases panel (Window > Databases).

2 Click the plus (+) button on the panel and choose “Sun JDBC-ODBC Driver (ODBC 
Database)” from the pop-up menu.

The ODBC Database (Sun JDBC-ODBC Driver) dialog box appears.

3 Enter connGlobal as the connection name.

4 Select the Using Driver On This Machine option.

5 Replace the [odbc dsn] placeholder in the URL text box with GlobalCar.

During installation, Dreamweaver created a DSN called GlobalCar pointing to the Microsoft 
Access database in the Samples\Database folder in the Dreamweaver MX application folder.

The URL text box should look like this:

jdbc:odbc:GlobalCar
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6 Click Test.

Dreamweaver attempts to connect to the database. If the connection fails, do the following:

• Double-check the DSN and the other connection parameters. 

• Check the settings for the folder Dreamweaver uses to process dynamic pages (see “Specifying 
where dynamic pages can be processed” on page 126).

• Consult “Troubleshooting Database Connections” on page 145.

7 Click OK.

The new connection appears in the Databases panel.

The sample JSP application is set up for the Getting Started guide and the tutorials. See 
“Developing a Web Application in Dreamweaver MX” on page 69 and the tutorials in Help 
(Help > Tutorials).

Connecting to the sample database (remote server 
configuration)

During installation, Dreamweaver copies a sample Microsoft Access database to your hard disk. 
This section describes how to create a connection to the sample database if you have a remote 
server configuration—that is, if your web server is running on a remote computer. If your web 
server is running on the same computer as Dreamweaver, see “Connecting to the sample database 
(local configuration)” on page 127.

Note: If you want to connect to another database, see “Database Connections for JSP Developers” in Help 
(Help > Using Dreamweaver).

To create a database connection with a remote server configuration:

1 Set up the sample database on the computer running your web server (see “Setting up the 
database on the remote computer” on page 129)

2 Create the connection in Dreamweaver (see “Creating a database connection” on page 130).

Setting up the database on the remote computer 

Before creating a connection to the sample database, perform the following tasks on the remote 
computer running your web server: copy the sample database to the computer’s hard disk, create a 
DSN on the computer that points to the database, and install the Sun JDBC-ODBC Bridge 
driver on the computer.

To set up the sample database on the remote computer: 

1 Copy the sample database file to the remote computer.

The database file, global.mdb, is located in the following folder on your local hard disk:

\Macromedia\Dreamweaver MX\Samples\Database\global.mdb

You can place the file in any folder on the remote computer, or you can create a new folder for it.
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2 Make sure the Microsoft Access Driver, version 4.0 or higher, is installed on the remote computer.

To find out whether the driver is already installed, see “Viewing the ODBC drivers installed on 
a Windows system” in Help (Help > Using Dreamweaver). 

If the driver is not installed, download and install the Microsoft Data Access Components 
(MDAC) 2.5 and 2.6 packages on the remote computer. You can download MDAC for free 
from the Microsoft website at http://www.microsoft.com/data/download.htm. These packages 
contain the latest Microsoft drivers, including the Microsoft Access Driver.

Note: Install MDAC 2.5 before installing MDAC 2.6.

3 Set up a DSN for the sample database on the remote computer. 

For instructions, see “Setting Up a DSN in Windows” in Help (Help > Using Dreamweaver).

4 Make sure the Sun JDBC-ODBC Bridge driver is installed on the remote computer. 

You will use this driver along with the DSN to create a connection to the database. For 
instructions, see “Installing the bridge driver” on page 128.

After the database, DSN, and bridge driver are in place, create a database connection in Dreamweaver.

Creating a database connection

After setting up the sample database on the remote computer, create a database connection 
in Dreamweaver.

To create a database connection in Dreamweaver:

1 Open any JSP page in Dreamweaver, then open the Databases panel (Window > Databases).

2 Click the plus (+) button on the panel and choose “ODBC Database (Sun JDBC-ODBC 
Driver)” from the pop-up menu.

The ODBC Database (Sun JDBC-ODBC Driver) dialog box appears.

3 Enter connGlobal as the connection name.

4 Select the Using Driver On Testing Server option.

Macintosh users can ignore this step because all database connections use drivers on the 
testing server.

5 Replace the [odbc dsn] placeholder in the URL text box with the DSN you defined on the 
remote computer.

The URL text box should look like this:

jdbc:odbc:myDSN

6 Click Test.

Dreamweaver attempts to connect to the database. If the connection fails, do the following:

• Double-check the DSN and the other connection parameters. 

• Check the settings for the folder Dreamweaver uses to process dynamic pages (see “Specifying 
where dynamic pages can be processed” on page 126).

• Consult “Troubleshooting Database Connections” on page 145.
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7 Click OK.

The new connection appears in the Databases panel.

The sample JSP application is set up for the Getting Started guide and the tutorials. See 
“Developing a Web Application in Dreamweaver MX” on page 69 and the tutorials in 
Dreamweaver Help (Help > Tutorials).
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CHAPTER 11

Setup for Sample PHP Site

Macromedia Dreamweaver MX comes with sample PHP pages to let you build a small web 
application. This chapter describes one way to set up the sample application using Microsoft 
Internet Information Server (IIS) or Personal Web Server (PWS). For more information on these 
web servers, see “Installing a Web Server in Windows” on page 83. If you’re using a different web 
server, see “Setting Up a Web Application” in Help (Help > Using Dreamweaver).

If you’re a Mac OS X user, you can develop PHP sites locally using the Apache web server and 
PHP application server installed with your operating system. For setup information, see the 
following websites:

• http://developer.apple.com/internet/macosx/php.html

• http://www.entropy.ch/software/macosx/

• http://www.stepwise.com/Articles/Workbench/2001-10-11.01.html 

Setting up a web application is a three-step process. First, configure your system. Second, define a 
Dreamweaver site. Third, connect the application to your database. This setup guide follows this 
three-step process. 

This chapter contains the following sections:

• “Setup checklist for PHP developers” on page 134

• “Configuring your system” on page 135

• “Defining a Dreamweaver site” on page 139

• “Connecting to the sample database” on page 142
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Setup checklist for PHP developers
To set up a web application, you must configure your system, define a Dreamweaver site, and 
connect to a database. This section provides checklists for each task. The procedures are described 
in the rest of the chapter.

Configure your system: 

1 Make sure you have a web server.

2 Install the PHP application server.

3 Test your installation.

4 Create a root folder. 

Define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk.

2 Define the folder as a Dreamweaver local folder.

3 Define a web server folder as a Dreamweaver remote folder.

4 Specify a folder to process dynamic pages.

5 Upload the sample files to the web server.

Connect to the database:

1 Create the sample MySQL database.

2 Create a database connection in Dreamweaver.
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Configuring your system
This section provides instructions for two common system configurations—one where Microsoft 
IIS or PWS is installed on your hard disk, and one where IIS or PWS is installed on a remote 
Windows computer. If you don’t want to use these configurations, see “Setting Up a Web 
Application” in Help (Help > Using Dreamweaver).

Note: If you’re a Mac OS X user, you can use the Apache web server and PHP application server installed with your 
operating system. For more information, see the Apple website at http://developer.apple.com/internet/macosx/
php.html. Other useful websites include http://www.entropy.ch/software/macosx/, and http://www.stepwise.com/
Articles/Workbench/2001-10-11.01.html. 

The following illustration shows the two configurations described in this section: 

To configure your system:

1 Make sure you have a web server (see “Checking for a web server” on page 136).

2 Install the PHP application server (see “Installing a PHP application server” on page 136).

3 Test your installation (see “Testing the installation” on page 137).

4 Create a root folder (see“Creating a root folder” on page 138). 

Note: Installing the web server and application server are one-time only tasks.
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Checking for a web server

To develop and test dynamic web pages, you need a web server. A web server is software that 
serves web pages in response to requests from web browsers.

Make sure Microsoft IIS or PWS is installed and running on your hard disk or on a remote 
Windows computer. (Macintosh users need to install Microsoft IIS or PWS on a remote 
Windows computer.) A quick way to check whether or not PWS or IIS is installed on a computer 
is to look at the folder structure. Does it contain a c:\Inetpub or d:\Inetpub folder? PWS and IIS 
create this folder during installation.

If PWS or IIS is not installed, install it now. For instructions, see “Installing a Web Server in 
Windows” on page 83.

After installing the web server, install the application server. 

Installing a PHP application server 

To process dynamic web pages, you need an application server. An application server is software 
that helps a web server process web pages containing server-side scripts or tags. When such a page 
is requested from the server, the web server hands the page off to the application server for 
processing before sending the page to the browser.

Make sure the PHP application server is installed and running on the system running PWS 
or IIS. (PWS or IIS may be located on your hard disk or on a remote Windows computer.)

If you do not have PHP, you can download and install it from the PHP website at http://
www.php.net/downloads.php. Select the Windows installer file, which uses InstallShield to 
install PHP and configure IIS or PWS.

To install PHP on a Windows system:

1 Close all open applications.

2 If applicable, log into your Windows system using the Administrator account.

3 Double-click the installer file you downloaded from the PHP website.

4 Follow the onscreen instructions to install the program.

When the installation is finished, the installer tells you if you need to restart your system, restart 
the server, or just start using PHP. 

For more information on configuring the server, see the PHP documentation, which you can 
download from the PHP website at http://www.php.net/download-docs.php.

After installing PHP, you can test the server to make sure it works properly. 
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Testing the installation

You can test the PHP application server by running a test page, as described in this section.

To test the PHP application server: 

1 In Dreamweaver or any text editor, create a plain text file called timetest.php.

2 In the file, enter the following code: 

<p>This page was created at <b>
<?php echo date("h:i:s a", time()); ?>
</b> on the computer running PHP.</p>

The code displays the time the page was processed on the server.

3 Copy the page to the Inetpub\wwwroot folder on the hard disk of the Windows computer 
running PWS or IIS. 

4 In your web browser, enter the URL of the test page and press Enter.

If you installed PHP on your local computer, you can enter the following URL:

http://localhost/timetest.php

The test page should open and display a time of day, as follows: 

The specified time is known as dynamic content because it changes every time you request the 
page. Click Refresh on your browser to generate a new page with a different time. 

Note: Looking at the source code (View > Source in Internet Explorer) will confirm that the page does not use any 
client-side JavaScript to achieve this effect.
Setup for Sample PHP Site 137



If the page doesn’t work as expected, check for the following possible errors: 

• The file does not have a .php extension.

• The page’s file path (c:\Inetput\wwwroot\timetest.php), not its URL (for example, http://
localhost/timetest.php), is entered in the browser’s Address text box. 

If you type a file path in the browser (as you might be used to doing with normal HTML 
pages), you bypass the web server and the application server. As a result, your page never gets 
processed by the server.

• The URL contains a typing mistake. Check for errors and make sure the filename is not 
followed by a slash, such as http://localhost/timetest.php/.

After installing and testing the server software, create a root folder for your web application. 

Creating a root folder

After the server software is installed, create a root folder for your web application on the system 
running Microsoft PWS or IIS, and make sure the folder has the necessary permissions. 

To create a root folder for your web application:

1 Create a folder called MySampleApp on the system running PWS or IIS.

A good place to create the folder is in C:\Inetpub\wwwroot\. By default, your PWS or IIS web 
server is set up in the Inetpub\wwwroot folder. The web server will serve any page in this folder 
or in any of its subfolders in response to a HTTP request from a web browser.

2 Make sure the Read and Scripts permissions are enabled for the folder.

If you’re using PWS, launch Personal Web Manager by double-clicking the web server icon in 
the system tray. (The icon depicts a hand holding a web page.) In Personal Web Manager, click 
the Advanced icon. The Advanced Options dialog box appears. Select Home and click Edit 
Properties. The Edit Directory dialog box appears. Make sure the Read and Scripts options are 
selected. For security reasons, you should not select the Execute option. 

If you’re using IIS, launch the IIS administrative tool (in Windows XP, select Start > 
Control Panel > Performance Maintenance > Administrative Tools > Internet Information 
Services). Under Web Sites > Default Web Site, right-click your MySampleSite folder and choose 
Properties from the pop-up menu. In the Execute Permissions text box, make sure the Scripts 
option is selected. For security reasons, do not select the “Scripts and Executables” option.

The web server is now configured to serve web pages in your root folder in response to HTTP 
requests from web browsers.

After configuring your system, you must define a Dreamweaver site. 
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Defining a Dreamweaver site
After configuring your system, you must copy the sample files to a local folder and define a 
Dreamweaver site to manage the files. 

Note: Macromedia HomeSite and ColdFusion Studio users can think of a Dreamweaver site as a HomeSite or 
Studio project.

To define a Dreamweaver site:

1 Copy the sample files to a folder on your hard disk (see “Copying the sample files” on page 139).

2 Define the folder as a Dreamweaver local folder (see “Defining a local folder” on page 139).

3 Define a web server folder as a Dreamweaver remote folder (see “Defining a remote folder” on 
page 140).

4 Specify a folder to process dynamic pages (see “Specifying where dynamic pages can be 
processed” on page 140).

5 Upload the sample files to the web server (see “Uploading the samples files” on page 141).

Copying the sample files

If you have not already done so, copy the sample files from the Dreamweaver application folder to 
a folder on your hard disk.

To copy the sample files:

1 Create a new folder called Sites on your hard disk.

For example, create C:\Sites (Windows) or Hard Drive:Documents:Sites (Macintosh).

2 Locate the GettingStarted folder in the Dreamweaver application folder on your hard disk.

The path to the folder is as follows:

\Macromedia\Dreamweaver MX\Samples\GettingStarted\

3 Copy the GettingStarted folder into the Sites folder.

After copying the GettingStarted folder, define the folder as a Dreamweaver local folder.

Defining a local folder

After copying the GettingStarted folder, define the folder containing the PHP sample files as a 
Dreamweaver local folder. 

To define the Dreamweaver local folder:

1 In Dreamweaver, select Site > New Site.

The Site Definition dialog box appears. 

2 If the wizard is showing, click Advanced.

3 In the Site Name text box, enter GlobalCar - PHP.

The name identifies your site within Dreamweaver. 
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4 In the Local Root Folder text box, specify the folder in the GettingStarted folder that contains 
the PHP sample files.

You can click the folder icon next to the text box to find and select the folder. In Windows, the 
folder should be as follows:

C:\Sites\GettingStarted\Develop\php

On the Macintosh, the folder should be as follows:

Hard Drive:Documents:Sites:GettingStarted:Develop:php

5 Leave the Site Definition dialog box open. You need to define a web server folder as a 
Dreamweaver remote folder next. 

Defining a remote folder

After defining a local folder, define a web server folder as a Dreamweaver remote folder, as 
described in this section. 

To define the Dreamweaver remote folder:

1 In the advanced Site Definition dialog box, click Remote Info in the Category list. 

The Remote Info screen appears.

2 In the Access text box, choose how you want to move your files to and from the server—
directly (the Local/Network option) or FTP. 

3 Enter the path or FTP settings to the web server folder you created in “Creating a root folder” 
on page 138.

The folder may be on your hard disk or on a remote computer. Even if you created the folder 
on your hard disk, that folder is still the valid “remote” folder. Here’s an example if you chose 
Local/Network access:

Remote Folder: c:\Inetpub\wwwroot\MySampleApp

For more information on FTP, see “Setting Remote Info options for FTP access” in Help 
(Help > Using Dreamweaver).

Leave the Site Definition dialog box open. You need to define a folder to process dynamic pages next.

Specifying where dynamic pages can be processed

After defining the Dreamweaver remote folder, specify a folder to process dynamic pages as 
described in this section. Dreamweaver uses this folder to display dynamic pages and connect to 
databases while you work. 

To specify the folder to process dynamic pages:

1 In the advanced Site Definition dialog box, click Testing Server in the Category list.

The Testing Server screen appears. Dreamweaver needs the services of a testing server to 
generate and display dynamic content while you work. The testing server can be your local 
computer, a development server, a staging server, or a production server. As long as it can 
process PHP pages, the choice doesn’t matter. In this case, you can use the same settings as the 
Remote Info category (see “Defining a remote folder” on page 140) because they point to a 
server capable of processing PHP pages.
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2 Select PHP MySQL as your server technology.

3 In the Access text box, choose the method (Local/Network or FTP) you specified for accessing 
your remote folder.

Dreamweaver enters the settings you specified in the Remote Info category. Leave the 
settings unchanged.

4 In the URL Prefix text box, enter the root URL you would enter in a web browser to request a 
page in your web application. 

To display live data in your pages while you work, Dreamweaver creates a temporary file, 
copies it to the website’s root folder, and attempts to request it using the URL prefix. 

Dreamweaver makes a best guess at the URL prefix based on the information you provided in 
the Site Definition dialog box. However, the suggested URL prefix may be incorrect. For 
example, if the folder specified in the Remote Folder text box is 
c:\Inetpub\wwwroot\MySampleApp, then the URL prefix should be as follows:

http://localhost/MySampleApp/

Tip: The URL prefix should never specify a particular page on the site. 

However, the suggested URL prefix may be incorrect. Correct or enter a new URL prefix if 
Dreamweaver’s suggestion is incorrect. For more information, see “About the URL prefix” in 
Help (Help > Using Dreamweaver).

5 Click OK, then Done.

After specifying a folder to process dynamic pages, upload the sample files to the web server.

Uploading the samples files 

After specifying a folder to process dynamic pages, upload the sample files to the web server as 
described in this section. You must “upload” the files even if the web server is running on your 
local computer. 

If you don’t upload the files, features such as Live Data view and Preview in Browser may not work 
properly with dynamic pages. For example, image links might be broken in Live Data view because 
the image files are not on the server yet. Similarly, clicking a link to a detail page while previewing a 
master page in a browser will cause an error if the detail page is missing from the server.

To upload the samples files to the web server:

1 In the Site panel (Window > Site), select the root folder in the Local Files pane.

The root folder should be the first folder in the list.

2 Click the blue up arrow on the toolbar. 

Dreamweaver copies all the files to the web server folder you defined in “Defining a remote 
folder” on page 140. 

The Dreamweaver site is defined. The next step is to connect to the sample database installed 
with Dreamweaver.
Setup for Sample PHP Site 141



Connecting to the sample database
During installation, Dreamweaver copies a SQL script to your hard disk. You can use this script 
to automatically create a sample MySQL database. This section describes how to create a 
connection to the sample database. 

This section assumes you have installed and configured MySQL on your local or remote computer. 
To download and install the database system, visit the MySQL website at www.mysql.com.

The first step is to create the sample MySQL database using the SQL script (see “Creating the 
MySQL database” on page 142). Once the database is created, you must create a database 
connection in Dreamweaver (see “Creating a database connection” on page 143).

Creating the MySQL database

During installation, Dreamweaver MX copies a SQL script capable of creating and populating a 
sample MySQL database.

Before starting, make sure MySQL is installed and configured on your local or remote computer. 
You can download the latest version from the MySQL website at www.mysql.com.

To create the sample MySQL database:

1 Copy the SQL script file, insert.sql, to the MySql\Bin folder on the computer with MySQL.

The script file is located in the following folder on your hard disk:

\Macromedia\Dreamweaver MX\Samples\Database\insert.sql 

2 On the computer with MySQL, open the command prompt window.

In Windows, you can open the command prompt by selecting Start > Programs > 
Command Prompt. 

Note: On some systems, the Command Prompt may be located under Accessories in the Start > Programs menu.

3 Change to the mysql\bin directory by entering the following commands at the command prompt:

> cd\
> cd mysql\bin

4 Launch the MySQL client by entering the following command at the mysql\bin\ prompt:

> mysql -uUser -pPassword

For example, if your MySQL user name (also known as an account name) and password are 
Tara and Telly3, then enter the following command:

> mysql -uTara -pTelly3

If you don’t have a password, omit the -p argument as follows:

> mysql -uTara

If you didn’t define a user name while configuring your MySQL installation, enter root as the 
user name, as follows:

> mysql -uroot

The MySQL client’s command prompt appears, as follows:

mysql>
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5 Create a new database by entering the following command at the MySQL prompt:

mysql>CREATE DATABASE GlobalCar;

MySQL creates a new database, but it doesn’t contain any tables or records yet.

6 Log out of the MySQL client by entering the following command at the prompt:

mysql>quit

7 At the system command prompt, populate the new GlobalCar database in MySQL with the 
following command: 

> mysql -uUser -pPassword GlobalCar < insert.sql

This command uses the insert.sql file to add tables and records to the GlobalCar database you 
created in step 5.

After creating the MySQL database, create a database connection to it in Dreamweaver. 

Creating a database connection

After the sample database is set up, you can create a database connection in Dreamweaver. 

To create a database connection in Dreamweaver:

1 Open any PHP page in Dreamweaver, then open the Databases panel (Window > Databases).

2 Click the plus (+) button on the panel and choose MySQL Connection from the popup menu.

The MySQL Connection dialog box appears,

3 Enter connGlobal as the connection name.

4 In the MySQL Server text box, specify the computer hosting MySQL.

Enter an IP address or a server name. If MySQL is running on the same computer as PHP, 
enter localhost.

5 Enter your MySQL user name and password.

If you didn’t define a user name while configuring your MySQL installation on a Windows 
computer, enter the word “root” in the Username text box. If you don’t have a password, leave 
the Password text box blank.

6 In the Database text box, enter GlobalCar, or click Select and choose GlobalCar from the list 
of MySQL databases.

GlobalCar is the name of the sample MySQL database you created (see “Creating the MySQL 
database” on page 142).

7 Click Test.

Dreamweaver attempts to connect to the database. If the connection fails, double-check the 
server name, user name, and password. If the connection still fails, check the settings for the 
folder Dreamweaver uses to process dynamic pages (see “Specifying where dynamic pages can 
be processed” on page 140).

8 Click OK.

The new connection appears in the Databases panel.
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The sample PHP application is set up for the Getting Started guide and the tutorials. See 
“Developing a Web Application in Dreamweaver MX” on page 69 and the tutorials in 
Dreamweaver Help (Help > Tutorials).
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CHAPTER 12

Troubleshooting Database Connections

This chapter describes some common problems encountered after creating a database connection, 
and describes ways to fix them. The chapter includes the following sections:

• “Troubleshooting Microsoft error messages” on page 145

• “Troubleshooting ColdFusion error messages” on page 149

• “Troubleshooting permissions problems” on page 150 

Troubleshooting Microsoft error messages
This section describes some common Microsoft error messages and ways to troubleshoot them. 
These errors can occur if you use Internet Information Server (IIS) with a Microsoft database 
system such as Access or SQL Server. These errors normally occur when you request a dynamic 
page from the server. 

Note: Macromedia does not provide technical support for third-party software such as Microsoft Windows, and IIS. 
If this section does not fix your problem, please contact Microsoft technical support or visit the Microsoft support 
website at http://support.microsoft.com/.

The following errors messages are covered in this section:

• “80004005—Data source name not found and no default driver specified” on page 146 (other 
variations of this message include “80004005—Driver's SQLSetConnectAttr failed,” and 
“80004005—General error Unable to open registry key ‘DriverId’”)

• “80004005—Couldn’t use ‘(unknown)’; file already in use” on page 146 (another variation is 
“80004005—Microsoft Jet database engine cannot open the file (unknown)”)

• “80004005—Logon Failed()” on page 147

• “80004005—Operation must use an updateable query” on page 147

• “80040e07—Data type mismatch in criteria expression” on page 147

• “80040e10—Too few parameters” on page 148

• “80040e10—COUNT field incorrect” on page 148

• “80040e14—Syntax error in INSERT INTO statement” on page 148

• “80040e21—ODBC error on Insert or Update” on page 148

• “800a0bcd—Either BOF or EOF is true” on page 149

For more information on 80004005 errors, see “INFO: Troubleshooting Guide for 80004005 
Errors in Active Server Pages and Microsoft Data Access Components (Q306518),” on the 
Microsoft website at http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306518.
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80004005—Data source name not found and no default driver specified

This error occurs when you attempt to view a dynamic page in a web browser or in Live Data 
mode. The error message may vary depending on your database and web server. Other variations 
of the error message include: 

• 80004005—Driver's SQLSetConnectAttr failed 

• 80004005—General error Unable to open registry key 'DriverId'

Here are possible causes and solutions:

• The page can’t find the DSN. Make sure a DSN has been created on both the web server and 
on the local machine. For more information, see “Setting Up a DSN in Windows” in Help 
(Help > Using Dreamweaver). 

• The DSN might have been set up as a user DSN, not as a system DSN. Delete the user DSN 
and create a system DSN to replace it. 

Note: If you don’t delete the user DSN, the duplicate DSN names produce a new ODBC error.

• If you use Microsoft Access, the database file (.mdb) might be locked. The lock might be due 
to a DSN with a different name accessing the database. In Windows Explorer, search for the 
lock file (.ldb) in the folder containing the database file (.mdb) and delete the .ldb file. If 
another DSN is pointing to the same database file, you may want to delete the DSN to prevent 
the error in the future. Be sure to reboot the computer after making these changes.

80004005—Couldn’t use ‘(unknown)’; file already in use

This error occurs when you use a Microsoft Access database and attempt to view a dynamic page 
in a web browser or in Live Data mode. Another variation of this error message is “80004005—
Microsoft Jet database engine cannot open the file (unknown).” 

The probable cause is a permissions problem. For more information, see “Troubleshooting 
permissions problems” on page 150. Here are some specific causes and solutions:

• The account being used by Internet Information Server (usually IUSR) might not have the 
correct Windows NT permissions for a file-based database or for the folder containing the file. 
Check the permissions on the IIS account (IUSR) in the NT user manager. 

• You might not have permission to create or destroy temporary files. Check the permissions on 
the file and the folder. Make sure you have permission to create or destroy any temporary files. 
Temporary files are usually created in the same folder as the database, but the file may also be 
created in other folders such as /Winnt. 

• In Windows 2000, the time-out value may need to be changed for the Access database DSN. 
To change the time-out value, choose Start > Settings > Control Panel > Administrative Tools > 
Data Sources (ODBC). Click on the System tab, highlight the correct DSN, and click on the 
Configure button. Click the Options button and change the Page Timeout value to 5000. 

If you still have problems, see the following Microsoft Knowledge Base articles: 

• PRB: 80004005 “Couldn't Use ‘(unknown)’; File Already in Use” at http://
support.microsoft.com/default.aspx?scid=kb;en-us;Q174943.

• PRB: Microsoft Access Database Connectivity Fails in Active Server Pages at http://
support.microsoft.com/default.aspx?scid=kb;en-us;Q253604.

• PRB: Error “Cannot Open File Unknown” Using Access at http://support.microsoft.com/
default.aspx?scid=kb;en-us;Q166029.
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80004005—Logon Failed() 

This error occurs when you use Microsoft SQL Server and attempt to view a dynamic page in a 
web browser or in Live Data mode. 

This error is generated by SQL Server if it doesn’t accept or recognize the logon account or 
password being submitted (if you’re using standard security), or if a Windows NT account does 
not map to a SQL account (if you’re using integrated security).

Here are possible solutions:

• If you use standard security, the account name and password might be incorrect. Try the 
system Admin account and password (UID= “sa” and no password), which must be defined in 
the connection string line. (DSNs do not store user names and passwords.) 

• If you use integrated security, check the Windows NT account calling the page, and find its 
mapped SQL account (if any).

• SQL Server does not allow an underscore in SQL account names. If someone manually maps 
the Windows NT IUSR_machinename account to a SQL account of the same name, it will 
fail. Map any account that uses an underscore to an account name on SQL that does not use 
an underscore.

80004005—Operation must use an updateable query 

This error occurs when an event is updating a recordset or inserting data in a recordset.

Here are possible causes and solutions:

• The permissions set on the folder containing the database are too restrictive. IUSR privileges 
must be set to read/write. See “Troubleshooting permissions problems” on page 150.

• The permissions on the database file itself does not have full read/write privileges in effect. See 
“Troubleshooting permissions problems” on page 150.

• The database might be located outside the Inetpub/wwwroot directory. Though you can view 
and search the data, you might not be able to update it unless the database is located in the 
wwwroot directory. 

• The recordset is based on a non-updateable query. Joins are good examples of non-updateable 
queries within a database. Restructure your queries so they are updateable. 

For more information on this error, see “PRB: ASP ‘Error The Query Is Not Updateable’ When 
You Update Table Record,” in the Microsoft Knowledge Base at http://support.microsoft.com/
default.aspx?scid=kb;en-us;Q174640.

80040e07—Data type mismatch in criteria expression

This error occurs when the server tries to process a page containing an Insert Record or Update 
Record server behavior, and the server behavior attempts to set the value of a Date/Time column 
in a Microsoft Access database to an empty string (""). 

Microsoft Access has strong data typing; it imposes a rigorous set of rules on given column values. 
The empty string value in the SQL query cannot be stored in an Access Date/Time column. 
Currently, the only known workaround is to avoid inserting or updating Date/Time columns in 
Access with empty strings ("") or with any other value that does not correspond to the range of 
values specified for the data type.
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80040e10—Too few parameters

This error occurs when a column specified in your SQL query does not exist in the database table. 
Check the column names in your database table against the SQL query. The cause of this error is 
often a typographical error. 

80040e10—COUNT field incorrect

This error occurs when you preview a page containing an Insert Record server behavior in a web 
browser and try to use it to insert a record in a Microsoft Access 2000 database. 

You might be trying to insert a record into a database field that has a question mark (?) in its field 
name. The question mark is a special character for some database engines, including Microsoft 
Access, and should not be used for database table names or field names. 

Open your database system and delete the question mark (?) from the field names, and update the 
server behaviors on your page that refer to this field.

80040e14—Syntax error in INSERT INTO statement

This error occurs when the server tries to process a page containing an Insert Record server behavior.

This error typically results from one or more of the following problems with the name of a field, 
object, or variable in the database:

• Using a reserved word as a name. Most databases have a set of reserved words. For example, 
“date” is a reserved word and cannot be used for column names in a database. 

• Using special characters in the name. Examples of special characters include: 

. / * : ! # & - ? 

• Using a space in the name.

The error can also occur when an input mask is defined for an object in the database, and the 
inserted data does not conform to the mask.

To fix the problem, avoid using reserved words such as “date”, “name”, “select”, “where,” and “level” 
when specifying column names in your database. Also, eliminate spaces and special characters.

See the following web pages for lists of reserved words for common database systems:

• Microsoft Access at http://support.microsoft.com/default.aspx?scid=kb;en-us;Q209187

• Microsoft SQL Server at http://support.microsoft.com/support/sql/content/inprodhlp/
_reserved_keywords.asp?GSSNB=1

• Oracle at http://technet.oracle.com/doc/server.804/a58234/vol2_wor.htm#421705

• MySQL at http://www.mysql.com/doc/R/e/Reserved_words.html

80040e21—ODBC error on Insert or Update

This error occurs when the server tries to process a page containing an Update Record or Insert 
Record server behavior. The database cannot handle the update or insert operation the server 
behavior is trying to perform. 
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Here are possible causes and solutions:

• The server behavior is trying to update a database table’s auto-number field or to insert a record 
into an auto-number field. Because auto-number fields are populated automatically by the 
database system, any attempt to populate them with a value fails. 

• The data the server behavior is updating or inserting is the wrong type for the database field, 
such as inserting a date into a Boolean (yes/no) field, inserting a string into a numeric field, or 
inserting an improperly formatted string into Date/Time field. 

800a0bcd—Either BOF or EOF is true

This error occurs when you attempt to view a dynamic page in a web browser or in Live Data mode.

The problem occurs when the page tries to display data from an empty recordset. To solve the 
problem, apply the Show Region server behavior to the dynamic content to be displayed on the 
page, as follows: 

1 Highlight the dynamic content on the page.

2 In the Server Behaviors panel, click the plus (+) button and choose Show Region > 
Show Region If Recordset Is Not Empty.

3 Select the recordset supplying the dynamic content and click OK.

4 Repeat steps 1 to 3 for each element of dynamic content on the page.

Troubleshooting ColdFusion error messages
This section describes some common database error messages generated by ColdFusion and 
suggests ways to troubleshoot them. 

ColdFusion—Access Denied 

This error occurs with ColdFusion 4 or 5 when writing to a file-based database (such as Microsoft 
Access or Foxpro) that ColdFusion is accessing through a data source. The error usually occurs 
when you try to overwrite the file through FTP or by copying over it. 

The workaround is to recycle the ColdFusion services or disable “Maintain Database 
Connection” from the Data Source section in ColdFusion Administrator.

ColdFusion—Operation must use an updateable query error

This error occurs with ColdFusion 4 or 5 when attempting to run a ColdFusion page that 
updates or deletes from a Microsoft Access (or other file-based) database. 

This error usually occurs because ColdFusion does not having appropriate permissions at the 
network operating system level to write to the database.

To solve this issue in Windows NT, click Start > Settings > Control Panel > Services. Double-click 
the ColdFusion Application Server service and note the start-up account. It should be the System 
account by default. Next, go to the folder containing the database file and explicitly give the 
noted account full permissions to that folder. Even if the folder says “Everyone” has full 
permissions, add the ColdFusion startup account.
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Troubleshooting permissions problems
If your database is located on a Windows NT, Windows 2000, or Windows XP computer and 
you receive an error message when you try to view a dynamic page in a web browser or in Live 
Data mode, the error can be due to a permissions problem. 

Here are possible error messages pointing to a permissions problem:

• Microsoft OLE DB Provider for ODBC Drivers error ’80004005’ [Microsoft][ODBC 
Microsoft Access 97 Driver] Couldn’t use ’(unknown)’; file already in use. 

• Microsoft OLE DB Provider for ODBC Drivers (0x80004005) [Microsoft][ODBC Microsoft 
Access Driver] The Microsoft Jet database engine cannot open the file ’(unknown)’. It is 
already opened exclusively by another user, or you need permission to view its data. 

• Microsoft OLE DB Provider for ODBC Drivers error ’80004005’ [Microsoft][ODBC 
Microsoft Access 97 Driver] Couldn’t lock file.

The Windows account attempting to access the database doesn’t have sufficient permissions. The 
account might be either the anonymous Windows account (by default, IUSR_computername) or a 
specific user account, if the page has been secured for authenticated access.

You must change the permissions to give the IUSR_computername account the correct 
permissions so the web server can access the database file. In addition, the folder containing the 
database file must also have certain permissions set to write to that database.

If the page is meant to be accessed anonymously, give the IUSR_computername account full 
control to the folder and database file, as described in the procedure below. 

Additionally, if the path to the database is being referenced using UNC (\\Server\Share), make 
sure the Share Permissions give the IUSR_computername account full access. This step applies 
even if the share is on the local web server. 

If you copy the database from another location, it might not automatically inherit the permissions 
from its destination folder. You might have to change the permissions for the database. 

To check or change the database file permissions:

1 In Windows Explorer, locate the database file or the folder containing the database, right-click 
the file or folder, and select Properties. 

2 If you use Windows 2000, select the Security tab; if you use Windows NT, select the Security 
tab then click the Permissions button.

Note: This step applies only if you have an NTFS file system. If you have an FAT file system, the dialog box won’t 
have a Security tab. 

3 If the IUSR_computername account is not listed among the Windows accounts in the File 
Permissions dialog box, click the Add button to add it.

4 In the Add Users and Groups dialog box, choose the computer name from the List Names 
From pop-up menu.

Note: If you use Windows 2000, the dialog box is called “Select Users, Computers, or Groups” and the pop-up 
menu is called “Look In:”.

A list of account names associated with the computer appears. If the IUSR account does not 
appear in the Names list, click the Show Users button. 

Note: Windows 2000 does not have a Show Users button.
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5 Select the IUSR_computername account, then click Add.

6 Assign the IUSR account full permissions by choosing Full Control from the Type of Access 
pop-up menu, and click OK.

For added security, permissions can be set so that Read permission is turned off for the web folder 
containing the database. Browsing the folder won’t be permitted, but web pages will still be able 
to access the database. 

For more information about the IUSR account and web server permissions, see the following 
TechNotes on the Macromedia Support Center:

• Understanding anonymous authentication and the IUSR account at http://
www.macromedia.com/go/authentication

• Setting IIS web server permissions at http://www.macromedia.com/go/server_permissions
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Part II
Tutorials

Learn how to perform some specific common tasks in 
Dreamweaver.

This part contains the following chapters:

• Chapter 13, “Dreamweaver MX Tutorials”

• Chapter 14, “Using Tables to Design a Page Layout 
Tutorial”

• Chapter 15, “Image Alignment and Image Maps 
Tutorial”

• Chapter 16, “Working with Dreamweaver Design Files 
Tutorial”

• Chapter 17, “Designing with Cascading Style Sheets 
Tutorial”

• Chapter 18, “Building a Master-Detail Page Set Tutorial”

• Chapter 19, “Building an Insert Record Page Tutorial”





CHAPTER 13

Dreamweaver MX Tutorials

The Dreamweaver MX tutorials are step-by-step lessons, designed to teach you the fundamentals 
of Dreamweaver MX. We recommend that you go through the tutorials using the sample files 
installed in the GettingStarted folder within the Dreamweaver application folder. 

By completing these hands-on tutorials, you’ll learn how to use Dreamweaver’s visual environment 
to add design elements as you create web pages and web applications. The tutorials are targeted 
toward beginner to intermediate-level web designers who are looking to get up-to-speed quickly 
with processes they may already perform while developing web pages and applications.

Each tutorial focuses on a specific web design feature or topic. We suggest that you complete the 
tutorials in sequence, although you may choose to review only the sections of interest to you.

Additional tutorials are available at the Macromedia website (http://www.macromedia.com/go/
dreamweaver_tutorials).

What you will learn
Each tutorial takes approximately 30 - 45 minutes to complete, depending on your experience. 
The tutorials cover the following topics and tasks: 

“Using Tables to Design a Page Layout Tutorial” on page 157, takes approximately 45 minutes to 
complete and focuses on the following tasks:

• “Create and modify a table in Standard view” on page 158

• “Add color to a table” on page 162

• “Set a relative width table in Standard view” on page 164

• “Design a page in Layout view” on page 165

• “Draw a layout cell” on page 166

“Image Alignment and Image Maps Tutorial” on page 173, takes approximately 20 - 30 minutes 
to complete, and focuses on these tasks:

• “Set image alignment” on page 174

• “Set image spacing” on page 176

• “Set space and alignment options” on page 176

• “Create an image map” on page 176

• “Set image map areas” on page 177

• “Open a linked file in a new window” on page 179
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“Working with Dreamweaver Design Files Tutorial” on page 181, takes approximately 20 - 30 
minutes to complete, and focuses on these tasks:

• “Working with code snippets” on page 182

• “Insert a code snippet” on page 182

• “Modify the snippet content” on page 186

• “Save code as a snippet” on page 187

“Designing with Cascading Style Sheets Tutorial” on page 189, takes approximately 30 minutes 
to complete and focuses on these tasks:

• “Open the CSS Styles panel” on page 191

• “Open a document to work in” on page 190

• “Set a style for links” on page 194

• “Export styles to create an external style sheet” on page 195

“Building a Master-Detail Page Set Tutorial” on page 197, takes approximately 30 minutes to 
complete and focuses on these tasks:

• “Create a master-detail page set” on page 198

• “Create a database recordset” on page 200

• “Insert a Master-Detail Page Set application object” on page 203

• “View your pages” on page 205

“Building an Insert Record Page Tutorial” on page 207, takes approximately 40 minutes to 
complete and focuses on these tasks:

• “Create an insert page” on page 208

• “Add form objects” on page 209

• “Define an Insert Record server behavior” on page 213

• “Test your page” on page 215
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CHAPTER 14

Using Tables to Design a Page Layout

Tutorial

If you are familiar with HTML coding, you already know that text or any other content you add 
in a web page flows from one margin to the other unless it is inserted in a “container,” such as a 
layer or a table. HTML tables are an excellent solution for designing web page layout, because 
they are easy to modify and compatible with most browsers. You can use tables to structure the 
layout of tabular data or to set the display of visual elements (such as Flash buttons, images, or 
paragraphs of text).

Dreamweaver has two views in which you can design tables—Standard view and Layout view. In 
this tutorial you learn to design page layout in both views. In the first section of the tutorial, you 
work in Standard view and insert a table in a page. In the latter section, you work in Layout view, 
where you use layout options to draw a table and table cells to design the layout.

This tutorial focuses on using tables as a page layout element. By completing this tutorial you will 
learn how to accomplish the following tasks:

• “Create and modify a table in Standard view” on page 158

• “Add color to a table” on page 162

• “Set a relative width table in Standard view” on page 164

• “Design a page in Layout view” on page 165

• “Draw a layout cell” on page 166

• “Add multiple layout cells” on page 167

• “Move or resize a layout cell” on page 168

• “Set a relative width table in Layout view” on page 171

• “Design a page in Layout view” on page 165
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Before You Begin
If you haven’t already done so, before you start the tutorial, create a new folder into which you’ll 
transfer the GettingStarted sample files.

1 At the root level of your local disk, create a new folder and name it Sites—for example, 
C:\Sites (Windows) or Hard Drive:Sites (Macintosh).

If you are using Windows XP or Macintosh OS X, create the Sites folder inside your user folder.

2 Locate the Tutorials folder in the Dreamweaver application folder on your hard disk. The path 
to the folder is:

\Macromedia|Dreamweaver MX\Samples\GettingStarted\ Tutorials

3 Copy the Tutorial folder into the Sites folder.

4 In Dreamweaver, define the Tutorials folder you copied as your local site. If you do not know 
how to define a local site in Dreamweaver, you can follow the directions provided in Chapter 
2, “Creating Your First Website in Dreamweaver,” on page 19.

You can also use the Dreamweaver Site Definition Wizard to be guided through the site 
setup process. In Dreamweaver, choose Site > New Site, then click the Basic tab to begin 
setting up your site.

Create and modify a table in Standard view
Standard view is the typical Dreamweaver design view. To create a table in Standard view, you use 
the Insert Table command. Dreamweaver creates a table based on options you select in the Insert 
Table dialog box. You can easily modify the initial table structure to create more complex design 
by merging and splitting cells, and by inserting rows and columns.

You use the table cells (the boxes created at the intersection of each column or row in a table) to 
control the placement of text and images in a web page. Because you can make the borders of 
tables invisible, viewers won’t see the underlying structure of your design when they look at the 
page in a browser.

1 In Dreamweaver, choose File > New.

The New Document dialog box appears.

2 In the Blank Document list, choose HTML, then click Create to create a new HTML document.

3 In the Title text field in the Document toolbar, enter Table Design to add a title to your document.

4 Choose File > Save, then save the document in your local site folder. Name it 
tableModify.htm. 

Insert a table

Now you’re ready to insert a table in the document.

1 In the Document window, place the insertion point in the document, then do one of 
the following:

• Select Insert > Table.
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• In the Insert bar’s Common category, click the Table icon. 

The Insert Table dialog box appears.

2 In the dialog box, set the following options: 

• In the Rows text box, type 2.

• In the Columns text box, type 2.

• In the Width text box, type 600, and then select Pixels in the pop-up menu to the right of the 
Width text box.

Setting the width to 600 pixels creates a fixed width table. We’ll discuss table width in more 
detail a little later in this tutorial.

• In the Border text box, type 1 to set a 1-pixel border around the table and table cells. 

3 Click OK.

Dreamweaver inserts the table in the document. 
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4 Save your document by doing one of the following:

• Select File > Save.

• Press Control+S (Windows) or Command+S (Macintosh).

Modify the table

Next, you’ll modify the table’s layout. You’ll add rows and columns to the table, and learn how to 
merge and split cells to create the desired page layout.

1 Click in the top-left cell then drag down to the bottom row to select the left column. 

2 Select Modify > Table > Insert Column.

The table now contains three columns. 

3 Click in the bottom left cell and then select Modify > Table > Insert Rows or Columns.

The Insert Rows or Columns dialog box appears. 

Tip: Select the Insert Rows or Columns option when you want to add a specific number of rows or columns, or to 
choose where a row or column is inserted in a table.

4 In the dialog box, set the following options:

For Insert, select Rows.

In Number of Rows, type 2.

For Where, select Above the Selection.

5 Click OK.

The table updates. You now have a four-row by three-column table.

6 Save your changes (File > Save).
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Merge and split cells

By merging and splitting cells you can customize a table’s design to fit your layout needs. Next, 
you’ll see how to use menu options or the Property inspector to merge or split table cells. 

1 In the document, select the first two cells in the left column of the table, by dragging your 
pointer from the top left cell to the cell below it.

2 Choose Modify > Table > Merge Cells. 

The two cells merge into a single cell.

3 Click in the third row of the second column, then drag to the right and down to select the last 
two rows of cells in the second and third columns. 

4 In the Property inspector, click the Merge button to combine the cells.

The selected cells merge into one cell.

You can split a single cell or column.

5 Click in the top left cell.

Split cell

Merge cells
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6 In the Property inspector, click the Split Cell button.

The Split Cell dialog box appears.

7 In the dialog box, set the following options:

• For Split Cell Into, select Columns.

• In Number of Rows, enter 2.

8 Click OK.

The table is modified.

Change row height and column width

Let’s adjust the table’s dimensions. You’ll increase the amount of space between the table rows, 
and adjust the amount of space between the table columns.

1 Move the pointer along the bottom table border until it changes into a border selector, then 
drag it down to resize the table.

You can use this method to resize the other row heights in the table if you’d like.

2 Move the pointer along a column border until it changes to a border selector, then drag it to 
the left or right to change a column’s width.

3 When you are done adjusting your table, save your document.

Add color to a table
You can add color to any part of a table. You’ll start by adding a background color to the entire 
table, then apply a different background color to cells in the table. You’ll finish by changing the 
border color.
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1 In the document, click in any cell of the table, then in the tag selector located at the bottom 
left of the Document window, click the <table> tag to select the entire table.

2 Open the Property inspector (Window > Properties), if it isn’t already open.

Properties for the selected table appear in the Property inspector.

3 In the Property inspector, in the Bg Color text box select a color by doing one of the following:

• Click the color picker pop-up, then choose a color from the color picker.

• Enter a color using a hexadecimal value, for example #CC9933.

• Enter a web-safe color name, such as goldenrod.

A background color applies to the table.

4 You can apply a background color to the cells of the table the same way. Click in the top-left 
cell, then in the Property inspector, select a different color in the Bg Color text box.

5 Color additional cells as you desire.

Add a border color

Now, you’ll set the table border color. Border color applies to both the outside and inside borders 
of a table.

1 In the Document window, select the table.

2 In the Property inspector, in the Brdr Color text box, use the color picker to select a border 
color for your table. 

3 When you are done, save your document.

4 Press F12 (Windows only) or select File > Preview in Browser and select a browser to view the 
document in.
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Set a relative width table in Standard view
A percentage-based table stretches and shrinks based on the width of a browser window. (For 
example if you specify that a table uses a width of 75%, the table stretches to fill 75% of the 
horizontal space regardless of the browser window size. This can be useful in some instances, such 
as making sure a navigation menu is always displayed when a window is resized. 

When you want to set the size of a table regardless of how a user resizes the browser window, use 
pixel-based tables. When you want the table to stretch to the size of the browser window, 
percentage-based tables are best. 

To see the difference in percentage-based and pixel-based tables, you’ll add one of each to a page, 
then view it in a browser.

1 In Dreamweaver, choose File > New.

2 In the New Document dialog box, the Basic Page category is already selected; in the Basic 
Pages list, double-click HTML to create a new HTML document.

The document opens in the Document window.

3 Save this file to your local site folder. Name it tableWidth.

4 Place the insertion point in the document.

5 In the Common tab of the Insert bar, click the Table button.

6 In the dialog box that appears, set the following options:

In the Rows text box, type 2.

In the Columns text box, type 3.

In the Width text box, type 90, and select Percentage in the pop-up menu to the right of the 
Width text box.

In the Border text box, enter 1 to set a 1-pixel border around the table and table cells.

7 Click OK.

The table appears in the document.

8 Click in the top, middle cell and drag to the bottom cell to select the middle column. 

9 In the Property inspector, use the color picker to apply a background color to the column. 

Create a pixel width based table
Now you’ll add another table. A pixel width table is set to a specific width and doesn’t adjust to 
the browser window size.

1 Insert a paragraph return after the table you just inserted.

2 In the Common tab of the Insert bar, click the Table button.
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3 In the dialog box that appears, set the following options:

In the Rows text box, type 2.

In the Columns text box, type 3.

In the Width text box, type 600, and then select Pixel in the pop-up menu to the right of the 
Width text box.

In the Border text box, type 1 to set a 1-pixel border around the table and table cells.

4 Click OK.

The table appears in the document.

5 Select the middle column by clicking in the top, middle cell and dragging down to the 
bottom cell. 

6 In the Property inspector, use the color picker to apply a background color to the column. 

7 Press F12 (Windows only) or select File > Preview in Browser and select a browser to view the 
document in.

Resize the browser window to see how the two tables respond to browser window changes. The 
pixel-based table retains its size, while the percentage-based table adjusts to fill the browser. 

8 When you are done viewing the document, close your browser window.

9 Save your document.

Design a page in Layout view
Now that you’ve learned how to work with the Insert Table command, let’s look at another way to 
work with tables—by drawing the table layout.

Next, you’ll work in Layout view, which allows you to draw layout cells or layout tables into 
which you can add content such as images, text, or other media. 

In Layout view you can draw layout cells and layout tables to define the design areas of a 
document. You can start by inserting a table cell or a layout cell. When you insert a layout cell 
first Dreamweaver automatically creates a table to surround it.

Create and save a new document

1 In Dreamweaver, choose File > New.

2 In the New Document dialog box, Basic Page is already selected, in the Basic Pages list select 
HTML then click Create to create a new HTML document.

The document opens in the Document window.

3 Save the document in your local site folder, and name it tableLayout.htm. 
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Draw a layout cell
1 In the Insert bar, click the Layout tab, then click the Layout view button to switch from 

Standard view.

The Getting Started in Layout View dialog box appears and describes the Layout view options.

2 Review the options, then click OK to close the dialog box. 

3 In the Insert bar there are two Layout options available—Draw Layout Cell and Draw Layout 
Table; these options aren’t available in Standard view.

4 If the Property inspector isn’t already open, choose Window > Properties to open it. 

5 In the Insert bar, click the Draw Layout Cell button.

6 Move the pointer to the Document window; the mouse pointer changes to a drawing tool 
(looks like a small cross). Click in the upper left corner of the document, then drag to draw 
a layout cell.

When you release the mouse, a layout cell appears in a layout table. 

The layout table expands to fill the Document window, and sets the page’s layout area. The 
white rectangle is the layout cell you drew. You can place additional layout cells in the empty 
area of the layout table. 

Layout table

Layout cell
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7 Draw another cell to create a text area above the navigation buttons. 

Add multiple layout cells
Next you’ll learn how to add a series of layout cells. You’ll add three layout cells next to the cell 
you just created to create layout for the page’s navigation buttons. 

1 In the Insert bar, click the Draw Layout Cell button; then hold down the Control key 
(Windows) or Command key (Macintosh) so you can draw multiple cells in the table. 
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2 In the Document window, position the pointer below the last cell you drew; then drag to draw 
a layout cell. 

Continue to hold the Control key (Windows) or Command key (Macintosh) and draw two 
more layout cells. Your screen should look similar to this:

3 Click in a blank area of the Insert bar, to deselect the Draw Layout Cell tool. (The drawing 
tool changes to a selection arrow.)

Move or resize a layout cell
If you need to line up the cells next to each other you can resize and move the layout cells. You 
change the size of a layout cell by using one of its resize handles. 

You can move a layout cell to a new position in a document, as long as there is room in the layout 
table to reposition the cell. Sometimes you will have to resize surrounding cells to make a desired 
change. If you want to move a layout cell to reposition it in a document, follow these steps.
Chapter 14168



1 Click the border of a layout cell to select it.

Handles appear around a selected layout cell.

2 Do one of the following:

• Drag the layout cell to move it to another position.

• If there is space around the layout cell, use the left, right, or up arrow, as appropriate, to 
move the cell.

Resize a layout cell

To design a page precisely, you can set the size of cells you add in a document. You can also 
reposition cells in the page.

1 Click the border of the layout cell to select it.

2 To resize a layout cell: 

In the Property inspector for the layout cell, type a number for the desired cell width or height. 
For example, type 200 in the Height text box to set the cell’s height to 200 pixels, then click in 
the document to see the cell width change.

Note: If you enter a pixel width or height that exceeds the dimension of the layout table, or that causes the cell to 
overlap another cell in a layout table, Dreamweaver alerts you and adjusts the cell width to a valid width.
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Add color to a table
You can add color to any part of a table. You’ll start by adding a background color to the entire 
table, then apply a different background color to cells in the table. You’ll finish by changing the 
border color.

1 In the document, click in any cell of the table, then in the tag selector located at the bottom 
left of the Document window, click the <table> tag to select the entire table.

2 Open the Property inspector (Window > Properties), if it isn’t already open.

Properties for the selected table appear in the Property inspector.

3 In the Property inspector’s Bg Color text box, select a color by doing one of the following:

• Click the color picker pop-up then choose a color from the color picker.

• Enter a color using a hexadecimal value, for example #CC9933.

• Enter a web-safe color name, such as goldenrod.

A background color applies to the table.

4 Select a cell by clicking the cell’s border, then in the Property inspector choose a color to 
apply to it.
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5 Add a background color to the other cells in your table, if you’d like. 

6 Save your document.

Set a relative width table in Layout view
By default, when you draw a table or cell in Layout view, Dreamweaver creates the table with 
fixed width columns. You can change a fixed-width table or cell to relative width by using the 
Autostretch feature.

Autostretch allows you to create a relative width table, and applies flexible layout for the column 
you set as an expandable column, so that a table automatically spans to fill a browser window.

Information about column widths appears in the column header area at the top of each column of 
a table. Table width information appears in the table’s column header. A fixed-width column has 
a specific numeric width, such as 200 pixels, while the column header for an autostretch column 
contains a wavy line. You can only make one column in a table autostretch. You can easily change 
which column Autostretch applies to.

You’ll set one of the columns of your table to automatically stretch so that the table fills a browser 
when viewed.
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1 In the document, in the column header click the table column you want to make autostretch. 

2 In the pop-up menu that appears, choose Make Column Autostretch.

The Choose Spacer Image dialog box appears. 

3 In the dialog box, select Create a Spacer Image File. 

4 The Save Spacer Image File As dialog box appears, accept the default values to save the image as 
spacer.gif, in a location relative to the Site Root.

Tip: If you already have a spacer image you can select that choice so you don’t create different spacer images for 
each table you design.

The column header changes from a numeric value to a wavy line. The Property inspector also 
updates to reflect that Autostretch is applied to the table.

5 Save your file.

6 Choose File > Preview in Browser, and select which browser to view your page in.

The column automatically expands and contracts depending on the size of the browser window.

Take the next step
In this tutorial you learned how to create tables in Dreamweaver. Along the way, you modified 
table rows and columns, set background colors to table elements, and learned how to create 
“flexible” table design in both Standard and Layout view.

For detailed information about topics covered in this tutorial, see the following topics in the 
Using Dreamweaver MX documentation or Dreamweaver Help:

• Designing the Page Layout 

• Presenting Content with Tables
Chapter 14172



CHAPTER 15

Image Alignment and Image Maps Tutorial

Working with images in Macromedia Dreamweaver MX is quite easy. You can use various 
Dreamweaver visual tools to insert an image. This tutorial presents you with image options you can 
apply once an image is inserted in a page. You will learn about aligning images and text, and setting 
space around an image. You’ll also learn how to use a single image to link to multiple web pages.

This tutorial is designed for beginning Dreamweaver users. It covers some basic features in 
Dreamweaver and will help you understand how to align images, as well as how to create an 
image map. 

In this tutorial you will accomplish the following tasks:

• “Set image alignment” on page 174

• “Set image spacing” on page 176

• “Set space and alignment options” on page 176

• “Create an image map” on page 176

• “Set image map areas” on page 177

• “Open a linked file in a new window” on page 179

Before You Begin
If you haven’t already done so, before you start the tutorial, create a new folder into which you’ll 
transfer the GettingStarted sample files.

1 At the root level of your local disk, create a new folder and name it Sites—for example, 
C:\Sites (Windows) or Hard Drive:Sites (Macintosh).

If you are using Windows XP or Macintosh OS X, create the Sites folder inside your user folder.

2 Locate the Tutorials folder in the Dreamweaver application folder on your hard disk. The path 
to the folder is:

\Macromedia|Dreamweaver MX\Samples\GettingStarted\ Tutorials

3 Copy the Tutorial folder into the Sites folder.

4 In Dreamweaver, define the Tutorials folder you copied as your local site. If you do not know 
how to define a local site in Dreamweaver, you can follow the directions provided in Chapter 
2, “Creating Your First Website in Dreamweaver,” on page 19.

You can also use the Dreamweaver Site Definition Wizard to be guided through the site setup process. 
In Dreamweaver, choose Site > New Site, then click the Basic tab to begin setting up your site.
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Set image alignment
An image, like text, appears in the normal flow of HTML in a page and can appear as a paragraph 
by itself, or as part of a paragraph of text. You can set the alignment of an image in two ways in 
the Property inspector using the text alignment or image alignment controls.

Text alignment positions the paragraph in which the image is inserted and can be used to align an 
image to the left or right margin or to center it. Image alignment lets you set the relationship of 
an image to other content in the same paragraph (including another image). In Dreamweaver, the 
Align pop-up menu lets you select how the image aligns with the text.

Note: Not all of the image alignment options work in all browsers. In this tutorial you will use alignment options that 
work in Microsoft Internet Explorer and in Netscape Navigator. 

View the completed document

Before you begin, look at the completed file to see what you’ll do in this tutorial.

1 Choose File > Open, and in the dialog box that appears, navigate to the GettingStarted folder 
you created, then navigate to Tutorials/Completed and open the file named 
imageAlign_comp.htm. 

The file opens in the Document window.

2 Press F12 (Windows only) or select File > Preview in Browser and select a browser to view the 
document in.

The file shows three examples using image alignment and spacing to work with images and 
text together.

3 When you are done viewing the file close your browser window.

Open a file to work in

You’ll work in a partially completed document that contains three images and text in a table. The 
table confines the layout, enabling you to easily see how the different settings affect the alignment.

1 Choose File > Open and navigate to the imageAlign.htm file located in the Tutorials folder. 
This document contains the same images and text as the completed file you viewed previously.

Text alignment

Image alignment
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In the Document window, click the first image (next to the table cell that contains the text 
Alignment).

The image is in the same paragraph as the text. 

2 Open the Property inspector (Window > Properties), if it isn’t already open. 

In the Align text box, notice that this is the default alignment for an image. It places the image 
on the baseline of the line of text. 

3 With the image still selected, in the Align pop-up menu choose Middle to see what this 
setting does.

The first line of text aligns to the middle of the image.

4 With the image still selected, in the Align pop-up menu, choose Left.

The image now appears on the left and the text wraps along its right side. 

Tip: Text in the same paragraph as an image wraps around the image and then flows beneath the image. If you 
insert a paragraph return in the flowed paragraph, it is no longer aligned to the image and appears in a new 
paragraph below the image. If you want to add space without disrupting the text wrap use a paragraph break, 
Control+Enter (Windows) or Command+Return (Macintosh).

5 Choose File > Save to save your changes.

6 Select File > Preview in Browser, then select a browser to preview the document in or press F12 
(Windows only) to view it in a browser window.

You see the image and text aligned.

7 When you are done viewing the file, close your browser window.
Image Alignment and Image Maps Tutorial 175



Set image spacing
As you see, when you place an image in a paragraph, text appears right next to the edge of the 
image. In the next step you’ll add a margin of space between the image and text. 

You can use the horizontal and vertical space properties in the Property inspector to create space 
around an image. The horizontal space property adds space to the Left and right of the image, 
while the vertical space property adds space above and below an image.

1 In the image_align.htm document, click the second image in the page (next to the table cell 
that contains the text Spacing).

2 In the Property inspector, enter 10 in the V Space text box to set the vertical spacing.

3 Move the pointer to the H Space text box, enter 30, then press Enter or Return to set the 
horizontal spacing.

A margin of space is created between the text and the image. The spacing also affects the 
distance between the image and the table border.

Set space and alignment options

As the final step in this part of the tutorial, you’ll set both alignment and space properties 
for the image.

1 In the imageAlign.htm document, click the third image in the page (next to the table cell that 
contains the text Alignment and Spacing).

2 In the Property inspector, in the Align pop-up menu choose Right.

The image moves to the right.

3 In the HSpace text box, enter 30, then click elsewhere in the Property inspector or in the 
Document window for the value to update. 

A margin of space is added between the image and text.

Create an image map
An image map is an image that serves as a navigation device. With an image map, you can create 
multiple hotspots (clickable areas) in a single image and have each hotspot link to a different URL 
or file to open. You can also set where a linked document opens; for example you can open the 
document in a particular frame of a frameset document, or open it in a new browser window. 
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View the completed file

Take a look at the completed file to see what you’ll create. The completed image map includes links 
to other document. You will open the document in a browser window to see how the links work.

1 Choose File > Open, and in the dialog box that appears, navigate to the GettingStarted 
folder you created, then navigate to Tutorials/Completed and open the file named 
imagemap_comp.htm.

The document opens in the Document window.

2 Press F12 (Windows only) or select File > Preview in Browser then select a browser to view the 
document in.

3 Roll the pointer over the light purple areas. The pointer changes to a hand, letting you know 
that the areas link to another document.

4 Click North America. 

A new page opens.

5 Click your browser’s back button to return to the world map page.

6 Click the other hotspot. 

The linked document opens in a new browser window.

7 When you are done viewing the pages, close your browser.

Set image map areas

You will create an image map so that a single image links to multiple pages.

1 In Dreamweaver, choose File > Open, then navigate to and open the file named 
imagemap_start.htm.

2 In the document, click the image of the world map to select it.
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3 Open the Property inspector if it isn’t already open, and click the expander arrow in the lower 
right area of the Property inspector to see all the image properties, if necessary. 

Image map options appear in the expanded Property inspector.

4 In the Map Name text box, type Locations. 

Tip: If you create more than one image map in a document, each map must have a unique name. Each image 
map can have multiple hotspots as well.

5 Click the Rectangular Hotspot Tool to select it.

6 In the Document window, click in the area above and to the left of North America, then drag 
the pointer down and to the right over the image to create a hotspot area.

A blue layer appears over the image, and the hotspot Property inspector appears.

7 In the Link text box, click the folder icon. In the dialog box that appears, navigate to the file 
named location1.htm to set a link to it.

8 In the Alt text box, type North America. 

Image map options
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Note: You should always set alternate text for images in your documents, including image maps, this provides 
descriptive information about an image for page viewers who are using text-only browsers. 

That’s it—you’ve set the first hotspot. Let’s set one more.

Open a linked file in a new window

So you can see how hotspot tools differ, this time you’ll use the Polygon Hotspot tool to define 
the hotspot area. The polygon tool allows you to set connecting points to define a hotspot area.

You’ll also learn how to open the linked document in a new window.

1 In the Property inspector, click the Polygon Hotspot Tool to select it.

2 In the Document window, click the image where you want to start the hotspot, and move the 
pointer to the next position; a line forms between the dots. 

3 Continue clicking around the shape to define Europe as the hotspot area. 
Note: As you click, the image map area adjusts and fills in, keep clicking around the shape to cover the area you 
want to include.

4 When you’re finished mapping the image, click the Arrow button in the Property inspector to 
change the pointer from a drawing tool. 

5 In the Link text box, click the folder icon, then browse to the file named location3.htm to 
open this file when the hotspot is clicked.

6 In the Target pop-up menu, choose _blank. 

When a user clicks the hotspot, the Locations3 page will open in a new window.

7 In the Alt text box, enter Europe. 

8 Press F12 (Windows only) or select File > Preview in Browser then select a browser to view the 
document in and test the links. 

9 Save and close your file.
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Take the next steps
In this tutorial you worked with several aspects of images. You learned how to use the Property 
inspector to set image alignment, define space around an image, and to create an image map.

For more information about topics covered in this tutorial, see the Inserting Images chapter, and 
the Linking and Navigation chapter in the Using Dreamweaver MX documentation and 
Dreamweaver Help.

Topics you may also be interested in:

• Cascading style sheets (positioning)

• Table alignment

• Attaching behaviors
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CHAPTER 16

Working with Dreamweaver Design

Files Tutorial

Macromedia Dreamweaver MX comes with an extensive set of professionally designed assets—
page layout documents, Cascading Style Sheets (CSS), and code snippets. You can use these assets 
to quickly get started creating professionally designed web pages. 

In this tutorial, you will create a new document, then insert and modify design element code 
snippets. You’ll also learn how to create your own code snippet.

This tutorial focuses on the following tasks:

• “Working with code snippets” on page 182

• “Insert a code snippet” on page 182

• “Modify the snippet content” on page 186

• “Save code as a snippet” on page 187
181



Before You Begin
If you haven’t already done so, before you start the tutorial, create a new folder into which you’ll 
transfer the GettingStarted sample files.

1 At the root level of your local disk, create a new folder and name it Sites—for example, C:\Sites 
(Windows) or Hard Drive:Sites (Macintosh).

If you are using Windows XP or Macintosh OS X, create the Sites folder inside your user folder.

2 Locate the Tutorials folder in the Dreamweaver application folder on your hard disk. The path 
to the folder is:

\Macromedia|Dreamweaver MX\Samples\GettingStarted\ Tutorials

3 Copy the Tutorial folder into the Sites folder.

4 In Dreamweaver, define the Tutorials folder you copied as your local site. If you do not know 
how to define a local site in Dreamweaver, you can follow the directions provided in Chapter 
2, “Creating Your First Website in Dreamweaver,” on page 19.

You can also use the Dreamweaver Site Definition Wizard to be guided through the site 
setup process. In Dreamweaver, choose Site > New Site, then click the Basic tab to begin 
setting up your site. 

Working with code snippets
Using code snippets can be a real time-saver in creating a professional looking page layout. Code 
snippets are reusable bits of code. You can insert existing code snippets that come with 
Dreamweaver or you can easily create you own code snippets to reuse in pages in your sites. You 
can create snippets of HTML, JavaScript, CFML, ASP, JSP, and more. 

You’ll start by working with some of the code snippets that come with Dreamweaver.

You can create a new document that is based on a Page Design document in the New Document 
dialog box.

1 Select File > New. 

The New Document dialog box appears.

2 In the General tab, the Basic Page category is already selected.

3 In the Basic Page document list, select HTML, then click Create.

The document opens in the Document window.

4 Save the document as myCodeSnippets in your site (File > Save).

Insert a code snippet
Dreamweaver comes with quite a variety of code snippets from which to choose. Code snippets 
are located in the Code panel. As you complete this tutorial, you’ll insert a navigation code 
snippet, a content snippet, and a footer snippet.

1 Place the insertion point in the document where you want the snippet inserted.

2 Open the Snippets panel by doing one of the following:

• Choose Window > Snippets.
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• In the Code panel, click the expander arrow if you need to, then choose Snippets.

The Snippets panel appears.

3 Click the plus (+) button in front of the Navigation folder to see its content. 

Additional folders appear.

4 Click the plus (+) button in front of the Tab folder to see its content, then click Basic Tabs 
to select it.

The snippet is displayed in the preview pane.
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5 In the Snippets panel, click the Insert button located at the bottom of the Snippets panel to 
insert it in the document.

The snippet appears in the document.

6 Save your document (File > Save). 
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Add a content code snippet
Next you’ll add a table in which to add content. You’ll insert the snippet directly below the 
navigation table code snippet you just inserted.

1 Press Enter or Return to move the insertion point to the next line. 

2 In the Snippets panel, click the plus (+) button in front of the Content Tables folder, then click 
the plus (+) button in front of the One-pixel-border folder to see the snippets in the folder.

3 Click Text B to select it, and then click Insert to insert the snippet in the document.

The snippet appears in the document. 

4 Save your document (File > Save). 
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Add a footer code snippet
Now you’ll add the final snippet, a snippet for footer content.

1 Press Enter or Return to move the insertion point to the next line. 

2 In the Snippets panel, click the plus (+) button in front of the Footers folder to see the snippets 
in the folder.

3 Click Basic: Brief Text to select it, and then click Insert to insert the snippet in the document.

The snippet appears in the document. 

Modify the snippet content
Next, you’ll edit the placeholder text and apply color changes. You’ll apply background color to 
the cells to set your own color scheme. 

1 Open the Property inspector (Window > Properties), if it isn’t already open.

2 Place the pointer in the first cell of the Navigation table you inserted. The cell contains the 
text “Lorem.”

3 In the Property inspector’s Bg text box, click the arrow on the color swatch to open the color 
picker, then select a color to apply to a background of the cell. 

We used purple, #9966FF.

4 Place the pointer in the cell that contains the text “Ipsum.” 

5 In the Property inspector’s Bg text box, click the arrow on the color swatch, then choose a 
different color to apply to a background of the cell. 

We used a lighter purple, #9999FF.
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6 Repeat step 5, applying the same color to the cells containing the text “Dolor” and “Amit.”

7 Click in the table cell that contains the text content, then select a color to apply to the table cell.

8 Make additional changes you want. 

9 When you are done, save your document.

10 Press F12 (Windows only) or select File > Preview in Browser and select a browser to view the 
document in.

Save code as a snippet
Working with existing code snippets is very easy. You can just as easily create code snippets of your 
own. For example, let’s say you want to reuse the code snippets you updated in the document you 
just created. 

Let’s save the navigation snippets as a new snippet.

1 In the Snippets panel navigate to the Navigation Folder, then to the Tab folder to select the 
folder in which the snippet will be saved.

2 In the Document window, click in the navigation cell which contains the text “Lorem.”

3 In the tag selector, located at the bottom left of the document window, click the <table> tag.

In the Document window, the table is selected.
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4 Do one of the following to save the selection as a code snippet:

• Right-click (Windows) or control-click (Macintosh) the selected table, then choose Create 
New Snippet.

• In the Snippets panel, click the plus (+) button located at the bottom of the panel.

The Snippet dialog box appears.

5 In the Name text box, enter a name to describe your snippet.

We named the example snippet purple navigation.

6 In Description, enter a description for the snippet. 

7 You can view snippet descriptions in the Snippets panel to the right of the snippet name. 

8 For Snippet Type, select Insert Block. This will insert the snippet as a complete block of code, 
rather than a snippet that wraps the text it is applied to.

9 Click OK.

10 In the Snippets panel, the new code snippet is added to the Tab folder.

Take the next steps
In this tutorial, you learned how to locate, view, and insert code snippets that come with 
Dreamweaver. You also learned that creating your own code snippets is a easy task to accomplish. 

For more information about topics covered in this tutorial, see Dreamweaver Help (Help > Using 
Dreamweaver).
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CHAPTER 17

Designing with Cascading Style

Sheets Tutorial

You can use Cascading Style Sheets (CSS) in Macromedia Dreamweaver MX to apply style 
elements consistently across multiple pages of a site. CSS styles offer great flexibility in that style is 
not confined to text objects. You can define positioning and formatting styles to text, images, 
tables, layers, and so on. 

In this tutorial you experiment with a few styles, and get a glimpse of just some of the many style 
options CSS affords you.

In this tutorial you will accomplish the following tasks:

“Open the CSS Styles panel” on page 191

“Redefine an HTML tag” on page 191

“Set a style for links” on page 194

“Export styles to create an external style sheet” on page 195
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Before you begin
If you haven’t already done so, before you start the tutorial, create a new folder into which you’ll 
transfer the GettingStarted sample files.

1 At the root level of your local disk, create a new folder and name it Sites—for example, C:\Sites 
(Windows) or Hard Drive:Sites (Macintosh).

If you are using Windows XP or Macintosh OS X, create the Sites folder inside your user folder.

2 Locate the Tutorials folder in the Dreamweaver application folder on your hard disk. The path 
to the folder is:

\Macromedia|Dreamweaver MX\Samples\GettingStarted\ Tutorials

3 Copy the Tutorial folder into the Sites folder.

4 In Dreamweaver, define the Tutorials folder you copied as your local site. If you do not know 
how to define a local site in Dreamweaver, you can follow the directions provided in Chapter 
2, “Creating Your First Website in Dreamweaver,” on page 19.

You can also use the Dreamweaver Site Definition Wizard to be guided through the site 
setup process. In Dreamweaver, choose Site > New Site, then click the Basic tab to begin 
setting up your site. 

Open a document to work in

You’ll start by opening a document to work in.

1 In Dreamweaver, select File > Open.

2 In the dialog box that appears, navigate to the Tutorial folder in the local site you defined, then 
double-click the file named css_start.htm to select it.

The document opens in the Document window. 

This document includes several elements—text, tables, and links. Very few elements in the page 
have any formatting style applied to them at all. By redefining the body tag, you’ll define styles 
which will apply a global change to the document.
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Open the CSS Styles panel
You use the CSS Styles panel to create, view, apply or edit style attributes. 

The CSS Styles panel has two views or modes. Use the Apply Styles view to apply custom or class 
CSS styles, and you use the Edit Styles view to make changes to styles you have applied to your 
document. You can create a new style while working in either view.

1 Open the CSS Styles panel (Window > CSS Styles), if it is not already open.

2 In the CSS Styles panel, click the New CSS Style button (+) at the bottom of the panel.

The New CSS Style dialog box appears.

Redefine an HTML tag
You can apply CSS styles to any tag in a document. The first style you’ll create will redefine the 
style attributes of the body tag. 

1 In the New CSS Style dialog box, for Type, select Redefine HTML Tag.

2 In the Tag pop-up menu, select body.
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3 In Define In, select This Document Only.

For now we’ll apply the style to this document, later you’ll see how to export the style so you 
can use it in other pages in the site. Your dialog box should look similar to this:

4 Click OK.

The CSS Style definition dialog box appears.

5 Set the following Type settings:

In the Font pop-up menu, select Arial, Helvetica, sans serif.

6 In the Size pop-up menu, select 12 and pixels.

7 In Color, click the color picker, then use the eyedropper to select white.
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Set a page background color
Next, you’ll use the Background category in the CSS Styles panel to set background options.

1 Under Category, select Background.

CSS background attributes appear.

2 In Background Color, do one of the following to set a background color:

• Click the color picker then use the eyedropper to select a dark blue or move eyedropper to the 
Document window and select the blue in the Global logo image.

• In the Background Color text box, enter #333366

3 Click OK.

The dialog box closes and the style is immediately applied to the document.
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4 In the CSS Styles panel, select Edit Styles.

The new style appears in the list along with a description of the style attributes.

Set a style for links
With the new style applied you can barely distinguish the hypertext links in the document. Let’s 
create a style for the links.

1 In the CSS Styles panel, click the New CSS Style button (+) located at the bottom of the panel.

The New CSS Style dialog box appears.

2 In Type, select Use CSS Selector.

3 In the Selector pop-up menu, select a:link.

4 In Define In, select This Document Only.

5 Click OK.

The CSS Style definition dialog box appears.
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6 Set the following Type attributes for the link:

In Decoration, select Overline.

In Color, in the text box, enter #FFCC99.

7 Click OK.

8 To see the style you applied to the links you must view the page in a browser, press F12 to 
preview your page. 

Export styles to create an external style sheet
The CSS styles you’ve created so far have only applied to this document. Internal style sheets 
apply only to the document in which they were created. Now, you’ll learn how to create an 
external style sheet which contains the styles you defined in this document. 

1 Choose File > Export > Export CSS Styles.

In the Export CSS Styles dialog box appears.

2 In the dialog box, in the Save In (Windows) or Where (Macintosh) pop-up menu, navigate to 
your local site folder.

3 In File Name (Windows) or Save As (Macintosh), name the file mystyle.css.

Note: You can name a CSS style sheet any name you want, with the following exceptions; the name must be 
lowercase and contain no spaces.

4 Click Save.

Attach an external style sheet
You’ll attach the CSS style sheet you just created to another document in your site. The document 
you’ll work with is the same as the original css_start.htm file, before you added style to it.

1 In Dreamweaver, open the Site panel (Window > Site), if it isn’t already open.

2 In the Site panel, locate the file named css_start2.htm, then double-click it to open it in the 
Document window.

3 In the CSS Styles panel, click the Attach Style Sheet button located at the bottom of the panel.

The Link External Style Sheet dialog box appears.

4 In the File/URL text box, enter the path to mystyle.css or click Browse and in the dialog box 
that appears navigate to the mystyle.css file, then click OK to select it.

5 In the Link External Style Sheet dialog box, for Add As, select Link.

6 Click OK.

The selected style sheet links to the current document, and the style attributes are 
immediately applied. 
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Take the next steps
In this tutorial, you learned how to create basic CSS styles. You also learned how to export styles 
you applied in a document to create an external CSS style sheet. 

For more information about topics covered in this tutorial, see the following topics in 
Dreamweaver Help (Help > Using Dreamweaver).

About Cascading Style Sheets

Creating a new CSS style

Creating and linking to an external CSS style sheet

Creating a document based on a Dreamweaver design file
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CHAPTER 18

Building a Master-Detail Page Set Tutorial

A Master-Detail Page set is a web application which presents information extracted from a 
database in two formats. The master page displays a list of all records retrieved as a result of a 
database search. A detail page links from the master page and usually provides more specific 
details about an item selected in the master page. 

You can complete this tutorial in following server models—ColdFusion, ASP, and JSP. 

In this tutorial you will build a master and detail page set. The tutorial takes approximately 20 minutes 
to complete, depending on your experience, and will teach you how to do the following tasks:

• “Create a master-detail page set” on page 198

• “Create a database recordset” on page 200

• “Insert a Master-Detail Page Set application object” on page 203

• “View your pages” on page 205
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Before you begin
If you completed Chapter 5, “Developing a Web Application in Dreamweaver MX,” on page 69 
in the Getting Started with Dreamweaver MX section of this guide, the files you need to complete 
this tutorial are already located in your local site and your remote site. 

If you did not complete the lesson, you will need to transfer the Sample files to your local drive 
and to your application server. See the appropriate set up chapter for your web application server 
for direction on how to set up the files.

Chapter 7, “Setup for Sample ColdFusion Site,” on page 89

Chapter 9, “Setup for Sample ASP Site,” on page 109

Chapter 10, “Setup for Sample JSP Site,” on page 121

You must have completed the following tasks prior to starting this tutorial:

• Configured your system.

• Configured Dreamweaver to work with your chosen application server.

• Defined a connection to the database.

Create a master-detail page set
A good starting point for developing a database application is to display a list of the records stored 
in a database. The master-detail page set you develop will list the company’s car rental locations, 
as well as detailed information about each location, such as the telephone number and address.

All of the information about Global’s locations is stored in a Microsoft Access database file, 
global.mdb. If you followed the instructions in the appropriate Setup chapter in this guide, you 
should already have a connection to this database. The web application pages will not update 
without a connection to this database.

Let’s start by selecting a page to work in.

1 Do one of the following to open the Site panel:

• In the Files panel group, click the expander arrow, then select the Site tab if it is not 
already selected.

• Choose Window > Site.
Chapter 18198



• Press F8.

The Site panel opens.

2 In the Sites pop-up menu, select the GlobalCar site you defined. 

3 In the Site panel, double-click the locationMaster file to open it.

The document opens in the Document window. You will edit the partially completed page.
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Create a database recordset
Now you’ll create a recordset to display data that is stored in a database. A recordset is a subset of 
information extracted from a database by a database query. (In ASP.NET,. a recordset is known as 
a DataSet.) A database query consists of search criteria, which defines what’s included in the 
recordset. You then use the information extracted as a source of data for your dynamic pages.

Dreamweaver MX provides an easy-to-use interface for creating simple SQL queries—you don’t 
need to know SQL to create a recordset in Dreamweaver.

You’ll create a recordset that selects all of the values from the Locations table.

1 In Dreamweaver, open the Recordset or DataSet (ASP.NET) dialog box by doing one of the 
following:

• In the Insert bar’s Application tab, click the Recordset or DataSet (ASP.NET) button.

• Choose Window > Bindings to open the Bindings panel, then click the plus (+) button and 
select Recordset or DataSet.

• In the Application panel group, select the Bindings panel, then click the plus (+) button and 
select Recordset or DataSet.

The Recordset or DataSet dialog box appears. The screen below shows the ColdFusion 
recordset dialog box. (In ASP.NET this is the DataSet dialog box; most of the recordset options 
are the same for all server models.)

2 In the Name text box, enter rsLocations. 

This is the name of the recordset you are defining.
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3 In the Data Source pop-up menu (ColdFusion) or the Connection pop-up menu (other server 
page types), select connGlobal.

The Recordset or DataSet dialog box updates and displays information for the first table in the 
Global database. 

Note: If the connGlobal connection doesn’t appear in the menu, click the Define button to create it. 

4 In the Table pop-up menu, select LOCATIONS.

The recordset updates with records in the LOCATIONS table.

5 For Columns, accept the default setting, All. 

Tip: To limit the information the recordset includes you can choose Selected, then select the column(s) you want 
to work with.
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6 Click Test to test the recordset.

The database records that match your recordset request are displayed in the Test SQL 
Statement window. 

7 Click OK to close the Test SQL Statement window.

8 Click OK to close the Recordset or DataSet dialog box, and add the recordset code to your page.

Dreamweaver confirms that a recordset has been added to the page and the recordset appears in 
the Bindings panel.

Tip: If you do not see all of the recordset fields, click the plus button to expand the recordset branch. 
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Insert a Master-Detail Page Set application object
Dreamweaver includes several application objects that help you create web application pages 
quickly and easily. 

Next, you’ll use an application object to create a master-detail page set. Application objects create 
layout and server-side scripts for many common web applications. After you select a few options, 
the Master-Detail Page Set application object generates the forms and scripting for both the 
master list and the page containing the details for you. Additionally, the application object creates 
record navigation and a record counter in the master page.

1 Save your document (File > Save).

2 In the Document window the locationMaster file should still be open, place the insertion 
point after the “Rental Locations” text, then press Enter or Return to set where the live object 
will be inserted.

3 Insert the data, by doing one of the following: 

• In the Insert bar’s Application tab, click the Master Detail button or drag it to the document.

• Choose Insert > Application Objects > Master Detail Page Set.

The Insert Master Detail Pages Set dialog box appears. 

4 In the dialog box, in the Recordset pop-up menu, select rsLocations.

5 In the Master Page Fields list, select CODE, then click the minus (-) button to remove it from 
the list of data which appears in the master page list. 
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6 Remove all the fields in the Master Page Fields list except LOCATION_NAME, CITY, and 
STATE_COUNTRY.

7 In the Link To Detail From pop-up menu, select LOCATION_NAME.

To view the detail page for a location, a link needs to be created for each location that appears 
in the master list. When a site visitor clicks the Location Name in the master page the 
appropriate detail page will open.

8 In the Pass Unique Key pop-up menu, accept the default value, Code and make sure Numeric 
is not checked.

The CODE field is the unique key or primary key in the Locations table. This field contains a 
unique three letter code for each record.

9 In Show, accept the default setting to display ten records at a time.

10 In Detail Page Name, click Browse, then in the Select File dialog box, navigate to the 
locationDetail file in your site folder.

11 Click OK.

12 In the Detail Page Fields, set the fields you want to appear in the detail page, by doing the following:

In the Detail Page Fields list, select CODE, then click the minus (-) button.

Select REGION_ID, then click the minus (-) button. 

13 Click OK.

Dreamweaver updates the master and detail pages, and adds all the necessary server scripts and 
queries for both the list page and the detail page. 

The master list page updates. It includes a table for the database data, a table for recordset page 
navigation, and a record set counter.

The detail page also updates. It includes a table that lists details for each record in the master page.
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View your pages
Next, you’ll save the pages, then view them to see how the application you developed works. To 
view pages as they would look when processed by the server, you can preview your page in a browser.

1 In the Document window, select the locationDetail document, and choose File > Save 
to save your work. 

2 In the Site panel, select the locationDetail document, then click the Put Files button (blue up 
arrow) to copy the local file to your server.

3 In the Document window, select the locationMaster document, and choose File > Save to save it.

4 In the Site panel, select the locationMaster document, then click the Put Files button (blue up 
arrow) to copy the local file to your server.

5 With the locationMaster document still selected, press F12 to view the page in a browser. Test 
the links from the master page to the details page. 

6 Below the table of data, click Next, to view the next set of ten records. 

The data table, navigation bar, and record counter update.

7 Click one of the location names to see the detail page. 

The master page passes the unique key to the server, the server processes the query, and the 
detail page opens and displays the data for the selected location. 

8 Press the Locations button located at the top of the page to return to the locations list.

9 Close the browser window when you are finished viewing the pages. 

10 In Dreamweaver, close your pages.
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Take the next steps
In this tutorial you learned how to create a master-detail page set in Dreamweaver. 

For detailed information about topics covered in this tutorial, see the following topics in the 
Using Dreamweaver MX documentation or Dreamweaver Help:

• Building master/detail pages rapidly

• Building master/detail pages block by block

• Modifying master/details pages
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CHAPTER 19

Building an Insert Record Page Tutorial

This tutorial walks you through the steps of building an form which inserts information into a 
database. As you create the insert page you’ll learn how to insert and define form fields. You’ll also learn 
how to create a form field which let’s users insert information using a dynamically generated menu.

You can complete this tutorial in all of the server models supported by Dreamweaver MX—
ColdFusion, ASP, ASP.NET, JSP, and PHP.

In this tutorial you will accomplish the following tasks:

• “Create an insert page” on page 208

• “Add form objects” on page 209

• “Define an Insert Record server behavior” on page 213

• “Test your page” on page 215

Before you begin
If you completed Chapter 5, “Developing a Web Application in Dreamweaver MX,” on page 69 
in the Getting Started with Dreamweaver MX section of this guide, the files you need to complete 
this tutorial are already located in your local site and your remote site. 

If you did not complete the lesson, you will need to transfer the Sample files to your local drive 
and to your application server. See the appropriate set up chapter for your web application server 
for direction on how to set up the files.

Chapter 7, “Setup for Sample ColdFusion Site,” on page 89

Chapter 8, “Setup for Sample ASP.NET Site,” on page 99

Chapter 9, “Setup for Sample ASP Site,” on page 109

Chapter 10, “Setup for Sample JSP Site,” on page 121

Chapter 11, “Setup for Sample PHP Site,” on page 133

You must have completed the following tasks prior to starting this tutorial:

• Configured your system.

• Configured Dreamweaver to work with your chosen application server.

• Defined a connection to the database.
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Create an insert page
The page you’ll create lets the site administrator insert new rental car location information in the 
Global Car Rental database.

You’ll start in a partially completed page. Along the way you’ll add form objects and dynamic 
content to the page. 

Let’s start by selecting a page to work in.

1 Do one of the following to open the Site panel:

• In the Files panel group, click the expander arrow, then select the Site tab if it is not already selected.

• Choose Window > Site.

• Press F8.

The Site panel opens. 

2 In the Site pop-up menu, select the Global Car site you defined fir your application server type.
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3 In the Site panel, double-click the insertLocation document to open it.

The document opens in the Document window.

Add form objects
A table and some of the form fields have already been added to this page. A red, dashed rectangle 
appears in the document, this is the form boundary. Dreamweaver automatically inserts a form 
boundary in a document when you insert a form object.

Now you’ll add the remaining form fields for the insert page—three text fields, a list/menu field, a 
submit button, and a reset button. 

You’ll also provide labels for form fields. Naming the fields makes it easier for you to identify the 
fields you are working with later when you connect the form fields to the database fields.

We’ll begin by looking at one of the existing form fields.

1 Open the Property inspector (Window > Properties), if it isn’t already open.

2 Move the pointer to the top-right cell, click the form field to select it. 

The Property inspector updates displaying the form field properties.

The Name field contains the form object’s name, and the Char Width field sets the field’s width 
to 30 characters. You’ll update these same two fields in the text fields you add to the form.

3 In the document, place the insertion point in the table cell to the right of the State or Country 
label, then do one of the following to insert a text field:

• In the Insert bar, click the Forms tab, then click the Text Field button (second from the left) or 
drag it from the Insert bar to the table cell.

• Choose Insert > Form Objects > Text Field

The text field form object is inserted in the document.
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4 With the text field still selected, in the Property inspector, enter state_country in the Name 
text box and enter 30 in the Char Width text box. 

5 In the document, place the insertion point in the table cell to the right of the Region label, 
then do one of the following to insert a List/Menu:

• In the Insert bar’s Forms category, click the List/Menu button or drag it from the Insert bar to 
the table cell.

• Choose Insert > Form Objects > Text Field

The list/menu form object inserts in the document.

6 In the Property inspector, enter region_id in the Name text box.

A list/menu object generates its character width to the length of the longest item in the list or 
menu. We’ll define the menu items and values for this field a little later.

7 Insert a text field for Telephone, and then in the Property inspector name it telephone, and in 
the Char Width field enter 30.

8 Insert a text field for Fax, and then in the Property inspector name it fax, and in the Char 
Width field enter 30.

9 In the document, place the insertion point in the bottom table cell.
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10 Add a submit button for the form by doing one of the following:

• In the Insert bar’s Forms category, click the Button button or drag it from the Insert bar to 
the table cell.

• Choose Insert > Form Objects > Button.

A Submit button inserts in the document. In the Property inspector, the button is already 
labeled and the Action is set to Submit form.

11 Repeat step 10 to add a another button to the form. You’ll add a reset button to let a user reset 
the form if they need to..

12 In the Property inspector, for Action, select Reset form.

13 In the Button Name text box, enter Reset.

Your form is now complete and should look similar this:

14 Save your document.
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Define the List/Menu form field

Now you’ll update the list/menu field adding information which will let a user select the text 
name for a region, and update the database with its numeric value. This way a user doen’t have to 
check to verify which number matches which name.

1 In the document, click the Region_Id list/menu form field to select it.

The Property inspector updates with information about the object.

2 In the Property inspector, click the List Values button.

The List/Menu dialog box appears.

3 In the List Values dialog box, add Item Labels and Values to match the data in the REGIONS 
database table.

4 In Item Label, enter North America, press Tab, and in Value enter 1.

5 Click the plus (+) button to add another entry, then enter South/Central America, press Tab, 
then enter 2.

6 Repeat steps 4 and 5, until you enter all of the regions as in the dialog box below.

7 Click OK to close the dialog box.
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Define an Insert Record server behavior
You’ll use a server behavior to create the necessary server scripts for the application. You’ll create a 
connection between the form field data and the database data so that completing the form and 
clicking the Submit button inserts the information into the database. 

1 In the Server Behaviors panel (Window > Server Behaviors), click the plus (+) button and 
choose Insert Record from the pop-up menu.

The Insert Record dialog box appears.

2 In the Data Source (ColdFusion) or Connection pop-up menu (other server page types), 
choose connGlobal.
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3 In the Insert Into Table pop-up menu, choose LOCATIONS.

The Columns list updates with information about how the form fields relate to the database fields.

4 Make sure REGION_ID’s value is set to Numeric or Integer (ASP.NET), since the Region ID 
is a numeric value rather than a text value.

5 In After Inserting, Go To or On Success, Go To (ASP.NET), click Browse and in the dialog 
box that appears select the LocationOK file, then click OK to close the dialog box. 

6 Click OK to close the Insert Record dialog box.

In the Document window, the form updates and the Server Behaviors panel shows the Insert 
Record behavior is added.

7 Save your document.
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Test your page
Next, you’ll copy the completed page to your server, then open it in a browser and insert 
some information.

1 In the Site panel, select insertLocation, then click the Put Files button (blue up arrow) to copy 
the local file to your server. Choose Yes, when asked to copy dependent files.

2 With insertLocation selected in the Document window, choose File > Preview in Browser or 
press F12 (Windows) to view your document. 

3 Enter test data in the form, then click the Submit button.

The locationOK page appears indicating information was successfully inserted in the 
Global database.

4 To view the entry you added to the database do the following:

In the Application panel group, select the Databases panel. Locate the connGlobal database, 
then click the plus (+) in front of it to expand it. Click the plus (+) in front of Tables to view 
the database tables. Right-click (Windows) or Control-click (Macintosh) the LOCATIONS 
table and then select View Data. The database records appear; the new record is the last entry 
in the database.

Take the next steps
In this tutorial you learned how to create a dynamic record insertion form in Dreamweaver. For 
detailed information about topics covered in this tutorial, see the following topics in the Using 
Dreamweaver MX documentation or Dreamweaver Help:

• CreatingInteractive Forms

• Adding Dynamic Content to Web Pages

• Building a page to insert records

• Setting the Record Insertion Form dialog box options
Building an Insert Record Page Tutorial 215



Chapter 19216



INDEX
Symbols

? in field names  148

Numerics

127.0.0.1 IP number  87

A

"access denied" error message  149
Access. See Microsoft Access
accounts

IIS, permissions  146
troubleshooting account names  147

Active Server Pages. See ASP
adding

assets to a site  25
styles to text  37
text to a page  35

adjusting page layouts  29
animation and "static" pages  61
Apache Tomcat application server  66
Apache web server on Mac OS X  83
Apple. See Mac OS X
Application panel group  71
application servers

about  66
ColdFusion MX, installing  91
for ASP, installing  112
for JSP, installing  123
.NET Framework (ASP.NET), installing  101
overview  62
PHP, installing  136

Application tab of Insert bar  76,  77
applications, web. See web applications
ASP

application servers, installing  112
time, displaying  112
troubleshooting  113
web applications, setting up  109

ASP.NET
DataSets  71
languages used with  65
.NET Framework  101
servers, supported  101
web applications, setting up  99

assets, adding to a site  25
attaching CSS style sheets  38
attributes

in Code Hints  56
reference information  55

auto-number fields, troubleshooting  149
autostretch columns  34

B

background colors, setting  40
Bindings panel  71
browsers

differences between  46
buttons on web pages (rollovers)  44

C

C# (language)  65
cells  34

background colors  40
deleting  29
selecting  40

CFML (ColdFusion Markup Language)  65
Change Workspace button  50
changing

background colors  40
page layouts  29

characters, valid in account names  147
checklists

ASP setup  109
ASP.NET setup  99
ColdFusion setup  89
JSP setup  121
PHP setup  134
217



choosing
colors  41
image source files  40
server technologies  66
tags  53

choosing a workspace layout  15
closing documents  36
code

creating with the Tag Chooser  53
printing  58

Code and Design view  41
Code Hints  56
Code view

displaying text files  36
making changes appear in Design view  42
switching to  52

coding workspace  49
ColdFusion

error messages  149
installing  91
languages used with  65
web applications, setting up  89

ColdFusion Administrator  96
ColdFusion Markup Language (CFML)  65
ColdFusion MX Server Developer Edition  91
ColdFusion Studio  15,  49
color picker  41
columns

autostretch columns in tables  34
names of columns in databases  148
table, changing widths  33

Commands menu  17
common terms, definitions of  66
configuring

Dreamweaver  14
systems with ASP application server  110
systems with ColdFusion MX  90
systems with JSP application server  122
systems with .NET Framework  100
systems with PHP application server  135

connecting
to databases (ASP)  117
to databases (ASP.NET)  105
to databases (ColdFusion)  96
to databases (JSP)  127
to databases (PHP)  142
to remote sites  48

content,
. See text, images, dynamic pages

context menus  17

conventions, typographical  12
copying

files  43
files and folders in Site panel  51
navigation bars  46
text  36

creating
CSS style sheets  37
pages  26
recordsets  71
repeated regions  76
root folders (ASP)  114
root folders (ASP.NET)  102
root folders (ColdFusion)  92
root folders (JSP)  124
root folders (PHP)  138
temporary files  146

CSS Styles panel  38
customizing

Dreamweaver  14

D

Data Source Name. See DSN
data sources

ColdFusion  96
data types, mismatched  147,  149
data, dynamic, inserting  75
database management systems  67
databases

about  67
choosing  64
column names  148
connecting to (ASP)  117
connecting to (ASP.NET)  105
connecting to (ColdFusion)  96
connecting to (JSP)  127
connecting to (PHP)  142
displaying data  63,  74
drivers, defined  67
drivers, overview  63
file locations  147
file-based  64
locked  146
permissions, changing  150
queries  63,  67
recordsets  63
relational  68
server-based  64
tables  63
using with web applications  60
Index218



DataSets (ASP.NET recordsets)  71
dates, troubleshooting  147
DBMS (database management system)  67
defining

CSS styles  38
remote folders  94,  103,  116,  126,  140

deleting
table cells  29

Design view  41
destroying temporary files, permissions for  146
dialog boxes

CSS Style Definition  38
Link External Style Sheet  38
New Document  26

disk, viewing in the Site panel  51
displaying

Document toolbar  35
docking and undocking panel groups  17
Document toolbar

introduced  16
Live Data view  76
showing  35

Document window  16
documentation  12
document-relative links  39
documents

closing  36
duplicating  43
renaming  43
saving  28
switching between  52
unsaved  39

Dreamweaver
customizing  14
features  48
installing  13
menus  17
registering  14

Dreamweaver 4 workspace layout  15
Dreamweaver Help  12
drivers

databases  63,  67
not specified  146

DSN (data source name) troubleshooting  146
duplicating files  43
dynamic pages

about  67
creating  65
processing  62,  94,  104,  116,  126,  140

dynamic text, inserting  75

E

Edit menu  17
editing

styles  38
tags  54

error messages
ColdFusion  149
file already in use  146
Microsoft, troubleshooting  145
See also troubleshooting

examples of web applications  60
expanding

panel groups  17
Property inspector  40

extracting data from databases  63
eyedropper pointer  41

F

FAT file systems  150
features of Dreamweaver  48
fields

dynamic  75
"file already in use" error message  146
file browser in Site panel  51
File menu  17
files

copying in Site panel  51
uploading  81,  95,  105,  117,  127,  141

Files panel group  70
floating workspace layout  15
folders

copying in Site panel  51
root  83

formatting text  37
FTP (File Transfer Protocol)  48

G

General preferences  50
glossary of common web-application terms  66
graphical links  44
gripper, using to drag a panel group  17
groups of panels  17

H

hand-coding  15
Help menu  17
help system  12
HomeSite  15,  49
HTML

embedded programming languages  65
importing  36
See also code
Index 219



HTTP server. See servers
hyperlinks. See links

I

IBM WebSphere application server  66
IIS  47,  66,  84

administrative tool, launching  102
ASP.NET support  101
installing  85
permissions  146

illegal characters in account names  147
images

adding  25
inserting  39
outside of a site  40
placeholders  32
rollovers  44
source file, selecting  40
spacers  34

Import Word HTML command  36
Insert bar  16

Application tab  76,  77
inserting links  57

Insert Image Placeholder menu item  32
Insert menu  17
Insert Record object  77
inserting

dynamic text  75
rollover images  44
tables  74

inspectors. See panels
installing

application servers, ASP  112
application servers, JSP  123
application servers, PHP  136
ColdFusion MX  91
Dreamweaver  13
IIS  85
.NET Framework  101
web servers  84

integrated workspace layout  15
interpreting database data  63
intranets  48
IP addresses  87
iPlanet Web Server  68
IUSR accounts  146

J

Java  65
JavaScript  65
JavaServer Pages (JSP)  65
JRun  66
JSP

application servers, installing  123
web applications, setting up  121

L

languages, server-side  65
laying out pages  29
layout tables  33
Layout view, switching to  33
layouts

adjusting  29
Standard view  34

Link External Style Sheet dialog box  38
links

creating  44
document-relative and root-relative  39
graphical  44
inserting  57

Live Data view  76
troubleshooting  95,  105,  117,  127,  141

local folders
defining  93,  103,  115,  125,  139

local network connections  48
local sites

about  20
setting up  20

localhost  86
locked database files  146
logon failures  147
Lorem Ipsum placeholder text  28

M

Macintosh
Mac OS X multiuser environment  14
Mac OS X running Apache and PHP  135
servers  83
system requirements  13

Macromedia ColdFusion Studio  15
Macromedia HomeSite  15
Macromedia JRun  66

installing  123
Make Cell Widths Consistent command  34
making columns autostretch  34
MDI (Multiple Document Interface)  15
menus  17
Index220



Microsoft Access  64
locked database files  146
troubleshooting  145

Microsoft error messages, troubleshooting  145
Microsoft Internet Information Server (IIS). See IIS
Microsoft Knowledge Base articles  146
Microsoft Personal Web Server (PWS)  68,  84
Microsoft SQL Server  64
Microsoft Word HTML, importing  36
Modify menu  17
modifying

page layouts  29
page properties  35
tags  54

Multiple Document Interface (MDI)  15
multiuser operating systems  14
MySQL  64

downloading  142

N

names of columns  148
naming files  43
navigation bars

copying  46
.NET Framework  66

installing  101
Netscape Enterprise Server  68
New Document dialog box  26

CSS style sheets, creating  37
NT. See Windows NT
NTFS file systems  150
numeric addresses  87

O

ODBC errors  148
opening the Property inspector  40
operating systems

multiuser  14
operating systems, requirements  13
Option Pack, Windows NT 4.0  84
Oracle 9i  64
other resources  48
overview

of menus  17

P

page designs, predesigned  26
page layouts

adjusting  29
page properties

setting  35

pages
creating  26
displaying database data  63
dynamic  59
dynamic, creating  65
dynamic, processing  62
layout  26
layouts  29
predesigned  26
properties, setting  35
record-insertion  77
static  61

panel groups  17
Application  71
Files  70

panels
Bindings panel  71
CSS Styles panel  38
descriptions  16
Property inspector  40
Server Behaviors panel  76
Site panel  70

parameters, too few  148
passwords, incorrect  147
pasting

text  36
PDF documentation  12
permissions

creating and destroying temporary files  146
folder containing database  147
security  151
troubleshooting  150

Personal Web Manager  86
launching  92,  114,  124,  138

PHP  65
application servers, installing  136
Mac OS X  135
time, displaying  137
troubleshooting  138
web applications, setting up  133

picking colors  41
placeholders

images  32
images, replacing  39
text  28

pointers, eyedropper  41
Point-to-File icon  40
predesigned page designs  26
Index 221



Preferences dialog box
Code Hints category  56
General category  50

Preview in Browser
troubleshooting dynamic pages  95,  105,  117,  

127,  141
previewing

overview  46
rollover images  46

printing code  58
projects (HomeSite and ColdFusion Studio term). 

See sites
Property inspector  16

expanding  40
opening  40

publishing  47
Put Files button  48,  81
PWS  68,  84

ASP.NET support  101
installing  84

Q

queries  67
database  63
joins  147
testing  73
troubleshooting  148
updateable  149

question marks  148

R

Record Insertion Form dialog box  78
record-insertion forms

creating  77
records  63

displaying  74
inserting  77

recordsets
creating  71
defined  67
empty, troubleshooting  149
testing  73
See also databases

reference information  55
Reference panel  55
Refresh button  42
regions

repeated  76
registering Dreamweaver  14
relational databases, about  68

remote folders
defining  94,  103,  116,  126,  140

remote sites  47
about  20
connecting  48

remote web servers  47
renaming files  43
repeated regions, creating  76
requirements  13
reserved words  148
resources

for learning Dreamweaver  12,  48
rollover images

creating  44
viewing and previewing  46

root folders  83
creating  92,  102,  114,  124,  138
defining  93,  103,  115,  125,  139
See also local folders

root-relative links  39
RWS servers  47

S

sample database
connecting to  96,  97,  105,  106,  117,  118,  127,  

142
sample site, viewing  18
scripts

server-side  63
security and permissions  151
selecting

an image source file  40
selecting a workspace layout  15
selecting cells  40
selecting text  36
Sequel (SQL)  63
Server Behaviors panel  76
server models. See server technologies
server technologies  65

choosing  66
defined  68

servers
application servers  62
ASP.NET support  101
basics  86
choosing  84
HTTP  86
installing  84
IP addresses  87
root folders  94,  103,  116,  126,  140
setting up  83
Index222



servers continued
testing  85
troubleshooting  85
uploading files  95,  105,  117,  127,  141
web servers, defined  61
Windows Me  84
See also web servers, application servers

server-side scripting languages  65
setting

page properties  35
setting background colors  41
setting up

ASP  109
ASP.NET  99
ColdFusion  89
JSP  121
PHP  133
sites  20

setup
ASP, checklists  109
ASP.NET, checklists  99
ColdFusion, checklists  89
JSP, checklists  121
PHP, checklists  134

Site Definition Wizard  20
Site menu  17
Site panel  17,  70

copying files and folders  51
file browser  51

sites
about  20
assets, adding  25
defining  92,  102,  114,  124,  139
definitions  20
files outside of  51
remote  47
selecting in the Site panel  51
setting up  20
static, creating  19

spacer images  34
spaces in column names  148
special characters

column names  148
in SQL account names  147
question marks in field names  148

specifying
testing servers  94,  104,  116,  126,  140

SQL (Structured Query Language)  63
SQL Server

dynamic pages, troubleshooting  147
troubleshooting  145

Standard view  34
static pages  61
static pages, about  68
static sites, creating  19
Structured Query Language (SQL)  63
styles, CSS  38
syntax errors in insert statements  148
system DSNs  146
system requirements  13
systems

configuring  90,  100,  110,  122,  135

T

tables
cells, background colors  40
cells, deleting  29
columns, autostretch  34
columns, changing widths of  33
database  63
inserting  74
Layout view  33
Standard view  34

Tag Chooser  53
tag editors  53
Tag inspector  54
tag selector  30
tags

editing  54
finding reference information  55
hints  56
server-side  63
Tag Chooser  53

technical support  145
servers  83

templates  43
terminology  66
Test Connection button  48
testing servers  85

specifying  94,  104,  116,  126,  140
text

adding  35
dynamic  75
formatting  37
placeholder  35
placeholder text  28
selecting  36
styles, applying  38

text files
in Code view  36

Text menu  17
Index 223



time, displaying
in ASP  112
in PHP  137

time-out values, Windows 2000  146
titles,setting page  35
Tomcat application server  66
toolbars

Document  76
Document, displaying  35

tools  48
troubleshooting

access denied  149
ASP  113
BOF  149
ColdFusion  149
COUNT field incorrect  148
data type mismatch  147
DSN  146
dynamic pages, Preview in Browser  95,  105,  117,  

127,  141
EOF  149
file in use  146
Live Data view  95,  105,  117,  127,  141
logon failed  147
Microsoft error messages  145
ODBC errors  148
pages not displaying  113,  138
pages not opening  85
parameters, too few  148
permissions  150
PHP  138
servers  83,  85
syntax errors  148
updateable queries  147,  149

tutorials  12
typographical conventions  12

U

UNC  150
underscores in SQL account names  147
uninstalling Dreamweaver  14
unsaved documents, inserting images  39
uploading  47,  81
uploading files  95,  105,  117,  127,  141
URL Prefix option  95,  104,  117,  127,  141
URLs, document-relative and root-relative  39
user DSNs  146
user interface  14
Using Dreamweaver user guide  12

V

variables in CFML  65
VBScript  65
verifying

that web server is running  91,  101,  111,  123,  136
View menu  17
viewing

rollover images  46
views

Code view  41
Layout view  33
Live Data  76
Standard view  34

Visual Basic  65

W

web applications
ASP, setting up  109
ASP.NET, setting up  99
ColdFusion, setting up  89
common uses  60
definition of term  68
developing  69
JSP, setting up  121
overview  59
PHP, setting up  133

web servers  47
checking  91,  101,  111,  123,  136
defined  61,  68
See also servers, application servers

WebSphere  66
Welcome window  16
widths of columns, changing  33
widths, making consistent  34
Window menu  17
Windows  13,  14
Windows 2000 time-out values  146
Windows Me servers  84
Windows NT 4.0 Option Pack  84
windows. See panels
Wizard, Site Definition  20
workflow for creating static sites  19
workspace layouts

choosing  15
coding  49
Index224


	Contents
	Part I Getting Started
	Introduction
	Learning Dreamweaver basics
	How to use this guide
	Other resources
	Typographical conventions

	Installing and running Dreamweaver
	System requirements
	Installing Dreamweaver
	Using Dreamweaver in a multiuser environment
	Registering Dreamweaver MX

	A first look at the Dreamweaver workspace
	Choosing a workspace layout (Windows only)
	Windows and panels overview
	Menus overview

	View the sample site

	Creating Your First Website in Dreamweaver
	Set up a local site
	Add assets to your site

	Create and save a new page
	Adjust the layout
	Remove unnecessary elements
	Add an image placeholder
	Make a column autostretch

	Set a page title
	Add styled text
	Add text
	Add styles to the text

	Add images
	Set background colors
	Look at the code
	Create a second page
	Add text links between pages
	Create rollovers for graphical links
	Copy the navigation bar
	Preview in browser
	Set up a remote site, then publish
	Further reading

	Editing code in Dreamweaver
	Switch to the coding workspace
	Copy a Folder to Your Site
	View the finished pages
	Open multiple pages
	Add an image by dragging it
	Add a link with the Tag Chooser
	Edit a tag
	Look up information about a tag
	Add an image with Code Hints
	Check your changes
	Add a link with the Insert bar
	Printing your code
	Further reading

	Understanding Web Applications
	What is a web application?
	Common uses for web applications
	Web application example

	How a web application works
	Processing regular web pages
	Processing dynamic pages
	Accessing a database

	Authoring dynamic pages
	Choosing a server technology
	Frequently used terms

	Developing a Web Application in Dreamweaver MX
	Before you begin
	Open a document to work in
	Define a recordset
	Display the database records
	Add dynamic fields to the table
	Set a repeated region
	View your pages
	Create a record insert form
	Add a Record Insertion Form application object
	Create the insert form

	Copy files to the server
	View the update

	Further reading

	Installing a Web Server in Windows
	Getting started
	Installing Personal Web Server
	Installing Internet Information Server
	Testing the web server
	Web server basics

	Setup for Sample ColdFusion Site
	Setup checklists for ColdFusion developers
	Configuring your system
	Checking for a web server
	Installing ColdFusion MX
	Creating a root folder

	Defining a Dreamweaver site
	Copying the sample files
	Defining a local folder
	Defining a remote folder
	Specifying where dynamic pages can be processed
	Uploading the samples files

	Connecting to the sample database
	Setting up the database (remote server configuration)
	Creating a ColdFusion data source
	Connecting to the database


	Setup for Sample ASP.NET Site
	Setup checklist for ASP.NET developers
	Configuring your system
	Checking for a web server
	Installing the .NET Framework
	Creating a root folder

	Defining a Dreamweaver site
	Copying the sample files
	Defining a local folder
	Defining a remote folder
	Specifying where dynamic pages can be processed
	Uploading the samples files

	Connecting to the sample database (local configuration)
	Connecting to the sample database (remote server configuration)

	Setup for Sample ASP Site
	Setup checklist for ASP developers
	Configuring your system
	Checking for a web server
	Installing an ASP application server
	Testing the installation
	Creating a root folder

	Defining a Dreamweaver site
	Copying the sample files
	Defining a local folder
	Defining a remote folder
	Specifying where dynamic pages can be processed
	Uploading the samples files

	Connecting to the sample database (local configuration)
	Connecting to the sample database (remote server configuration)
	Setting up the database on the remote computer
	Creating a database connection


	Setup for Sample JSP Site
	Setup checklist for JSP developers
	Configuring your system
	Checking for a web server
	Installing the JSP application server
	Creating a root folder

	Defining a Dreamweaver site
	Copying the sample files
	Defining a local folder
	Defining a remote folder
	Specifying where dynamic pages can be processed
	Uploading the samples files

	Connecting to the sample database (local configuration)
	Installing the bridge driver
	Creating a database connection

	Connecting to the sample database (remote server configuration)
	Setting up the database on the remote computer
	Creating a database connection


	Setup for Sample PHP Site
	Setup checklist for PHP developers
	Configuring your system
	Checking for a web server
	Installing a PHP application server
	Testing the installation
	Creating a root folder

	Defining a Dreamweaver site
	Copying the sample files
	Defining a local folder
	Defining a remote folder
	Specifying where dynamic pages can be processed
	Uploading the samples files

	Connecting to the sample database
	Creating the MySQL database
	Creating a database connection


	Troubleshooting Database Connections
	Troubleshooting Microsoft error messages
	80004005—Data source name not found and no default driver specified
	80004005—Couldn’t use ‘(unknown)’; file already in use
	80004005—Logon Failed()
	80004005—Operation must use an updateable query
	80040e07—Data type mismatch in criteria expression
	80040e10—Too few parameters
	80040e10—COUNT field incorrect
	80040e14—Syntax error in INSERT INTO statement
	80040e21—ODBC error on Insert or Update
	800a0bcd—Either BOF or EOF is true

	Troubleshooting ColdFusion error messages
	ColdFusion—Access Denied
	ColdFusion—Operation must use an updateable query error

	Troubleshooting permissions problems


	Part II Tutorials
	Dreamweaver MX Tutorials
	What you will learn

	Using Tables to Design a Page Layout Tutorial
	Before You Begin
	Create and modify a table in Standard view
	Insert a table
	Modify the table
	Merge and split cells
	Change row height and column width

	Add color to a table
	Add a border color

	Set a relative width table in Standard view
	Create a pixel width based table
	Design a page in Layout view
	Create and save a new document

	Draw a layout cell
	Add multiple layout cells
	Move or resize a layout cell
	Resize a layout cell

	Add color to a table
	Set a relative width table in Layout view
	Take the next step

	Image Alignment and Image Maps Tutorial
	Before You Begin
	Set image alignment
	View the completed document
	Open a file to work in

	Set image spacing
	Set space and alignment options

	Create an image map
	View the completed file
	Set image map areas
	Open a linked file in a new window

	Take the next steps

	Working with Dreamweaver Design Files Tutorial
	Before You Begin
	Working with code snippets
	Insert a code snippet
	Add a content code snippet
	Add a footer code snippet
	Modify the snippet content
	Save code as a snippet
	Take the next steps

	Designing with Cascading Style Sheets Tutorial
	Before you begin
	Open a document to work in

	Open the CSS Styles panel
	Redefine an HTML tag
	Set a page background color
	Set a style for links
	Export styles to create an external style sheet
	Attach an external style sheet
	Take the next steps

	Building a Master-Detail Page Set Tutorial
	Before you begin
	Create a master-detail page set
	Create a database recordset
	Insert a Master-Detail Page Set application object
	View your pages
	Take the next steps

	Building an Insert Record Page Tutorial
	Before you begin
	Create an insert page
	Add form objects
	Define the List/Menu form field

	Define an Insert Record server behavior
	Test your page
	Take the next steps


	Index

